source: projects/specs/trunk/p/papi/papi-vl.spec @ 9431

Revision 9431, 10.6 KB checked in by inagaki, 9 years ago (diff)

2015-03-13 Ryoichi INAGAKI <ryo1@…>

  • libpfm, papi, sysstat: updated


Line 
1%bcond_with bundled_libpfm
2
3Summary: Performance Application Programming Interface
4Summary(ja): パフォーマンス計測 API
5Name: papi
6Version: 5.4.1
7Release: 1%{?_dist_release}
8License: BSD
9Group: Development/Tools
10URL: http://icl.cs.utk.edu/papi/
11
12Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: autoconf
16BuildRequires: doxygen
17BuildRequires: ncurses-devel
18BuildRequires: gcc-gfortran
19BuildRequires: kernel-headers >= 2.6.32
20BuildRequires: chrpath
21BuildRequires: lm-sensors-devel >= 3.0.0
22%if %{without bundled_libpfm}
23BuildRequires: libpfm-devel >= 4.4.0-5
24BuildRequires: libpfm-static >= 4.4.0-5
25%endif
26# Following required for net component
27BuildRequires: net-tools
28# Following required for inifiband component
29# BuildRequires: libibmad-devel
30BuildRequires: pkgconfig
31
32Requires: papi-libs = %{version}-%{release}
33
34# Right now libpfm does not know anything about s390 and will fail
35ExcludeArch: s390 s390x
36
37%description
38PAPI provides a programmer interface to monitor the performance of
39running programs.
40
41%package libs
42Summary: Libraries for PAPI clients
43Summary(ja): PAPI クライアント用のライブラリ
44Group: System Environment/Libraries
45
46%description libs
47This package contains the run-time libraries for any application that wishes
48to use PAPI.
49
50%package devel
51Summary: Header files for the compiling programs with PAPI
52Summary(ja): PAPI を用いたプログラムのコンパイルに必要なヘッダファイル
53Group: Development/Libraries
54Requires: papi = %{version}-%{release}
55Requires: pkgconfig
56
57%description devel
58PAPI-devel includes the C header files that specify the PAPI user-space
59libraries and interfaces. This is required for rebuilding any program
60that uses PAPI.
61
62%package testsuite
63Summary: Set of tests for checking PAPI functionality
64Summary(ja): PAPI の機能を確認するためのテストプログラム集
65Group: Development/Libraries
66Requires: papi = %{version}-%{release}
67
68%description testsuite
69PAPI-testuiste includes compiled versions of papi tests to ensure
70that PAPI functions on particular hardware.
71
72%package static
73Summary: Static libraries for the compiling programs with PAPI
74Summary(ja): PAPI を用いたプログラムのコンパイルに必要な静的ライブラリ
75Group: Development/Libraries
76Requires: papi-devel = %{version}-%{release}
77
78%description static
79PAPI-static includes the static versions of the library files for
80the PAPI user-space libraries and interfaces.
81
82%prep
83%setup -q
84
85%build
86%if %{without bundled_libpfm}
87# Build our own copy of libpfm.
88%global libpfm_config --with-pfm-incdir=%{_includedir} --with-pfm-libdir=%{_libdir}
89%endif
90
91cd src
92#autoconf
93
94%configure \
95    --with-perf-events \
96    %{?libpfm_config} \
97    --with-static-lib=yes --with-shared-lib=yes --with-shlib \
98    --with-components='appio coretemp example lmsensors lustre micpower net rapl stealtime'
99
100# implicit enabled components: perf_event perf_event_uncore
101#components currently removed from configure: infiniband, mx
102#components currently left out because of build configure/build issues
103# --with-components="bgpm coretemp_freebsd cuda host_micpower nvml vmware"
104
105cd components/lmsensors
106%configure --with-sensors_incdir=%{_includedir}/sensors \
107           --with-sensors_libdir=%{_libdir}
108cd ../..
109
110#DBG workaround to make sure libpfm just uses the normal CFLAGS
111DBG="" make %{?_smp_mflags}
112
113#generate updated versions of the documentation
114#DBG workaround to make sure libpfm just uses the normal CFLAGS
115pushd ../doc
116DBG="" make
117DBG="" make install
118popd
119
120%install
121rm -rf $RPM_BUILD_ROOT
122cd src
123make DESTDIR=$RPM_BUILD_ROOT LDCONFIG=/bin/true install-all
124
125chrpath --delete $RPM_BUILD_ROOT%{_libdir}/*.so*
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post libs -p /sbin/ldconfig
131%postun libs -p /sbin/ldconfig
132
133
134%files
135%defattr(-,root,root,-)
136%{_bindir}/*
137%dir /usr/share/papi
138/usr/share/papi/papi_events.csv
139%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
140%doc %{_mandir}/man1/*
141
142%files libs
143%defattr(-,root,root,-)
144%{_libdir}/*.so.*
145%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
146
147%files devel
148%defattr(-,root,root,-)
149%{_includedir}/*.h
150%if %{with bundled_libpfm}
151%{_includedir}/perfmon/*.h
152%endif
153%{_libdir}/*.so
154%{_libdir}/pkgconfig/*.pc
155%doc %{_mandir}/man3/*
156
157%files testsuite
158%defattr(-,root,root,-)
159/usr/share/papi/run_tests*
160/usr/share/papi/ctests
161/usr/share/papi/ftests
162/usr/share/papi/components
163/usr/share/papi/testlib
164
165%files static
166%defattr(-,root,root,-)
167%{_libdir}/*.a
168
169%changelog
170* Wed Mar 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.4.1-1
171- new upstream release
172
173* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.4.0-3
174- initial build for Vine Linux
175
176* Thu Dec 18 2014 William Cohen <wcohen@redhat.com> - 5.4.0-2
177- Split out papi-libs as separate subpackage. (#1172875)
178
179* Mon Nov 17 2014 William Cohen <wcohen@redhat.com> - 5.4.0-1
180- Rebase to papi-5.4.0.
181
182* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
184
185* Mon Aug 4 2014 William Cohen <wcohen@redhat.com> - 5.3.2-1
186- Rebase to 5.3.2.
187
188* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2.16.ga7f6159
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
190
191* Fri Jan 17 2014 Lukas Berk <lberk@redhat.com> - 5.3.0-1.16.ga7f6159
192- Automated weekly rawhide release
193
194* Thu Jan 16 2014 William Cohen <wcohen@redhat.com> - 5.3.0-1
195- Rebase to 5.3.0.
196
197* Tue Jan 14 2014 William Cohen <wcohen@redhat.com> - 5.2.0-5
198- Add presets for Intel Silvermont.
199
200* Mon Jan 13 2014 William Cohen <wcohen@redhat.com> - 5.2.0-4
201- Add presets for Haswell and Ivy Bridge.
202
203* Wed Aug 14 2013 William Cohen <wcohen@redhat.com> - 5.2.0-2
204- Enable infiniband and stealtime components.
205
206* Wed Aug 07 2013 William Cohen <wcohen@redhat.com> - 5.2.0-1
207- Rebase to 5.2.0
208
209* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-8
210- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
211
212* Wed Jul 24 2013 William Cohen <wcohen@redhat.com> - 5.1.1-7
213- rhbz830275 - Add support for POWER8 processor to PAPI
214
215* Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-6
216- Add autoconf buildrequires.
217
218* Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-5
219- rhbz986673 - /usr/lib64/libpapi.so is unowned
220- Package files in /usr/share/papi only once.
221- Avoid dependency problem with parallel make of man pages.
222
223* Fri Jul 19 2013 William Cohen <wcohen@redhat.com> - 5.1.1-4
224- Correct changelog.
225
226* Fri Jul 5 2013 William Cohen <wcohen@redhat.com> - 5.1.1-3
227- Add man page corrections/updates.
228
229* Fri Jun 28 2013 William Cohen <wcohen@redhat.com> - 5.1.1-2
230- Add testsuite subpackage.
231
232* Thu May 30 2013 William Cohen <wcohen@redhat.com> - 5.1.1-1
233- Rebase to 5.1.1
234
235* Mon Apr 15 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-2
236- Fix arm FTBS rhbz 951806.
237
238* Tue Apr 9 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-1
239- Rebase to 5.1.0.2
240
241* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-6
242- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
243
244* Mon Jan 14 2013 William Cohen <wcohen@redhat.com> - 5.0.1-5
245- Add armv7 cortex a15 presets.
246
247* Tue Dec 04 2012 William Cohen <wcohen@redhat.com> - 5.0.1-4
248- Disable ldconfig on install.
249
250* Thu Nov 08 2012 William Cohen <wcohen@redhat.com> - 5.0.1-3
251- Avoid duplicated shared library.
252
253* Wed Oct 03 2012 William Cohen <wcohen@redhat.com> - 5.0.1-2
254- Make sure using compatible version of libpfm.
255
256* Thu Sep 20 2012 William Cohen <wcohen@redhat.com> - 5.0.1-1
257- Rebase to 5.0.1.
258
259* Mon Sep 10 2012 William Cohen <wcohen@redhat.com> - 5.0.0-6
260- Back port fixes for Intel Ivy Bridge event presets.
261
262* Thu Aug 30 2012 William Cohen <wcohen@redhat.com> - 5.0.0-5
263- Fixes to make papi with unbundled libpfm.
264
265* Mon Aug 27 2012 William Cohen <wcohen@redhat.com> - 5.0.0-2
266- Keep libpfm unbundled.
267
268* Fri Aug 24 2012 William Cohen <wcohen@redhat.com> - 5.0.0-1
269- Rebase to 5.0.0.
270
271* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-5
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
273
274* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-4
275- Use siginfo_t rather than struct siginfo.
276
277* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-3
278- Correct build requires.
279
280* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-2
281- Unbundle libpfm4 from papi.
282- Correct description spellings.
283- Remove unused test section.
284
285* Fri Apr 20 2012 William Cohen <wcohen@redhat.com> - 4.4.0-1
286- Rebase to 4.4.0.
287
288* Fri Mar 9 2012 William Cohen <wcohen@redhat.com> - 4.2.1-2
289- Fix overrun in lmsensor component. (rhbz797692)
290
291* Tue Feb 14 2012 William Cohen <wcohen@redhat.com> - 4.2.1-1
292- Rebase to 4.2.1.
293
294* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4
295- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
296
297* Wed Nov 02 2011 William Cohen <wcohen@redhat.com> - 4.2.0-3
298- Remove unwanted man1/*.c.1 files. (rhbz749725)
299
300* Mon Oct 31 2011 William Cohen <wcohen@redhat.com> - 4.2.0-2
301- Include appropirate man pages with papi rpm. (rhbz749725)
302- Rebase to papi-4.2.0, fixup for coretemp component. (rhbz746851)
303
304* Thu Oct 27 2011 William Cohen <wcohen@redhat.com> - 4.2.0-1
305- Rebase to papi-4.2.0.
306
307* Fri Aug 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-3
308- Provide papi-static.
309
310* Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-2
311- Use corrected papi-4.1.3.
312
313* Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-1
314- Rebase to papi-4.1.3
315
316* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.1.2.1-2
317- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
318
319* Mon Jan 24 2011 William Cohen <wcohen@redhat.com> - 4.1.2.1-1
320- Rebase to papi-4.1.2.1
321
322* Fri Oct 1 2010 William Cohen <wcohen@redhat.com> - 4.1.1-1
323- Rebase to papi-4.1.1
324
325* Tue Jun 22 2010 William Cohen <wcohen@redhat.com> - 4.1.0-1
326- Rebase to papi-4.1.0
327
328* Mon May 17 2010 William Cohen <wcohen@redhat.com> - 4.0.0-5
329- Test run with upstream cvs version.
330
331* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-4
332- Resolves: rhbz562935 Rebase to papi-4.0.0 (correct ExcludeArch).
333
334* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-3
335- Resolves: rhbz562935 Rebase to papi-4.0.0 (bump nvr).
336
337* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-2
338- correct the ctests/shlib test
339- have PAPI_set_multiplex() return proper value
340- properly handle event unit masks
341- correct PAPI_name_to_code() to match events
342- Resolves: rhbz562935 Rebase to papi-4.0.0
343
344* Wed Jan 13 2010 William Cohen <wcohen@redhat.com> - 4.0.0-1
345- Generate papi.spec file for papi-4.0.0.
Note: See TracBrowser for help on using the repository browser.