source: projects/specs/trunk/p/papi/papi-vl.spec @ 9342

Revision 9342, 10.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-08 Ryoichi INAGAKI <ryo1@…>

  • libpfm, papi: new package


Line 
1%bcond_with bundled_libpfm
2
3Summary: Performance Application Programming Interface
4Summary(ja): パフォーマンス計測 API
5Name: papi
6Version: 5.4.0
7Release: 3%{?_dist_release}
8License: BSD
9Group: Development/Tools
10URL: http://icl.cs.utk.edu/papi/
11
12Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: autoconf
16BuildRequires: doxygen
17BuildRequires: ncurses-devel
18BuildRequires: gcc-gfortran
19BuildRequires: kernel-headers >= 2.6.32
20BuildRequires: chrpath
21BuildRequires: lm-sensors-devel >= 3.0.0
22%if %{without bundled_libpfm}
23BuildRequires: libpfm-devel >= 4.4.0-5
24BuildRequires: libpfm-static >= 4.4.0-5
25%endif
26# Following required for net component
27BuildRequires: net-tools
28# Following required for inifiband component
29# BuildRequires: libibmad-devel
30
31Requires: papi-libs = %{version}-%{release}
32
33# Right now libpfm does not know anything about s390 and will fail
34ExcludeArch: s390 s390x
35
36%description
37PAPI provides a programmer interface to monitor the performance of
38running programs.
39
40%package libs
41Summary: Libraries for PAPI clients
42Summary(ja): PAPI クライアント用のライブラリ
43Group: System Environment/Libraries
44
45%description libs
46This package contains the run-time libraries for any application that wishes
47to use PAPI.
48
49%package devel
50Summary: Header files for the compiling programs with PAPI
51Summary(ja): PAPI を用いたプログラムのコンパイルに必要なヘッダファイル
52Group: Development/Libraries
53Requires: papi = %{version}-%{release}
54
55%description devel
56PAPI-devel includes the C header files that specify the PAPI user-space
57libraries and interfaces. This is required for rebuilding any program
58that uses PAPI.
59
60%package testsuite
61Summary: Set of tests for checking PAPI functionality
62Summary(ja): PAPI の機能を確認するためのテストプログラム集
63Group: Development/Libraries
64Requires: papi = %{version}-%{release}
65
66%description testsuite
67PAPI-testuiste includes compiled versions of papi tests to ensure
68that PAPI functions on particular hardware.
69
70%package static
71Summary: Static libraries for the compiling programs with PAPI
72Summary(ja): PAPI を用いたプログラムのコンパイルに必要な静的ライブラリ
73Group: Development/Libraries
74Requires: papi-devel = %{version}-%{release}
75
76%description static
77PAPI-static includes the static versions of the library files for
78the PAPI user-space libraries and interfaces.
79
80%prep
81%setup -q
82
83%build
84%if %{without bundled_libpfm}
85# Build our own copy of libpfm.
86%global libpfm_config --with-pfm-incdir=%{_includedir} --with-pfm-libdir=%{_libdir}
87%endif
88
89cd src
90#autoconf
91
92%configure \
93    --with-perf-events \
94    %{?libpfm_config} \
95    --with-static-lib=yes --with-shared-lib=yes --with-shlib \
96    --with-components='appio coretemp example lmsensors lustre micpower net rapl stealtime'
97
98# implicit enabled components: perf_event perf_event_uncore
99#components currently removed from configure: infiniband, mx
100#components currently left out because of build configure/build issues
101# --with-components="bgpm coretemp_freebsd cuda host_micpower nvml vmware"
102
103cd components/lmsensors
104%configure --with-sensors_incdir=%{_includedir}/sensors \
105           --with-sensors_libdir=%{_libdir}
106cd ../..
107
108#DBG workaround to make sure libpfm just uses the normal CFLAGS
109DBG="" make %{?_smp_mflags}
110
111#generate updated versions of the documentation
112#DBG workaround to make sure libpfm just uses the normal CFLAGS
113pushd ../doc
114DBG="" make
115DBG="" make install
116popd
117
118%install
119rm -rf $RPM_BUILD_ROOT
120cd src
121make DESTDIR=$RPM_BUILD_ROOT LDCONFIG=/bin/true install-all
122
123chrpath --delete $RPM_BUILD_ROOT%{_libdir}/*.so*
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post libs -p /sbin/ldconfig
129%postun libs -p /sbin/ldconfig
130
131
132%files
133%defattr(-,root,root,-)
134%{_bindir}/*
135%dir /usr/share/papi
136/usr/share/papi/papi_events.csv
137%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
138%doc %{_mandir}/man1/*
139
140%files libs
141%defattr(-,root,root,-)
142%{_libdir}/*.so.*
143%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
144
145%files devel
146%defattr(-,root,root,-)
147%{_includedir}/*.h
148%if %{with bundled_libpfm}
149%{_includedir}/perfmon/*.h
150%endif
151%{_libdir}/*.so
152%doc %{_mandir}/man3/*
153
154%files testsuite
155%defattr(-,root,root,-)
156/usr/share/papi/run_tests*
157/usr/share/papi/ctests
158/usr/share/papi/ftests
159/usr/share/papi/components
160/usr/share/papi/testlib
161
162%files static
163%defattr(-,root,root,-)
164%{_libdir}/*.a
165
166%changelog
167* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.4.0-3
168- initial build for Vine Linux
169
170* Thu Dec 18 2014 William Cohen <wcohen@redhat.com> - 5.4.0-2
171- Split out papi-libs as separate subpackage. (#1172875)
172
173* Mon Nov 17 2014 William Cohen <wcohen@redhat.com> - 5.4.0-1
174- Rebase to papi-5.4.0.
175
176* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
178
179* Mon Aug 4 2014 William Cohen <wcohen@redhat.com> - 5.3.2-1
180- Rebase to 5.3.2.
181
182* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2.16.ga7f6159
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
184
185* Fri Jan 17 2014 Lukas Berk <lberk@redhat.com> - 5.3.0-1.16.ga7f6159
186- Automated weekly rawhide release
187
188* Thu Jan 16 2014 William Cohen <wcohen@redhat.com> - 5.3.0-1
189- Rebase to 5.3.0.
190
191* Tue Jan 14 2014 William Cohen <wcohen@redhat.com> - 5.2.0-5
192- Add presets for Intel Silvermont.
193
194* Mon Jan 13 2014 William Cohen <wcohen@redhat.com> - 5.2.0-4
195- Add presets for Haswell and Ivy Bridge.
196
197* Wed Aug 14 2013 William Cohen <wcohen@redhat.com> - 5.2.0-2
198- Enable infiniband and stealtime components.
199
200* Wed Aug 07 2013 William Cohen <wcohen@redhat.com> - 5.2.0-1
201- Rebase to 5.2.0
202
203* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-8
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
205
206* Wed Jul 24 2013 William Cohen <wcohen@redhat.com> - 5.1.1-7
207- rhbz830275 - Add support for POWER8 processor to PAPI
208
209* Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-6
210- Add autoconf buildrequires.
211
212* Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-5
213- rhbz986673 - /usr/lib64/libpapi.so is unowned
214- Package files in /usr/share/papi only once.
215- Avoid dependency problem with parallel make of man pages.
216
217* Fri Jul 19 2013 William Cohen <wcohen@redhat.com> - 5.1.1-4
218- Correct changelog.
219
220* Fri Jul 5 2013 William Cohen <wcohen@redhat.com> - 5.1.1-3
221- Add man page corrections/updates.
222
223* Fri Jun 28 2013 William Cohen <wcohen@redhat.com> - 5.1.1-2
224- Add testsuite subpackage.
225
226* Thu May 30 2013 William Cohen <wcohen@redhat.com> - 5.1.1-1
227- Rebase to 5.1.1
228
229* Mon Apr 15 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-2
230- Fix arm FTBS rhbz 951806.
231
232* Tue Apr 9 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-1
233- Rebase to 5.1.0.2
234
235* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-6
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
237
238* Mon Jan 14 2013 William Cohen <wcohen@redhat.com> - 5.0.1-5
239- Add armv7 cortex a15 presets.
240
241* Tue Dec 04 2012 William Cohen <wcohen@redhat.com> - 5.0.1-4
242- Disable ldconfig on install.
243
244* Thu Nov 08 2012 William Cohen <wcohen@redhat.com> - 5.0.1-3
245- Avoid duplicated shared library.
246
247* Wed Oct 03 2012 William Cohen <wcohen@redhat.com> - 5.0.1-2
248- Make sure using compatible version of libpfm.
249
250* Thu Sep 20 2012 William Cohen <wcohen@redhat.com> - 5.0.1-1
251- Rebase to 5.0.1.
252
253* Mon Sep 10 2012 William Cohen <wcohen@redhat.com> - 5.0.0-6
254- Back port fixes for Intel Ivy Bridge event presets.
255
256* Thu Aug 30 2012 William Cohen <wcohen@redhat.com> - 5.0.0-5
257- Fixes to make papi with unbundled libpfm.
258
259* Mon Aug 27 2012 William Cohen <wcohen@redhat.com> - 5.0.0-2
260- Keep libpfm unbundled.
261
262* Fri Aug 24 2012 William Cohen <wcohen@redhat.com> - 5.0.0-1
263- Rebase to 5.0.0.
264
265* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-5
266- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
267
268* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-4
269- Use siginfo_t rather than struct siginfo.
270
271* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-3
272- Correct build requires.
273
274* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-2
275- Unbundle libpfm4 from papi.
276- Correct description spellings.
277- Remove unused test section.
278
279* Fri Apr 20 2012 William Cohen <wcohen@redhat.com> - 4.4.0-1
280- Rebase to 4.4.0.
281
282* Fri Mar 9 2012 William Cohen <wcohen@redhat.com> - 4.2.1-2
283- Fix overrun in lmsensor component. (rhbz797692)
284
285* Tue Feb 14 2012 William Cohen <wcohen@redhat.com> - 4.2.1-1
286- Rebase to 4.2.1.
287
288* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4
289- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
290
291* Wed Nov 02 2011 William Cohen <wcohen@redhat.com> - 4.2.0-3
292- Remove unwanted man1/*.c.1 files. (rhbz749725)
293
294* Mon Oct 31 2011 William Cohen <wcohen@redhat.com> - 4.2.0-2
295- Include appropirate man pages with papi rpm. (rhbz749725)
296- Rebase to papi-4.2.0, fixup for coretemp component. (rhbz746851)
297
298* Thu Oct 27 2011 William Cohen <wcohen@redhat.com> - 4.2.0-1
299- Rebase to papi-4.2.0.
300
301* Fri Aug 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-3
302- Provide papi-static.
303
304* Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-2
305- Use corrected papi-4.1.3.
306
307* Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-1
308- Rebase to papi-4.1.3
309
310* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.1.2.1-2
311- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
312
313* Mon Jan 24 2011 William Cohen <wcohen@redhat.com> - 4.1.2.1-1
314- Rebase to papi-4.1.2.1
315
316* Fri Oct 1 2010 William Cohen <wcohen@redhat.com> - 4.1.1-1
317- Rebase to papi-4.1.1
318
319* Tue Jun 22 2010 William Cohen <wcohen@redhat.com> - 4.1.0-1
320- Rebase to papi-4.1.0
321
322* Mon May 17 2010 William Cohen <wcohen@redhat.com> - 4.0.0-5
323- Test run with upstream cvs version.
324
325* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-4
326- Resolves: rhbz562935 Rebase to papi-4.0.0 (correct ExcludeArch).
327
328* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-3
329- Resolves: rhbz562935 Rebase to papi-4.0.0 (bump nvr).
330
331* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-2
332- correct the ctests/shlib test
333- have PAPI_set_multiplex() return proper value
334- properly handle event unit masks
335- correct PAPI_name_to_code() to match events
336- Resolves: rhbz562935 Rebase to papi-4.0.0
337
338* Wed Jan 13 2010 William Cohen <wcohen@redhat.com> - 4.0.0-1
339- Generate papi.spec file for papi-4.0.0.
Note: See TracBrowser for help on using the repository browser.