source: projects/specs/trunk/p/pango/pango-vl.spec @ 1851

Revision 1851, 16.8 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21790]

Line 
1%define glib2_version 2.24.0
2%define pkgconfig_version 0.12
3%define freetype2_version 2.3.9
4%define cairo_version 1.8.8
5
6# biarch support
7%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
8%define _querymodules_suffix %{nil}
9%if %{build_compat32}
10%define _querymodules_suffix -32
11%endif
12
13Summary: System for layout and rendering of internationalized text.
14Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
15Name: pango
16Version: 1.28.1
17Release: 2%{?_dist_release}
18License: LGPL
19Group: System Environment/Libraries
20Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.26/pango-%{version}.tar.bz2
21URL: http://www.pango.org
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24# We need to prereq this so we can run pango-querymodules
25Requires: glib2 >= %{glib2_version}
26Requires: freetype2 >= %{freetype2_version}
27BuildRequires: libtool >= 1.4.2
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: pkgconfig >= %{pkgconfig_version}
30BuildRequires: freetype2-devel >= %{freetype2_version}
31BuildRequires: fontconfig-devel
32BuildRequires: libX11-devel, libXft-devel, libXrender
33BuildRequires: cairo-devel >= %{cairo_version}
34Obsoletes: pango-gtkbeta, fribidi-gtkbeta
35
36# Look for pango.modules in an arch-specific directory
37Patch0: pango-1.2.5-lib64.patch
38# biarch support (mdk)
39#Patch5: pango-1.2.5-lib64.patch.bz2
40
41
42%description
43Pango is a system for layout and rendering of internationalized text.
44
45%description -l ja
46Pango は国際化テキストのレイアウト・レンダリングシステムです。
47
48
49%package devel
50Summary: System for layout and rendering of internationalized text.
51Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
52Group: Development/Libraries
53Requires: pango = %{version}
54Requires: glib2-devel >= %{glib2_version}
55Requires: freetype2-devel >= %{freetype2_version}
56Requires: cairo-devel >= %{cairo_version}
57Requires: libX11-devel, libXft-devel, libXrender
58Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
59
60%description devel
61The pango-devel package includes the static libraries, header files,
62and developer docs for the pango package.
63
64Install pango-devel if you want to develop programs which will use
65pango.
66
67#####################################################################
68# compat32
69%package -n compat32-%{name}
70Summary: System for layout and rendering of internationalized text.
71Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
72Group: Development/Libraries
73%description -n compat32-%{name}
74Pango is a system for layout and rendering of internationalized text.
75%description -n compat32-%{name} -l ja
76Pango は国際化テキストのレイアウト・レンダリングシステムです。
77
78%package -n compat32-%{name}-devel
79Summary: Development files for pango
80Summary(ja): pango 用の開発ファイル
81Group: Development/Libraries
82Requires: compat32-%{name} = %{version}
83Requires: %{name}-devel = %{version}
84%description -n compat32-%{name}-devel
85The pango-devel package includes the static libraries, header files,
86and developer docs for the pango package.
87
88
89%prep
90%setup -q -n pango-%{version}
91%patch0 -p1 -b .lib64
92
93%build
94%configure --with-included-modules=basic-fc
95make %{?_smp_mflags}
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make DESTDIR=$RPM_BUILD_ROOT install
100
101# biarch support
102mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
103touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
104
105%if %{build_compat32}
106cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
107   $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
108%endif
109
110# remove unpackaged files
111rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
112rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
113rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post
119/sbin/ldconfig
120%{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
121
122%postun -p /sbin/ldconfig
123
124%if %{build_compat32}
125%post -n compat32-%{name}
126/sbin/ldconfig
127%{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
128
129%postun -p /sbin/ldconfig -n compat32-%{name}
130%endif
131
132%files
133%defattr(-, root, root)
134%doc README AUTHORS COPYING NEWS
135%doc pango-view/HELLO.txt
136#doc README AUTHORS COPYING ChangeLog
137#doc examples/HELLO.utf8
138%{_bindir}/pango-querymodules
139%{_bindir}/pango-view
140%{_libdir}/libpango*-*.so.*
141%{_libdir}/pango
142%{_mandir}/man*/*
143%dir %{_sysconfdir}/pango
144%config %{_sysconfdir}/pango/pangox.aliases
145%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
146
147%files devel
148%defattr(-, root, root)
149%{_libdir}/libpango*.so
150%{_includedir}/*
151%{_libdir}/pkgconfig/*
152%{_datadir}/gtk-doc/*
153
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-, root, root)
157%{_libdir}/libpango*-*.so.*
158%{_bindir}/pango-querymodules%{_querymodules_suffix}
159%{_libdir}/pango
160%dir %{_sysconfdir}/pango/%{_arch}
161%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/libpango*.so
166%{_libdir}/pkgconfig/*
167%endif
168
169%changelog
170* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
171- build with rpm-4.8.1-1 for pkg-config file
172
173* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
174- new upstream release
175
176* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
177- new upstream release
178
179* Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
180- changed %%makeinstall to make install with DESTDIR option
181
182* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
183- new upstream release
184
185* Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
186- new upstream release
187
188* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
189- new upstream release
190
191* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
192- new upstream release
193
194* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
195- new upstream release
196
197* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
198- new upstream release
199
200* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
201- removed %%if !%%{build_compat32} case condition
202
203* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
204- new upstream release
205
206* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
207- new upstream release
208
209* Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
210- new upstream release
211
212* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
213- new upstream release
214
215* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
216- new upstream release
217
218* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
219- new upstream release
220
221* Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
222- new upstream release
223
224* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
225- spec in UTF-8 actually
226
227* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
228- new upstream release
229- rebuilt with xorg-x11 7.3
230
231* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
232- new upstream release
233
234* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
235- used %{?_dist_release}
236
237* Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
238- new upstream release
239
240* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
241- new upstream release
242
243* Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
244- new upstream release
245- added Patch0 instead of Patch5
246
247* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
248- replace build with new environment
249
250* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
251- rebuild with new environment
252
253* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
254- new upstream release
255
256* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
257- new upstream release
258
259* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
260- new upstream release
261
262* Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
263- new upstream release
264
265* Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
266- new upstream release
267
268* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
269- new upstream release
270
271* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
272- rebuild with cairo-1.2.0
273
274* Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
275- add Patch10 to create fake style(italic/bold) for all fonts.
276  http://bugzilla.gnome.org/show_bug.cgi?id=319808
277  - This patch is not applied in upstream, but it seems usefull
278    for us.
279
280* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
281- new upstream release
282
283* Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
284- new upstream release
285
286* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
287- new upstream release
288
289* Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
290- fix broken dependancy
291
292* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
293- new upstream release
294
295* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
296- new upstream release
297- add compat32 package for x86_64 arch support
298- add Patch5 for biarch support
299
300* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
301- new upstream release
302
303* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
304- new upstream release
305
306* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
307- new upstream release
308
309* Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
310- rebuild with cairo-0.9
311- add patch10 to disable building example programs
312
313* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
314- new upstream release
315
316* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
317- new upstream release
318- drop obsolete patches
319
320* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
321- new upstream release
322- import upstream patches from fedora package.
323
324* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
325- new upstream release
326
327* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
328- new upstream release
329
330* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
331- remove unneeded dependancy to freetype2-devel
332
333* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
334- add patch10 to build against freetype-2.1.7
335- rebuild with freetype-2.1.7
336
337* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
338- new upstream release
339
340* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
341- new upstream release
342
343* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
344- new upstream release
345
346* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
347- merge patch1,2 from rawhide package.
348
349* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
350- new upstream release
351
352* Thu Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
353- new upstream release
354- Build for Vine Linux, specfile are based on rawhide release
355
356* Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
357- change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
358
359* Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
360- explicitly require pangoxft to be built, so we catch situations such
361  as xft.pc moving to /usr/X11R6
362- also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
363  hack
364
365* Thu Nov  7 2002 Havoc Pennington <hp@redhat.com>
366- 1.1.3
367
368* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
369- Require the necessary freetype version, don't just
370  BuildRequires it (#74744)
371
372* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
373- Own /etc/pango (#73962, Enrico Scholz)
374- Remove .la files from the build root
375
376* Mon Oct  7 2002 Havoc Pennington <hp@redhat.com>
377- require glib 2.0.6-3, try rebuild on more arches
378
379* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
380- Version 1.1.1 (main change, fixes font selection for FT2 backend,
381  as in gdmgreeter)
382
383* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
384- Fix linked list manipulation problem that was causing hang for anaconda
385- Fix warning from loading mini-fonts with context == NULL
386
387* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
388- Fix major memory leak in the last patch
389
390* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
391- Actually use language tags at the rendering layer (should fix #68211)
392
393* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
394- Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
395- Fix bug causing hex boxes to be misrendered
396  leaving RPATH (#66005)
397- For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
398  fonts with embedded bitmaps (#67851)
399
400* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
401- Make basic-x shaper work with our big-5 fonts
402
403* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
404- New upstream tarball with hooks for change-on-the fly font rendering
405
406* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
407- Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
408  ABI changes for pango's OpenType code.
409
410* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
411- Add some Korean aliases that the installer wants
412
413* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
414- automated rebuild
415
416* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
417- devel package requires fontconfig/Xft devel packages
418
419* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
420- rebuild in different environment
421
422* Thu Jun  6 2002 Owen Taylor <otaylor@redhat.com>
423- Snapshot with Xft2/fontconfig support
424
425* Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
426- Version 1.0.2
427- Patch for charmaps problem
428
429* Sun May 26 2002 Tim Powers <timp@redhat.com>
430- automated rebuild
431
432* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
433- rebuild in different environment
434
435* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
436- add patch to adjust to newer version of freetype
437
438* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
439- Update to version 1.0.1, remove patch
440
441* Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
442- Patch from CVS for big speedup with FreeType-2.0.9
443
444* Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
445- Rebuild
446
447* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
448- Version 1.0.0
449
450* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
451- Update to 0.26
452
453* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
454- Bump for rebuild
455
456* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
457- Update to 0.25
458
459* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
460- add horrible buildrequires hack
461
462* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
463- 0.24.90 cvs snap
464
465* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
466- Version 0.24
467
468* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
469- automated rebuild
470
471* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
472- new snap 0.23.90
473
474* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
475- rebuild with 64-bit-fixed glib
476
477* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
478- Version 0.22
479- add explicit check for required glib2 version before we do the build,
480  so we don't end up with bad RPMs on --nodeps builds
481- PreReq the glib2_version version, instead of 1.3.8 hardcoded that
482  no one had updated recently
483
484* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
485- Version 0.21
486
487* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
488- cvs snap
489- new cvs snap with a bugfix
490
491* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
492- sync with Owen's changes, fix up dependency versions
493
494* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
495- 0.19
496
497* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
498- build CVS snap
499
500* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
501- no relinking junk
502
503* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
504- Version 0.18
505
506* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
507- Configure --disable-gtk-doc
508- BuildRequires freetype-devel, XFree86-devel
509
510* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
511- 0.17
512- libtool hackarounds
513
514* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
515- 0.16, rename back to pango from pango-gtkbeta
516
517* Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
518- Obsolete fribidi-gtkbeta
519
520* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
521- Remove that patch I just put in
522
523* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
524- Patch pangox.pc.in to include -Iincludedir
525
526* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
527- final 0.13
528
529* Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
530- New 0.13 tarball
531
532* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
533- 0.13pre1
534
535* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
536- Rename to 0.12b to avoid versioning problems
537
538* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
539- Move to a CVS snapshot
540
541* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
542- Move back to /usr
543- Version 0.12
544
545* Mon Jun 19 2000  Owen Taylor <otaylor@redhat.com>
546- Add missing %%defattr
547
548* Thu Jun 8 2000  Owen Taylor <otaylor@redhat.com>
549- Rebuild with a prefix of /opt/gtk-beta
550
551* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
552- version 0.11
553- add --without-qt
554
555* Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
556- Make the devel package require *-gtkbeta-* not the normal packages.
557
558* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
559- GTK+ snapshot version installing in /opt/gtk-beta
560
561* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
562- Created spec file
Note: See TracBrowser for help on using the repository browser.