source: projects/specs/trunk/p/pango/pango-vl.spec @ 1231

Revision 1231, 16.7 KB checked in by Takemikaduchi, 14 years ago (diff)

update libchamplain, libgda, anjuta, evolution, ekiga, evolution-data-server, gnome-python-desktop, gmime, glibmm, gtkhtml3, gtksourceview2, gnome-color-manager, gtkmm2, opal, pango, ptlib, tracker, totem-pl-parser

Line 
1%define glib2_version 2.24.0
2%define pkgconfig_version 0.12
3%define freetype2_version 2.3.9
4%define cairo_version 1.8.8
5
6# biarch support
7%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
8%define _querymodules_suffix %{nil}
9%if %{build_compat32}
10%define _querymodules_suffix -32
11%endif
12
13Summary: System for layout and rendering of internationalized text.
14Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
15Name: pango
16Version: 1.28.1
17Release: 1%{?_dist_release}
18License: LGPL
19Group: System Environment/Libraries
20Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.26/pango-%{version}.tar.bz2
21URL: http://www.pango.org
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24# We need to prereq this so we can run pango-querymodules
25Requires: glib2 >= %{glib2_version}
26Requires: freetype2 >= %{freetype2_version}
27BuildRequires: libtool >= 1.4.2
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: pkgconfig >= %{pkgconfig_version}
30BuildRequires: freetype2-devel >= %{freetype2_version}
31BuildRequires: fontconfig-devel
32BuildRequires: libX11-devel, libXft-devel, libXrender
33BuildRequires: cairo-devel >= %{cairo_version}
34Obsoletes: pango-gtkbeta, fribidi-gtkbeta
35
36# Look for pango.modules in an arch-specific directory
37Patch0: pango-1.2.5-lib64.patch
38# biarch support (mdk)
39#Patch5: pango-1.2.5-lib64.patch.bz2
40
41
42%description
43Pango is a system for layout and rendering of internationalized text.
44
45%description -l ja
46Pango は国際化テキストのレイアウト・レンダリングシステムです。
47
48
49%package devel
50Summary: System for layout and rendering of internationalized text.
51Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
52Group: Development/Libraries
53Requires: pango = %{version}
54Requires: glib2-devel >= %{glib2_version}
55Requires: freetype2-devel >= %{freetype2_version}
56Requires: cairo-devel >= %{cairo_version}
57Requires: libX11-devel, libXft-devel, libXrender
58Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
59
60%description devel
61The pango-devel package includes the static libraries, header files,
62and developer docs for the pango package.
63
64Install pango-devel if you want to develop programs which will use
65pango.
66
67#####################################################################
68# compat32
69%package -n compat32-%{name}
70Summary: System for layout and rendering of internationalized text.
71Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
72Group: Development/Libraries
73%description -n compat32-%{name}
74Pango is a system for layout and rendering of internationalized text.
75%description -n compat32-%{name} -l ja
76Pango は国際化テキストのレイアウト・レンダリングシステムです。
77
78%package -n compat32-%{name}-devel
79Summary: Development files for pango
80Summary(ja): pango 用の開発ファイル
81Group: Development/Libraries
82Requires: compat32-%{name} = %{version}
83Requires: %{name}-devel = %{version}
84%description -n compat32-%{name}-devel
85The pango-devel package includes the static libraries, header files,
86and developer docs for the pango package.
87
88
89%prep
90%setup -q -n pango-%{version}
91%patch0 -p1 -b .lib64
92
93%build
94%configure --with-included-modules=basic-fc
95make %{?_smp_mflags}
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make DESTDIR=$RPM_BUILD_ROOT install
100
101# biarch support
102mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
103touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
104
105%if %{build_compat32}
106cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
107   $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
108%endif
109
110# remove unpackaged files
111rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
112rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
113rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post
119/sbin/ldconfig
120%{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
121
122%postun -p /sbin/ldconfig
123
124%if %{build_compat32}
125%post -n compat32-%{name}
126/sbin/ldconfig
127%{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
128
129%postun -p /sbin/ldconfig -n compat32-%{name}
130%endif
131
132%files
133%defattr(-, root, root)
134%doc README AUTHORS COPYING NEWS
135%doc pango-view/HELLO.txt
136#doc README AUTHORS COPYING ChangeLog
137#doc examples/HELLO.utf8
138%{_bindir}/pango-querymodules
139%{_bindir}/pango-view
140%{_libdir}/libpango*-*.so.*
141%{_libdir}/pango
142%{_mandir}/man*/*
143%dir %{_sysconfdir}/pango
144%config %{_sysconfdir}/pango/pangox.aliases
145%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
146
147%files devel
148%defattr(-, root, root)
149%{_libdir}/libpango*.so
150%{_includedir}/*
151%{_libdir}/pkgconfig/*
152%{_datadir}/gtk-doc/*
153
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-, root, root)
157%{_libdir}/libpango*-*.so.*
158%{_bindir}/pango-querymodules%{_querymodules_suffix}
159%{_libdir}/pango
160%dir %{_sysconfdir}/pango/%{_arch}
161%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/libpango*.so
166%{_libdir}/pkgconfig/*
167%endif
168
169%changelog
170* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
171- new upstream release
172
173* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
174- new upstream release
175
176* Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
177- changed %%makeinstall to make install with DESTDIR option
178
179* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
180- new upstream release
181
182* Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
183- new upstream release
184
185* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
186- new upstream release
187
188* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
189- new upstream release
190
191* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
192- new upstream release
193
194* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
195- new upstream release
196
197* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
198- removed %%if !%%{build_compat32} case condition
199
200* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
201- new upstream release
202
203* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
204- new upstream release
205
206* Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
207- new upstream release
208
209* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
210- new upstream release
211
212* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
213- new upstream release
214
215* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
216- new upstream release
217
218* Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
219- new upstream release
220
221* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
222- spec in UTF-8 actually
223
224* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
225- new upstream release
226- rebuilt with xorg-x11 7.3
227
228* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
229- new upstream release
230
231* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
232- used %{?_dist_release}
233
234* Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
235- new upstream release
236
237* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
238- new upstream release
239
240* Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
241- new upstream release
242- added Patch0 instead of Patch5
243
244* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
245- replace build with new environment
246
247* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
248- rebuild with new environment
249
250* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
251- new upstream release
252
253* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
254- new upstream release
255
256* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
257- new upstream release
258
259* Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
260- new upstream release
261
262* Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
263- new upstream release
264
265* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
266- new upstream release
267
268* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
269- rebuild with cairo-1.2.0
270
271* Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
272- add Patch10 to create fake style(italic/bold) for all fonts.
273  http://bugzilla.gnome.org/show_bug.cgi?id=319808
274  - This patch is not applied in upstream, but it seems usefull
275    for us.
276
277* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
278- new upstream release
279
280* Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
281- new upstream release
282
283* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
284- new upstream release
285
286* Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
287- fix broken dependancy
288
289* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
290- new upstream release
291
292* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
293- new upstream release
294- add compat32 package for x86_64 arch support
295- add Patch5 for biarch support
296
297* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
298- new upstream release
299
300* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
301- new upstream release
302
303* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
304- new upstream release
305
306* Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
307- rebuild with cairo-0.9
308- add patch10 to disable building example programs
309
310* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
311- new upstream release
312
313* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
314- new upstream release
315- drop obsolete patches
316
317* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
318- new upstream release
319- import upstream patches from fedora package.
320
321* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
322- new upstream release
323
324* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
325- new upstream release
326
327* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
328- remove unneeded dependancy to freetype2-devel
329
330* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
331- add patch10 to build against freetype-2.1.7
332- rebuild with freetype-2.1.7
333
334* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
335- new upstream release
336
337* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
338- new upstream release
339
340* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
341- new upstream release
342
343* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
344- merge patch1,2 from rawhide package.
345
346* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
347- new upstream release
348
349* Thu Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
350- new upstream release
351- Build for Vine Linux, specfile are based on rawhide release
352
353* Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
354- change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
355
356* Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
357- explicitly require pangoxft to be built, so we catch situations such
358  as xft.pc moving to /usr/X11R6
359- also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
360  hack
361
362* Thu Nov  7 2002 Havoc Pennington <hp@redhat.com>
363- 1.1.3
364
365* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
366- Require the necessary freetype version, don't just
367  BuildRequires it (#74744)
368
369* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
370- Own /etc/pango (#73962, Enrico Scholz)
371- Remove .la files from the build root
372
373* Mon Oct  7 2002 Havoc Pennington <hp@redhat.com>
374- require glib 2.0.6-3, try rebuild on more arches
375
376* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
377- Version 1.1.1 (main change, fixes font selection for FT2 backend,
378  as in gdmgreeter)
379
380* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
381- Fix linked list manipulation problem that was causing hang for anaconda
382- Fix warning from loading mini-fonts with context == NULL
383
384* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
385- Fix major memory leak in the last patch
386
387* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
388- Actually use language tags at the rendering layer (should fix #68211)
389
390* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
391- Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
392- Fix bug causing hex boxes to be misrendered
393  leaving RPATH (#66005)
394- For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
395  fonts with embedded bitmaps (#67851)
396
397* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
398- Make basic-x shaper work with our big-5 fonts
399
400* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
401- New upstream tarball with hooks for change-on-the fly font rendering
402
403* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
404- Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
405  ABI changes for pango's OpenType code.
406
407* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
408- Add some Korean aliases that the installer wants
409
410* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
411- automated rebuild
412
413* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
414- devel package requires fontconfig/Xft devel packages
415
416* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
417- rebuild in different environment
418
419* Thu Jun  6 2002 Owen Taylor <otaylor@redhat.com>
420- Snapshot with Xft2/fontconfig support
421
422* Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
423- Version 1.0.2
424- Patch for charmaps problem
425
426* Sun May 26 2002 Tim Powers <timp@redhat.com>
427- automated rebuild
428
429* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
430- rebuild in different environment
431
432* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
433- add patch to adjust to newer version of freetype
434
435* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
436- Update to version 1.0.1, remove patch
437
438* Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
439- Patch from CVS for big speedup with FreeType-2.0.9
440
441* Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
442- Rebuild
443
444* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
445- Version 1.0.0
446
447* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
448- Update to 0.26
449
450* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
451- Bump for rebuild
452
453* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
454- Update to 0.25
455
456* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
457- add horrible buildrequires hack
458
459* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
460- 0.24.90 cvs snap
461
462* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
463- Version 0.24
464
465* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
466- automated rebuild
467
468* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
469- new snap 0.23.90
470
471* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
472- rebuild with 64-bit-fixed glib
473
474* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
475- Version 0.22
476- add explicit check for required glib2 version before we do the build,
477  so we don't end up with bad RPMs on --nodeps builds
478- PreReq the glib2_version version, instead of 1.3.8 hardcoded that
479  no one had updated recently
480
481* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
482- Version 0.21
483
484* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
485- cvs snap
486- new cvs snap with a bugfix
487
488* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
489- sync with Owen's changes, fix up dependency versions
490
491* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
492- 0.19
493
494* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
495- build CVS snap
496
497* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
498- no relinking junk
499
500* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
501- Version 0.18
502
503* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
504- Configure --disable-gtk-doc
505- BuildRequires freetype-devel, XFree86-devel
506
507* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
508- 0.17
509- libtool hackarounds
510
511* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
512- 0.16, rename back to pango from pango-gtkbeta
513
514* Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
515- Obsolete fribidi-gtkbeta
516
517* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
518- Remove that patch I just put in
519
520* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
521- Patch pangox.pc.in to include -Iincludedir
522
523* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
524- final 0.13
525
526* Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
527- New 0.13 tarball
528
529* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
530- 0.13pre1
531
532* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
533- Rename to 0.12b to avoid versioning problems
534
535* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
536- Move to a CVS snapshot
537
538* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
539- Move back to /usr
540- Version 0.12
541
542* Mon Jun 19 2000  Owen Taylor <otaylor@redhat.com>
543- Add missing %%defattr
544
545* Thu Jun 8 2000  Owen Taylor <otaylor@redhat.com>
546- Rebuild with a prefix of /opt/gtk-beta
547
548* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
549- version 0.11
550- add --without-qt
551
552* Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
553- Make the devel package require *-gtkbeta-* not the normal packages.
554
555* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
556- GTK+ snapshot version installing in /opt/gtk-beta
557
558* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
559- Created spec file
Note: See TracBrowser for help on using the repository browser.