source: projects/specs/trunk/p/pandoc/pandoc-vl.spec @ 10917

Revision 10917, 6.3 KB checked in by ara_t, 7 years ago (diff)

pandoc: rebuild with ghc-8.0.1

Line 
1%define pkg_name    pandoc
2%define pkg_version 1.17.1
3%define pkg_release 2%{?_dist_release}
4
5%define ghc_version 8.0.1
6
7Summary:     general markup converter
8Summary(ja): 汎用マークアップ変換ツール
9
10Name:    %{pkg_name}
11Version: %{pkg_version}
12Release: %{pkg_release}
13
14License: GPLv2+
15Group:   Applications/Text
16URL:     http://hackage.haskell.org
17
18Source0: pandoc-%{pkg_version}/pandoc-%{pkg_version}.tar.gz
19Source1: pandoc.cabal
20
21BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
22
23BuildRequires: ghc haskell-platform
24BuildRequires: libffi-devel gmp-devel zlib-devel
25
26BuildRequires: libghc-data-default-class
27BuildRequires: libghc-dlist
28BuildRequires: libghc-data-default
29BuildRequires: libghc-aeson
30# BuildRequires: libghc-http-client-tls
31BuildRequires: yaml
32BuildRequires: libghc-build-pandoc
33
34BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
35
36Requires: libffi
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: ara_t
41
42
43%description
44Pandoc is a Haskell library for converting from one markup format to another,
45 and a command-line tool that uses this library.
46It can read markdown and (subsets of) HTML, reStructuredText, LaTeX, DocBook,
47MediaWiki markup, Haddock markup, OPML, Emacs Org-mode, and Textile,
48 and it can write markdown, reStructuredText, HTML,
49LaTeX (including rendering as plain PDF or beamer slide shows),
50ConTeXt, DocBook, OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki, Textile,
51 groff man pages, GNU Texinfo, plain text, Emacs Org-Mode, AsciiDoc, InDesign
52 ICML, EPUB (v2 or v3), FictionBook2, and several kinds of HTML/javascript
53 slide shows  (S5, Slidy, Slideous, DZSlides, reveal.js).
54
55Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
56 definition lists, tables, and other features.
57A compatibility mode is provided for those who need a drop-in replacement for
58 Markdown.pl.
59
60In contrast to existing tools for converting markdown to HTML,
61 which use regex substitutions, pandoc has a modular design:
62 it consists of a set of readers, which parse text in a given format
63 and produce a native representation of the document,
64 and a set of writers, which convert this native representation into a target
65 format.
66Thus, adding an input or output format requires only adding a reader or writer.
67
68%description -l ja
69Pandoc はあるマークアップ形式から別の形式に変換するHaskellライブラリで、
70また、このライブラリを使ったコマンドラインツールです。
71markdown、HTML (のサブセット)、reStructuredText、 LaTeX、DocBook、
72MediaWikiマークアップ、Haddockマークアップ、OPML、Emacs Org-mode、
73およびTextileを読み取り、
74markdown、reStructuredText、HTML、LaTeX (プレインPDFまたはbeamerスライドショー
75での描画を含む)、ConTeXt、DocBook、OPML、OpenDocument、ODT、Word docx、RTF、
76MediaWiki、Textile、groff manページ、GNU Texinfo、プレーンテキスト、
77Emacs Org-Mode、AsciiDoc、InDesign ICML、EPUB (v2 または v3)、FictionBook2、
78およびいくつかの種類のHTML/javascriptスライドショー
79(S5, Slidy, Slideous, DZSlides, reveal.js) に書き出せます。
80
81Pandocは標準的なmarkdownの文法に脚注、組み込み LaTeX、定義リスト、表、
82およびその他の機能を拡張しています。
83Markdown.plの気軽な置き換えを希望する方向けに互換モードを提供しています。
84
85markdownからHTMLに変換する既存のツールは正規表現で置換していますが、
86これらとは異なり、pandoc はモジュール式の設計になっています:
87テキストを指定された形式でパースし、文書のネイティブ表現を生成するリーダ一式、
88および、このネイティブ表現を対象とする形式に変換するライタ一式で構成されて
89います。したがって、入力または出力形式を追加するにはリーダやライタを追加する
90ことだけが必要です。
91
92
93%package libs
94Summary:  Library of pandoc
95Group:    Development/Libraries
96
97%description libs
98Librariy of pandoc for building pandoc-citeproc and pandoc-crossref
99
100
101%prep
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%{__rm} -rf %{_builddir}/package.conf
104%{__rm} -rf ${HOME}/.ghc
105%setup -q
106
107%build
108# Initialise the package db
109ghc-pkg init %{_builddir}/package.conf
110
111PKG_CONF_DIR=${RPM_BUILD_ROOT}%{_libdir}/ghc-%{ghc_version}/package.conf.d
112%{__rm} -rf ${PKG_CONF_DIR}
113%{__mkdir_p} ${PKG_CONF_DIR}
114
115%{__cp} %{SOURCE1} .
116cabal configure \
117    --prefix=%{_prefix} \
118    --libdir=%{_libdir}/%{name}-%{version} \
119    --libsubdir= \
120    --datadir=%{_datadir}/%{name}-%{version} \
121    --datasubdir= \
122    --docdir=%{_docdir}/%{name}-%{version}
123
124cabal build
125cabal haddock
126cabal copy --destdir=${RPM_BUILD_ROOT}
127cabal register --gen-pkg-config=${PKG_CONF_DIR}/%{name}.conf
128
129%install
130%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
131%{__cp} BUGS changelog CONTRIBUTING.md COPYING COPYRIGHT README \
132 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
133%{__rm} ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/{COPYRIGHT,README}
134
135%{__mv} ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man \
136 ${RPM_BUILD_ROOT}%{_datadir}
137
138%clean
139%{__rm} -rf ${RPM_BUILD_ROOT}
140
141%post libs
142ghc-pkg recache
143
144%postun libs
145ghc-pkg recache
146
147
148%files
149%defattr(-, root, root)
150%{_bindir}/pandoc
151%{_datadir}/%{name}-%{version}/
152%{_docdir}/%{name}-%{version}/
153%{_mandir}/man1/pandoc.1.gz
154
155%files libs
156%defattr(-, root, root)
157%{_libdir}/%{name}-%{version}/
158%{_libdir}/ghc-%{ghc_version}/
159
160
161%changelog
162* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-2
163- rebuild using ghc-8.0.1
164
165* Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
166- update to 1.17.1
167
168* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-5
169- update to 1.17.0.3
170- add BuildRequires: libghc-build-pandoc
171- provide pandoc-libs for building pandoc-citeproc and pacdoc-crossref
172- delete subpackages: pandoc-citeproc and pacdoc-crossref
173
174* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-5
175- correct SPEC file
176
177* Mon Mar 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-4
178- correct pandoc-citeproc error
179
180* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
181- rebuild under dependent rpm packages
182
183* Sun Feb 21 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
184- rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
185
186* Sun Feb 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-1
187- new package
Note: See TracBrowser for help on using the repository browser.