source: projects/specs/trunk/p/pandoc/pandoc-vl.spec @ 11989

Revision 11989, 6.8 KB checked in by ara_t, 5 years ago (diff)

pandoc: update to 2.4

Line 
1%define pkg_name    pandoc
2%define pkg_version 2.4
3%define pkg_release 1%{?_dist_release}
4
5Summary:     general markup converter
6Summary(ja): 汎用マークアップ変換ツール
7
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License: GPLv2+
13Group:   Applications/Text
14URL:     http://hackage.haskell.org
15
16Source0: packages
17
18Source11: pandoc-2.4.tar.gz
19Source12: pandoc.cabal
20
21BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
22
23BuildRequires: ghc haskell-platform
24BuildRequires: libffi-devel gmp-devel zlib-devel
25
26BuildRequires: libghc-data-default-class
27BuildRequires: libghc-dlist
28BuildRequires: libghc-old-locale
29BuildRequires: libghc-aeson
30BuildRequires: libghc-semigroups
31BuildRequires: libghc-http-client-tls
32BuildRequires: libghc-haddock-library
33BuildRequires: libghc-build-pandoc
34
35BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
36
37Requires: libffi
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: ara_t
42
43
44%description
45Pandoc is a Haskell library for converting from one markup format to another,
46 and a command-line tool that uses this library.
47It can read markdown and (subsets of) HTML, reStructuredText, LaTeX, DocBook,
48MediaWiki markup, Haddock markup, OPML, Emacs Org-mode, and Textile,
49 and it can write markdown, reStructuredText, HTML,
50LaTeX (including rendering as plain PDF or beamer slide shows),
51ConTeXt, DocBook, OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki, Textile,
52 groff man pages, GNU Texinfo, plain text, Emacs Org-Mode, AsciiDoc, InDesign
53 ICML, EPUB (v2 or v3), FictionBook2, and several kinds of HTML/javascript
54 slide shows  (S5, Slidy, Slideous, DZSlides, reveal.js).
55
56Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
57 definition lists, tables, and other features.
58A compatibility mode is provided for those who need a drop-in replacement for
59 Markdown.pl.
60
61In contrast to existing tools for converting markdown to HTML,
62 which use regex substitutions, pandoc has a modular design:
63 it consists of a set of readers, which parse text in a given format
64 and produce a native representation of the document,
65 and a set of writers, which convert this native representation into a target
66 format.
67Thus, adding an input or output format requires only adding a reader or writer.
68
69%description -l ja
70Pandoc はあるマークアップ形式から別の形式に変換するHaskellライブラリで、
71また、このライブラリを使ったコマンドラインツールです。
72markdown、HTML (のサブセット)、reStructuredText、 LaTeX、DocBook、
73MediaWikiマークアップ、Haddockマークアップ、OPML、Emacs Org-mode、
74およびTextileを読み取り、
75markdown、reStructuredText、HTML、LaTeX (プレインPDFまたはbeamerスライドショー
76での描画を含む)、ConTeXt、DocBook、OPML、OpenDocument、ODT、Word docx、RTF、
77MediaWiki、Textile、groff manページ、GNU Texinfo、プレーンテキスト、
78Emacs Org-Mode、AsciiDoc、InDesign ICML、EPUB (v2 または v3)、FictionBook2、
79およびいくつかの種類のHTML/javascriptスライドショー
80(S5, Slidy, Slideous, DZSlides, reveal.js) に書き出せます。
81
82Pandocは標準的なmarkdownの文法に脚注、組み込み LaTeX、定義リスト、表、
83およびその他の機能を拡張しています。
84Markdown.plの気軽な置き換えを希望する方向けに互換モードを提供しています。
85
86markdownからHTMLに変換する既存のツールは正規表現で置換していますが、
87これらとは異なり、pandoc はモジュール式の設計になっています:
88テキストを指定された形式でパースし、文書のネイティブ表現を生成するリーダ一式、
89および、このネイティブ表現を対象とする形式に変換するライタ一式で構成されて
90います。したがって、入力または出力形式を追加するにはリーダやライタを追加する
91ことだけが必要です。
92
93
94%package libs
95Summary:  Library of pandoc
96Group:    Development/Libraries
97
98Requires: haskell-platform-dep
99Requires: libghc-data-default-class
100Requires: libghc-dlist
101Requires: libghc-old-locale
102Requires: libghc-aeson
103Requires: libghc-semigroups
104Requires: libghc-http-client-tls
105Requires: libghc-haddock-library
106Requires: libghc-build-pandoc
107
108%description libs
109Librariy of pandoc for building pandoc-citeproc and pandoc-crossref
110
111
112%prep
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115%build
116%ghc_pkg_init
117
118cd %{_builddir}
119for pkg in `cat %{SOURCE0}`; do
120    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
121    pushd ${pkg}
122        %ghc_fix_dependencies ${pkg}
123        %cabal_configure1 ${pkg}
124        %cabal_build
125        %cabal_haddock
126        %cabal_copy_resister ${pkg}
127    popd
128done
129
130
131%install
132%{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
133
134# copy documents and mannual
135pushd %{_builddir}/%{name}-%{version}
136    %{__cp} \
137     BUGS changelog CONTRIBUTING.md COPYING.md COPYRIGHT \
138     MANUAL.txt README.md \
139     ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
140    %{__cp} man/pandoc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/
141popd
142
143
144%clean
145%{__rm} -rf ${RPM_BUILD_ROOT}
146
147%post libs
148%ghc_pkg_recache
149
150%postun libs
151%ghc_pkg_recache
152
153
154%files
155%defattr(-, root, root)
156%{_bindir}/pandoc
157%{_datadir}/%{name}-%{version}/
158%{_docdir}/%{name}-%{version}/
159%{_mandir}/man1/
160
161%files libs
162%defattr(-, root, root)
163%{_libdir}/ghc-%{ghc_version}/
164%{_libdir}/ghc-lib/%{name}-%{version}/
165
166
167%changelog
168* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 2.4-1
169- update to 2.4
170- build using ghc-8.6.3
171
172* Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3.2-1
173- update to 2.2.3.2
174- build using ghc-8.4.3-2
175- drop BuildRequires: yaml
176
177* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 2.2.2-1
178- update to 2.2.2
179- build using ghc-8.4.3
180
181* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
182- update to 2.2.1
183- rebuild using ghc-8.4.2
184- rewrite using macro
185
186* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
187- update to 2.0.6
188- build using ghc-8.2.2
189
190* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-2
191- update to 1.19.2.1
192- build using ghc-8.0.2
193
194* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-2
195- rebuild using ghc-8.0.1
196
197* Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
198- update to 1.17.1
199
200* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-5
201- update to 1.17.0.3
202- add BuildRequires: libghc-build-pandoc
203- provide pandoc-libs for building pandoc-citeproc and pacdoc-crossref
204- delete subpackages: pandoc-citeproc and pacdoc-crossref
205
206* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-5
207- correct SPEC file
208
209* Mon Mar 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-4
210- correct pandoc-citeproc error
211
212* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
213- rebuild under dependent rpm packages
214
215* Sun Feb 21 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
216- rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
217
218* Sun Feb 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-1
219- new package
Note: See TracBrowser for help on using the repository browser.