source: projects/specs/trunk/p/pandoc/pandoc-vl.spec @ 11635

Revision 11635, 6.5 KB checked in by ara_t, 6 years ago (diff)

pandoc: new upstream release (build with ghc-8.4.2)

RevLine 
[10163]1%define pkg_name    pandoc
[11635]2%define pkg_version 2.2.1
[11217]3%define pkg_release 1%{?_dist_release}
[10163]4
5Summary:     general markup converter
6Summary(ja): 汎用マークアップ変換ツール
7
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License: GPLv2+
13Group:   Applications/Text
14URL:     http://hackage.haskell.org
15
[11635]16Source0: packages
[10163]17
[11635]18Source11: pandoc-2.2.1.tar.gz
19Source12: pandoc.cabal
20
[10163]21BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
22
[10917]23BuildRequires: ghc haskell-platform
[10163]24BuildRequires: libffi-devel gmp-devel zlib-devel
25
26BuildRequires: libghc-data-default-class
27BuildRequires: libghc-dlist
[11635]28BuildRequires: libghc-old-locale
[10163]29BuildRequires: libghc-aeson
[11635]30BuildRequires: libghc-semigroups
[10163]31BuildRequires: yaml
[11635]32BuildRequires: libghc-http-client-tls
33BuildRequires: libghc-haddock-library
[10241]34BuildRequires: libghc-build-pandoc
[10163]35
36BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
37
38Requires: libffi
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: ara_t
43
44
45%description
46Pandoc is a Haskell library for converting from one markup format to another,
47 and a command-line tool that uses this library.
48It can read markdown and (subsets of) HTML, reStructuredText, LaTeX, DocBook,
49MediaWiki markup, Haddock markup, OPML, Emacs Org-mode, and Textile,
50 and it can write markdown, reStructuredText, HTML,
51LaTeX (including rendering as plain PDF or beamer slide shows),
52ConTeXt, DocBook, OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki, Textile,
[10167]53 groff man pages, GNU Texinfo, plain text, Emacs Org-Mode, AsciiDoc, InDesign
54 ICML, EPUB (v2 or v3), FictionBook2, and several kinds of HTML/javascript
55 slide shows  (S5, Slidy, Slideous, DZSlides, reveal.js).
[10163]56
57Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
58 definition lists, tables, and other features.
[10167]59A compatibility mode is provided for those who need a drop-in replacement for
60 Markdown.pl.
[10163]61
62In contrast to existing tools for converting markdown to HTML,
63 which use regex substitutions, pandoc has a modular design:
64 it consists of a set of readers, which parse text in a given format
65 and produce a native representation of the document,
[10167]66 and a set of writers, which convert this native representation into a target
67 format.
[10163]68Thus, adding an input or output format requires only adding a reader or writer.
69
70%description -l ja
71Pandoc はあるマークアップ形式から別の形式に変換するHaskellライブラリで、
72また、このライブラリを使ったコマンドラインツールです。
73markdown、HTML (のサブセット)、reStructuredText、 LaTeX、DocBook、
74MediaWikiマークアップ、Haddockマークアップ、OPML、Emacs Org-mode、
75およびTextileを読み取り、
[10167]76markdown、reStructuredText、HTML、LaTeX (プレインPDFまたはbeamerスライドショー
77での描画を含む)、ConTeXt、DocBook、OPML、OpenDocument、ODT、Word docx、RTF、
78MediaWiki、Textile、groff manページ、GNU Texinfo、プレーンテキスト、
79Emacs Org-Mode、AsciiDoc、InDesign ICML、EPUB (v2 または v3)、FictionBook2、
80およびいくつかの種類のHTML/javascriptスライドショー
[10163]81(S5, Slidy, Slideous, DZSlides, reveal.js) に書き出せます。
82
83Pandocは標準的なmarkdownの文法に脚注、組み込み LaTeX、定義リスト、表、
84およびその他の機能を拡張しています。
85Markdown.plの気軽な置き換えを希望する方向けに互換モードを提供しています。
86
87markdownからHTMLに変換する既存のツールは正規表現で置換していますが、
88これらとは異なり、pandoc はモジュール式の設計になっています:
89テキストを指定された形式でパースし、文書のネイティブ表現を生成するリーダ一式、
[10167]90および、このネイティブ表現を対象とする形式に変換するライタ一式で構成されて
91います。したがって、入力または出力形式を追加するにはリーダやライタを追加する
92ことだけが必要です。
[10163]93
94
[10241]95%package libs
96Summary:  Library of pandoc
97Group:    Development/Libraries
[10163]98
[11635]99Requires: haskell-platform-dep
100Requires: libghc-data-default-class
101Requires: libghc-dlist
102Requires: libghc-old-locale
103Requires: libghc-aeson
104Requires: libghc-semigroups
105Requires: yaml
106Requires: libghc-http-client-tls
107Requires: libghc-haddock-library
108Requires: libghc-build-pandoc
109
[10241]110%description libs
111Librariy of pandoc for building pandoc-citeproc and pandoc-crossref
[10163]112
113
114%prep
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117%build
[11635]118%ghc_pkg_init
[10163]119
[11635]120cd %{_builddir}
121for pkg in `cat %{SOURCE0}`; do
122    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
123    pushd ${pkg}
124        %ghc_fix_dependencies ${pkg}
125        %cabal_configure1 ${pkg}
126        %cabal_build
127        %cabal_haddock
128        %cabal_copy_resister ${pkg}
129    popd
130done
[10163]131
132
133%install
[11635]134%{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
[10163]135
[11635]136# copy documents and mannual
137pushd %{_builddir}/%{name}-%{version}
138    %{__cp} \
139     BUGS changelog CONTRIBUTING.md COPYING.md COPYRIGHT \
140     MANUAL.txt README.md \
141     ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
142    %{__cp} man/pandoc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/
143popd
[10163]144
[11635]145
[10163]146%clean
147%{__rm} -rf ${RPM_BUILD_ROOT}
148
[10241]149%post libs
[11635]150%ghc_pkg_recache
[10163]151
[10241]152%postun libs
[11635]153%ghc_pkg_recache
[10241]154
155
[10163]156%files
157%defattr(-, root, root)
158%{_bindir}/pandoc
[10241]159%{_datadir}/%{name}-%{version}/
160%{_docdir}/%{name}-%{version}/
[11635]161%{_mandir}/man1/
[10163]162
[10241]163%files libs
[10163]164%defattr(-, root, root)
[10241]165%{_libdir}/ghc-%{ghc_version}/
[11635]166%{_libdir}/ghc-lib/%{name}-%{version}/
[10163]167
168
169%changelog
[11635]170* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
171- update to 2.2.1
172- rebuild using ghc-8.4.2
173- rewrite using macro
174
[11383]175* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
176- update to 2.0.6
177- build using ghc-8.2.2
[11217]178
[11383]179* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-2
180- update to 1.19.2.1
181- build using ghc-8.0.2
182
[10917]183* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-2
184- rebuild using ghc-8.0.1
185
[10380]186* Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
187- update to 1.17.1
188
[10241]189* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-5
190- update to 1.17.0.3
191- add BuildRequires: libghc-build-pandoc
192- provide pandoc-libs for building pandoc-citeproc and pacdoc-crossref
193- delete subpackages: pandoc-citeproc and pacdoc-crossref
194
195* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-5
[10163]196- correct SPEC file
197
[10241]198* Mon Mar 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-4
[10163]199- correct pandoc-citeproc error
200
[10241]201* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
[10163]202- rebuild under dependent rpm packages
203
204* Sun Feb 21 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
205- rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
206
207* Sun Feb 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-1
208- new package
Note: See TracBrowser for help on using the repository browser.