source: projects/specs/trunk/p/pandoc-citeproc/pandoc-citeproc-vl.spec @ 11762

Revision 11762, 4.0 KB checked in by ara_t, 6 years ago (diff)

pandoc: update to 2.2.3.2

Line 
1%define pkg_name    pandoc-citeproc
2%define pkg_version 0.14.3.1
3%define pkg_release 3%{?_dist_release}
4
5%define pandoc_version 2.2.3.2
6
7Summary:  Library and executable for using citeproc with pandoc
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License:  BSD3
13Group:    Applications/Text
14URL:      http://hackage.haskell.org
15
16Source0: packages
17
18Source11: base-orphans-0.8.tar.gz
19Source12: base-orphans.cabal
20Source13: hs-bibutils-6.6.0.0.tar.gz
21Source14: hs-bibutils.cabal
22Source15: rfc5051-0.1.0.3.tar.gz
23Source16: rfc5051.cabal
24Source17: setenv-0.1.1.3.tar.gz
25Source18: setenv.cabal
26Source19: typed-process-0.2.2.0.tar.gz
27Source20: typed-process.cabal
28Source21: unliftio-core-0.1.1.0.tar.gz
29Source22: unliftio-core.cabal
30Source23: vector-algorithms-0.7.0.1.tar.gz
31Source24: vector-algorithms.cabal
32Source25: xml-types-0.3.6.tar.gz
33Source26: xml-types.cabal
34Source27: transformers-base-0.4.5.2.tar.gz
35Source28: transformers-base.cabal
36Source29: resourcet-1.2.1.tar.gz
37Source30: resourcet.cabal
38Source31: mono-traversable-1.0.9.0.tar.gz
39Source32: mono-traversable.cabal
40Source33: monad-control-1.0.2.3.tar.gz
41Source34: monad-control.cabal
42Source35: conduit-1.3.0.3.tar.gz
43Source36: conduit.cabal
44Source37: yaml-0.9.0.tar.gz
45Source38: yaml.cabal
46Source39: conduit-extra-1.3.0.tar.gz
47Source40: conduit-extra.cabal
48Source41: xml-conduit-1.8.0.tar.gz
49Source42: xml-conduit.cabal
50Source43: pandoc-citeproc-0.14.3.1.tar.gz
51Source44: pandoc-citeproc.cabal
52
53BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
54
55BuildRequires: ghc haskell-platform
56BuildRequires: libffi-devel gmp-devel zlib-devel
57BuildRequires: libghc-build-pandoc
58BuildRequires: pandoc-libs = %{pandoc_version}
59
60BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
61
62Requires: pandoc = %{pandoc_version}
63
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: ara_t
68
69
70%description
71The pandoc-citeproc library exports functions for using the citeproc system
72with pandoc. It relies on citeproc-hs, a library for rendering bibliographic
73reference citations into a variety of styles using a macro language called
74Citation Style Language (CSL).
75More details on CSL can be found here: http://citationstyles.org/.
76
77
78%prep
79%{__rm} -rf ${RPM_BUILD_ROOT}
80
81%build
82%ghc_pkg_init
83
84cd %{_builddir}
85for pkg in `sed '$d' %{SOURCE0}`; do
86    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
87    pushd ${pkg}
88        %ghc_fix_dependencies ${pkg}
89        %{__cabal} configure
90        %{__cabal} build
91        %{__cabal} copy
92        %{__cabal} register --inplace
93    popd
94done
95
96for pkg in `tail -n 1 %{SOURCE0}`; do
97    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
98    pushd ${pkg}
99        %ghc_fix_dependencies ${pkg}
100        %cabal_configure1 ${pkg}
101        %cabal_build
102        %cabal_haddock
103        %cabal_copy_resister ${pkg}
104    popd
105done
106
107
108%install
109%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
110%{__mv} \
111 ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/{changelog,README.md} \
112 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
113%{__mv} \
114 ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man \
115 ${RPM_BUILD_ROOT}%{_datadir}/
116
117%clean
118%{__rm} -rf ${RPM_BUILD_ROOT}
119
120
121%files
122%defattr(-, root, root)
123%{_bindir}/pandoc-citeproc
124%{_datadir}/%{name}-%{version}/
125%{_docdir}/%{name}-%{version}/
126%{_mandir}/man1/
127
128
129%changelog
130* Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-3
131- build using ghc-8.4.3-2 and pandoc-2.2.3.2
132
133* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-2
134- build using ghc-8.4.3 and pandoc-2.2.2
135
136* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-1
137- update to 0.14.3.1
138- rebuild using ghc-8.4.2 and pandoc-2.2.1
139- rewrite using macro
140
141* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.12.2.5-1
142- update to 0.12.2.5
143- build using ghc-8.2.2
144
145* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4.1-1
146- update to 0.10.4.1
147- build using ghc-8.0.2
148
149* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4-1
150- update to 0.10.4
151- build using ghc-8.0.1
152
153* Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 0.10-1
154- update to 0.10
155
156* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 0.9.1.1-1
157- new package (devide from pandoc)
158
Note: See TracBrowser for help on using the repository browser.