source: projects/specs/trunk/p/pandoc-citeproc/pandoc-citeproc-vl.spec @ 11990

Revision 11990, 4.0 KB checked in by ara_t, 5 years ago (diff)

pandoc-citeproc: update to 0.15.0.1

Line 
1%define pkg_name    pandoc-citeproc
2%define pkg_version 0.15.0.1
3%define pkg_release 1%{?_dist_release}
4
5%define pandoc_version 2.4
6
7Summary:  Library and executable for using citeproc with pandoc
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License:  BSD3
13Group:    Applications/Text
14URL:      http://hackage.haskell.org
15
16Source0: packages
17
18Source11: hs-bibutils-6.7.0.0.tar.gz
19Source12: hs-bibutils.cabal
20Source13: rfc5051-0.1.0.4.tar.gz
21Source14: rfc5051.cabal
22Source15: setenv-0.1.1.3.tar.gz
23Source16: setenv.cabal
24Source17: typed-process-0.2.3.0.tar.gz
25Source18: typed-process.cabal
26Source19: unliftio-core-0.1.2.0.tar.gz
27Source20: unliftio-core.cabal
28Source21: vector-algorithms-0.8.0.1.tar.gz
29Source22: vector-algorithms.cabal
30Source23: xml-types-0.3.6.tar.gz
31Source24: xml-types.cabal
32Source25: resourcet-1.2.2.tar.gz
33Source26: resourcet.cabal
34Source27: mono-traversable-1.0.9.0.tar.gz
35Source28: mono-traversable.cabal
36Source29: conduit-1.3.1.tar.gz
37Source30: conduit.cabal
38Source31: libyaml-0.1.0.0.tar.gz
39Source32: libyaml.cabal
40Source33: conduit-extra-1.3.0.tar.gz
41Source34: conduit-extra.cabal
42Source35: yaml-0.11.0.0.tar.gz
43Source36: yaml.cabal
44Source37: xml-conduit-1.8.0.1.tar.gz
45Source38: xml-conduit.cabal
46Source39: pandoc-citeproc-0.15.0.1.tar.gz
47Source40: pandoc-citeproc.cabal
48
49BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
50
51BuildRequires: ghc haskell-platform
52BuildRequires: libffi-devel gmp-devel zlib-devel
53BuildRequires: libghc-build-pandoc
54BuildRequires: pandoc-libs = %{pandoc_version}
55
56BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
57
58Requires: pandoc = %{pandoc_version}
59
60
61Vendor: Project Vine
62Distribution: Vine Linux
63Packager: ara_t
64
65
66%description
67The pandoc-citeproc library exports functions for using the citeproc system
68with pandoc. It relies on citeproc-hs, a library for rendering bibliographic
69reference citations into a variety of styles using a macro language called
70Citation Style Language (CSL).
71More details on CSL can be found here: http://citationstyles.org/.
72
73
74%prep
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77%build
78%ghc_pkg_init
79
80cd %{_builddir}
81for pkg in `sed '$d' %{SOURCE0}`; do
82    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
83    pushd ${pkg}
84        %ghc_fix_dependencies ${pkg}
85        %{__cabal} configure
86        %{__cabal} build
87        %{__cabal} copy
88        %{__cabal} register --inplace
89    popd
90done
91
92for pkg in `tail -n 1 %{SOURCE0}`; do
93    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
94    pushd ${pkg}
95        %ghc_fix_dependencies ${pkg}
96        %cabal_configure1 ${pkg}
97        %cabal_build
98        %cabal_haddock
99        %cabal_copy_resister ${pkg}
100    popd
101done
102
103
104%install
105%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
106%{__mv} \
107 ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/{changelog,README.md} \
108 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
109%{__mv} \
110 ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man \
111 ${RPM_BUILD_ROOT}%{_datadir}/
112
113%clean
114%{__rm} -rf ${RPM_BUILD_ROOT}
115
116
117%files
118%defattr(-, root, root)
119%{_bindir}/pandoc-citeproc
120%{_datadir}/%{name}-%{version}/
121%{_docdir}/%{name}-%{version}/
122%{_mandir}/man1/
123
124
125%changelog
126* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.15.0.1-1
127- update to 0.15.0.1
128- build using ghc-8.6.3 and pandoc-2.4
129
130* Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-3
131- build using ghc-8.4.3-2 and pandoc-2.2.3.2
132
133* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-2
134- build using ghc-8.4.3 and pandoc-2.2.2
135
136* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-1
137- update to 0.14.3.1
138- rebuild using ghc-8.4.2 and pandoc-2.2.1
139- rewrite using macro
140
141* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.12.2.5-1
142- update to 0.12.2.5
143- build using ghc-8.2.2
144
145* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4.1-1
146- update to 0.10.4.1
147- build using ghc-8.0.2
148
149* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4-1
150- update to 0.10.4
151- build using ghc-8.0.1
152
153* Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 0.10-1
154- update to 0.10
155
156* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 0.9.1.1-1
157- new package (devide from pandoc)
158
Note: See TracBrowser for help on using the repository browser.