source: projects/specs/trunk/p/pandoc-citeproc/pandoc-citeproc-vl.spec @ 11635

Revision 11635, 3.4 KB checked in by ara_t, 6 years ago (diff)

pandoc: new upstream release (build with ghc-8.4.2)

Line 
1%define pkg_name    pandoc-citeproc
2%define pkg_version 0.14.3.1
3%define pkg_release 1%{?_dist_release}
4
5%define pandoc_version 2.2.1
6
7Summary:  Library and executable for using citeproc with pandoc
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License:  BSD3
13Group:    Applications/Text
14URL:      http://hackage.haskell.org
15
16Source0: packages
17
18Source11: base-orphans-0.7.tar.gz
19Source12: base-orphans.cabal
20Source13: hs-bibutils-6.2.0.1.tar.gz
21Source14: hs-bibutils.cabal
22Source15: rfc5051-0.1.0.3.tar.gz
23Source16: rfc5051.cabal
24Source17: setenv-0.1.1.3.tar.gz
25Source18: setenv.cabal
26Source19: typed-process-0.2.2.0.tar.gz
27Source20: typed-process.cabal
28Source21: xml-types-0.3.6.tar.gz
29Source22: xml-types.cabal
30Source23: transformers-base-0.4.5.2.tar.gz
31Source24: transformers-base.cabal
32Source25: conduit-extra-1.3.0.tar.gz
33Source26: conduit-extra.cabal
34Source27: monad-control-1.0.2.3.tar.gz
35Source28: monad-control.cabal
36Source29: xml-conduit-1.8.0.tar.gz
37Source30: xml-conduit.cabal
38Source31: pandoc-citeproc-0.14.3.1.tar.gz
39Source32: pandoc-citeproc.cabal
40
41BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
42
43BuildRequires: ghc haskell-platform
44BuildRequires: libffi-devel gmp-devel zlib-devel
45BuildRequires: libghc-build-pandoc
46BuildRequires: pandoc-libs = %{pandoc_version}
47
48BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
49
50Requires: pandoc = %{pandoc_version}
51
52Vendor: Project Vine
53Distribution: Vine Linux
54Packager: ara_t
55
56
57%description
58The pandoc-citeproc library exports functions for using the citeproc system
59with pandoc. It relies on citeproc-hs, a library for rendering bibliographic
60reference citations into a variety of styles using a macro language called
61Citation Style Language (CSL).
62More details on CSL can be found here: http://citationstyles.org/.
63
64
65%prep
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68%build
69%ghc_pkg_init
70
71cd %{_builddir}
72for pkg in `sed '$d' %{SOURCE0}`; do
73    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
74    pushd ${pkg}
75        %ghc_fix_dependencies ${pkg}
76        %{__cabal} configure
77        %{__cabal} build
78        %{__cabal} copy
79        %{__cabal} register --inplace
80    popd
81done
82
83for pkg in `tail -n 1 %{SOURCE0}`; do
84    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
85    pushd ${pkg}
86        %ghc_fix_dependencies ${pkg}
87        %cabal_configure1 ${pkg}
88        %cabal_build
89        %cabal_haddock
90        %cabal_copy_resister ${pkg}
91    popd
92done
93
94
95%install
96%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
97%{__mv} \
98 ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/{changelog,README.md} \
99 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
100%{__mv} \
101 ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man \
102 ${RPM_BUILD_ROOT}%{_datadir}/
103
104%clean
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107
108%files
109%defattr(-, root, root)
110%{_bindir}/pandoc-citeproc
111%{_datadir}/%{name}-%{version}/
112%{_docdir}/%{name}-%{version}/
113%{_mandir}/man1/
114
115
116%changelog
117* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-1
118- update to 0.14.3.1
119- rebuild using ghc-8.4.2 and pandoc-2.2.1
120- rewrite using macro
121
122* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.12.2.5-1
123- update to 0.12.2.5
124- build using ghc-8.2.2
125
126* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4.1-1
127- update to 0.10.4.1
128- build using ghc-8.0.2
129
130* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4-1
131- update to 0.10.4
132- build using ghc-8.0.1
133
134* Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 0.10-1
135- update to 0.10
136
137* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 0.9.1.1-1
138- new package (devide from pandoc)
139
Note: See TracBrowser for help on using the repository browser.