source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 7835

Revision 7835, 24.7 KB checked in by daisuke, 11 years ago (diff)

use ca-certificates

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1e
4%define release 2%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source6: make-dummy-cert
13Source7: renew-dummy-cert
14
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18Patch5: openssl-0.9.8j-version-add-engines.patch
19
20# security fix
21# nothing ;-)
22
23License: BSDish
24Group: System Environment/Libraries
25URL: http://www.openssl.org/
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: perl, sed
29BuildRequires: zlib-devel, krb5-devel
30
31Requires: mktemp
32Requires: ca-certificates
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: daisuke, iwamoto
37
38%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
39
40%description
41The OpenSSL certificate management tool and the shared libraries that
42provide various cryptographic algorithms and protocols.
43
44%package devel
45Summary: OpenSSL libraries and development headers.
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: krb5-devel
49
50%description devel
51The static libraries and include files needed to compile apps
52with support for various the cryptographic algorithms and protocols
53supported by OpenSSL.
54
55Patches for many networking apps can be found at:
56ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
57
58%package static
59Summary:  Libraries for static linking of applications which will use OpenSSL
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64OpenSSL is a toolkit for supporting cryptography. The openssl-static
65package contains static libraries needed for static linking of
66applications which support various cryptographic algorithms and
67protocols.
68
69%package perl
70Summary: OpenSSL scripts which require Perl.
71Group: Applications/Internet
72Requires: perl
73Requires: %{name} = %{version}-%{release}
74
75%description perl
76Perl scripts provided with OpenSSL for converting certificates and keys
77from other formats to those used by OpenSSL.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: Secure Sockets Layer Toolkit
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84%description -n compat32-%{name}
85The OpenSSL certificate management tool and the shared libraries that
86provide various cryptographic algorithms and protocols.
87
88%package -n compat32-%{name}-devel
89Summary: OpenSSL libraries and development headers.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-krb5-devel
93%description -n compat32-%{name}-devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98%prep
99%setup -q -n openssl-%{version}
100%patch0 -p1 -b .soversion
101%patch2 -p1 -b .rpm_opt
102%patch4 -p1 -b .enginesdir
103%patch5 -p1 -b .version-add-engines
104
105# security fix
106# nothing ;-)
107
108chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
109chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
110chmod 644 doc/openssl_button.html doc/openssl_button.gif
111chmod 644 doc/ssleay.txt
112
113# Link the configuration header to the one we're going to make.
114ln -sf ../../crypto/opensslconf.h include/openssl/
115
116%build
117PATH=${PATH}:${PWD}/bin
118TOPDIR=${PWD}
119LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
120
121# Modify the various perl scripts to reference perl in the right location.
122perl util/perlpath.pl `dirname %{__perl}`
123
124# Generate a table with the compile settings for my perusal.
125touch Makefile
126make TABLE PERL=%{__perl}
127
128# Figure out which flags we want to use.
129# default
130sslarch=%{_os}-%{_target_cpu}
131#
132%ifarch %ix86
133sslarch=linux-elf
134if ! echo %{_target} | grep -q i686 ; then
135   sslflags="no-asm 386"
136fi
137%endif
138%ifarch sparcv9
139sslarch=linux-sparcv9
140sslflags=no-asm
141%endif
142%ifarch sparc64
143sslarch=linux64-sparcv9
144sslflags=no-asm
145%endif
146%ifarch alpha alphaev56 alphaev6 alphaev67
147sslarch=linux-alpha-gcc
148%endif
149%ifarch s390 sh3eb sh4eb
150sslarch="linux-generic32 -DB_ENDIAN"
151%endif
152%ifarch s390x
153sslarch="linux64-s390x"
154%endif
155%ifarch %{arm} sh3 sh4
156sslarch=linux-generic32
157%endif
158# ia64/x86_64/ppc\ppc64 are OK by default.
159
160# Configure the build tree.  Override OpenSSL defaults with known-good defaults
161# usable on all platforms.  The Configure script already knows to use -fPIC and
162# RPM_OPT_FLAGS, so we can skip specifiying them here.
163./Configure  \
164         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
165         zlib-dynamic enable-camellia enable-seed enable-tlsext \
166         enable-rfc3779 enable-cms enable-md2 \
167         --enginesdir=%{_libdir}/openssl/engines \
168         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
169         shared ${sslarch}
170
171# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
172# marked as not requiring an executable stack.
173RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
174make depend
175make all build-shared
176
177# Generate hashes for the included certs.
178LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
179export LD_LIBRARY_PATH
180make rehash build-shared
181
182# Verify that what was compiled actually works.
183make -C test apps tests
184
185# Relink the main binary to get it dynamically linked.
186rm apps/openssl
187make all build-shared
188
189%install
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191# Install OpenSSL.
192install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
193make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
194install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
195# added for lib64
196# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
197mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
198# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
199mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
200mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
201rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
202rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
203for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
204        chmod 755 ${lib}
205        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
206        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
207done
208# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
209
210# Install a makefile for generating keys and self-signed certs, and a script
211# for generating them on the fly.
212mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
213install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
214install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
215install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
216
217# Make sure we actually include the headers we built against.
218for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
219        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
220                install -m644 include/openssl/`basename ${header}` ${header}
221        fi
222done
223
224# Rename man pages so that they don't conflict with system man pages.  We used
225# to change the file extensions, but that only prevents file conflicts.  The
226# man viewer still can't select either of the two unless we physically change
227# the directory.
228for section in 1 2 3 4 5 6 7 8 ; do
229        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
230                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
231                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
232        fi
233done
234
235# Pick a CA script.
236pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
237mv CA.sh CA
238popd
239
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
241mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
245
246# Ensure the openssl.cnf timestamp is identical across builds to avoid
247# mulitlib conflicts and unnecessary renames on upgrade
248touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
249
250%clean
251[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
252
253%files
254%defattr(-,root,root)
255%doc FAQ LICENSE CHANGES NEWS INSTALL README
256%doc doc/README doc/c-indentation.el doc/openssl.txt
257%doc doc/openssl_button.html doc/openssl_button.gif
258%doc doc/ssleay.txt
259
260%{_sysconfdir}/pki/tls/certs/make-dummy-cert
261%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
262%{_sysconfdir}/pki/tls/certs/Makefile
263%{_sysconfdir}/pki/tls/misc/CA
264%dir %{_sysconfdir}/pki/CA
265%dir %{_sysconfdir}/pki/CA/private
266%dir %{_sysconfdir}/pki/CA/certs
267%dir %{_sysconfdir}/pki/CA/crl
268%dir %{_sysconfdir}/pki/CA/newcerts
269%{_sysconfdir}/pki/tls/misc/c_*
270%dir %{_sysconfdir}/pki/tls
271%dir %{_sysconfdir}/pki/tls/certs
272%dir %{_sysconfdir}/pki/tls/misc
273%dir %{_sysconfdir}/pki/tls/private
274%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
275
276%attr(0755,root,root) %{_bindir}/openssl
277%attr(0755,root,root) /%{_lib}/*.so.*
278%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
279%attr(0755,root,root) %dir %{_mandir}/man1*
280%attr(0644,root,root) %{_mandir}/man1*/*
281%attr(0755,root,root) %dir %{_mandir}/man5*
282%attr(0644,root,root) %{_mandir}/man5*/*
283%attr(0755,root,root) %dir %{_mandir}/man7*
284%attr(0644,root,root) %{_mandir}/man7*/*
285
286%files devel
287%defattr(-,root,root)
288%{_prefix}/include/openssl
289%exclude %{_libdir}/lib*.a
290%attr(0755,root,root) %{_libdir}/*.so
291%attr(0755,root,root) %dir %{_mandir}/man3*
292%attr(0644,root,root) %{_mandir}/man3*/*
293%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
294
295%files static
296%defattr(-,root,root)
297%attr(0644,root,root) %{_libdir}/*.a
298
299%files perl
300%defattr(-,root,root)
301%attr(0755,root,root) %{_bindir}/c_rehash
302%attr(0755,root,root) %dir %{_mandir}/man1*
303%attr(0644,root,root) %{_mandir}/man1*/*.pl*
304%{_sysconfdir}/pki/tls/misc/*.pl
305#%{_sysconfdir}/pki/tls/misc/tsget
306%doc apps/tsget
307
308## to build compat32 for x86_64 architecture support
309%if %{build_compat32}
310%files -n compat32-%{name}
311%defattr(-,root,root)
312%attr(0755,root,root) /%{_lib}/*.so.*
313
314%files -n compat32-%{name}-devel
315%defattr(-,root,root)
316%exclude %{_libdir}/lib*.a
317%attr(0755,root,root) %{_libdir}/*.so
318%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
319%endif
320
321%post -p /sbin/ldconfig
322
323%postun -p /sbin/ldconfig
324
325%post -n compat32-%{name} -p /sbin/ldconfig
326
327%postun -n compat32-%{name} -p /sbin/ldconfig
328
329%changelog
330* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
331- move root CA bundle to ca-certificates package
332
333* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
334- update to 1.0.1e
335  - 1.0.1d has major regressions from 1.0.1c
336
337* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
338- remove tsget script to delete dependency perl(WWW::Curl::Easy)
339 - openssl-perl package contains it in docdir
340
341* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
342- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
343- fixed %%files
344
345* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
346- update to 1.0.1c
347- enable configure options:
348  enable-camellia enable-seed enable-tlsext enable-rfc3779
349  enable-cms enable-md2
350- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
351- generate a table with the compile settings before configure
352
353* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
354- new upstream release with security fix (CVE-2012-0050)
355
356* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
357- new upstream release with security fix
358  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
359
360* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
361- new upstream release with security fix (CVE-2011-3207, 3210)
362
363* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
364- rebuild with krb5-libs 1.8
365
366* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
367- new upstream release with security fix
368
369* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
370- use upstream openssl.pc instead of vine original one (SOURCE6)
371
372* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
373- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
374
375* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
376- add R: krb5-devel into devel pkg
377- add R: compat32-krb5-devel into compat32-devel pkg
378
379* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
380- new upstream release 1.0.0x
381- separate static libs into static package
382- change configure options
383- change so version 10
384- add tsget into perl package
385- update all patches
386
387* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
388- fix changelog typo...
389
390* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
391- new upstream release with security fix (CVE-2010-4180)
392
393* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
394- new upstream release with security fix (CVE-2010-3864)
395- drop patches included in new release
396- update patch4
397
398* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
399- add patch12 for fix CVE-2009-3555 (renegotiation)
400
401* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
402- add patch11 for fix CVE-2009-4355 (memory leak)
403
404* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
405- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
406
407* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
408- removed unnecessary %%if %{build_compat32} statements
409- removed lib*.a from devel package
410
411* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
412- new upstream release with security fix (CVE-2000-0590,0591,0789)
413
414* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
415- new upstream release with security fix (CVE-2008-5077)
416
417* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
418- new upstream release
419
420* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
421- new upstream release
422- new versioning policy
423
424* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
425- new upstream release
426- drop patch10,20 which is merged in upstream
427
428* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
429- add security patch in advance for CVE-2007-5135
430  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
431  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
432
433* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
434- add security patch for CVE-2007-3108
435  (http://openssl.org/news/patch-CVE-2007-3108.txt)
436
437* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
438- new upstream release
439
440* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
441- update (fix) openssl.pc <BTS:437>
442
443* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
444- new upstream release (with security fix)
445
446* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
447- new upstream release
448- add patch2 to use RPM_OPT macro
449
450* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
451- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
452
453* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
454- added compat32-* packages for x86_64 architecture support
455- added openssl-0.9.7i.Configure-compat32.patch
456- changed '/lib' to '/%{_lib}'
457
458* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
459- new upstream release
460
461* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
462- rebuild on VineSeed
463
464* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
465- added a security patch from Gentoo.
466  - Patch1: openssl-0.9.7c-tempfile.patch
467
468* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
469- sslarch for ppc was missing... added.
470
471* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
472- use sslarch=linux-alpha-gcc instead of alpha-gcc
473
474* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
475- new upstream version
476- clean up of spec file
477        -- removed old patches
478
479* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
480- new upstream release
481- SECURITY fix.
482  - http://www.openssl.org/news/secadv_20040317.txt
483
484* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
485- new upstream release
486- [Security fix]
487  - Vulnerabilities in ASN.1 parsing
488    http://www.openssl.org/news/secadv_20030930.txt
489- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
490
491* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
492- add openssl.pc for pkgconfig
493
494* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
495- New upstream version
496- dropped patch10, 11
497        -- merged upstream version
498
499* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
500- rebuild for VineSeed
501
502* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
503- [Security Fix]
504  - Timing-based attacks on RSA keys
505    http://www.openssl.org/news/secadv_20030317.txt
506  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
507    http://www.openssl.org/news/secadv_20030317.txt
508
509* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
510- new upstream release 0.9.6i
511- [Security Fix]
512- build for Vine Linux 2.6 errata
513
514* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
515- new upstream release 0.9.6h
516
517* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
518- new upstream release 0.9.6g
519
520* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
521- SECURITY: CAN-2002-0659 fixed
522  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
523    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
524    - update asn patch to fix accidental reversal of a logic check
525    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
526    - update asn patch to reduce chance that compiler optimization will remove
527      one of the added tests
528    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
529    - rebuild
530    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
531    - add patch to fix ASN.1 vulnerabilities
532
533* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
534- rename spec file name
535- SECURITY: CA-2002-23 fixed
536  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
537    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
538    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
539
540* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
541- added ${PATH} in LD_LIBRARY_PATH
542- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
543 
544* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
545- remove --no-<cipher>
546
547* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
548- add Patch10 for mipsel shared ( Configure )
549
550* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
551- build for Vine Linux
552- use openssl-engine-0.9.6b.tar.gz
553
554* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
555- update to 0.9.6b
556
557* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
558- move .so symlinks back to %%{_libdir}
559
560* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
561- move shared libraries to /lib (#38410)
562
563* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
564- switch to engine code base
565
566* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
567- add a script for creating dummy certificates
568- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
569
570* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
571- add s390x support
572
573* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
574- change two memcpy() calls to memmove()
575- don't define L_ENDIAN on alpha
576
577* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
578- make subpackages depend on the main package
579
580* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
581- adjust the hobble script to not disturb symlinks in include/ (fix from
582  Joe Orton)
583
584* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
585- drop the m2crypo patch we weren't using
586
587* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
588- configure using "shared" as well
589
590* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
591- update to 0.9.6a
592- use the build-shared target to build shared libraries
593- bump the soversion to 2 because we're no longer compatible with
594  our 0.9.5a packages or our 0.9.6 packages
595- drop the patch for making rsatest a no-op when rsa null support is used
596- put all man pages into <section>ssl instead of <section>
597- break the m2crypto modules into a separate package
598
599* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
600- use BN_LLONG on s390
601
602* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
603- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
604
605* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
606- move c_rehash to the perl subpackage, because it's a perl script now
607
608* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
609- update to 0.9.6
610- enable MD2
611- use the libcrypto.so and libssl.so targets to build shared libs with
612- bump the soversion to 1 because we're no longer compatible with any of
613  the various 0.9.5a packages circulating around, which provide lib*.so.0
614
615* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
616- change hobble-openssl for disabling MD2 again
617
618* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
619- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
620  bytes or so, causing EVP_DigestInit() to zero out stack variables in
621  apps built against a version of the library without it
622
623* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
624- disable some inline assembly, which on x86 is Pentium-specific
625- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
626
627* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
628- fix s390 patch
629
630* Fri Dec 8 2000 Than Ngo <than@redhat.com>
631- added support s390
632
633* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
634- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
635- add the CA.pl man page to the perl subpackage
636
637* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
638- always build with -mcpu=ev5 on alpha
639
640* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
641- add a symlink from cert.pem to ca-bundle.crt
642
643* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
644- add a ca-bundle file for packages like Samba to reference for CA certificates
645
646* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
647- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
648
649* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
650- add unzip as a buildprereq (#17662)
651- update m2crypto to 0.05-snap4
652
653* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
654- fix some issues in building when it's not installed
655
656* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
657- make sure the headers we include are the ones we built with (aaaaarrgh!)
658
659* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
660- add Richard Henderson's patch for BN on ia64
661- clean up the changelog
662
663* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
664- fix the building of python modules without openssl-devel already installed
665
666* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
667- byte-compile python extensions without the build-root
668- adjust the makefile to not remove temporary files (like .key files when
669  building .csr files) by marking them as .PRECIOUS
670
671* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
672- break out python extensions into a subpackage
673
674* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
675- tweak the makefile some more
676
677* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
678- disable MD2 support
679
680* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
681- disable MDC2 support
682
683* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
684- tweak the disabling of RC5, IDEA support
685- tweak the makefile
686
687* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
688- strip binaries and libraries
689- rework certificate makefile to have the right parts for Apache
690
691* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
692- use %%{_perl} instead of /usr/bin/perl
693- disable alpha until it passes its own test suite
694
695* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
696- move the passwd.1 man page out of the passwd package's way
697
698* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
699- update to 0.9.5a, modified for U.S.
700- add perl as a build-time requirement
701- move certificate makefile to another package
702- disable RC5, IDEA, RSA support
703- remove optimizations for now
704
705* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
706- Bero told me to move the Makefile into this package
707
708* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
709- add lib*.so symlinks to link dynamically against shared libs
710
711* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
712- update to 0.9.5
713- run ldconfig directly in post/postun
714- add FAQ
715
716* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
717- Fix build on non-x86 platforms
718
719* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
720- move /usr/share/ssl/* from -devel to main package
721
722* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
723- inital packaging
724- changes from base:
725  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
726  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.