source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 8139

Revision 8139, 24.8 KB checked in by iwamoto, 10 years ago (diff)

openssl: new upstream release with security fixes

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1f
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source6: make-dummy-cert
13Source7: renew-dummy-cert
14
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18Patch5: openssl-0.9.8j-version-add-engines.patch
19
20# security fix
21# nothing ;-)
22
23License: BSDish
24Group: System Environment/Libraries
25URL: http://www.openssl.org/
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: perl, sed
29BuildRequires: zlib-devel, krb5-devel
30
31Requires: mktemp
32Requires: ca-certificates
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: daisuke, iwamoto
37
38%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
39
40%description
41The OpenSSL certificate management tool and the shared libraries that
42provide various cryptographic algorithms and protocols.
43
44%package devel
45Summary: OpenSSL libraries and development headers.
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: krb5-devel
49
50%description devel
51The static libraries and include files needed to compile apps
52with support for various the cryptographic algorithms and protocols
53supported by OpenSSL.
54
55Patches for many networking apps can be found at:
56ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
57
58%package static
59Summary:  Libraries for static linking of applications which will use OpenSSL
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64OpenSSL is a toolkit for supporting cryptography. The openssl-static
65package contains static libraries needed for static linking of
66applications which support various cryptographic algorithms and
67protocols.
68
69%package perl
70Summary: OpenSSL scripts which require Perl.
71Group: Applications/Internet
72Requires: perl
73Requires: %{name} = %{version}-%{release}
74
75%description perl
76Perl scripts provided with OpenSSL for converting certificates and keys
77from other formats to those used by OpenSSL.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: Secure Sockets Layer Toolkit
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84%description -n compat32-%{name}
85The OpenSSL certificate management tool and the shared libraries that
86provide various cryptographic algorithms and protocols.
87
88%package -n compat32-%{name}-devel
89Summary: OpenSSL libraries and development headers.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-krb5-devel
93%description -n compat32-%{name}-devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98%prep
99%setup -q -n openssl-%{version}
100%patch0 -p1 -b .soversion
101%patch2 -p1 -b .rpm_opt
102%patch4 -p1 -b .enginesdir
103%patch5 -p1 -b .version-add-engines
104
105# security fix
106# nothing ;-)
107
108chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
109chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
110chmod 644 doc/openssl_button.html doc/openssl_button.gif
111chmod 644 doc/ssleay.txt
112
113# Link the configuration header to the one we're going to make.
114ln -sf ../../crypto/opensslconf.h include/openssl/
115
116%build
117PATH=${PATH}:${PWD}/bin
118TOPDIR=${PWD}
119LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
120
121# Modify the various perl scripts to reference perl in the right location.
122perl util/perlpath.pl `dirname %{__perl}`
123
124# Generate a table with the compile settings for my perusal.
125touch Makefile
126make TABLE PERL=%{__perl}
127
128# Figure out which flags we want to use.
129# default
130sslarch=%{_os}-%{_target_cpu}
131#
132%ifarch %ix86
133sslarch=linux-elf
134if ! echo %{_target} | grep -q i686 ; then
135   sslflags="no-asm 386"
136fi
137%endif
138%ifarch sparcv9
139sslarch=linux-sparcv9
140sslflags=no-asm
141%endif
142%ifarch sparc64
143sslarch=linux64-sparcv9
144sslflags=no-asm
145%endif
146%ifarch alpha alphaev56 alphaev6 alphaev67
147sslarch=linux-alpha-gcc
148%endif
149%ifarch s390 sh3eb sh4eb
150sslarch="linux-generic32 -DB_ENDIAN"
151%endif
152%ifarch s390x
153sslarch="linux64-s390x"
154%endif
155%ifarch %{arm} sh3 sh4
156sslarch=linux-generic32
157%endif
158# ia64/x86_64/ppc\ppc64 are OK by default.
159
160# Configure the build tree.  Override OpenSSL defaults with known-good defaults
161# usable on all platforms.  The Configure script already knows to use -fPIC and
162# RPM_OPT_FLAGS, so we can skip specifiying them here.
163./Configure  \
164         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
165         zlib-dynamic enable-camellia enable-seed enable-tlsext \
166         enable-rfc3779 enable-cms enable-md2 \
167         --enginesdir=%{_libdir}/openssl/engines \
168         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
169         shared ${sslarch}
170
171# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
172# marked as not requiring an executable stack.
173RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
174make depend
175make all build-shared
176
177# Generate hashes for the included certs.
178LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
179export LD_LIBRARY_PATH
180make rehash build-shared
181
182# Verify that what was compiled actually works.
183make -C test apps tests
184
185# Relink the main binary to get it dynamically linked.
186rm apps/openssl
187make all build-shared
188
189%install
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191# Install OpenSSL.
192install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
193make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
194install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
195# added for lib64
196# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
197mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
198# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
199mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
200mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
201rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
202rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
203for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
204        chmod 755 ${lib}
205        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
206        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
207done
208# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
209
210# Install a makefile for generating keys and self-signed certs, and a script
211# for generating them on the fly.
212mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
213install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
214install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
215install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
216
217# Make sure we actually include the headers we built against.
218for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
219        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
220                install -m644 include/openssl/`basename ${header}` ${header}
221        fi
222done
223
224# Rename man pages so that they don't conflict with system man pages.  We used
225# to change the file extensions, but that only prevents file conflicts.  The
226# man viewer still can't select either of the two unless we physically change
227# the directory.
228for section in 1 2 3 4 5 6 7 8 ; do
229        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
230                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
231                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
232        fi
233done
234
235# Pick a CA script.
236pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
237mv CA.sh CA
238popd
239
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
241mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
245
246# Ensure the openssl.cnf timestamp is identical across builds to avoid
247# mulitlib conflicts and unnecessary renames on upgrade
248touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
249
250%clean
251[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
252
253%files
254%defattr(-,root,root)
255%doc FAQ LICENSE CHANGES NEWS INSTALL README
256%doc doc/README doc/c-indentation.el doc/openssl.txt
257%doc doc/openssl_button.html doc/openssl_button.gif
258%doc doc/ssleay.txt
259
260%{_sysconfdir}/pki/tls/certs/make-dummy-cert
261%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
262%{_sysconfdir}/pki/tls/certs/Makefile
263%{_sysconfdir}/pki/tls/misc/CA
264%dir %{_sysconfdir}/pki/CA
265%dir %{_sysconfdir}/pki/CA/private
266%dir %{_sysconfdir}/pki/CA/certs
267%dir %{_sysconfdir}/pki/CA/crl
268%dir %{_sysconfdir}/pki/CA/newcerts
269%{_sysconfdir}/pki/tls/misc/c_*
270%dir %{_sysconfdir}/pki/tls
271%dir %{_sysconfdir}/pki/tls/certs
272%dir %{_sysconfdir}/pki/tls/misc
273%dir %{_sysconfdir}/pki/tls/private
274%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
275
276%attr(0755,root,root) %{_bindir}/openssl
277%attr(0755,root,root) /%{_lib}/*.so.*
278%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
279%attr(0755,root,root) %dir %{_mandir}/man1*
280%attr(0644,root,root) %{_mandir}/man1*/*
281%attr(0755,root,root) %dir %{_mandir}/man5*
282%attr(0644,root,root) %{_mandir}/man5*/*
283%attr(0755,root,root) %dir %{_mandir}/man7*
284%attr(0644,root,root) %{_mandir}/man7*/*
285
286%files devel
287%defattr(-,root,root)
288%{_prefix}/include/openssl
289%exclude %{_libdir}/lib*.a
290%attr(0755,root,root) %{_libdir}/*.so
291%attr(0755,root,root) %dir %{_mandir}/man3*
292%attr(0644,root,root) %{_mandir}/man3*/*
293%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
294
295%files static
296%defattr(-,root,root)
297%attr(0644,root,root) %{_libdir}/*.a
298
299%files perl
300%defattr(-,root,root)
301%attr(0755,root,root) %{_bindir}/c_rehash
302%attr(0755,root,root) %dir %{_mandir}/man1*
303%attr(0644,root,root) %{_mandir}/man1*/*.pl*
304%{_sysconfdir}/pki/tls/misc/*.pl
305#%{_sysconfdir}/pki/tls/misc/tsget
306%doc apps/tsget
307
308## to build compat32 for x86_64 architecture support
309%if %{build_compat32}
310%files -n compat32-%{name}
311%defattr(-,root,root)
312%attr(0755,root,root) /%{_lib}/*.so.*
313
314%files -n compat32-%{name}-devel
315%defattr(-,root,root)
316%exclude %{_libdir}/lib*.a
317%attr(0755,root,root) %{_libdir}/*.so
318%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
319%endif
320
321%post -p /sbin/ldconfig
322
323%postun -p /sbin/ldconfig
324
325%post -n compat32-%{name} -p /sbin/ldconfig
326
327%postun -n compat32-%{name} -p /sbin/ldconfig
328
329%changelog
330* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
331- new upstream release with security fixes
332
333* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
334- move root CA bundle to ca-certificates package
335
336* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
337- update to 1.0.1e
338  - 1.0.1d has major regressions from 1.0.1c
339
340* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
341- remove tsget script to delete dependency perl(WWW::Curl::Easy)
342 - openssl-perl package contains it in docdir
343
344* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
345- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
346- fixed %%files
347
348* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
349- update to 1.0.1c
350- enable configure options:
351  enable-camellia enable-seed enable-tlsext enable-rfc3779
352  enable-cms enable-md2
353- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
354- generate a table with the compile settings before configure
355
356* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
357- new upstream release with security fix (CVE-2012-0050)
358
359* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
360- new upstream release with security fix
361  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
362
363* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
364- new upstream release with security fix (CVE-2011-3207, 3210)
365
366* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
367- rebuild with krb5-libs 1.8
368
369* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
370- new upstream release with security fix
371
372* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
373- use upstream openssl.pc instead of vine original one (SOURCE6)
374
375* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
376- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
377
378* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
379- add R: krb5-devel into devel pkg
380- add R: compat32-krb5-devel into compat32-devel pkg
381
382* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
383- new upstream release 1.0.0x
384- separate static libs into static package
385- change configure options
386- change so version 10
387- add tsget into perl package
388- update all patches
389
390* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
391- fix changelog typo...
392
393* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
394- new upstream release with security fix (CVE-2010-4180)
395
396* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
397- new upstream release with security fix (CVE-2010-3864)
398- drop patches included in new release
399- update patch4
400
401* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
402- add patch12 for fix CVE-2009-3555 (renegotiation)
403
404* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
405- add patch11 for fix CVE-2009-4355 (memory leak)
406
407* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
408- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
409
410* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
411- removed unnecessary %%if %{build_compat32} statements
412- removed lib*.a from devel package
413
414* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
415- new upstream release with security fix (CVE-2000-0590,0591,0789)
416
417* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
418- new upstream release with security fix (CVE-2008-5077)
419
420* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
421- new upstream release
422
423* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
424- new upstream release
425- new versioning policy
426
427* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
428- new upstream release
429- drop patch10,20 which is merged in upstream
430
431* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
432- add security patch in advance for CVE-2007-5135
433  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
434  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
435
436* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
437- add security patch for CVE-2007-3108
438  (http://openssl.org/news/patch-CVE-2007-3108.txt)
439
440* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
441- new upstream release
442
443* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
444- update (fix) openssl.pc <BTS:437>
445
446* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
447- new upstream release (with security fix)
448
449* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
450- new upstream release
451- add patch2 to use RPM_OPT macro
452
453* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
454- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
455
456* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
457- added compat32-* packages for x86_64 architecture support
458- added openssl-0.9.7i.Configure-compat32.patch
459- changed '/lib' to '/%{_lib}'
460
461* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
462- new upstream release
463
464* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
465- rebuild on VineSeed
466
467* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
468- added a security patch from Gentoo.
469  - Patch1: openssl-0.9.7c-tempfile.patch
470
471* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
472- sslarch for ppc was missing... added.
473
474* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
475- use sslarch=linux-alpha-gcc instead of alpha-gcc
476
477* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
478- new upstream version
479- clean up of spec file
480        -- removed old patches
481
482* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
483- new upstream release
484- SECURITY fix.
485  - http://www.openssl.org/news/secadv_20040317.txt
486
487* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
488- new upstream release
489- [Security fix]
490  - Vulnerabilities in ASN.1 parsing
491    http://www.openssl.org/news/secadv_20030930.txt
492- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
493
494* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
495- add openssl.pc for pkgconfig
496
497* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
498- New upstream version
499- dropped patch10, 11
500        -- merged upstream version
501
502* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
503- rebuild for VineSeed
504
505* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
506- [Security Fix]
507  - Timing-based attacks on RSA keys
508    http://www.openssl.org/news/secadv_20030317.txt
509  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
510    http://www.openssl.org/news/secadv_20030317.txt
511
512* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
513- new upstream release 0.9.6i
514- [Security Fix]
515- build for Vine Linux 2.6 errata
516
517* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
518- new upstream release 0.9.6h
519
520* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
521- new upstream release 0.9.6g
522
523* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
524- SECURITY: CAN-2002-0659 fixed
525  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
526    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
527    - update asn patch to fix accidental reversal of a logic check
528    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
529    - update asn patch to reduce chance that compiler optimization will remove
530      one of the added tests
531    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
532    - rebuild
533    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
534    - add patch to fix ASN.1 vulnerabilities
535
536* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
537- rename spec file name
538- SECURITY: CA-2002-23 fixed
539  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
540    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
541    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
542
543* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
544- added ${PATH} in LD_LIBRARY_PATH
545- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
546 
547* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
548- remove --no-<cipher>
549
550* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
551- add Patch10 for mipsel shared ( Configure )
552
553* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
554- build for Vine Linux
555- use openssl-engine-0.9.6b.tar.gz
556
557* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
558- update to 0.9.6b
559
560* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
561- move .so symlinks back to %%{_libdir}
562
563* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
564- move shared libraries to /lib (#38410)
565
566* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
567- switch to engine code base
568
569* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
570- add a script for creating dummy certificates
571- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
572
573* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
574- add s390x support
575
576* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
577- change two memcpy() calls to memmove()
578- don't define L_ENDIAN on alpha
579
580* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
581- make subpackages depend on the main package
582
583* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
584- adjust the hobble script to not disturb symlinks in include/ (fix from
585  Joe Orton)
586
587* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
588- drop the m2crypo patch we weren't using
589
590* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
591- configure using "shared" as well
592
593* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
594- update to 0.9.6a
595- use the build-shared target to build shared libraries
596- bump the soversion to 2 because we're no longer compatible with
597  our 0.9.5a packages or our 0.9.6 packages
598- drop the patch for making rsatest a no-op when rsa null support is used
599- put all man pages into <section>ssl instead of <section>
600- break the m2crypto modules into a separate package
601
602* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
603- use BN_LLONG on s390
604
605* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
606- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
607
608* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
609- move c_rehash to the perl subpackage, because it's a perl script now
610
611* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
612- update to 0.9.6
613- enable MD2
614- use the libcrypto.so and libssl.so targets to build shared libs with
615- bump the soversion to 1 because we're no longer compatible with any of
616  the various 0.9.5a packages circulating around, which provide lib*.so.0
617
618* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
619- change hobble-openssl for disabling MD2 again
620
621* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
622- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
623  bytes or so, causing EVP_DigestInit() to zero out stack variables in
624  apps built against a version of the library without it
625
626* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
627- disable some inline assembly, which on x86 is Pentium-specific
628- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
629
630* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
631- fix s390 patch
632
633* Fri Dec 8 2000 Than Ngo <than@redhat.com>
634- added support s390
635
636* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
637- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
638- add the CA.pl man page to the perl subpackage
639
640* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
641- always build with -mcpu=ev5 on alpha
642
643* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
644- add a symlink from cert.pem to ca-bundle.crt
645
646* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
647- add a ca-bundle file for packages like Samba to reference for CA certificates
648
649* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
650- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
651
652* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
653- add unzip as a buildprereq (#17662)
654- update m2crypto to 0.05-snap4
655
656* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
657- fix some issues in building when it's not installed
658
659* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
660- make sure the headers we include are the ones we built with (aaaaarrgh!)
661
662* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
663- add Richard Henderson's patch for BN on ia64
664- clean up the changelog
665
666* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
667- fix the building of python modules without openssl-devel already installed
668
669* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
670- byte-compile python extensions without the build-root
671- adjust the makefile to not remove temporary files (like .key files when
672  building .csr files) by marking them as .PRECIOUS
673
674* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
675- break out python extensions into a subpackage
676
677* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
678- tweak the makefile some more
679
680* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
681- disable MD2 support
682
683* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
684- disable MDC2 support
685
686* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
687- tweak the disabling of RC5, IDEA support
688- tweak the makefile
689
690* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
691- strip binaries and libraries
692- rework certificate makefile to have the right parts for Apache
693
694* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
695- use %%{_perl} instead of /usr/bin/perl
696- disable alpha until it passes its own test suite
697
698* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
699- move the passwd.1 man page out of the passwd package's way
700
701* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
702- update to 0.9.5a, modified for U.S.
703- add perl as a build-time requirement
704- move certificate makefile to another package
705- disable RC5, IDEA, RSA support
706- remove optimizations for now
707
708* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
709- Bero told me to move the Makefile into this package
710
711* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
712- add lib*.so symlinks to link dynamically against shared libs
713
714* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
715- update to 0.9.5
716- run ldconfig directly in post/postun
717- add FAQ
718
719* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
720- Fix build on non-x86 platforms
721
722* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
723- move /usr/share/ssl/* from -devel to main package
724
725* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
726- inital packaging
727- changes from base:
728  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
729  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.