source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 3062

Revision 3062, 22.9 KB checked in by iwamoto, 13 years ago (diff)

update: krb5 and rebuild with krb5 1.8

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.0d
4%define release 2%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27BuildRequires: zlib-devel, krb5-devel
28Requires: mktemp
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
34
35%description
36The OpenSSL certificate management tool and the shared libraries that
37provide various cryptographic algorithms and protocols.
38
39%package devel
40Summary: OpenSSL libraries and development headers.
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: krb5-devel
44
45%description devel
46The static libraries and include files needed to compile apps
47with support for various the cryptographic algorithms and protocols
48supported by OpenSSL.
49
50Patches for many networking apps can be found at:
51ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
52
53%package static
54Summary:  Libraries for static linking of applications which will use OpenSSL
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59OpenSSL is a toolkit for supporting cryptography. The openssl-static
60package contains static libraries needed for static linking of
61applications which support various cryptographic algorithms and
62protocols.
63
64%package perl
65Summary: OpenSSL scripts which require Perl.
66Group: Applications/Internet
67Requires: perl
68Requires: %{name} = %{version}-%{release}
69
70%description perl
71Perl scripts provided with OpenSSL for converting certificates and keys
72from other formats to those used by OpenSSL.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: Secure Sockets Layer Toolkit
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79%description -n compat32-%{name}
80The OpenSSL certificate management tool and the shared libraries that
81provide various cryptographic algorithms and protocols.
82
83%package -n compat32-%{name}-devel
84Summary: OpenSSL libraries and development headers.
85Group: Development/Libraries
86Requires: compat32-%{name} = %{version}-%{release}
87Requires: compat32-krb5-devel
88%description -n compat32-%{name}-devel
89The static libraries and include files needed to compile apps
90with support for various the cryptographic algorithms and protocols
91supported by OpenSSL.
92
93%prep
94%setup -q -n openssl-%{version}
95%patch0 -p1 -b .soversion
96%patch2 -p1 -b .rpm_opt
97%patch4 -p1 -b .enginesdir
98
99# security fix
100# nothing ;-)
101
102chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
103chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
104chmod 644 doc/openssl_button.html doc/openssl_button.gif
105chmod 644 doc/ssleay.txt
106
107# Link the configuration header to the one we're going to make.
108ln -sf ../../crypto/opensslconf.h include/openssl/
109
110%build
111PATH=${PATH}:${PWD}/bin
112TOPDIR=${PWD}
113LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
114
115# Figure out which flags we want to use.  Can't use assembler because it's
116# not lowest-common-denominator in most cases.
117perl util/perlpath.pl `dirname %{__perl}`
118%ifarch %ix86
119sslarch=linux-elf
120sslflags="no-asm 386"
121%endif
122%ifarch ppc
123sslarch=linux-ppc
124sslflags=no-asm
125%endif
126%ifarch sparc
127sslarch=linux-sparcv9
128sslflags=no-asm
129%endif
130%ifarch ia64
131sslarch=linux-ia64
132sslflags=no-asm
133%endif
134%ifarch alpha
135sslarch=linux-alpha-gcc
136sslflags=no-asm
137%endif
138%ifarch s390
139sslarch=linux-s390
140%endif
141%ifarch s390x
142sslarch=linux-s390x
143%endif
144%ifarch mipsel
145sslarch=linux-mips
146sslflags=no-asm
147%endif
148## to build for x86_64 architecture support
149%ifarch x86_64
150sslarch=linux-x86_64
151sslflags=no-asm
152%endif
153
154# Configure the build tree.  Override OpenSSL defaults with known-good defaults
155# usable on all platforms.  The Configure script already knows to use -fPIC and
156# RPM_OPT_FLAGS, so we can skip specifiying them here.
157./Configure  \
158         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
159         zlib-dynamic enable-rfc3779 \
160         --enginesdir=%{_libdir}/openssl/engines \
161        --with-krb5-flavor=MIT  --with-krb5-dir=/usr \
162         shared ${sslarch}
163
164# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
165# marked as not requiring an executable stack.
166RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
167make depend
168make all build-shared
169
170# Generate hashes for the included certs.
171LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
172export LD_LIBRARY_PATH
173make rehash build-shared
174
175# Verify that what was compiled actually works.
176make -C test apps tests
177
178# Relink the main binary to get it dynamically linked.
179rm apps/openssl
180make all build-shared
181
182%install
183[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
184# Install OpenSSL.
185install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
186make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
187install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
188# added for lib64
189# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
190mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
191# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
192mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
193mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
194rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
195rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
196for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
197        chmod 755 ${lib}
198        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
199        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
200done
201# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
202
203# Install a makefile for generating keys and self-signed certs, and a script
204# for generating them on the fly.
205mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
206install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
207install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
208
209# Make sure we actually include the headers we built against.
210for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
211        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
212                install -m644 include/openssl/`basename ${header}` ${header}
213        fi
214done
215
216# Rename man pages so that they don't conflict with system man pages.  We used
217# to change the file extensions, but that only prevents file conflicts.  The
218# man viewer still can't select either of the two unless we physically change
219# the directory.
220for section in 1 2 3 4 5 6 7 8 ; do
221        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
222                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
223                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
224        fi
225done
226
227# Pick a CA script.
228pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
229mv CA.sh CA
230popd
231
232# Install root CA stuffs.
233cat %{SOURCE3} > ca-bundle.crt
234install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
235ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
236
237# Fix libdir.
238#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
239# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
240#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
241#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
242# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
243#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
244# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
245
246%clean
247[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
248
249%files
250%defattr(-,root,root)
251%doc FAQ LICENSE CHANGES NEWS INSTALL README
252%doc doc/README doc/c-indentation.el doc/openssl.txt
253%doc doc/openssl_button.html doc/openssl_button.gif
254%doc doc/ssleay.txt
255%dir %{_datadir}/ssl
256%{_datadir}/ssl/certs
257%{_datadir}/ssl/cert.pem
258%{_datadir}/ssl/misc/CA
259%{_datadir}/ssl/misc/c_*
260%{_datadir}/ssl/private
261
262%config(noreplace) %{_datadir}/ssl/openssl.cnf
263
264%attr(0755,root,root) %{_bindir}/openssl
265%attr(0755,root,root) /%{_lib}/*.so.*
266%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
267%attr(0755,root,root) %dir %{_mandir}/man1*
268%attr(0644,root,root) %{_mandir}/man1*/*
269%attr(0755,root,root) %dir %{_mandir}/man5*
270%attr(0644,root,root) %{_mandir}/man5*/*
271%attr(0755,root,root) %dir %{_mandir}/man7*
272%attr(0644,root,root) %{_mandir}/man7*/*
273
274%files devel
275%defattr(-,root,root)
276%{_prefix}/include/openssl
277%exclude %{_libdir}/lib*.a
278%attr(0755,root,root) %{_libdir}/*.so
279%attr(0755,root,root) %dir %{_mandir}/man3*
280%attr(0644,root,root) %{_mandir}/man3*/*
281%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
282
283%files static
284%defattr(-,root,root)
285%attr(0644,root,root) %{_libdir}/*.a
286
287%files perl
288%defattr(-,root,root)
289%attr(0755,root,root) %{_bindir}/c_rehash
290%attr(0755,root,root) %dir %{_mandir}/man1*
291%attr(0644,root,root) %{_mandir}/man1*/*.pl*
292%{_datadir}/ssl/misc/*.pl
293# %{_datadir}/ssl/misc/tsget
294%doc apps/tsget
295
296## to build compat32 for x86_64 architecture support
297%if %{build_compat32}
298%files -n compat32-%{name}
299%defattr(-,root,root)
300%attr(0755,root,root) /%{_lib}/*.so.*
301
302%files -n compat32-%{name}-devel
303%defattr(-,root,root)
304%exclude %{_libdir}/lib*.a
305%attr(0755,root,root) %{_libdir}/*.so
306%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
307%endif
308
309%post -p /sbin/ldconfig
310
311%postun -p /sbin/ldconfig
312
313%post -n compat32-%{name} -p /sbin/ldconfig
314
315%postun -n compat32-%{name} -p /sbin/ldconfig
316
317%changelog
318* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
319- rebuild with krb5-libs 1.8
320
321* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
322- new upstream release with security fix
323
324* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
325- use upstream openssl.pc instead of vine original one (SOURCE6)
326
327* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
328- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
329
330* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
331- add R: krb5-devel into devel pkg
332- add R: compat32-krb5-devel into compat32-devel pkg
333
334* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
335- new upstream release 1.0.0x
336- separate static libs into static package
337- change configure options
338- change so version 10
339- add tsget into perl package
340- update all patches
341
342* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
343- fix changelog typo...
344
345* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
346- new upstream release with security fix (CVE-2010-4180)
347
348* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
349- new upstream release with security fix (CVE-2010-3864)
350- drop patches included in new release
351- update patch4
352
353* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
354- add patch12 for fix CVE-2009-3555 (renegotiation)
355
356* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
357- add patch11 for fix CVE-2009-4355 (memory leak)
358
359* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
360- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
361
362* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
363- removed unnecessary %%if %{build_compat32} statements
364- removed lib*.a from devel package
365
366* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
367- new upstream release with security fix (CVE-2000-0590,0591,0789)
368
369* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
370- new upstream release with security fix (CVE-2008-5077)
371
372* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
373- new upstream release
374
375* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
376- new upstream release
377- new versioning policy
378
379* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
380- new upstream release
381- drop patch10,20 which is merged in upstream
382
383* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
384- add security patch in advance for CVE-2007-5135
385  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
386  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
387
388* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
389- add security patch for CVE-2007-3108
390  (http://openssl.org/news/patch-CVE-2007-3108.txt)
391
392* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
393- new upstream release
394
395* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
396- update (fix) openssl.pc <BTS:437>
397
398* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
399- new upstream release (with security fix)
400
401* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
402- new upstream release
403- add patch2 to use RPM_OPT macro
404
405* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
406- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
407
408* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
409- added compat32-* packages for x86_64 architecture support
410- added openssl-0.9.7i.Configure-compat32.patch
411- changed '/lib' to '/%{_lib}'
412
413* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
414- new upstream release
415
416* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
417- rebuild on VineSeed
418
419* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
420- added a security patch from Gentoo.
421  - Patch1: openssl-0.9.7c-tempfile.patch
422
423* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
424- sslarch for ppc was missing... added.
425
426* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
427- use sslarch=linux-alpha-gcc instead of alpha-gcc
428
429* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
430- new upstream version
431- clean up of spec file
432        -- removed old patches
433
434* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
435- new upstream release
436- SECURITY fix.
437  - http://www.openssl.org/news/secadv_20040317.txt
438
439* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
440- new upstream release
441- [Security fix]
442  - Vulnerabilities in ASN.1 parsing
443    http://www.openssl.org/news/secadv_20030930.txt
444- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
445
446* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
447- add openssl.pc for pkgconfig
448
449* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
450- New upstream version
451- dropped patch10, 11
452        -- merged upstream version
453
454* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
455- rebuild for VineSeed
456
457* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
458- [Security Fix]
459  - Timing-based attacks on RSA keys
460    http://www.openssl.org/news/secadv_20030317.txt
461  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
462    http://www.openssl.org/news/secadv_20030317.txt
463
464* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
465- new upstream release 0.9.6i
466- [Security Fix]
467- build for Vine Linux 2.6 errata
468
469* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
470- new upstream release 0.9.6h
471
472* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
473- new upstream release 0.9.6g
474
475* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
476- SECURITY: CAN-2002-0659 fixed
477  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
478    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
479    - update asn patch to fix accidental reversal of a logic check
480    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
481    - update asn patch to reduce chance that compiler optimization will remove
482      one of the added tests
483    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
484    - rebuild
485    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
486    - add patch to fix ASN.1 vulnerabilities
487
488* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
489- rename spec file name
490- SECURITY: CA-2002-23 fixed
491  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
492    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
493    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
494
495* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
496- added ${PATH} in LD_LIBRARY_PATH
497- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
498 
499* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
500- remove --no-<cipher>
501
502* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
503- add Patch10 for mipsel shared ( Configure )
504
505* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
506- build for Vine Linux
507- use openssl-engine-0.9.6b.tar.gz
508
509* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
510- update to 0.9.6b
511
512* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
513- move .so symlinks back to %%{_libdir}
514
515* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
516- move shared libraries to /lib (#38410)
517
518* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
519- switch to engine code base
520
521* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
522- add a script for creating dummy certificates
523- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
524
525* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
526- add s390x support
527
528* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
529- change two memcpy() calls to memmove()
530- don't define L_ENDIAN on alpha
531
532* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
533- make subpackages depend on the main package
534
535* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
536- adjust the hobble script to not disturb symlinks in include/ (fix from
537  Joe Orton)
538
539* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
540- drop the m2crypo patch we weren't using
541
542* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
543- configure using "shared" as well
544
545* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
546- update to 0.9.6a
547- use the build-shared target to build shared libraries
548- bump the soversion to 2 because we're no longer compatible with
549  our 0.9.5a packages or our 0.9.6 packages
550- drop the patch for making rsatest a no-op when rsa null support is used
551- put all man pages into <section>ssl instead of <section>
552- break the m2crypto modules into a separate package
553
554* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
555- use BN_LLONG on s390
556
557* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
558- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
559
560* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
561- move c_rehash to the perl subpackage, because it's a perl script now
562
563* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
564- update to 0.9.6
565- enable MD2
566- use the libcrypto.so and libssl.so targets to build shared libs with
567- bump the soversion to 1 because we're no longer compatible with any of
568  the various 0.9.5a packages circulating around, which provide lib*.so.0
569
570* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
571- change hobble-openssl for disabling MD2 again
572
573* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
574- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
575  bytes or so, causing EVP_DigestInit() to zero out stack variables in
576  apps built against a version of the library without it
577
578* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
579- disable some inline assembly, which on x86 is Pentium-specific
580- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
581
582* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
583- fix s390 patch
584
585* Fri Dec 8 2000 Than Ngo <than@redhat.com>
586- added support s390
587
588* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
589- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
590- add the CA.pl man page to the perl subpackage
591
592* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
593- always build with -mcpu=ev5 on alpha
594
595* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
596- add a symlink from cert.pem to ca-bundle.crt
597
598* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
599- add a ca-bundle file for packages like Samba to reference for CA certificates
600
601* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
602- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
603
604* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
605- add unzip as a buildprereq (#17662)
606- update m2crypto to 0.05-snap4
607
608* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
609- fix some issues in building when it's not installed
610
611* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
612- make sure the headers we include are the ones we built with (aaaaarrgh!)
613
614* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
615- add Richard Henderson's patch for BN on ia64
616- clean up the changelog
617
618* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
619- fix the building of python modules without openssl-devel already installed
620
621* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
622- byte-compile python extensions without the build-root
623- adjust the makefile to not remove temporary files (like .key files when
624  building .csr files) by marking them as .PRECIOUS
625
626* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
627- break out python extensions into a subpackage
628
629* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
630- tweak the makefile some more
631
632* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
633- disable MD2 support
634
635* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
636- disable MDC2 support
637
638* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
639- tweak the disabling of RC5, IDEA support
640- tweak the makefile
641
642* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
643- strip binaries and libraries
644- rework certificate makefile to have the right parts for Apache
645
646* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
647- use %%{_perl} instead of /usr/bin/perl
648- disable alpha until it passes its own test suite
649
650* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
651- move the passwd.1 man page out of the passwd package's way
652
653* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
654- update to 0.9.5a, modified for U.S.
655- add perl as a build-time requirement
656- move certificate makefile to another package
657- disable RC5, IDEA, RSA support
658- remove optimizations for now
659
660* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
661- Bero told me to move the Makefile into this package
662
663* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
664- add lib*.so symlinks to link dynamically against shared libs
665
666* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
667- update to 0.9.5
668- run ldconfig directly in post/postun
669- add FAQ
670
671* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
672- Fix build on non-x86 platforms
673
674* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
675- move /usr/share/ssl/* from -devel to main package
676
677* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
678- inital packaging
679- changes from base:
680  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
681  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.