source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 2673

Revision 2673, 22.8 KB checked in by iwamoto, 13 years ago (diff)

openssl/openssl098: new upstream release with security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.0d
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27BuildRequires: zlib-devel, krb5-devel
28Requires: mktemp
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
34
35%description
36The OpenSSL certificate management tool and the shared libraries that
37provide various cryptographic algorithms and protocols.
38
39%package devel
40Summary: OpenSSL libraries and development headers.
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: krb5-devel
44
45%description devel
46The static libraries and include files needed to compile apps
47with support for various the cryptographic algorithms and protocols
48supported by OpenSSL.
49
50Patches for many networking apps can be found at:
51ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
52
53%package static
54Summary:  Libraries for static linking of applications which will use OpenSSL
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59OpenSSL is a toolkit for supporting cryptography. The openssl-static
60package contains static libraries needed for static linking of
61applications which support various cryptographic algorithms and
62protocols.
63
64%package perl
65Summary: OpenSSL scripts which require Perl.
66Group: Applications/Internet
67Requires: perl
68Requires: %{name} = %{version}-%{release}
69
70%description perl
71Perl scripts provided with OpenSSL for converting certificates and keys
72from other formats to those used by OpenSSL.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: Secure Sockets Layer Toolkit
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79%description -n compat32-%{name}
80The OpenSSL certificate management tool and the shared libraries that
81provide various cryptographic algorithms and protocols.
82
83%package -n compat32-%{name}-devel
84Summary: OpenSSL libraries and development headers.
85Group: Development/Libraries
86Requires: compat32-%{name} = %{version}-%{release}
87Requires: compat32-krb5-devel
88%description -n compat32-%{name}-devel
89The static libraries and include files needed to compile apps
90with support for various the cryptographic algorithms and protocols
91supported by OpenSSL.
92
93%prep
94%setup -q -n openssl-%{version}
95%patch0 -p1 -b .soversion
96%patch2 -p1 -b .rpm_opt
97%patch4 -p1 -b .enginesdir
98
99# security fix
100# nothing ;-)
101
102chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
103chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
104chmod 644 doc/openssl_button.html doc/openssl_button.gif
105chmod 644 doc/ssleay.txt
106
107# Link the configuration header to the one we're going to make.
108ln -sf ../../crypto/opensslconf.h include/openssl/
109
110%build
111PATH=${PATH}:${PWD}/bin
112TOPDIR=${PWD}
113LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
114
115# Figure out which flags we want to use.  Can't use assembler because it's
116# not lowest-common-denominator in most cases.
117perl util/perlpath.pl `dirname %{__perl}`
118%ifarch %ix86
119sslarch=linux-elf
120sslflags="no-asm 386"
121%endif
122%ifarch ppc
123sslarch=linux-ppc
124sslflags=no-asm
125%endif
126%ifarch sparc
127sslarch=linux-sparcv9
128sslflags=no-asm
129%endif
130%ifarch ia64
131sslarch=linux-ia64
132sslflags=no-asm
133%endif
134%ifarch alpha
135sslarch=linux-alpha-gcc
136sslflags=no-asm
137%endif
138%ifarch s390
139sslarch=linux-s390
140%endif
141%ifarch s390x
142sslarch=linux-s390x
143%endif
144%ifarch mipsel
145sslarch=linux-mips
146sslflags=no-asm
147%endif
148## to build for x86_64 architecture support
149%ifarch x86_64
150sslarch=linux-x86_64
151sslflags=no-asm
152%endif
153
154# Configure the build tree.  Override OpenSSL defaults with known-good defaults
155# usable on all platforms.  The Configure script already knows to use -fPIC and
156# RPM_OPT_FLAGS, so we can skip specifiying them here.
157./Configure  \
158         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
159         zlib-dynamic enable-rfc3779 \
160         --enginesdir=%{_libdir}/openssl/engines \
161        --with-krb5-flavor=MIT  --with-krb5-dir=/usr \
162         shared ${sslarch}
163
164# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
165# marked as not requiring an executable stack.
166RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
167make depend
168make all build-shared
169
170# Generate hashes for the included certs.
171LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
172export LD_LIBRARY_PATH
173make rehash build-shared
174
175# Verify that what was compiled actually works.
176make -C test apps tests
177
178# Relink the main binary to get it dynamically linked.
179rm apps/openssl
180make all build-shared
181
182%install
183[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
184# Install OpenSSL.
185install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
186make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
187install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
188# added for lib64
189# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
190mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
191# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
192mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
193mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
194rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
195rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
196for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
197        chmod 755 ${lib}
198        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
199        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
200done
201# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
202
203# Install a makefile for generating keys and self-signed certs, and a script
204# for generating them on the fly.
205mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
206install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
207install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
208
209# Make sure we actually include the headers we built against.
210for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
211        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
212                install -m644 include/openssl/`basename ${header}` ${header}
213        fi
214done
215
216# Rename man pages so that they don't conflict with system man pages.  We used
217# to change the file extensions, but that only prevents file conflicts.  The
218# man viewer still can't select either of the two unless we physically change
219# the directory.
220for section in 1 2 3 4 5 6 7 8 ; do
221        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
222                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
223                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
224        fi
225done
226
227# Pick a CA script.
228pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
229mv CA.sh CA
230popd
231
232# Install root CA stuffs.
233cat %{SOURCE3} > ca-bundle.crt
234install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
235ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
236
237# Fix libdir.
238#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
239# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
240#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
241#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
242# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
243#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
244# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
245
246%clean
247[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
248
249%files
250%defattr(-,root,root)
251%doc FAQ LICENSE CHANGES NEWS INSTALL README
252%doc doc/README doc/c-indentation.el doc/openssl.txt
253%doc doc/openssl_button.html doc/openssl_button.gif
254%doc doc/ssleay.txt
255%dir %{_datadir}/ssl
256%{_datadir}/ssl/certs
257%{_datadir}/ssl/cert.pem
258%{_datadir}/ssl/misc/CA
259%{_datadir}/ssl/misc/c_*
260%{_datadir}/ssl/private
261
262%config(noreplace) %{_datadir}/ssl/openssl.cnf
263
264%attr(0755,root,root) %{_bindir}/openssl
265%attr(0755,root,root) /%{_lib}/*.so.*
266%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
267%attr(0755,root,root) %dir %{_mandir}/man1*
268%attr(0644,root,root) %{_mandir}/man1*/*
269%attr(0755,root,root) %dir %{_mandir}/man5*
270%attr(0644,root,root) %{_mandir}/man5*/*
271%attr(0755,root,root) %dir %{_mandir}/man7*
272%attr(0644,root,root) %{_mandir}/man7*/*
273
274%files devel
275%defattr(-,root,root)
276%{_prefix}/include/openssl
277%exclude %{_libdir}/lib*.a
278%attr(0755,root,root) %{_libdir}/*.so
279%attr(0755,root,root) %dir %{_mandir}/man3*
280%attr(0644,root,root) %{_mandir}/man3*/*
281%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
282
283%files static
284%defattr(-,root,root)
285%attr(0644,root,root) %{_libdir}/*.a
286
287%files perl
288%defattr(-,root,root)
289%attr(0755,root,root) %{_bindir}/c_rehash
290%attr(0755,root,root) %dir %{_mandir}/man1*
291%attr(0644,root,root) %{_mandir}/man1*/*.pl*
292%{_datadir}/ssl/misc/*.pl
293# %{_datadir}/ssl/misc/tsget
294%doc apps/tsget
295
296## to build compat32 for x86_64 architecture support
297%if %{build_compat32}
298%files -n compat32-%{name}
299%defattr(-,root,root)
300%attr(0755,root,root) /%{_lib}/*.so.*
301
302%files -n compat32-%{name}-devel
303%defattr(-,root,root)
304%exclude %{_libdir}/lib*.a
305%attr(0755,root,root) %{_libdir}/*.so
306%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
307%endif
308
309%post -p /sbin/ldconfig
310
311%postun -p /sbin/ldconfig
312
313%post -n compat32-%{name} -p /sbin/ldconfig
314
315%postun -n compat32-%{name} -p /sbin/ldconfig
316
317%changelog
318* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
319- new upstream release with security fix
320
321* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
322- use upstream openssl.pc instead of vine original one (SOURCE6)
323
324* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
325- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
326
327* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
328- add R: krb5-devel into devel pkg
329- add R: compat32-krb5-devel into compat32-devel pkg
330
331* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
332- new upstream release 1.0.0x
333- separate static libs into static package
334- change configure options
335- change so version 10
336- add tsget into perl package
337- update all patches
338
339* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
340- fix changelog typo...
341
342* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
343- new upstream release with security fix (CVE-2010-4180)
344
345* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
346- new upstream release with security fix (CVE-2010-3864)
347- drop patches included in new release
348- update patch4
349
350* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
351- add patch12 for fix CVE-2009-3555 (renegotiation)
352
353* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
354- add patch11 for fix CVE-2009-4355 (memory leak)
355
356* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
357- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
358
359* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
360- removed unnecessary %%if %{build_compat32} statements
361- removed lib*.a from devel package
362
363* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
364- new upstream release with security fix (CVE-2000-0590,0591,0789)
365
366* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
367- new upstream release with security fix (CVE-2008-5077)
368
369* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
370- new upstream release
371
372* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
373- new upstream release
374- new versioning policy
375
376* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
377- new upstream release
378- drop patch10,20 which is merged in upstream
379
380* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
381- add security patch in advance for CVE-2007-5135
382  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
383  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
384
385* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
386- add security patch for CVE-2007-3108
387  (http://openssl.org/news/patch-CVE-2007-3108.txt)
388
389* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
390- new upstream release
391
392* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
393- update (fix) openssl.pc <BTS:437>
394
395* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
396- new upstream release (with security fix)
397
398* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
399- new upstream release
400- add patch2 to use RPM_OPT macro
401
402* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
403- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
404
405* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
406- added compat32-* packages for x86_64 architecture support
407- added openssl-0.9.7i.Configure-compat32.patch
408- changed '/lib' to '/%{_lib}'
409
410* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
411- new upstream release
412
413* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
414- rebuild on VineSeed
415
416* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
417- added a security patch from Gentoo.
418  - Patch1: openssl-0.9.7c-tempfile.patch
419
420* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
421- sslarch for ppc was missing... added.
422
423* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
424- use sslarch=linux-alpha-gcc instead of alpha-gcc
425
426* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
427- new upstream version
428- clean up of spec file
429        -- removed old patches
430
431* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
432- new upstream release
433- SECURITY fix.
434  - http://www.openssl.org/news/secadv_20040317.txt
435
436* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
437- new upstream release
438- [Security fix]
439  - Vulnerabilities in ASN.1 parsing
440    http://www.openssl.org/news/secadv_20030930.txt
441- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
442
443* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
444- add openssl.pc for pkgconfig
445
446* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
447- New upstream version
448- dropped patch10, 11
449        -- merged upstream version
450
451* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
452- rebuild for VineSeed
453
454* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
455- [Security Fix]
456  - Timing-based attacks on RSA keys
457    http://www.openssl.org/news/secadv_20030317.txt
458  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
459    http://www.openssl.org/news/secadv_20030317.txt
460
461* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
462- new upstream release 0.9.6i
463- [Security Fix]
464- build for Vine Linux 2.6 errata
465
466* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
467- new upstream release 0.9.6h
468
469* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
470- new upstream release 0.9.6g
471
472* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
473- SECURITY: CAN-2002-0659 fixed
474  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
475    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
476    - update asn patch to fix accidental reversal of a logic check
477    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
478    - update asn patch to reduce chance that compiler optimization will remove
479      one of the added tests
480    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
481    - rebuild
482    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
483    - add patch to fix ASN.1 vulnerabilities
484
485* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
486- rename spec file name
487- SECURITY: CA-2002-23 fixed
488  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
489    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
490    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
491
492* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
493- added ${PATH} in LD_LIBRARY_PATH
494- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
495 
496* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
497- remove --no-<cipher>
498
499* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
500- add Patch10 for mipsel shared ( Configure )
501
502* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
503- build for Vine Linux
504- use openssl-engine-0.9.6b.tar.gz
505
506* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
507- update to 0.9.6b
508
509* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
510- move .so symlinks back to %%{_libdir}
511
512* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
513- move shared libraries to /lib (#38410)
514
515* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
516- switch to engine code base
517
518* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
519- add a script for creating dummy certificates
520- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
521
522* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
523- add s390x support
524
525* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
526- change two memcpy() calls to memmove()
527- don't define L_ENDIAN on alpha
528
529* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
530- make subpackages depend on the main package
531
532* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
533- adjust the hobble script to not disturb symlinks in include/ (fix from
534  Joe Orton)
535
536* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
537- drop the m2crypo patch we weren't using
538
539* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
540- configure using "shared" as well
541
542* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
543- update to 0.9.6a
544- use the build-shared target to build shared libraries
545- bump the soversion to 2 because we're no longer compatible with
546  our 0.9.5a packages or our 0.9.6 packages
547- drop the patch for making rsatest a no-op when rsa null support is used
548- put all man pages into <section>ssl instead of <section>
549- break the m2crypto modules into a separate package
550
551* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
552- use BN_LLONG on s390
553
554* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
555- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
556
557* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
558- move c_rehash to the perl subpackage, because it's a perl script now
559
560* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
561- update to 0.9.6
562- enable MD2
563- use the libcrypto.so and libssl.so targets to build shared libs with
564- bump the soversion to 1 because we're no longer compatible with any of
565  the various 0.9.5a packages circulating around, which provide lib*.so.0
566
567* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
568- change hobble-openssl for disabling MD2 again
569
570* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
571- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
572  bytes or so, causing EVP_DigestInit() to zero out stack variables in
573  apps built against a version of the library without it
574
575* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
576- disable some inline assembly, which on x86 is Pentium-specific
577- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
578
579* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
580- fix s390 patch
581
582* Fri Dec 8 2000 Than Ngo <than@redhat.com>
583- added support s390
584
585* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
586- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
587- add the CA.pl man page to the perl subpackage
588
589* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
590- always build with -mcpu=ev5 on alpha
591
592* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
593- add a symlink from cert.pem to ca-bundle.crt
594
595* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
596- add a ca-bundle file for packages like Samba to reference for CA certificates
597
598* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
599- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
600
601* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
602- add unzip as a buildprereq (#17662)
603- update m2crypto to 0.05-snap4
604
605* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
606- fix some issues in building when it's not installed
607
608* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
609- make sure the headers we include are the ones we built with (aaaaarrgh!)
610
611* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
612- add Richard Henderson's patch for BN on ia64
613- clean up the changelog
614
615* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
616- fix the building of python modules without openssl-devel already installed
617
618* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
619- byte-compile python extensions without the build-root
620- adjust the makefile to not remove temporary files (like .key files when
621  building .csr files) by marking them as .PRECIOUS
622
623* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
624- break out python extensions into a subpackage
625
626* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
627- tweak the makefile some more
628
629* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
630- disable MD2 support
631
632* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
633- disable MDC2 support
634
635* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
636- tweak the disabling of RC5, IDEA support
637- tweak the makefile
638
639* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
640- strip binaries and libraries
641- rework certificate makefile to have the right parts for Apache
642
643* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
644- use %%{_perl} instead of /usr/bin/perl
645- disable alpha until it passes its own test suite
646
647* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
648- move the passwd.1 man page out of the passwd package's way
649
650* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
651- update to 0.9.5a, modified for U.S.
652- add perl as a build-time requirement
653- move certificate makefile to another package
654- disable RC5, IDEA, RSA support
655- remove optimizations for now
656
657* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
658- Bero told me to move the Makefile into this package
659
660* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
661- add lib*.so symlinks to link dynamically against shared libs
662
663* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
664- update to 0.9.5
665- run ldconfig directly in post/postun
666- add FAQ
667
668* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
669- Fix build on non-x86 platforms
670
671* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
672- move /usr/share/ssl/* from -devel to main package
673
674* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
675- inital packaging
676- changes from base:
677  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
678  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.