source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 11981

Revision 11981, 29.7 KB checked in by tomop, 5 years ago (diff)

openssl-1.1.1a-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?_pkgdocdir:%define _pkgdocdir %{_docdir}}
3%define version 1.1.1a
4%define release 1%{_dist_release}
5# 1.0.0 soversion = 10
6# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
7#                        depends on build configuration options)
8%define soversion 1.1
9
10Summary: Secure Sockets Layer Toolkit
11Name: openssl
12Version: %{version}
13Release: %{release}
14# We have to remove certain patented algorithms from the openssl source
15# tarball with the hobble-openssl script which is included below.
16# The original openssl upstream tarball cannot be shipped in the .src.rpm.
17Source: openssl-%{version}-hobbled.tar.xz
18Source1: hobble-openssl
19Source2: Makefile.certificate
20Source6: make-dummy-cert
21Source7: renew-dummy-cert
22Source9: opensslconf-new.h
23Source10: opensslconf-new-warning.h
24#Source11: README.FIPS
25Source12: ec_curve.c
26Source13: ectest.c
27
28# Build changes
29Patch1: openssl-1.1.1-build.patch
30Patch2: openssl-1.1.0-defaults.patch
31Patch3: openssl-1.1.0-no-html.patch
32Patch4: openssl-1.1.1-man-rename.patch
33# Bug fixes
34Patch21: openssl-1.1.0-issuer-hash.patch
35# Functionality changes
36Patch31: openssl-1.1.1-conf-paths.patch
37Patch32: openssl-1.1.1-version-add-engines.patch
38Patch33: openssl-1.1.0-apps-dgst.patch
39#Patch36: openssl-1.1.1-secure-getenv.patch
40Patch37: openssl-1.1.1-ec-curves.patch
41Patch38: openssl-1.1.0-no-weak-verify.patch
42Patch40: openssl-1.1.1-disable-ssl3.patch
43Patch41: openssl-1.1.1-system-cipherlist.patch
44#Patch42: openssl-1.1.1-fips.patch
45Patch43: openssl-1.1.1-ignore-bound.patch
46#Patch44: openssl-1.1.1-version-override.patch
47Patch45: openssl-1.1.1-weak-ciphers.patch
48#Patch46: openssl-1.1.1-seclevel.patch
49
50# security fix
51# nothing ;-)
52
53License: BSDish
54Group: System Environment/Libraries
55URL: http://www.openssl.org/
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58BuildRequires: perl, sed
59BuildRequires: zlib-devel, krb5-devel
60BuildRequires: lksctp-tools-devel
61
62Requires: mktemp
63Requires: ca-certificates
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: daisuke, iwamoto
68
69%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
70
71%description
72The OpenSSL certificate management tool and the shared libraries that
73provide various cryptographic algorithms and protocols.
74
75%package devel
76Summary: OpenSSL libraries and development headers.
77Group: Development/Libraries
78Requires: %{name} = %{version}-%{release}
79Requires: krb5-devel
80
81%description devel
82The static libraries and include files needed to compile apps
83with support for various the cryptographic algorithms and protocols
84supported by OpenSSL.
85
86Patches for many networking apps can be found at:
87ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
88
89%package static
90Summary:  Libraries for static linking of applications which will use OpenSSL
91Group: Development/Libraries
92Requires: %{name}-devel = %{version}-%{release}
93
94%description static
95OpenSSL is a toolkit for supporting cryptography. The openssl-static
96package contains static libraries needed for static linking of
97applications which support various cryptographic algorithms and
98protocols.
99
100%package perl
101Summary: OpenSSL scripts which require Perl.
102Group: Applications/Internet
103Requires: %{name} = %{version}-%{release}
104Requires: perl
105Requires: perl-WWW-Curl
106
107%description perl
108Perl scripts provided with OpenSSL for converting certificates and keys
109from other formats to those used by OpenSSL.
110
111## to build compat32 for x86_64 architecture support
112%package -n compat32-%{name}
113Summary: Secure Sockets Layer Toolkit
114Group: System Environment/Libraries
115Requires: %{name} = %{version}-%{release}
116%description -n compat32-%{name}
117The OpenSSL certificate management tool and the shared libraries that
118provide various cryptographic algorithms and protocols.
119
120%package -n compat32-%{name}-devel
121Summary: OpenSSL libraries and development headers.
122Group: Development/Libraries
123Requires: compat32-%{name} = %{version}-%{release}
124Requires: compat32-krb5-devel
125%description -n compat32-%{name}-devel
126The static libraries and include files needed to compile apps
127with support for various the cryptographic algorithms and protocols
128supported by OpenSSL.
129
130%prep
131%setup -q -n %{name}-%{version}
132
133# The hobble_openssl is called here redundantly, just to be sure.
134# The tarball has already the sources removed.
135%{SOURCE1} > /dev/null
136
137cp %{SOURCE12} crypto/ec/
138cp %{SOURCE13} test/
139
140%patch1 -p1 -b .build   %{?_rawbuild}
141%patch2 -p1 -b .defaults
142%patch3 -p1 -b .no-html  %{?_rawbuild}
143%patch4 -p1 -b .man-rename
144
145%patch21 -p1 -b .issuer-hash
146
147%patch31 -p1 -b .conf-paths
148%patch32 -p1 -b .version-add-engines
149%patch33 -p1 -b .dgst
150#%patch36 -p1 -b .secure-getenv
151%patch37 -p1 -b .curves
152%patch38 -p1 -b .no-weak-verify
153%patch40 -p1 -b .disable-ssl3
154%patch41 -p1 -b .system-cipherlist
155#patch42 -p1 -b .fips
156%patch43 -p1 -b .ignore-bound
157#patch44 -p1 -b .version-override
158%patch45 -p1 -b .weak-ciphers
159#%patch46 -p1 -b .seclevel
160
161# security fix
162# nothing ;-)
163
164%build
165# Figure out which flags we want to use.
166# default
167sslarch=%{_os}-%{_target_cpu}
168#
169%ifarch %ix86
170sslarch=linux-elf
171if ! echo %{_target} | grep -q i686 ; then
172   sslflags="no-asm 386"
173fi
174%endif
175%ifarch x86_64
176sslflags=enable-ec_nistp_64_gcc_128
177%endif
178
179# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
180# marked as not requiring an executable stack.
181# Also add -DPURIFY to make using valgrind with openssl easier as we do not
182# want to depend on the uninitialized memory as a source of entropy anyway.
183RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
184
185export HASHBANGPERL=/usr/bin/perl
186
187perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
188
189# ia64, x86_64, ppc are OK by default
190# Configure the build tree.  Override OpenSSL defaults with known-good defaults
191# usable on all platforms.  The Configure script already knows to use -fPIC and
192# RPM_OPT_FLAGS, so we can skip specifiying them here.
193./Configure \
194        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
195        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
196        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
197        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
198        enable-weak-ssl-ciphers \
199        no-mdc2 no-ec2m no-sm2 no-sm4 \
200        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
201
202# Do not run this in a production package the FIPS symbols must be patched-in
203#util/mkdef.pl crypto update
204
205make all
206
207# Clean up the .pc files
208for i in libcrypto.pc libssl.pc openssl.pc ; do
209  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
210done
211
212%check
213# Verify that what was compiled actually works.
214
215# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
216(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
217(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
218 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
219 touch -r configdata.pm configdata.pm.new && \
220 mv -f configdata.pm.new configdata.pm)
221
222# We must revert patch31 before tests otherwise they will fail
223patch -p1 -R < %{PATCH31}
224
225# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
226rm -f test/recipes/80-test_ssl_new.t
227
228
229LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
230export LD_LIBRARY_PATH
231OPENSSL_ENABLE_MD5_VERIFY=
232export OPENSSL_ENABLE_MD5_VERIFY
233OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
234export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
235make test
236
237
238# Add generation of HMAC checksum of the final stripped library
239%define __spec_install_post \
240    %{?__debug_package:%{__debug_install_post}} \
241    %{__arch_install_post} \
242    %{__os_install_post} \
243%{nil}
244
245%define __provides_exclude_from %{_libdir}/openssl
246
247%install
248[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
249# Install OpenSSL.
250install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
251make DESTDIR=$RPM_BUILD_ROOT install
252mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
253rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
254for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
255        chmod 755 ${lib}
256        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
257        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
258done
259
260# Install a makefile for generating keys and self-signed certs, and a script
261# for generating them on the fly.
262mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
263install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
264install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
265install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
266
267# Move runable perl scripts to bindir
268mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
269mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
270
271# Rename man pages so that they don't conflict with other system man pages.
272pushd $RPM_BUILD_ROOT%{_mandir}
273ln -s -f config.5 man5/openssl.cnf.5
274for manpage in man*/* ; do
275        if [ -L ${manpage} ]; then
276                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
277                ln -snf ${TARGET}ssl ${manpage}ssl
278                rm -f ${manpage}
279        else
280                mv ${manpage} ${manpage}ssl
281        fi
282done
283for conflict in passwd rand ; do
284        rename ${conflict} ssl${conflict} man*/${conflict}*
285# Fix dangling symlinks
286        manpage=man1/openssl-${conflict}.*
287        if [ -L ${manpage} ] ; then
288                ln -snf ssl${conflict}.1ssl ${manpage}
289        fi
290done
291popd
292
293mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
294mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
295mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
296mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
297mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
298
299# Ensure the config file timestamps are identical across builds to avoid
300# mulitlib conflicts and unnecessary renames on upgrade
301touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
302touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
303
304rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
305rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
306
307# Determine which arch opensslconf.h is going to try to #include.
308basearch=%{_arch}
309%ifarch %{ix86}
310basearch=i386
311%endif
312
313# Next step of gradual disablement of SSL3.
314# Make SSL3 disappear to newly built dependencies.
315sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
316#ifndef OPENSSL_NO_SSL3\
317# define OPENSSL_NO_SSL3\
318#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
319
320%ifarch %{multilib_arches}
321# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
322# can have both a 32- and 64-bit version of the library, and they each need
323# their own correct-but-different versions of opensslconf.h to be usable.
324install -m644 %{SOURCE10} \
325        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
326cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
327        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
328install -m644 %{SOURCE9} \
329        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
330%endif
331LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
332export LD_LIBRARY_PATH
333
334
335%clean
336[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
337
338%files
339%defattr(-,root,root)
340%{!?_licensedir:%global license %%doc}
341%license LICENSE
342%doc FAQ NEWS README
343%{_pkgdocdir}/Makefile.certificate
344%dir %{_sysconfdir}/pki/tls
345%dir %{_sysconfdir}/pki/tls/certs
346%dir %{_sysconfdir}/pki/tls/misc
347%dir %{_sysconfdir}/pki/tls/private
348%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
349%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
350
351%{_bindir}/make-dummy-cert
352%{_bindir}/renew-dummy-cert
353%{_bindir}/openssl
354%attr(0755,root,root) /%{_lib}/*.so.*
355/%{_lib}/*.so.%{soversion}
356%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
357%dir %{_mandir}/man1*
358%{_mandir}/man1*/*
359%dir %{_mandir}/man5*
360%{_mandir}/man5*/*
361%dir %{_mandir}/man7*
362%{_mandir}/man7*/*
363
364%files devel
365%defattr(-,root,root)
366%{_prefix}/include/openssl
367%exclude %{_libdir}/lib*.a
368%attr(0755,root,root) %{_libdir}/*.so
369%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
370%dir %{_mandir}/man3*
371%{_mandir}/man3*/*
372
373%files static
374%defattr(-,root,root)
375%attr(0644,root,root) %{_libdir}/*.a
376
377%files perl
378%defattr(-,root,root)
379%{_bindir}/c_rehash
380%{_bindir}/*.pl
381%{_bindir}/tsget
382%{_mandir}/man1*/*.pl*
383%{_mandir}/man1*/c_rehash*
384%{_mandir}/man1*/tsget*
385%{_mandir}/man1*/openssl-tsget*
386%dir %{_sysconfdir}/pki/CA
387%dir %{_sysconfdir}/pki/CA/private
388%dir %{_sysconfdir}/pki/CA/certs
389%dir %{_sysconfdir}/pki/CA/crl
390%dir %{_sysconfdir}/pki/CA/newcerts
391
392## to build compat32 for x86_64 architecture support
393%if %{build_compat32}
394%files -n compat32-%{name}
395%defattr(-,root,root)
396%attr(0755,root,root) /%{_lib}/*.so.*
397
398%files -n compat32-%{name}-devel
399%defattr(-,root,root)
400%exclude %{_libdir}/lib*.a
401%attr(0755,root,root) %{_libdir}/*.so
402%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
403%endif
404
405%post -p /sbin/ldconfig
406
407%postun -p /sbin/ldconfig
408
409%post -n compat32-%{name} -p /sbin/ldconfig
410
411%postun -n compat32-%{name} -p /sbin/ldconfig
412
413%changelog
414* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
415- new upstream release.
416- updated Patch2.
417- dropped Patch36 and 46: fixed in upstream.
418
419* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
420- fixed symlinks.
421
422* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
423- new upstream release (newest LTS version).
424- imported fedora stuff (except FIPS).
425
426* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
427- new upstream release with security fixes
428
429* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
430- new upstream release with security fixes
431
432* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
433- new upstream release with security fixes
434
435* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
436- new upstream release with security fixes
437
438* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
439- new upstream release with security fixes
440
441* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
442- new upstream release 1.0.2 with security fixes
443- Patch2 is merged into Patch0
444
445* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
446- new upstream release with security fixes
447
448* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
449- new upstream release with security fixes
450
451* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
452- new upstream release
453
454* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
455- merged into Vine6
456  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
457  - new upstream release with security fixes 
458  - update Patch2,5
459
460* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
461- new upstream release with security fixes 
462
463* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
464- new upstream release with security fixes
465- add patch8 from fc21 (fix perl find.pl)
466
467* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
468- new upstream release with security fixes.
469
470* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
471- new upstream release with security fixes
472
473* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
474- new upstream release with security fixes
475
476* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
477- move root CA bundle to ca-certificates package
478
479* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
480- update to 1.0.1e
481  - 1.0.1d has major regressions from 1.0.1c
482
483* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
484- remove tsget script to delete dependency perl(WWW::Curl::Easy)
485 - openssl-perl package contains it in docdir
486
487* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
488- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
489- fixed %%files
490
491* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
492- update to 1.0.1c
493- enable configure options:
494  enable-camellia enable-seed enable-tlsext enable-rfc3779
495  enable-cms enable-md2
496- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
497- generate a table with the compile settings before configure
498
499* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
500- new upstream release with security fix (CVE-2012-0050)
501
502* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
503- new upstream release with security fix
504  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
505
506* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
507- new upstream release with security fix (CVE-2011-3207, 3210)
508
509* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
510- rebuild with krb5-libs 1.8
511
512* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
513- new upstream release with security fix
514
515* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
516- use upstream openssl.pc instead of vine original one (SOURCE6)
517
518* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
519- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
520
521* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
522- add R: krb5-devel into devel pkg
523- add R: compat32-krb5-devel into compat32-devel pkg
524
525* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
526- new upstream release 1.0.0x
527- separate static libs into static package
528- change configure options
529- change so version 10
530- add tsget into perl package
531- update all patches
532
533* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
534- fix changelog typo...
535
536* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
537- new upstream release with security fix (CVE-2010-4180)
538
539* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
540- new upstream release with security fix (CVE-2010-3864)
541- drop patches included in new release
542- update patch4
543
544* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
545- add patch12 for fix CVE-2009-3555 (renegotiation)
546
547* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
548- add patch11 for fix CVE-2009-4355 (memory leak)
549
550* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
551- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
552
553* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
554- removed unnecessary %%if %{build_compat32} statements
555- removed lib*.a from devel package
556
557* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
558- new upstream release with security fix (CVE-2000-0590,0591,0789)
559
560* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
561- new upstream release with security fix (CVE-2008-5077)
562
563* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
564- new upstream release
565
566* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
567- new upstream release
568- new versioning policy
569
570* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
571- new upstream release
572- drop patch10,20 which is merged in upstream
573
574* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
575- add security patch in advance for CVE-2007-5135
576  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
577  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
578
579* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
580- add security patch for CVE-2007-3108
581  (http://openssl.org/news/patch-CVE-2007-3108.txt)
582
583* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
584- new upstream release
585
586* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
587- update (fix) openssl.pc <BTS:437>
588
589* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
590- new upstream release (with security fix)
591
592* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
593- new upstream release
594- add patch2 to use RPM_OPT macro
595
596* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
597- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
598
599* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
600- added compat32-* packages for x86_64 architecture support
601- added openssl-0.9.7i.Configure-compat32.patch
602- changed '/lib' to '/%{_lib}'
603
604* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
605- new upstream release
606
607* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
608- rebuild on VineSeed
609
610* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
611- added a security patch from Gentoo.
612  - Patch1: openssl-0.9.7c-tempfile.patch
613
614* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
615- sslarch for ppc was missing... added.
616
617* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
618- use sslarch=linux-alpha-gcc instead of alpha-gcc
619
620* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
621- new upstream version
622- clean up of spec file
623        -- removed old patches
624
625* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
626- new upstream release
627- SECURITY fix.
628  - http://www.openssl.org/news/secadv_20040317.txt
629
630* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
631- new upstream release
632- [Security fix]
633  - Vulnerabilities in ASN.1 parsing
634    http://www.openssl.org/news/secadv_20030930.txt
635- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
636
637* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
638- add openssl.pc for pkgconfig
639
640* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
641- New upstream version
642- dropped patch10, 11
643        -- merged upstream version
644
645* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
646- rebuild for VineSeed
647
648* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
649- [Security Fix]
650  - Timing-based attacks on RSA keys
651    http://www.openssl.org/news/secadv_20030317.txt
652  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
653    http://www.openssl.org/news/secadv_20030317.txt
654
655* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
656- new upstream release 0.9.6i
657- [Security Fix]
658- build for Vine Linux 2.6 errata
659
660* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
661- new upstream release 0.9.6h
662
663* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
664- new upstream release 0.9.6g
665
666* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
667- SECURITY: CAN-2002-0659 fixed
668  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
669    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
670    - update asn patch to fix accidental reversal of a logic check
671    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
672    - update asn patch to reduce chance that compiler optimization will remove
673      one of the added tests
674    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
675    - rebuild
676    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
677    - add patch to fix ASN.1 vulnerabilities
678
679* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
680- rename spec file name
681- SECURITY: CA-2002-23 fixed
682  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
683    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
684    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
685
686* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
687- added ${PATH} in LD_LIBRARY_PATH
688- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
689 
690* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
691- remove --no-<cipher>
692
693* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
694- add Patch10 for mipsel shared ( Configure )
695
696* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
697- build for Vine Linux
698- use openssl-engine-0.9.6b.tar.gz
699
700* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
701- update to 0.9.6b
702
703* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
704- move .so symlinks back to %%{_libdir}
705
706* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
707- move shared libraries to /lib (#38410)
708
709* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
710- switch to engine code base
711
712* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
713- add a script for creating dummy certificates
714- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
715
716* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
717- add s390x support
718
719* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
720- change two memcpy() calls to memmove()
721- don't define L_ENDIAN on alpha
722
723* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
724- make subpackages depend on the main package
725
726* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
727- adjust the hobble script to not disturb symlinks in include/ (fix from
728  Joe Orton)
729
730* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
731- drop the m2crypo patch we weren't using
732
733* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
734- configure using "shared" as well
735
736* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
737- update to 0.9.6a
738- use the build-shared target to build shared libraries
739- bump the soversion to 2 because we're no longer compatible with
740  our 0.9.5a packages or our 0.9.6 packages
741- drop the patch for making rsatest a no-op when rsa null support is used
742- put all man pages into <section>ssl instead of <section>
743- break the m2crypto modules into a separate package
744
745* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
746- use BN_LLONG on s390
747
748* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
749- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
750
751* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
752- move c_rehash to the perl subpackage, because it's a perl script now
753
754* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
755- update to 0.9.6
756- enable MD2
757- use the libcrypto.so and libssl.so targets to build shared libs with
758- bump the soversion to 1 because we're no longer compatible with any of
759  the various 0.9.5a packages circulating around, which provide lib*.so.0
760
761* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
762- change hobble-openssl for disabling MD2 again
763
764* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
765- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
766  bytes or so, causing EVP_DigestInit() to zero out stack variables in
767  apps built against a version of the library without it
768
769* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
770- disable some inline assembly, which on x86 is Pentium-specific
771- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
772
773* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
774- fix s390 patch
775
776* Fri Dec 8 2000 Than Ngo <than@redhat.com>
777- added support s390
778
779* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
780- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
781- add the CA.pl man page to the perl subpackage
782
783* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
784- always build with -mcpu=ev5 on alpha
785
786* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
787- add a symlink from cert.pem to ca-bundle.crt
788
789* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
790- add a ca-bundle file for packages like Samba to reference for CA certificates
791
792* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
793- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
794
795* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
796- add unzip as a buildprereq (#17662)
797- update m2crypto to 0.05-snap4
798
799* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
800- fix some issues in building when it's not installed
801
802* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
803- make sure the headers we include are the ones we built with (aaaaarrgh!)
804
805* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
806- add Richard Henderson's patch for BN on ia64
807- clean up the changelog
808
809* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
810- fix the building of python modules without openssl-devel already installed
811
812* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
813- byte-compile python extensions without the build-root
814- adjust the makefile to not remove temporary files (like .key files when
815  building .csr files) by marking them as .PRECIOUS
816
817* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
818- break out python extensions into a subpackage
819
820* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
821- tweak the makefile some more
822
823* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
824- disable MD2 support
825
826* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
827- disable MDC2 support
828
829* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
830- tweak the disabling of RC5, IDEA support
831- tweak the makefile
832
833* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
834- strip binaries and libraries
835- rework certificate makefile to have the right parts for Apache
836
837* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
838- use %%{_perl} instead of /usr/bin/perl
839- disable alpha until it passes its own test suite
840
841* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
842- move the passwd.1 man page out of the passwd package's way
843
844* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
845- update to 0.9.5a, modified for U.S.
846- add perl as a build-time requirement
847- move certificate makefile to another package
848- disable RC5, IDEA, RSA support
849- remove optimizations for now
850
851* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
852- Bero told me to move the Makefile into this package
853
854* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
855- add lib*.so symlinks to link dynamically against shared libs
856
857* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
858- update to 0.9.5
859- run ldconfig directly in post/postun
860- add FAQ
861
862* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
863- Fix build on non-x86 platforms
864
865* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
866- move /usr/share/ssl/* from -devel to main package
867
868* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
869- inital packaging
870- changes from base:
871  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
872  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.