source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 12062

Revision 12062, 30.3 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%bcond_with fips
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}}
5%define version 1.1.1b
6%define release 1%{_dist_release}
7# 1.0.0 soversion = 10
8# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
9#                        depends on build configuration options)
10%define soversion 1.1
11
12Summary: Secure Sockets Layer Toolkit
13Name: openssl
14Version: %{version}
15Release: %{release}
16# We have to remove certain patented algorithms from the openssl source
17# tarball with the hobble-openssl script which is included below.
18# The original openssl upstream tarball cannot be shipped in the .src.rpm.
19Source: openssl-%{version}-hobbled.tar.xz
20Source1: hobble-openssl
21Source2: Makefile.certificate
22Source6: make-dummy-cert
23Source7: renew-dummy-cert
24Source9: opensslconf-new.h
25Source10: opensslconf-new-warning.h
26Source11: README.FIPS
27Source12: ec_curve.c
28Source13: ectest.c
29
30# Build changes
31Patch1: openssl-1.1.1-build.patch
32Patch2: openssl-1.1.0-defaults.patch
33Patch3: openssl-1.1.0-no-html.patch
34Patch4: openssl-1.1.1-man-rename.patch
35# Bug fixes
36Patch21: openssl-1.1.0-issuer-hash.patch
37# Functionality changes
38Patch31: openssl-1.1.1-conf-paths.patch
39Patch32: openssl-1.1.1-version-add-engines.patch
40Patch33: openssl-1.1.1-apps-dgst.patch
41Patch36: openssl-1.1.1-no-brainpool.patch
42Patch37: openssl-1.1.1-ec-curves.patch
43Patch38: openssl-1.1.1-no-weak-verify.patch
44Patch40: openssl-1.1.1-disable-ssl3.patch
45Patch41: openssl-1.1.1-system-cipherlist.patch
46Patch42: openssl-1.1.1-fips.patch
47Patch43: openssl-1.1.1-ignore-bound.patch
48Patch44: openssl-1.1.1-version-override.patch
49Patch45: openssl-1.1.1-weak-ciphers.patch
50Patch46: openssl-1.1.1-seclevel.patch
51Patch48: openssl-1.1.1-fips-post-rand.patch
52Patch49: openssl-1.1.1-evp-kdf.patch
53Patch50: openssl-1.1.1-ssh-kdf.patch
54# Backported fixes including security fixes
55Patch51: openssl-1.1.1-upstream-sync.patch
56
57# security fix
58# nothing ;-)
59
60License: BSDish
61Group: System Environment/Libraries
62URL: http://www.openssl.org/
63
64BuildRoot: %{_tmppath}/%{name}-%{version}-root
65BuildRequires: perl, sed
66BuildRequires: zlib-devel, krb5-devel
67BuildRequires: lksctp-tools-devel
68
69Requires: mktemp
70Requires: ca-certificates
71
72Vendor: Project Vine
73Distribution: Vine Linux
74Packager: daisuke, iwamoto
75
76%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
77
78%description
79The OpenSSL certificate management tool and the shared libraries that
80provide various cryptographic algorithms and protocols.
81
82%package devel
83Summary: OpenSSL libraries and development headers.
84Group: Development/Libraries
85Requires: %{name} = %{version}-%{release}
86Requires: krb5-devel
87
88%description devel
89The static libraries and include files needed to compile apps
90with support for various the cryptographic algorithms and protocols
91supported by OpenSSL.
92
93Patches for many networking apps can be found at:
94ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
95
96%package static
97Summary:  Libraries for static linking of applications which will use OpenSSL
98Group: Development/Libraries
99Requires: %{name}-devel = %{version}-%{release}
100
101%description static
102OpenSSL is a toolkit for supporting cryptography. The openssl-static
103package contains static libraries needed for static linking of
104applications which support various cryptographic algorithms and
105protocols.
106
107%package perl
108Summary: OpenSSL scripts which require Perl.
109Group: Applications/Internet
110Requires: %{name} = %{version}-%{release}
111Requires: perl
112Requires: perl-WWW-Curl
113
114%description perl
115Perl scripts provided with OpenSSL for converting certificates and keys
116from other formats to those used by OpenSSL.
117
118## to build compat32 for x86_64 architecture support
119%package -n compat32-%{name}
120Summary: Secure Sockets Layer Toolkit
121Group: System Environment/Libraries
122Requires: %{name} = %{version}-%{release}
123%description -n compat32-%{name}
124The OpenSSL certificate management tool and the shared libraries that
125provide various cryptographic algorithms and protocols.
126
127%package -n compat32-%{name}-devel
128Summary: OpenSSL libraries and development headers.
129Group: Development/Libraries
130Requires: compat32-%{name} = %{version}-%{release}
131Requires: compat32-krb5-devel
132%description -n compat32-%{name}-devel
133The static libraries and include files needed to compile apps
134with support for various the cryptographic algorithms and protocols
135supported by OpenSSL.
136
137%prep
138%setup -q -n %{name}-%{version}
139
140# The hobble_openssl is called here redundantly, just to be sure.
141# The tarball has already the sources removed.
142%{SOURCE1} > /dev/null
143
144cp %{SOURCE12} crypto/ec/
145cp %{SOURCE13} test/
146
147%patch1 -p1 -b .build   %{?_rawbuild}
148%patch2 -p1 -b .defaults
149%patch3 -p1 -b .no-html  %{?_rawbuild}
150%patch4 -p1 -b .man-rename
151
152%patch21 -p1 -b .issuer-hash
153
154%patch31 -p1 -b .conf-paths
155%patch32 -p1 -b .version-add-engines
156%patch33 -p1 -b .dgst
157%patch36 -p1 -b .no-brainpool
158%patch37 -p1 -b .curves
159%patch38 -p1 -b .no-weak-verify
160%patch40 -p1 -b .disable-ssl3
161%patch41 -p1 -b .system-cipherlist
162%if %{with fips}
163%patch42 -p1 -b .fips
164%endif
165%patch43 -p1 -b .ignore-bound
166%if %{with fips}
167%patch44 -p1 -b .version-override
168%endif
169%patch45 -p1 -b .weak-ciphers
170%if %{with fips}
171%patch46 -p1 -b .seclevel
172%patch49 -p1 -b .evp-kdf
173%patch50 -p1 -b .ssh-kdf
174%patch51 -p1 -b .upstream-sync
175%endif
176
177# security fix
178# nothing ;-)
179
180%build
181# Figure out which flags we want to use.
182# default
183sslarch=%{_os}-%{_target_cpu}
184#
185%ifarch %ix86
186sslarch=linux-elf
187if ! echo %{_target} | grep -q i686 ; then
188   sslflags="no-asm 386"
189fi
190%endif
191%ifarch x86_64
192sslflags=enable-ec_nistp_64_gcc_128
193%endif
194
195# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
196# marked as not requiring an executable stack.
197# Also add -DPURIFY to make using valgrind with openssl easier as we do not
198# want to depend on the uninitialized memory as a source of entropy anyway.
199RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
200
201export HASHBANGPERL=/usr/bin/perl
202
203perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
204
205# ia64, x86_64, ppc are OK by default
206# Configure the build tree.  Override OpenSSL defaults with known-good defaults
207# usable on all platforms.  The Configure script already knows to use -fPIC and
208# RPM_OPT_FLAGS, so we can skip specifiying them here.
209./Configure \
210        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
211        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
212        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
213        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
214        enable-weak-ssl-ciphers \
215        no-mdc2 no-ec2m no-sm2 no-sm4 \
216        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
217
218# Do not run this in a production package the FIPS symbols must be patched-in
219#util/mkdef.pl crypto update
220
221make all
222
223%if %{with fips}
224# Overwrite FIPS README
225cp -f %{SOURCE11} .
226%endif
227
228# Clean up the .pc files
229for i in libcrypto.pc libssl.pc openssl.pc ; do
230  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
231done
232
233%check
234# Verify that what was compiled actually works.
235
236# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
237(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
238(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
239 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
240 touch -r configdata.pm configdata.pm.new && \
241 mv -f configdata.pm.new configdata.pm)
242
243# We must revert patch31 before tests otherwise they will fail
244patch -p1 -R < %{PATCH31}
245
246# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
247rm -f test/recipes/80-test_ssl_new.t
248
249
250LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
251export LD_LIBRARY_PATH
252OPENSSL_ENABLE_MD5_VERIFY=
253export OPENSSL_ENABLE_MD5_VERIFY
254OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
255export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
256make test
257
258
259# Add generation of HMAC checksum of the final stripped library
260%define __spec_install_post \
261    %{?__debug_package:%{__debug_install_post}} \
262    %{__arch_install_post} \
263    %{__os_install_post} \
264%{nil}
265
266%define __provides_exclude_from %{_libdir}/openssl
267
268%install
269[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
270# Install OpenSSL.
271install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
272make DESTDIR=$RPM_BUILD_ROOT install
273mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
274rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
275for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
276        chmod 755 ${lib}
277        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
278        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
279done
280
281# Install a makefile for generating keys and self-signed certs, and a script
282# for generating them on the fly.
283mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
284install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
285install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
286install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
287
288# Move runable perl scripts to bindir
289mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
290mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
291
292# Rename man pages so that they don't conflict with other system man pages.
293pushd $RPM_BUILD_ROOT%{_mandir}
294ln -s -f config.5 man5/openssl.cnf.5
295for manpage in man*/* ; do
296        if [ -L ${manpage} ]; then
297                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
298                ln -snf ${TARGET}ssl ${manpage}ssl
299                rm -f ${manpage}
300        else
301                mv ${manpage} ${manpage}ssl
302        fi
303done
304for conflict in passwd rand ; do
305        rename ${conflict} ssl${conflict} man*/${conflict}*
306# Fix dangling symlinks
307        manpage=man1/openssl-${conflict}.*
308        if [ -L ${manpage} ] ; then
309                ln -snf ssl${conflict}.1ssl ${manpage}
310        fi
311done
312popd
313
314mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
315mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
316mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
317mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
318mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
319
320# Ensure the config file timestamps are identical across builds to avoid
321# mulitlib conflicts and unnecessary renames on upgrade
322touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
323touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
324
325rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
326rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
327
328# Determine which arch opensslconf.h is going to try to #include.
329basearch=%{_arch}
330%ifarch %{ix86}
331basearch=i386
332%endif
333
334# Next step of gradual disablement of SSL3.
335# Make SSL3 disappear to newly built dependencies.
336sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
337#ifndef OPENSSL_NO_SSL3\
338# define OPENSSL_NO_SSL3\
339#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
340
341%ifarch %{multilib_arches}
342# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
343# can have both a 32- and 64-bit version of the library, and they each need
344# their own correct-but-different versions of opensslconf.h to be usable.
345install -m644 %{SOURCE10} \
346        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
347cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
348        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
349install -m644 %{SOURCE9} \
350        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
351%endif
352LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
353export LD_LIBRARY_PATH
354
355
356%clean
357[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
358
359%files
360%defattr(-,root,root)
361%{!?_licensedir:%global license %%doc}
362%license LICENSE
363%doc FAQ NEWS README
364%if %{with fips}
365%doc README.FIPS
366%endif
367%{_pkgdocdir}/Makefile.certificate
368%dir %{_sysconfdir}/pki/tls
369%dir %{_sysconfdir}/pki/tls/certs
370%dir %{_sysconfdir}/pki/tls/misc
371%dir %{_sysconfdir}/pki/tls/private
372%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
373%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
374
375%{_bindir}/make-dummy-cert
376%{_bindir}/renew-dummy-cert
377%{_bindir}/openssl
378%attr(0755,root,root) /%{_lib}/*.so.*
379%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
380%dir %{_mandir}/man1*
381%{_mandir}/man1*/*
382%dir %{_mandir}/man5*
383%{_mandir}/man5*/*
384%dir %{_mandir}/man7*
385%{_mandir}/man7*/*
386
387%files devel
388%defattr(-,root,root)
389%{_prefix}/include/openssl
390%exclude %{_libdir}/lib*.a
391%attr(0755,root,root) %{_libdir}/*.so
392%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
393%dir %{_mandir}/man3*
394%{_mandir}/man3*/*
395
396%files static
397%defattr(-,root,root)
398%attr(0644,root,root) %{_libdir}/*.a
399
400%files perl
401%defattr(-,root,root)
402%{_bindir}/c_rehash
403%{_bindir}/*.pl
404%{_bindir}/tsget
405%{_mandir}/man1*/*.pl*
406%{_mandir}/man1*/c_rehash*
407%{_mandir}/man1*/tsget*
408%{_mandir}/man1*/openssl-tsget*
409%dir %{_sysconfdir}/pki/CA
410%dir %{_sysconfdir}/pki/CA/private
411%dir %{_sysconfdir}/pki/CA/certs
412%dir %{_sysconfdir}/pki/CA/crl
413%dir %{_sysconfdir}/pki/CA/newcerts
414
415## to build compat32 for x86_64 architecture support
416%if %{build_compat32}
417%files -n compat32-%{name}
418%defattr(-,root,root)
419%attr(0755,root,root) /%{_lib}/*.so.*
420
421%files -n compat32-%{name}-devel
422%defattr(-,root,root)
423%exclude %{_libdir}/lib*.a
424%attr(0755,root,root) %{_libdir}/*.so
425%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
426%endif
427
428%post -p /sbin/ldconfig
429
430%postun -p /sbin/ldconfig
431
432%post -n compat32-%{name} -p /sbin/ldconfig
433
434%postun -n compat32-%{name} -p /sbin/ldconfig
435
436%changelog
437* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-1
438- new upstream release.
439- imported Patch36 from rawhide.
440- updated Patch32.
441
442* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
443- new upstream release.
444- updated Patch2.
445- dropped Patch36 and 46: fixed in upstream.
446
447* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
448- fixed symlinks.
449
450* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
451- new upstream release (newest LTS version).
452- imported fedora stuff (except FIPS).
453
454* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
455- new upstream release with security fixes
456
457* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
458- new upstream release with security fixes
459
460* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
461- new upstream release with security fixes
462
463* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
464- new upstream release with security fixes
465
466* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
467- new upstream release with security fixes
468
469* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
470- new upstream release 1.0.2 with security fixes
471- Patch2 is merged into Patch0
472
473* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
474- new upstream release with security fixes
475
476* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
477- new upstream release with security fixes
478
479* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
480- new upstream release
481
482* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
483- merged into Vine6
484  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
485  - new upstream release with security fixes 
486  - update Patch2,5
487
488* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
489- new upstream release with security fixes 
490
491* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
492- new upstream release with security fixes
493- add patch8 from fc21 (fix perl find.pl)
494
495* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
496- new upstream release with security fixes.
497
498* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
499- new upstream release with security fixes
500
501* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
502- new upstream release with security fixes
503
504* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
505- move root CA bundle to ca-certificates package
506
507* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
508- update to 1.0.1e
509  - 1.0.1d has major regressions from 1.0.1c
510
511* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
512- remove tsget script to delete dependency perl(WWW::Curl::Easy)
513 - openssl-perl package contains it in docdir
514
515* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
516- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
517- fixed %%files
518
519* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
520- update to 1.0.1c
521- enable configure options:
522  enable-camellia enable-seed enable-tlsext enable-rfc3779
523  enable-cms enable-md2
524- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
525- generate a table with the compile settings before configure
526
527* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
528- new upstream release with security fix (CVE-2012-0050)
529
530* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
531- new upstream release with security fix
532  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
533
534* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
535- new upstream release with security fix (CVE-2011-3207, 3210)
536
537* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
538- rebuild with krb5-libs 1.8
539
540* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
541- new upstream release with security fix
542
543* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
544- use upstream openssl.pc instead of vine original one (SOURCE6)
545
546* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
547- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
548
549* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
550- add R: krb5-devel into devel pkg
551- add R: compat32-krb5-devel into compat32-devel pkg
552
553* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
554- new upstream release 1.0.0x
555- separate static libs into static package
556- change configure options
557- change so version 10
558- add tsget into perl package
559- update all patches
560
561* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
562- fix changelog typo...
563
564* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
565- new upstream release with security fix (CVE-2010-4180)
566
567* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
568- new upstream release with security fix (CVE-2010-3864)
569- drop patches included in new release
570- update patch4
571
572* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
573- add patch12 for fix CVE-2009-3555 (renegotiation)
574
575* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
576- add patch11 for fix CVE-2009-4355 (memory leak)
577
578* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
579- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
580
581* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
582- removed unnecessary %%if %{build_compat32} statements
583- removed lib*.a from devel package
584
585* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
586- new upstream release with security fix (CVE-2000-0590,0591,0789)
587
588* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
589- new upstream release with security fix (CVE-2008-5077)
590
591* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
592- new upstream release
593
594* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
595- new upstream release
596- new versioning policy
597
598* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
599- new upstream release
600- drop patch10,20 which is merged in upstream
601
602* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
603- add security patch in advance for CVE-2007-5135
604  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
605  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
606
607* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
608- add security patch for CVE-2007-3108
609  (http://openssl.org/news/patch-CVE-2007-3108.txt)
610
611* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
612- new upstream release
613
614* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
615- update (fix) openssl.pc <BTS:437>
616
617* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
618- new upstream release (with security fix)
619
620* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
621- new upstream release
622- add patch2 to use RPM_OPT macro
623
624* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
625- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
626
627* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
628- added compat32-* packages for x86_64 architecture support
629- added openssl-0.9.7i.Configure-compat32.patch
630- changed '/lib' to '/%{_lib}'
631
632* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
633- new upstream release
634
635* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
636- rebuild on VineSeed
637
638* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
639- added a security patch from Gentoo.
640  - Patch1: openssl-0.9.7c-tempfile.patch
641
642* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
643- sslarch for ppc was missing... added.
644
645* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
646- use sslarch=linux-alpha-gcc instead of alpha-gcc
647
648* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
649- new upstream version
650- clean up of spec file
651        -- removed old patches
652
653* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
654- new upstream release
655- SECURITY fix.
656  - http://www.openssl.org/news/secadv_20040317.txt
657
658* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
659- new upstream release
660- [Security fix]
661  - Vulnerabilities in ASN.1 parsing
662    http://www.openssl.org/news/secadv_20030930.txt
663- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
664
665* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
666- add openssl.pc for pkgconfig
667
668* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
669- New upstream version
670- dropped patch10, 11
671        -- merged upstream version
672
673* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
674- rebuild for VineSeed
675
676* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
677- [Security Fix]
678  - Timing-based attacks on RSA keys
679    http://www.openssl.org/news/secadv_20030317.txt
680  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
681    http://www.openssl.org/news/secadv_20030317.txt
682
683* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
684- new upstream release 0.9.6i
685- [Security Fix]
686- build for Vine Linux 2.6 errata
687
688* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
689- new upstream release 0.9.6h
690
691* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
692- new upstream release 0.9.6g
693
694* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
695- SECURITY: CAN-2002-0659 fixed
696  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
697    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
698    - update asn patch to fix accidental reversal of a logic check
699    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
700    - update asn patch to reduce chance that compiler optimization will remove
701      one of the added tests
702    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
703    - rebuild
704    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
705    - add patch to fix ASN.1 vulnerabilities
706
707* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
708- rename spec file name
709- SECURITY: CA-2002-23 fixed
710  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
711    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
712    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
713
714* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
715- added ${PATH} in LD_LIBRARY_PATH
716- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
717 
718* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
719- remove --no-<cipher>
720
721* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
722- add Patch10 for mipsel shared ( Configure )
723
724* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
725- build for Vine Linux
726- use openssl-engine-0.9.6b.tar.gz
727
728* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
729- update to 0.9.6b
730
731* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
732- move .so symlinks back to %%{_libdir}
733
734* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
735- move shared libraries to /lib (#38410)
736
737* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
738- switch to engine code base
739
740* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
741- add a script for creating dummy certificates
742- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
743
744* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
745- add s390x support
746
747* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
748- change two memcpy() calls to memmove()
749- don't define L_ENDIAN on alpha
750
751* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
752- make subpackages depend on the main package
753
754* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
755- adjust the hobble script to not disturb symlinks in include/ (fix from
756  Joe Orton)
757
758* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
759- drop the m2crypo patch we weren't using
760
761* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
762- configure using "shared" as well
763
764* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
765- update to 0.9.6a
766- use the build-shared target to build shared libraries
767- bump the soversion to 2 because we're no longer compatible with
768  our 0.9.5a packages or our 0.9.6 packages
769- drop the patch for making rsatest a no-op when rsa null support is used
770- put all man pages into <section>ssl instead of <section>
771- break the m2crypto modules into a separate package
772
773* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
774- use BN_LLONG on s390
775
776* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
777- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
778
779* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
780- move c_rehash to the perl subpackage, because it's a perl script now
781
782* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
783- update to 0.9.6
784- enable MD2
785- use the libcrypto.so and libssl.so targets to build shared libs with
786- bump the soversion to 1 because we're no longer compatible with any of
787  the various 0.9.5a packages circulating around, which provide lib*.so.0
788
789* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
790- change hobble-openssl for disabling MD2 again
791
792* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
793- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
794  bytes or so, causing EVP_DigestInit() to zero out stack variables in
795  apps built against a version of the library without it
796
797* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
798- disable some inline assembly, which on x86 is Pentium-specific
799- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
800
801* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
802- fix s390 patch
803
804* Fri Dec 8 2000 Than Ngo <than@redhat.com>
805- added support s390
806
807* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
808- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
809- add the CA.pl man page to the perl subpackage
810
811* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
812- always build with -mcpu=ev5 on alpha
813
814* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
815- add a symlink from cert.pem to ca-bundle.crt
816
817* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
818- add a ca-bundle file for packages like Samba to reference for CA certificates
819
820* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
821- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
822
823* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
824- add unzip as a buildprereq (#17662)
825- update m2crypto to 0.05-snap4
826
827* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
828- fix some issues in building when it's not installed
829
830* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
831- make sure the headers we include are the ones we built with (aaaaarrgh!)
832
833* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
834- add Richard Henderson's patch for BN on ia64
835- clean up the changelog
836
837* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
838- fix the building of python modules without openssl-devel already installed
839
840* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
841- byte-compile python extensions without the build-root
842- adjust the makefile to not remove temporary files (like .key files when
843  building .csr files) by marking them as .PRECIOUS
844
845* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
846- break out python extensions into a subpackage
847
848* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
849- tweak the makefile some more
850
851* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
852- disable MD2 support
853
854* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
855- disable MDC2 support
856
857* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
858- tweak the disabling of RC5, IDEA support
859- tweak the makefile
860
861* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
862- strip binaries and libraries
863- rework certificate makefile to have the right parts for Apache
864
865* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
866- use %%{_perl} instead of /usr/bin/perl
867- disable alpha until it passes its own test suite
868
869* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
870- move the passwd.1 man page out of the passwd package's way
871
872* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
873- update to 0.9.5a, modified for U.S.
874- add perl as a build-time requirement
875- move certificate makefile to another package
876- disable RC5, IDEA, RSA support
877- remove optimizations for now
878
879* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
880- Bero told me to move the Makefile into this package
881
882* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
883- add lib*.so symlinks to link dynamically against shared libs
884
885* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
886- update to 0.9.5
887- run ldconfig directly in post/postun
888- add FAQ
889
890* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
891- Fix build on non-x86 platforms
892
893* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
894- move /usr/share/ssl/* from -devel to main package
895
896* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
897- inital packaging
898- changes from base:
899  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
900  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.