source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 875

Revision 875, 26.8 KB checked in by daisuke, 14 years ago (diff)

openssh: update to 5.5p1

Line 
1%define ver 5.5p1
2%define rel 1%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of x11-askpass? (1=yes 0=no)
15%define no_x11_askpass 0
16
17# Do we want to disable building of gnome-askpass? (1=yes 0=no)
18%define no_gnome_askpass 0
19
20# Use GTK2 for gnome-ssh-askpass
21%define gtk2 1
22
23# Build position-independent executables (requires toolchain support)?
24%define pie 1
25
26# Do we want to link against a static libcrypto? (1=yes 0=no)
27%define static_libcrypto 0
28
29# Do we want smartcard support (1=yes 0=no)
30%define scard 0
31
32# Disable IPv6 (avoids DNS hangs on some glibc versions)
33%define noip6 0
34
35# Do we want kerberos5 support (1=yes 0=no)
36%define kerberos5 0
37
38# Reserve options to override askpass settings with:
39# rpm -ba|--rebuild --define 'skip_xxx 1'
40%{?skip_x11_askpass:%define no_x11_askpass 1}
41%{?skip_gnome_askpass:%define no_gnome_askpass 1}
42
43# Options for static OpenSSL link:
44# rpm -ba|--rebuild --define "static_openssl 1"
45%{?static_openssl:%define static_libcrypto 1}
46
47# Options for Smartcard support: (needs libsectok and openssl-engine)
48# rpm -ba|--rebuild --define "smartcard 1"
49%{?smartcard:%define scard 1}
50
51# Option to disable ipv6
52# rpm -ba|--rebuild --define "noipv6 1"
53%{?noipv6:%define noip6 1}
54
55# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
56%define rescue 0
57%{?build_rescue:%define rescue 1}
58
59# Turn off some stuff for resuce builds
60%if %{rescue}
61%define kerberos5 0
62%endif
63
64Summary: The OpenSSH implementation of SSH.
65Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
66Name: openssh
67Version: %{ver}
68Release: %{rel}
69URL: http://www.openssh.com/portable.html
70Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
71Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
72Patch0: openssh-5.5p1-vine.patch
73Patch2: openssh-5.3p1-skip-initial.patch
74Patch4: openssh-5.2p1-vendor.patch
75Patch5: openssh-3.9p1-noinitlog.patch
76Patch12: openssh-selinux.patch
77Patch20: openssh-3.9p1-gssapimitm.patch
78Patch21: openssh-3.9p1-safe-stop.patch
79Patch24: openssh-4.3p1-fromto-remote.patch
80Patch26: openssh-5.2p1-pam-no-stack.patch
81Patch27: openssh-5.1p1-log-in-chroot.patch
82Patch30: openssh-4.0p1-exit-deadlock.patch
83# Patch31: openssh-3.9p1-skip-used.patch
84Patch35: openssh-4.2p1-askpass-progress.patch
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87Patch120: openssh-4.7p1-sshd.init.patch
88
89License: BSD
90Group: Applications/Internet
91BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
92Obsoletes: ssh
93
94PreReq: initscripts >= 5.20
95BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
96BuildRequires: util-linux
97BuildRequires: db4-devel
98BuildRequires: pam-devel
99BuildRequires: zlib-devel
100%if ! %{no_x11_askpass}
101BuildRequires: libX11-devel, libSM-devel, libXt-devel, libICE-devel
102%endif
103%if ! %{no_gnome_askpass}
104BuildRequires: libX11-devel
105BuildRequires: gtk2-devel
106%endif
107
108Vendor: Project Vine
109Distribution: Vine Linux
110Packager: daisuke
111
112%package clients
113Summary: OpenSSH clients.
114Summary(ja): OpenSSH Secure Shell プロトコルクライアント
115Requires: openssh = %{version}-%{release}
116Group: Applications/Internet
117Obsoletes: ssh-clients
118
119%package server
120Summary: The OpenSSH server daemon.
121Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
122Group: System Environment/Daemons
123Obsoletes: ssh-server
124PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
125Requires: pam
126
127%package askpass
128Summary: A passphrase dialog for OpenSSH and X.
129Summary(ja): OpenSSH X11 パスフレーズ入力ダイアログ
130Group: Applications/Internet
131Requires: openssh = %{version}-%{release}
132Obsoletes: ssh-extras
133
134%package askpass-gnome
135Summary: A passphrase dialog for OpenSSH, X, and GNOME.
136Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
137Group: Applications/Internet
138Requires: openssh = %{version}-%{release}
139Obsoletes: ssh-extras
140
141%package contrib
142Summary: addons for OpenSSH
143Summary(ja): OpenSSH のためのアドオン
144Group: Applications/Internet
145Requires: openssh-clients = %{version}-%{release}
146
147%description
148SSH (Secure SHell) is a program for logging into and executing
149commands on a remote machine. SSH is intended to replace rlogin and
150rsh, and to provide secure encrypted communications between two
151untrusted hosts over an insecure network. X11 connections and
152arbitrary TCP/IP ports can also be forwarded over the secure channel.
153
154OpenSSH is OpenBSD's version of the last free version of SSH, bringing
155it up to date in terms of security and features, as well as removing
156all patented algorithms to separate libraries.
157
158This package includes the core files necessary for both the OpenSSH
159client and server. To make this package useful, you should also
160install openssh-clients, openssh-server, or both.
161
162#'
163%description -l ja
164OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
165Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
166するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
167ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
168可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
169な通信路の中を通すことができます。
170
171OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
172最新のセキュリティと機能を提供しています。またすべての特許がからむ
173アルゴリズムは分割したライブラリにわかれています。
174
175このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
176コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
177openssh-clients および/または openssh-server が必要です。
178
179%description clients
180OpenSSH is a free version of SSH (Secure SHell), a program for logging
181into and executing commands on a remote machine. This package includes
182the clients necessary to make encrypted connections to SSH servers.
183You'll also need to install the openssh package on OpenSSH clients.
184
185#'
186%description -l ja clients
187OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
188Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
189するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
190ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
191可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
192な通信路の中を通すことができます。
193
194OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
195最新のセキュリティと機能を提供しています。またすべての特許がからむ
196アルゴリズムは分割したライブラリにわかれています。
197
198このパッケージは OpenSSH をクライアントとして使用する場合に
199必要なものを含んでいます。
200
201
202%description server
203OpenSSH is a free version of SSH (Secure SHell), a program for logging
204into and executing commands on a remote machine. This package contains
205the secure shell daemon (sshd). The sshd daemon allows SSH clients to
206securely connect to your SSH server. You also need to have the openssh
207package installed.
208
209%description -l ja server
210OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
211Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
212するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
213ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
214可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
215な通信路の中を通すことができます。
216
217OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
218最新のセキュリティと機能を提供しています。またすべての特許がからむ
219アルゴリズムは分割したライブラリにわかれています。
220
221このパッケージは OpenSSH をサーバとして使用する場合に必要な
222デーモンなどを含んでいます。
223
224%description askpass
225OpenSSH is a free version of SSH (Secure SHell), a program for logging
226into and executing commands on a remote machine. This package contains
227an X11 passphrase dialog for OpenSSH.
228
229%description -l ja askpass
230OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
231Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
232するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
233ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
234可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
235な通信路の中を通すことができます。
236
237OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
238最新のセキュリティと機能を提供しています。またすべての特許がからむ
239アルゴリズムは分割したライブラリにわかれています。
240
241このパッケージは Jim Knoble <jmknoble@jmknoble.cx> による X11 上の
242パスフレーズ入力ダイアログを含んでいます。
243
244%description askpass-gnome
245OpenSSH is a free version of SSH (Secure SHell), a program for logging
246into and executing commands on a remote machine. This package contains
247an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
248environment.
249
250%description -l ja askpass-gnome
251OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
252Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
253するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
254ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
255可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
256な通信路の中を通すことができます。
257
258OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
259最新のセキュリティと機能を提供しています。またすべての特許がからむ
260アルゴリズムは分割したライブラリにわかれています。
261
262このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
263
264%description contrib
265addons for OpenSSH
266
267%description -l ja contrib
268OpenSSH のためのアドオン
269
270%prep
271
272%if ! %{no_x11_askpass}
273%setup -q -a 1
274%else
275%setup -q
276%endif
277%patch0 -p1 -b .vine
278%patch2 -p1 -b .skip-initial
279%patch4 -p1 -b .vendor
280%patch5 -p1 -b .noinitlog
281
282%if %{WITH_SELINUX}
283#SELinux
284%patch12 -p1 -b .selinux
285%endif
286
287%patch21 -p1 -b .safe-stop
288%patch24 -p1 -b .fromto-remote
289%patch26 -p1 -b .stack
290%patch27 -p1 -b .log-chroot
291%patch30 -p1 -b .exit-deadlock
292%patch35 -p1 -b .progress
293
294%patch100 -p1 -b .norootlogin
295%patch120 -p1 -b .localtime
296
297autoreconf
298
299
300%build
301CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
302%if %{rescue}
303CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
304%endif
305%if %{pie}
306%ifarch s390 s390x sparc sparc64
307CFLAGS="$CFLAGS -fPIE"
308%else
309CFLAGS="$CFLAGS -fpie"
310%endif
311export CFLAGS
312LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
313%endif
314
315%configure \
316        --sysconfdir=%{_sysconfdir}/ssh \
317        --libexecdir=%{_libexecdir}/openssh \
318        --datadir=%{_datadir}/openssh \
319        --with-tcp-wrappers \
320        --with-rsh=%{_bindir}/rsh \
321        --with-default-path=/usr/local/bin:/bin:/usr/bin \
322        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
323        --with-privsep-path=%{_var}/empty/sshd \
324        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
325%if %{scard}
326        --with-smartcard \
327%endif
328%if %{noip6}
329        --with-ipv4-default \
330%endif
331%if %{rescue}
332        --without-pam --with-md5-passwords
333%else
334        --with-pam
335%endif
336
337%if %{static_libcrypto}
338perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
339%endif
340
341make
342
343%if ! %{no_x11_askpass}
344pushd x11-ssh-askpass-%{aversion}
345%configure --libexecdir=%{_libexecdir}/openssh
346xmkmf -a
347make
348popd
349%endif
350
351%if %{gtk2}
352        gtk2=yes
353%else
354        gtk2=no
355%endif
356
357%if ! %{no_gnome_askpass}
358pushd contrib
359if [ $gtk2 = yes ]; then
360        make gnome-ssh-askpass2
361        mv gnome-ssh-askpass2 gnome-ssh-askpass
362else
363        make gnome-ssh-askpass1
364        mv gnome-ssh-askpass1 gnome-ssh-askpass
365fi
366popd
367%endif
368
369%install
370rm -rf $RPM_BUILD_ROOT
371mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
372mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
373mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
374mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
375
376make install DESTDIR=$RPM_BUILD_ROOT
377
378touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
379install -d $RPM_BUILD_ROOT/etc/pam.d/
380install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
381install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
382install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
383install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
384
385%if ! %{no_x11_askpass}
386install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
387ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
388%endif
389
390%if ! %{scard}
391        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
392%endif
393
394%if ! %{no_gnome_askpass}
395install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
396install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
397install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
398%endif
399
400%if %{no_gnome_askpass}
401rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
402%endif
403
404# for contrib package
405install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
406install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
407mv contrib/README contrib/README.contrib
408
409perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
410
411%clean
412rm -rf $RPM_BUILD_ROOT
413
414%triggerun server -- ssh-server
415if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
416        touch /var/run/sshd.restart
417fi
418
419%triggerun server -- openssh-server < 2.5.0p1
420# Count the number of HostKey and HostDsaKey statements we have.
421gawk    'BEGIN {IGNORECASE=1}
422         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
423         END {exit sawhostkey}' /etc/ssh/sshd_config
424# And if we only found one, we know the client was relying on the old default
425# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
426# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
427# one nullifies the default, which would have loaded both.
428if [ $? -eq 1 ] ; then
429        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
430        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
431fi
432
433%triggerpostun server -- ssh-server
434if [ "$1" != 0 ] ; then
435        /sbin/chkconfig --add sshd
436        if test -f /var/run/sshd.restart ; then
437                rm -f /var/run/sshd.restart
438                # /sbin/service sshd start > /dev/null 2>&1 || :
439                /sbin/service sshd start
440        fi
441fi
442
443%pre server
444%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
445%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
446        -g sshd -M -r sshd 2>/dev/null || :
447
448%post server
449/sbin/chkconfig --add sshd
450
451%postun server
452# /sbin/service sshd condrestart > /dev/null 2>&1 || :
453/sbin/service sshd condrestart
454
455%preun server
456if [ "$1" = 0 ]
457then
458        /sbin/service sshd stop > /dev/null 2>&1 || :
459        /sbin/chkconfig --del sshd
460fi
461
462%files
463%defattr(-,root,root)
464%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
465%attr(0755,root,root) %{_bindir}/scp
466%attr(0644,root,root) %{_mandir}/man1/scp.1*
467%attr(0755,root,root) %dir %{_sysconfdir}/ssh
468%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
469%attr(644,root,root) %{_mandir}/man5/moduli.5*
470%if ! %{rescue}
471%attr(0755,root,root) %{_bindir}/ssh-keygen
472%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
473%attr(0755,root,root) %dir %{_libexecdir}/openssh
474%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
475%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
476%endif
477%if %{scard}
478%attr(0755,root,root) %dir %{_datadir}/openssh
479%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
480%endif
481
482%files clients
483%defattr(-,root,root)
484%attr(0755,root,root) %{_bindir}/ssh
485%attr(0644,root,root) %{_mandir}/man1/ssh.1*
486%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
487%attr(0644,root,root) %{_mandir}/man1/slogin.1*
488%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
489%attr(-,root,root) %{_bindir}/slogin
490%if ! %{rescue}
491%attr(0755,root,root) %{_bindir}/ssh-agent
492%attr(0755,root,root) %{_bindir}/ssh-add
493%attr(0755,root,root) %{_bindir}/ssh-keyscan
494%attr(0755,root,root) %{_bindir}/sftp
495%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
496%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
497%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
498%attr(0644,root,root) %{_mandir}/man1/sftp.1*
499%endif
500
501%if ! %{rescue}
502%files server
503%defattr(-,root,root)
504%dir %attr(0711,root,root) %{_var}/empty/sshd
505%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
506%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
507%attr(0755,root,root) %{_sbindir}/sshd
508%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
509%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
510%attr(0644,root,root) %{_mandir}/man8/sshd.8*
511%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
512%attr(0755,root,root) %dir %{_sysconfdir}/ssh
513%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
514%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
515%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
516%endif
517
518%if ! %{no_x11_askpass}
519%files askpass
520%defattr(-,root,root)
521%doc x11-ssh-askpass-%{aversion}/README
522%doc x11-ssh-askpass-%{aversion}/ChangeLog
523%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
524%attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
525%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
526%endif
527
528%if ! %{no_gnome_askpass}
529%files askpass-gnome
530%defattr(-,root,root)
531%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
532%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
533%endif
534
535%files contrib
536%defattr(-,root,root)
537%doc contrib/README.contrib
538%{_bindir}/ssh-copy-id
539%{_mandir}/man1/ssh-copy-id.1*
540
541%changelog
542* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
543- new upstream release
544- update patch0,2
545- drop patch3,22
546
547* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
548- new upstream release
549
550* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
551- new upstream release
552
553* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
554- rebuild with xorg-x11-7.3
555
556* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
557- new upstream release with security fix (CVE-2008-1483)
558- drop patch31 which is included in new release (This was for CVE-2008-1483)
559
560* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
561- new upstream release with security fix ("ForceCommand" Directive)
562- turn on daemon restart message
563- new versioning policy
564
565* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
566- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
567
568* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
569- new upstream release
570
571* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
572- build with -fpie/-pie by default.
573- enable ipv6 by default.
574
575* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
576- new upstream release
577
578* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
579- new upstream release
580
581* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
582- new upstream release
583
584* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
585- new upstream release
586
587* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
588- new upstream release
589- remove build6x stuff
590- remove libgnome-devel from BuildRequires
591- cleanup BuildRequires
592- drop Patch200, it is merged in upstream.
593- import patches(25-35) from FC-devel
594
595* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
596- SECURITY FIX: CVE-2006-0225
597  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
598- update BuildPreReq: s/XFree86-devel/XOrg-devel/
599- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
600  - When GNOME2 is used, using libgnome-devel
601  - add BuildPreReq: gtk2-devel for GNOME2
602
603* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
604- rebuild with gtk+-2.8 final
605
606* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
607- new upstream release
608- build with gtk+-2.7
609
610* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
611- new upstream release
612
613* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
614- cleanup obsolete patches and added patches from fedora
615
616* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
617- new upstream release
618
619* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
620- new upstream release
621
622* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
623- new upstream release
624
625* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
626- rebuild with openssl-0.9.7d
627
628* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
629- new upstream release
630
631* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
632- create contrib package
633
634* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
635- new upstream release
636- fix security issue: http://www.openssh.com/txt/sshpam.adv
637
638* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
639- new upstream release
640- fix security issue: http://www.openssh.com/txt/buffer.adv
641
642* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
643- new upstream release
644
645* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
646- rebuild with gtk2
647
648* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
649- new upstream release
650
651* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
652- rebuild with new tool chain
653
654* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
655- new upstream release
656- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
657
658* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
659- change some defines in spec files
660
661* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
662- add patch110 ( 3.4p1 does not include mmap-fallback patch )
663
664* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
665- new upstream release
666  - security fix
667- drop patch10
668
669* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
670- add patch from Solar Designer to make privsep work with a 2.2 kernel.
671
672* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
673- new upstream release
674- add {sshd,ssh}_config.5 manpages
675- add ssh-keysign
676
677* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
678- new upstream release
679
680* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
681- new upstream release
682- drop patch1
683
684* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
685- new upstream release
686- merged with rawhide release.
687- drop Patch101 (merged in upstream)
688
689* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
690- seurity patch for off-by-one bug
691
692* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
693- merged with Rawhide 3.0.2p1-2
694
695* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
696- updated to 3.0.2p1
697
698* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
699- updated to 3.0.1p1
700
701* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
702- updated to 3.0p1
703
704* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
705- add japanese summery and descriptions.
706- update x11-askpass 1.2.5
707
708* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
709- update to openssh-2.9.9p2
710
711* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
712- rebuilt with openssl-0.9.6b
713
714* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
715- do not Permit RootLogin
716
717* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
718- update to openssh-2.5.2p2
719
720* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
721- update to openssh-2.5.2p1
722
723* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
724- update to openssh-2.5.1p2
725
726* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
727- update to openssh-2.5.1p1
728
729* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
730- update to openssh-2.5.1p1
731
732* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
733- remove suid bit from ssh
734
735* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
736- moved man dir to /usr/share/man
737
738* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
739- fixed askpass's link in ssh-add
740- partially used rpmmacros
741
742* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
743- update to 2.3.0p1
744- update x11-askpass 1.0.3
745
746* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
747- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
748  Redhat 7.0 spec file
749
750* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
751- rebuild for Vine Linux
752
753* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
754- Use RPM configure macro
755* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
756- Some surgery to sshd.init (generate keys at runtime)
757- Cleanup of groups and removal of keygen calls
758* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
759- Make building of X11-askpass and gnome-askpass optional
760* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
761- Glob manpages to catch compressed files
762* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
763- Updated for new location
764- Updated for new gnome-ssh-askpass build
765* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
766- Added Jim Knoble's <jmknoble@pobox.com> askpass
767* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
768- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
769* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
770- Added 'Obsoletes' directives
771* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
772- Use make install
773- Subpackages
774* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
775- Added links for slogin
776- Fixed perms on manpages
777* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
778- Renamed init script
779* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
780- Back to old binary names
781* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
782- Use autoconf
783- New binary names
784* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
785- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
786
Note: See TracBrowser for help on using the repository browser.