source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 1063

Revision 1063, 26.9 KB checked in by daisuke, 14 years ago (diff)

openssh: add BR: xorg-x11-xauth for X11 forwarding support

Line 
1%define ver 5.5p1
2%define rel 2%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of x11-askpass? (1=yes 0=no)
15%define no_x11_askpass 0
16
17# Do we want to disable building of gnome-askpass? (1=yes 0=no)
18%define no_gnome_askpass 0
19
20# Use GTK2 for gnome-ssh-askpass
21%define gtk2 1
22
23# Build position-independent executables (requires toolchain support)?
24%define pie 1
25
26# Do we want to link against a static libcrypto? (1=yes 0=no)
27%define static_libcrypto 0
28
29# Do we want smartcard support (1=yes 0=no)
30%define scard 0
31
32# Disable IPv6 (avoids DNS hangs on some glibc versions)
33%define noip6 0
34
35# Do we want kerberos5 support (1=yes 0=no)
36%define kerberos5 0
37
38# Reserve options to override askpass settings with:
39# rpm -ba|--rebuild --define 'skip_xxx 1'
40%{?skip_x11_askpass:%define no_x11_askpass 1}
41%{?skip_gnome_askpass:%define no_gnome_askpass 1}
42
43# Options for static OpenSSL link:
44# rpm -ba|--rebuild --define "static_openssl 1"
45%{?static_openssl:%define static_libcrypto 1}
46
47# Options for Smartcard support: (needs libsectok and openssl-engine)
48# rpm -ba|--rebuild --define "smartcard 1"
49%{?smartcard:%define scard 1}
50
51# Option to disable ipv6
52# rpm -ba|--rebuild --define "noipv6 1"
53%{?noipv6:%define noip6 1}
54
55# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
56%define rescue 0
57%{?build_rescue:%define rescue 1}
58
59# Turn off some stuff for resuce builds
60%if %{rescue}
61%define kerberos5 0
62%endif
63
64Summary: The OpenSSH implementation of SSH.
65Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
66Name: openssh
67Version: %{ver}
68Release: %{rel}
69URL: http://www.openssh.com/portable.html
70Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
71Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
72Patch0: openssh-5.5p1-vine.patch
73Patch2: openssh-5.3p1-skip-initial.patch
74Patch4: openssh-5.2p1-vendor.patch
75Patch5: openssh-3.9p1-noinitlog.patch
76Patch12: openssh-selinux.patch
77Patch20: openssh-3.9p1-gssapimitm.patch
78Patch21: openssh-3.9p1-safe-stop.patch
79Patch24: openssh-4.3p1-fromto-remote.patch
80Patch26: openssh-5.2p1-pam-no-stack.patch
81Patch27: openssh-5.1p1-log-in-chroot.patch
82Patch30: openssh-4.0p1-exit-deadlock.patch
83# Patch31: openssh-3.9p1-skip-used.patch
84Patch35: openssh-4.2p1-askpass-progress.patch
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87Patch120: openssh-4.7p1-sshd.init.patch
88
89License: BSD
90Group: Applications/Internet
91BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
92Obsoletes: ssh
93
94PreReq: initscripts >= 5.20
95BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
96BuildRequires: util-linux
97BuildRequires: db4-devel
98BuildRequires: pam-devel
99BuildRequires: zlib-devel
100%if ! %{no_x11_askpass}
101BuildRequires: libX11-devel, libSM-devel, libXt-devel, libICE-devel
102%endif
103%if ! %{no_gnome_askpass}
104BuildRequires: libX11-devel
105BuildRequires: gtk2-devel
106%endif
107BuildRequires: xorg-x11-xauth
108
109Vendor: Project Vine
110Distribution: Vine Linux
111Packager: daisuke
112
113%package clients
114Summary: OpenSSH clients.
115Summary(ja): OpenSSH Secure Shell プロトコルクライアント
116Requires: openssh = %{version}-%{release}
117Group: Applications/Internet
118Obsoletes: ssh-clients
119
120%package server
121Summary: The OpenSSH server daemon.
122Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
123Group: System Environment/Daemons
124Obsoletes: ssh-server
125PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
126Requires: pam
127
128%package askpass
129Summary: A passphrase dialog for OpenSSH and X.
130Summary(ja): OpenSSH X11 パスフレーズ入力ダイアログ
131Group: Applications/Internet
132Requires: openssh = %{version}-%{release}
133Obsoletes: ssh-extras
134
135%package askpass-gnome
136Summary: A passphrase dialog for OpenSSH, X, and GNOME.
137Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
138Group: Applications/Internet
139Requires: openssh = %{version}-%{release}
140Obsoletes: ssh-extras
141
142%package contrib
143Summary: addons for OpenSSH
144Summary(ja): OpenSSH のためのアドオン
145Group: Applications/Internet
146Requires: openssh-clients = %{version}-%{release}
147
148%description
149SSH (Secure SHell) is a program for logging into and executing
150commands on a remote machine. SSH is intended to replace rlogin and
151rsh, and to provide secure encrypted communications between two
152untrusted hosts over an insecure network. X11 connections and
153arbitrary TCP/IP ports can also be forwarded over the secure channel.
154
155OpenSSH is OpenBSD's version of the last free version of SSH, bringing
156it up to date in terms of security and features, as well as removing
157all patented algorithms to separate libraries.
158
159This package includes the core files necessary for both the OpenSSH
160client and server. To make this package useful, you should also
161install openssh-clients, openssh-server, or both.
162
163#'
164%description -l ja
165OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
166Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
167するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
168ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
169可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
170な通信路の中を通すことができます。
171
172OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
173最新のセキュリティと機能を提供しています。またすべての特許がからむ
174アルゴリズムは分割したライブラリにわかれています。
175
176このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
177コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
178openssh-clients および/または openssh-server が必要です。
179
180%description clients
181OpenSSH is a free version of SSH (Secure SHell), a program for logging
182into and executing commands on a remote machine. This package includes
183the clients necessary to make encrypted connections to SSH servers.
184You'll also need to install the openssh package on OpenSSH clients.
185
186#'
187%description -l ja clients
188OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
189Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
190するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
191ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
192可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
193な通信路の中を通すことができます。
194
195OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
196最新のセキュリティと機能を提供しています。またすべての特許がからむ
197アルゴリズムは分割したライブラリにわかれています。
198
199このパッケージは OpenSSH をクライアントとして使用する場合に
200必要なものを含んでいます。
201
202
203%description server
204OpenSSH is a free version of SSH (Secure SHell), a program for logging
205into and executing commands on a remote machine. This package contains
206the secure shell daemon (sshd). The sshd daemon allows SSH clients to
207securely connect to your SSH server. You also need to have the openssh
208package installed.
209
210%description -l ja server
211OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
212Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
213するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
214ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
215可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
216な通信路の中を通すことができます。
217
218OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
219最新のセキュリティと機能を提供しています。またすべての特許がからむ
220アルゴリズムは分割したライブラリにわかれています。
221
222このパッケージは OpenSSH をサーバとして使用する場合に必要な
223デーモンなどを含んでいます。
224
225%description askpass
226OpenSSH is a free version of SSH (Secure SHell), a program for logging
227into and executing commands on a remote machine. This package contains
228an X11 passphrase dialog for OpenSSH.
229
230%description -l ja askpass
231OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
232Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
233するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
234ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
235可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
236な通信路の中を通すことができます。
237
238OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
239最新のセキュリティと機能を提供しています。またすべての特許がからむ
240アルゴリズムは分割したライブラリにわかれています。
241
242このパッケージは Jim Knoble <jmknoble@jmknoble.cx> による X11 上の
243パスフレーズ入力ダイアログを含んでいます。
244
245%description askpass-gnome
246OpenSSH is a free version of SSH (Secure SHell), a program for logging
247into and executing commands on a remote machine. This package contains
248an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
249environment.
250
251%description -l ja askpass-gnome
252OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
253Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
254するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
255ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
256可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
257な通信路の中を通すことができます。
258
259OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
260最新のセキュリティと機能を提供しています。またすべての特許がからむ
261アルゴリズムは分割したライブラリにわかれています。
262
263このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
264
265%description contrib
266addons for OpenSSH
267
268%description -l ja contrib
269OpenSSH のためのアドオン
270
271%prep
272
273%if ! %{no_x11_askpass}
274%setup -q -a 1
275%else
276%setup -q
277%endif
278%patch0 -p1 -b .vine
279%patch2 -p1 -b .skip-initial
280%patch4 -p1 -b .vendor
281%patch5 -p1 -b .noinitlog
282
283%if %{WITH_SELINUX}
284#SELinux
285%patch12 -p1 -b .selinux
286%endif
287
288%patch21 -p1 -b .safe-stop
289%patch24 -p1 -b .fromto-remote
290%patch26 -p1 -b .stack
291%patch27 -p1 -b .log-chroot
292%patch30 -p1 -b .exit-deadlock
293%patch35 -p1 -b .progress
294
295%patch100 -p1 -b .norootlogin
296%patch120 -p1 -b .localtime
297
298autoreconf
299
300
301%build
302CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
303%if %{rescue}
304CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
305%endif
306%if %{pie}
307%ifarch s390 s390x sparc sparc64
308CFLAGS="$CFLAGS -fPIE"
309%else
310CFLAGS="$CFLAGS -fpie"
311%endif
312export CFLAGS
313LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
314%endif
315
316%configure \
317        --sysconfdir=%{_sysconfdir}/ssh \
318        --libexecdir=%{_libexecdir}/openssh \
319        --datadir=%{_datadir}/openssh \
320        --with-tcp-wrappers \
321        --with-rsh=%{_bindir}/rsh \
322        --with-default-path=/usr/local/bin:/bin:/usr/bin \
323        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
324        --with-privsep-path=%{_var}/empty/sshd \
325        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
326%if %{scard}
327        --with-smartcard \
328%endif
329%if %{noip6}
330        --with-ipv4-default \
331%endif
332%if %{rescue}
333        --without-pam --with-md5-passwords
334%else
335        --with-pam
336%endif
337
338%if %{static_libcrypto}
339perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
340%endif
341
342make
343
344%if ! %{no_x11_askpass}
345pushd x11-ssh-askpass-%{aversion}
346%configure --libexecdir=%{_libexecdir}/openssh
347xmkmf -a
348make
349popd
350%endif
351
352%if %{gtk2}
353        gtk2=yes
354%else
355        gtk2=no
356%endif
357
358%if ! %{no_gnome_askpass}
359pushd contrib
360if [ $gtk2 = yes ]; then
361        make gnome-ssh-askpass2
362        mv gnome-ssh-askpass2 gnome-ssh-askpass
363else
364        make gnome-ssh-askpass1
365        mv gnome-ssh-askpass1 gnome-ssh-askpass
366fi
367popd
368%endif
369
370%install
371rm -rf $RPM_BUILD_ROOT
372mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
373mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
374mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
375mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
376
377make install DESTDIR=$RPM_BUILD_ROOT
378
379touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
380install -d $RPM_BUILD_ROOT/etc/pam.d/
381install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
382install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
383install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
384install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
385
386%if ! %{no_x11_askpass}
387install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
388ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
389%endif
390
391%if ! %{scard}
392        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
393%endif
394
395%if ! %{no_gnome_askpass}
396install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
397install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
398install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
399%endif
400
401%if %{no_gnome_askpass}
402rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
403%endif
404
405# for contrib package
406install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
407install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
408mv contrib/README contrib/README.contrib
409
410perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
411
412%clean
413rm -rf $RPM_BUILD_ROOT
414
415%triggerun server -- ssh-server
416if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
417        touch /var/run/sshd.restart
418fi
419
420%triggerun server -- openssh-server < 2.5.0p1
421# Count the number of HostKey and HostDsaKey statements we have.
422gawk    'BEGIN {IGNORECASE=1}
423         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
424         END {exit sawhostkey}' /etc/ssh/sshd_config
425# And if we only found one, we know the client was relying on the old default
426# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
427# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
428# one nullifies the default, which would have loaded both.
429if [ $? -eq 1 ] ; then
430        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
431        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
432fi
433
434%triggerpostun server -- ssh-server
435if [ "$1" != 0 ] ; then
436        /sbin/chkconfig --add sshd
437        if test -f /var/run/sshd.restart ; then
438                rm -f /var/run/sshd.restart
439                # /sbin/service sshd start > /dev/null 2>&1 || :
440                /sbin/service sshd start
441        fi
442fi
443
444%pre server
445%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
446%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
447        -g sshd -M -r sshd 2>/dev/null || :
448
449%post server
450/sbin/chkconfig --add sshd
451
452%postun server
453# /sbin/service sshd condrestart > /dev/null 2>&1 || :
454/sbin/service sshd condrestart
455
456%preun server
457if [ "$1" = 0 ]
458then
459        /sbin/service sshd stop > /dev/null 2>&1 || :
460        /sbin/chkconfig --del sshd
461fi
462
463%files
464%defattr(-,root,root)
465%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
466%attr(0755,root,root) %{_bindir}/scp
467%attr(0644,root,root) %{_mandir}/man1/scp.1*
468%attr(0755,root,root) %dir %{_sysconfdir}/ssh
469%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
470%attr(644,root,root) %{_mandir}/man5/moduli.5*
471%if ! %{rescue}
472%attr(0755,root,root) %{_bindir}/ssh-keygen
473%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
474%attr(0755,root,root) %dir %{_libexecdir}/openssh
475%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
476%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
477%endif
478%if %{scard}
479%attr(0755,root,root) %dir %{_datadir}/openssh
480%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
481%endif
482
483%files clients
484%defattr(-,root,root)
485%attr(0755,root,root) %{_bindir}/ssh
486%attr(0644,root,root) %{_mandir}/man1/ssh.1*
487%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
488%attr(0644,root,root) %{_mandir}/man1/slogin.1*
489%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
490%attr(-,root,root) %{_bindir}/slogin
491%if ! %{rescue}
492%attr(0755,root,root) %{_bindir}/ssh-agent
493%attr(0755,root,root) %{_bindir}/ssh-add
494%attr(0755,root,root) %{_bindir}/ssh-keyscan
495%attr(0755,root,root) %{_bindir}/sftp
496%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
497%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
498%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
499%attr(0644,root,root) %{_mandir}/man1/sftp.1*
500%endif
501
502%if ! %{rescue}
503%files server
504%defattr(-,root,root)
505%dir %attr(0711,root,root) %{_var}/empty/sshd
506%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
507%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
508%attr(0755,root,root) %{_sbindir}/sshd
509%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
510%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
511%attr(0644,root,root) %{_mandir}/man8/sshd.8*
512%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
513%attr(0755,root,root) %dir %{_sysconfdir}/ssh
514%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
515%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
516%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
517%endif
518
519%if ! %{no_x11_askpass}
520%files askpass
521%defattr(-,root,root)
522%doc x11-ssh-askpass-%{aversion}/README
523%doc x11-ssh-askpass-%{aversion}/ChangeLog
524%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
525%attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
526%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
527%endif
528
529%if ! %{no_gnome_askpass}
530%files askpass-gnome
531%defattr(-,root,root)
532%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
533%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
534%endif
535
536%files contrib
537%defattr(-,root,root)
538%doc contrib/README.contrib
539%{_bindir}/ssh-copy-id
540%{_mandir}/man1/ssh-copy-id.1*
541
542%changelog
543* Mon May 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
544- add BR: xorg-x11-xauth for X11 forwarding support
545
546* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
547- new upstream release
548- update patch0,2
549- drop patch3,22
550
551* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
552- new upstream release
553
554* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
555- new upstream release
556
557* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
558- rebuild with xorg-x11-7.3
559
560* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
561- new upstream release with security fix (CVE-2008-1483)
562- drop patch31 which is included in new release (This was for CVE-2008-1483)
563
564* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
565- new upstream release with security fix ("ForceCommand" Directive)
566- turn on daemon restart message
567- new versioning policy
568
569* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
570- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
571
572* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
573- new upstream release
574
575* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
576- build with -fpie/-pie by default.
577- enable ipv6 by default.
578
579* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
580- new upstream release
581
582* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
583- new upstream release
584
585* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
586- new upstream release
587
588* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
589- new upstream release
590
591* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
592- new upstream release
593- remove build6x stuff
594- remove libgnome-devel from BuildRequires
595- cleanup BuildRequires
596- drop Patch200, it is merged in upstream.
597- import patches(25-35) from FC-devel
598
599* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
600- SECURITY FIX: CVE-2006-0225
601  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
602- update BuildPreReq: s/XFree86-devel/XOrg-devel/
603- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
604  - When GNOME2 is used, using libgnome-devel
605  - add BuildPreReq: gtk2-devel for GNOME2
606
607* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
608- rebuild with gtk+-2.8 final
609
610* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
611- new upstream release
612- build with gtk+-2.7
613
614* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
615- new upstream release
616
617* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
618- cleanup obsolete patches and added patches from fedora
619
620* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
621- new upstream release
622
623* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
624- new upstream release
625
626* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
627- new upstream release
628
629* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
630- rebuild with openssl-0.9.7d
631
632* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
633- new upstream release
634
635* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
636- create contrib package
637
638* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
639- new upstream release
640- fix security issue: http://www.openssh.com/txt/sshpam.adv
641
642* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
643- new upstream release
644- fix security issue: http://www.openssh.com/txt/buffer.adv
645
646* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
647- new upstream release
648
649* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
650- rebuild with gtk2
651
652* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
653- new upstream release
654
655* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
656- rebuild with new tool chain
657
658* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
659- new upstream release
660- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
661
662* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
663- change some defines in spec files
664
665* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
666- add patch110 ( 3.4p1 does not include mmap-fallback patch )
667
668* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
669- new upstream release
670  - security fix
671- drop patch10
672
673* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
674- add patch from Solar Designer to make privsep work with a 2.2 kernel.
675
676* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
677- new upstream release
678- add {sshd,ssh}_config.5 manpages
679- add ssh-keysign
680
681* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
682- new upstream release
683
684* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
685- new upstream release
686- drop patch1
687
688* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
689- new upstream release
690- merged with rawhide release.
691- drop Patch101 (merged in upstream)
692
693* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
694- seurity patch for off-by-one bug
695
696* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
697- merged with Rawhide 3.0.2p1-2
698
699* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
700- updated to 3.0.2p1
701
702* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
703- updated to 3.0.1p1
704
705* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
706- updated to 3.0p1
707
708* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
709- add japanese summery and descriptions.
710- update x11-askpass 1.2.5
711
712* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
713- update to openssh-2.9.9p2
714
715* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
716- rebuilt with openssl-0.9.6b
717
718* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
719- do not Permit RootLogin
720
721* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
722- update to openssh-2.5.2p2
723
724* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
725- update to openssh-2.5.2p1
726
727* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
728- update to openssh-2.5.1p2
729
730* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
731- update to openssh-2.5.1p1
732
733* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
734- update to openssh-2.5.1p1
735
736* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
737- remove suid bit from ssh
738
739* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
740- moved man dir to /usr/share/man
741
742* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
743- fixed askpass's link in ssh-add
744- partially used rpmmacros
745
746* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
747- update to 2.3.0p1
748- update x11-askpass 1.0.3
749
750* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
751- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
752  Redhat 7.0 spec file
753
754* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
755- rebuild for Vine Linux
756
757* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
758- Use RPM configure macro
759* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
760- Some surgery to sshd.init (generate keys at runtime)
761- Cleanup of groups and removal of keygen calls
762* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
763- Make building of X11-askpass and gnome-askpass optional
764* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
765- Glob manpages to catch compressed files
766* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
767- Updated for new location
768- Updated for new gnome-ssh-askpass build
769* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
770- Added Jim Knoble's <jmknoble@pobox.com> askpass
771* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
772- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
773* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
774- Added 'Obsoletes' directives
775* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
776- Use make install
777- Subpackages
778* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
779- Added links for slogin
780- Fixed perms on manpages
781* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
782- Renamed init script
783* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
784- Back to old binary names
785* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
786- Use autoconf
787- New binary names
788* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
789- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
790
Note: See TracBrowser for help on using the repository browser.