source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 2649

Revision 2649, 25.0 KB checked in by daisuke, 13 years ago (diff)

openssh: update to 5.8p1

Line 
1%define ver 5.8p1
2%define rel 1%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-5.5p1-vine.patch
70Patch4: openssh-5.2p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-4.0p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-4.2p1-askpass-progress.patch
80
81# Vine Patch
82Patch100: openssh-norootlogin.patch
83Patch120: openssh-4.7p1-sshd.init.patch
84
85License: BSD
86Group: Applications/Internet
87BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
88
89Obsoletes: ssh
90
91BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
92BuildRequires: util-linux
93BuildRequires: db4-devel
94BuildRequires: pam-devel
95BuildRequires: zlib-devel
96%if ! %{no_gnome_askpass}
97BuildRequires: libX11-devel
98BuildRequires: gtk2-devel
99%endif
100BuildRequires: xorg-x11-xauth
101BuildRequires: groff
102BuildRequires: libedit-devel
103
104Vendor: Project Vine
105Distribution: Vine Linux
106Packager: daisuke
107
108%package clients
109Summary: OpenSSH clients.
110Summary(ja): OpenSSH Secure Shell プロトコルクライアント
111Requires: openssh = %{version}-%{release}
112Group: Applications/Internet
113Obsoletes: ssh-clients
114Obsoletes: openssh-contrib
115
116%package server
117Summary: The OpenSSH server daemon.
118Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
119Group: System Environment/Daemons
120Obsoletes: ssh-server
121Requires(post): openssh = %{version}-%{release}
122Requires(post): chkconfig
123Requires(pre): shadow-utils
124Requires(post): initscripts >= 5.20
125Requires: pam
126
127%package askpass-gnome
128Summary: A passphrase dialog for OpenSSH, X, and GNOME.
129Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
130Group: Applications/Internet
131Requires: openssh = %{version}-%{release}
132Obsoletes: ssh-extras
133Obsoletes: openssh-askpass < 5.5p1-3vl6
134Provides: openssh-askpass = %{version}-%{release}
135
136%description
137SSH (Secure SHell) is a program for logging into and executing
138commands on a remote machine. SSH is intended to replace rlogin and
139rsh, and to provide secure encrypted communications between two
140untrusted hosts over an insecure network. X11 connections and
141arbitrary TCP/IP ports can also be forwarded over the secure channel.
142
143OpenSSH is OpenBSD's version of the last free version of SSH, bringing
144it up to date in terms of security and features, as well as removing
145all patented algorithms to separate libraries.
146
147This package includes the core files necessary for both the OpenSSH
148client and server. To make this package useful, you should also
149install openssh-clients, openssh-server, or both.
150
151#'
152%description -l ja
153OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
154Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
155するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
156ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
157可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
158な通信路の中を通すことができます。
159
160OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
161最新のセキュリティと機能を提供しています。またすべての特許がからむ
162アルゴリズムは分割したライブラリにわかれています。
163
164このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
165コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
166openssh-clients および/または openssh-server が必要です。
167
168%description clients
169OpenSSH is a free version of SSH (Secure SHell), a program for logging
170into and executing commands on a remote machine. This package includes
171the clients necessary to make encrypted connections to SSH servers.
172You'll also need to install the openssh package on OpenSSH clients.
173
174#'
175%description -l ja clients
176OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
177Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
178するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
179ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
180可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
181な通信路の中を通すことができます。
182
183OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
184最新のセキュリティと機能を提供しています。またすべての特許がからむ
185アルゴリズムは分割したライブラリにわかれています。
186
187このパッケージは OpenSSH をクライアントとして使用する場合に
188必要なものを含んでいます。
189
190
191%description server
192OpenSSH is a free version of SSH (Secure SHell), a program for logging
193into and executing commands on a remote machine. This package contains
194the secure shell daemon (sshd). The sshd daemon allows SSH clients to
195securely connect to your SSH server. You also need to have the openssh
196package installed.
197
198%description -l ja server
199OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
200Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
201するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
202ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
203可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
204な通信路の中を通すことができます。
205
206OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
207最新のセキュリティと機能を提供しています。またすべての特許がからむ
208アルゴリズムは分割したライブラリにわかれています。
209
210このパッケージは OpenSSH をサーバとして使用する場合に必要な
211デーモンなどを含んでいます。
212
213%description askpass-gnome
214OpenSSH is a free version of SSH (Secure SHell), a program for logging
215into and executing commands on a remote machine. This package contains
216an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
217environment.
218
219%description -l ja askpass-gnome
220OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
221Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
222するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
223ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
224可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
225な通信路の中を通すことができます。
226
227OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
228最新のセキュリティと機能を提供しています。またすべての特許がからむ
229アルゴリズムは分割したライブラリにわかれています。
230
231このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
232
233%prep
234
235%setup -q
236%patch0 -p1 -b .vine
237%patch4 -p1 -b .vendor
238
239%if %{WITH_SELINUX}
240#SELinux
241%patch12 -p1 -b .selinux
242%endif
243
244%patch21 -p1 -b .safe-stop
245%patch24 -p1 -b .fromto-remote
246%patch26 -p1 -b .stack
247%patch27 -p1 -b .log-chroot
248%patch30 -p1 -b .exit-deadlock
249%patch35 -p1 -b .progress
250
251%patch100 -p1 -b .norootlogin
252%patch120 -p1 -b .localtime
253
254autoreconf
255
256
257%build
258CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
259%if %{rescue}
260CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
261%endif
262%if %{pie}
263%ifarch s390 s390x sparc sparc64
264CFLAGS="$CFLAGS -fPIE"
265%else
266CFLAGS="$CFLAGS -fpie"
267%endif
268export CFLAGS
269LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
270%endif
271
272%configure \
273        --sysconfdir=%{_sysconfdir}/ssh \
274        --libexecdir=%{_libexecdir}/openssh \
275        --datadir=%{_datadir}/openssh \
276        --with-tcp-wrappers \
277        --with-default-path=/usr/local/bin:/bin:/usr/bin \
278        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
279        --with-privsep-path=%{_var}/empty/sshd \
280        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
281        --with-libedit \
282%if %{scard}
283        --with-smartcard \
284%endif
285%if %{noip6}
286        --with-ipv4-default \
287%endif
288%if %{rescue}
289        --without-pam --with-md5-passwords
290%else
291        --with-pam
292%endif
293
294%if %{static_libcrypto}
295perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
296%endif
297
298make
299
300%if %{gtk2}
301        gtk2=yes
302%else
303        gtk2=no
304%endif
305
306%if ! %{no_gnome_askpass}
307pushd contrib
308if [ $gtk2 = yes ]; then
309        make gnome-ssh-askpass2
310        mv gnome-ssh-askpass2 gnome-ssh-askpass
311else
312        make gnome-ssh-askpass1
313        mv gnome-ssh-askpass1 gnome-ssh-askpass
314fi
315popd
316%endif
317
318%install
319rm -rf $RPM_BUILD_ROOT
320mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
321mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
322mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
323mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
324
325make install DESTDIR=$RPM_BUILD_ROOT
326
327touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
328install -d $RPM_BUILD_ROOT/etc/pam.d/
329install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
330install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
331install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
332install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
333
334%if ! %{scard}
335        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
336%endif
337
338%if ! %{no_gnome_askpass}
339install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
340install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
341install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
342%endif
343
344%if %{no_gnome_askpass}
345rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
346%endif
347
348# for contrib package
349install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
350install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
351mv contrib/README contrib/README.contrib
352
353perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
354
355%clean
356rm -rf $RPM_BUILD_ROOT
357
358%triggerun server -- ssh-server
359if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
360        touch /var/run/sshd.restart
361fi
362
363%triggerun server -- openssh-server < 2.5.0p1
364# Count the number of HostKey and HostDsaKey statements we have.
365gawk    'BEGIN {IGNORECASE=1}
366         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
367         END {exit sawhostkey}' /etc/ssh/sshd_config
368# And if we only found one, we know the client was relying on the old default
369# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
370# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
371# one nullifies the default, which would have loaded both.
372if [ $? -eq 1 ] ; then
373        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
374        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
375fi
376
377%triggerpostun server -- ssh-server
378if [ "$1" != 0 ] ; then
379        /sbin/chkconfig --add sshd
380        if test -f /var/run/sshd.restart ; then
381                rm -f /var/run/sshd.restart
382                # /sbin/service sshd start > /dev/null 2>&1 || :
383                /sbin/service sshd start
384        fi
385fi
386
387%pre server
388%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
389%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
390        -g sshd -M -r sshd 2>/dev/null || :
391
392%post server
393/sbin/chkconfig --add sshd
394
395%postun server
396# /sbin/service sshd condrestart > /dev/null 2>&1 || :
397/sbin/service sshd condrestart
398exit 0
399
400%preun server
401if [ "$1" = 0 ]
402then
403        /sbin/service sshd stop > /dev/null 2>&1 || :
404        /sbin/chkconfig --del sshd
405fi
406
407%files
408%defattr(-,root,root)
409%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
410%attr(0755,root,root) %{_bindir}/scp
411%attr(0644,root,root) %{_mandir}/man1/scp.1*
412%attr(0755,root,root) %dir %{_sysconfdir}/ssh
413%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
414%attr(644,root,root) %{_mandir}/man5/moduli.5*
415%if ! %{rescue}
416%attr(0755,root,root) %{_bindir}/ssh-keygen
417%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
418%attr(0755,root,root) %dir %{_libexecdir}/openssh
419%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
420%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
421%endif
422%if %{scard}
423%attr(0755,root,root) %dir %{_datadir}/openssh
424%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
425%endif
426
427%files clients
428%defattr(-,root,root)
429%attr(0755,root,root) %{_bindir}/ssh
430%attr(0644,root,root) %{_mandir}/man1/ssh.1*
431%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
432%attr(0644,root,root) %{_mandir}/man1/slogin.1*
433%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
434%attr(-,root,root) %{_bindir}/slogin
435%if ! %{rescue}
436%attr(0755,root,root) %{_bindir}/ssh-agent
437%attr(0755,root,root) %{_bindir}/ssh-add
438%attr(0755,root,root) %{_bindir}/ssh-keyscan
439%attr(0755,root,root) %{_bindir}/sftp
440%attr(0755,root,root) %{_bindir}/ssh-copy-id
441%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
442%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
443%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
444%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
445%attr(0644,root,root) %{_mandir}/man1/sftp.1*
446%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
447%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
448%endif
449
450%if ! %{rescue}
451%files server
452%defattr(-,root,root)
453%dir %attr(0711,root,root) %{_var}/empty/sshd
454%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
455%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
456%attr(0755,root,root) %{_sbindir}/sshd
457%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
458%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
459%attr(0644,root,root) %{_mandir}/man8/sshd.8*
460%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
461%attr(0755,root,root) %dir %{_sysconfdir}/ssh
462%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
463%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
464%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
465%endif
466
467%if ! %{no_gnome_askpass}
468%files askpass-gnome
469%defattr(-,root,root)
470%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
471%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
472%endif
473
474
475%changelog
476* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
477- new upstream release
478
479* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
480- new upstream release
481
482* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
483- new upstream release
484- obsolete contrib subpackage, move ssh-copy-id to client subpackage
485
486* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
487- rebuilt with openssl 1.0.0c
488
489* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
490- drop x11-askpass, add Obsoletes: openssh-askpass
491- add BR: groff
492- enable --with-libedit option, add BR: libedit-devel
493- remove unrecognized option '--with-rsh'
494
495* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
496- add BR: xorg-x11-xauth for X11 forwarding support
497
498* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
499- new upstream release
500- update patch0,2
501- drop patch3,22
502
503* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
504- new upstream release
505
506* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
507- new upstream release
508
509* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
510- rebuild with xorg-x11-7.3
511
512* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
513- new upstream release with security fix (CVE-2008-1483)
514- drop patch31 which is included in new release (This was for CVE-2008-1483)
515
516* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
517- new upstream release with security fix ("ForceCommand" Directive)
518- turn on daemon restart message
519- new versioning policy
520
521* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
522- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
523
524* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
525- new upstream release
526
527* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
528- build with -fpie/-pie by default.
529- enable ipv6 by default.
530
531* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
532- new upstream release
533
534* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
535- new upstream release
536
537* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
538- new upstream release
539
540* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
541- new upstream release
542
543* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
544- new upstream release
545- remove build6x stuff
546- remove libgnome-devel from BuildRequires
547- cleanup BuildRequires
548- drop Patch200, it is merged in upstream.
549- import patches(25-35) from FC-devel
550
551* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
552- SECURITY FIX: CVE-2006-0225
553  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
554- update BuildPreReq: s/XFree86-devel/XOrg-devel/
555- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
556  - When GNOME2 is used, using libgnome-devel
557  - add BuildPreReq: gtk2-devel for GNOME2
558
559* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
560- rebuild with gtk+-2.8 final
561
562* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
563- new upstream release
564- build with gtk+-2.7
565
566* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
567- new upstream release
568
569* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
570- cleanup obsolete patches and added patches from fedora
571
572* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
573- new upstream release
574
575* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
576- new upstream release
577
578* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
579- new upstream release
580
581* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
582- rebuild with openssl-0.9.7d
583
584* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
585- new upstream release
586
587* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
588- create contrib package
589
590* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
591- new upstream release
592- fix security issue: http://www.openssh.com/txt/sshpam.adv
593
594* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
595- new upstream release
596- fix security issue: http://www.openssh.com/txt/buffer.adv
597
598* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
599- new upstream release
600
601* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
602- rebuild with gtk2
603
604* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
605- new upstream release
606
607* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
608- rebuild with new tool chain
609
610* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
611- new upstream release
612- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
613
614* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
615- change some defines in spec files
616
617* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
618- add patch110 ( 3.4p1 does not include mmap-fallback patch )
619
620* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
621- new upstream release
622  - security fix
623- drop patch10
624
625* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
626- add patch from Solar Designer to make privsep work with a 2.2 kernel.
627
628* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
629- new upstream release
630- add {sshd,ssh}_config.5 manpages
631- add ssh-keysign
632
633* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
634- new upstream release
635
636* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
637- new upstream release
638- drop patch1
639
640* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
641- new upstream release
642- merged with rawhide release.
643- drop Patch101 (merged in upstream)
644
645* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
646- seurity patch for off-by-one bug
647
648* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
649- merged with Rawhide 3.0.2p1-2
650
651* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
652- updated to 3.0.2p1
653
654* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
655- updated to 3.0.1p1
656
657* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
658- updated to 3.0p1
659
660* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
661- add japanese summery and descriptions.
662- update x11-askpass 1.2.5
663
664* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
665- update to openssh-2.9.9p2
666
667* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
668- rebuilt with openssl-0.9.6b
669
670* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
671- do not Permit RootLogin
672
673* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
674- update to openssh-2.5.2p2
675
676* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
677- update to openssh-2.5.2p1
678
679* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
680- update to openssh-2.5.1p2
681
682* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
683- update to openssh-2.5.1p1
684
685* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
686- update to openssh-2.5.1p1
687
688* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
689- remove suid bit from ssh
690
691* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
692- moved man dir to /usr/share/man
693
694* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
695- fixed askpass's link in ssh-add
696- partially used rpmmacros
697
698* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
699- update to 2.3.0p1
700- update x11-askpass 1.0.3
701
702* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
703- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
704  Redhat 7.0 spec file
705
706* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
707- rebuild for Vine Linux
708
709* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
710- Use RPM configure macro
711* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
712- Some surgery to sshd.init (generate keys at runtime)
713- Cleanup of groups and removal of keygen calls
714* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
715- Make building of X11-askpass and gnome-askpass optional
716* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
717- Glob manpages to catch compressed files
718* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
719- Updated for new location
720- Updated for new gnome-ssh-askpass build
721* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
722- Added Jim Knoble's <jmknoble@pobox.com> askpass
723* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
724- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
725* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
726- Added 'Obsoletes' directives
727* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
728- Use make install
729- Subpackages
730* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
731- Added links for slogin
732- Fixed perms on manpages
733* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
734- Renamed init script
735* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
736- Back to old binary names
737* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
738- Use autoconf
739- New binary names
740* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
741- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
742
Note: See TracBrowser for help on using the repository browser.