source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 2485

Revision 2485, 24.9 KB checked in by daisuke, 13 years ago (diff)

openssh:

  • update to 5.6p1
  • merge ssh-copy-id to -client subpackage
  • obsoletes -contrib subpackage
Line 
1%define ver 5.6p1
2%define rel 1%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-5.5p1-vine.patch
70Patch4: openssh-5.2p1-vendor.patch
71Patch5: openssh-3.9p1-noinitlog.patch
72Patch12: openssh-selinux.patch
73Patch20: openssh-3.9p1-gssapimitm.patch
74Patch21: openssh-3.9p1-safe-stop.patch
75Patch24: openssh-4.3p1-fromto-remote.patch
76Patch26: openssh-5.2p1-pam-no-stack.patch
77Patch27: openssh-5.1p1-log-in-chroot.patch
78Patch30: openssh-4.0p1-exit-deadlock.patch
79# Patch31: openssh-3.9p1-skip-used.patch
80Patch35: openssh-4.2p1-askpass-progress.patch
81
82# Vine Patch
83Patch100: openssh-norootlogin.patch
84Patch120: openssh-4.7p1-sshd.init.patch
85
86License: BSD
87Group: Applications/Internet
88BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
89
90Obsoletes: ssh
91
92BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
93BuildRequires: util-linux
94BuildRequires: db4-devel
95BuildRequires: pam-devel
96BuildRequires: zlib-devel
97%if ! %{no_gnome_askpass}
98BuildRequires: libX11-devel
99BuildRequires: gtk2-devel
100%endif
101BuildRequires: xorg-x11-xauth
102BuildRequires: groff
103BuildRequires: libedit-devel
104
105Vendor: Project Vine
106Distribution: Vine Linux
107Packager: daisuke
108
109%package clients
110Summary: OpenSSH clients.
111Summary(ja): OpenSSH Secure Shell プロトコルクライアント
112Requires: openssh = %{version}-%{release}
113Group: Applications/Internet
114Obsoletes: ssh-clients
115Obsoletes: openssh-contrib
116
117%package server
118Summary: The OpenSSH server daemon.
119Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
120Group: System Environment/Daemons
121Obsoletes: ssh-server
122Requires(post): openssh = %{version}-%{release}
123Requires(post): chkconfig
124Requires(pre): shadow-utils
125Requires(post): initscripts >= 5.20
126Requires: pam
127
128%package askpass-gnome
129Summary: A passphrase dialog for OpenSSH, X, and GNOME.
130Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
131Group: Applications/Internet
132Requires: openssh = %{version}-%{release}
133Obsoletes: ssh-extras
134Obsoletes: openssh-askpass < 5.5p1-3vl6
135Provides: openssh-askpass = %{version}-%{release}
136
137%description
138SSH (Secure SHell) is a program for logging into and executing
139commands on a remote machine. SSH is intended to replace rlogin and
140rsh, and to provide secure encrypted communications between two
141untrusted hosts over an insecure network. X11 connections and
142arbitrary TCP/IP ports can also be forwarded over the secure channel.
143
144OpenSSH is OpenBSD's version of the last free version of SSH, bringing
145it up to date in terms of security and features, as well as removing
146all patented algorithms to separate libraries.
147
148This package includes the core files necessary for both the OpenSSH
149client and server. To make this package useful, you should also
150install openssh-clients, openssh-server, or both.
151
152#'
153%description -l ja
154OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
155Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
156するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
157ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
158可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
159な通信路の中を通すことができます。
160
161OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
162最新のセキュリティと機能を提供しています。またすべての特許がからむ
163アルゴリズムは分割したライブラリにわかれています。
164
165このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
166コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
167openssh-clients および/または openssh-server が必要です。
168
169%description clients
170OpenSSH is a free version of SSH (Secure SHell), a program for logging
171into and executing commands on a remote machine. This package includes
172the clients necessary to make encrypted connections to SSH servers.
173You'll also need to install the openssh package on OpenSSH clients.
174
175#'
176%description -l ja clients
177OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
178Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
179するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
180ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
181可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
182な通信路の中を通すことができます。
183
184OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
185最新のセキュリティと機能を提供しています。またすべての特許がからむ
186アルゴリズムは分割したライブラリにわかれています。
187
188このパッケージは OpenSSH をクライアントとして使用する場合に
189必要なものを含んでいます。
190
191
192%description server
193OpenSSH is a free version of SSH (Secure SHell), a program for logging
194into and executing commands on a remote machine. This package contains
195the secure shell daemon (sshd). The sshd daemon allows SSH clients to
196securely connect to your SSH server. You also need to have the openssh
197package installed.
198
199%description -l ja server
200OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
201Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
202するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
203ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
204可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
205な通信路の中を通すことができます。
206
207OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
208最新のセキュリティと機能を提供しています。またすべての特許がからむ
209アルゴリズムは分割したライブラリにわかれています。
210
211このパッケージは OpenSSH をサーバとして使用する場合に必要な
212デーモンなどを含んでいます。
213
214%description askpass-gnome
215OpenSSH is a free version of SSH (Secure SHell), a program for logging
216into and executing commands on a remote machine. This package contains
217an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
218environment.
219
220%description -l ja askpass-gnome
221OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
222Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
223するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
224ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
225可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
226な通信路の中を通すことができます。
227
228OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
229最新のセキュリティと機能を提供しています。またすべての特許がからむ
230アルゴリズムは分割したライブラリにわかれています。
231
232このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
233
234%prep
235
236%setup -q
237%patch0 -p1 -b .vine
238%patch4 -p1 -b .vendor
239%patch5 -p1 -b .noinitlog
240
241%if %{WITH_SELINUX}
242#SELinux
243%patch12 -p1 -b .selinux
244%endif
245
246%patch21 -p1 -b .safe-stop
247%patch24 -p1 -b .fromto-remote
248%patch26 -p1 -b .stack
249%patch27 -p1 -b .log-chroot
250%patch30 -p1 -b .exit-deadlock
251%patch35 -p1 -b .progress
252
253%patch100 -p1 -b .norootlogin
254%patch120 -p1 -b .localtime
255
256autoreconf
257
258
259%build
260CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
261%if %{rescue}
262CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
263%endif
264%if %{pie}
265%ifarch s390 s390x sparc sparc64
266CFLAGS="$CFLAGS -fPIE"
267%else
268CFLAGS="$CFLAGS -fpie"
269%endif
270export CFLAGS
271LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
272%endif
273
274%configure \
275        --sysconfdir=%{_sysconfdir}/ssh \
276        --libexecdir=%{_libexecdir}/openssh \
277        --datadir=%{_datadir}/openssh \
278        --with-tcp-wrappers \
279        --with-default-path=/usr/local/bin:/bin:/usr/bin \
280        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
281        --with-privsep-path=%{_var}/empty/sshd \
282        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
283        --with-libedit \
284%if %{scard}
285        --with-smartcard \
286%endif
287%if %{noip6}
288        --with-ipv4-default \
289%endif
290%if %{rescue}
291        --without-pam --with-md5-passwords
292%else
293        --with-pam
294%endif
295
296%if %{static_libcrypto}
297perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
298%endif
299
300make
301
302%if %{gtk2}
303        gtk2=yes
304%else
305        gtk2=no
306%endif
307
308%if ! %{no_gnome_askpass}
309pushd contrib
310if [ $gtk2 = yes ]; then
311        make gnome-ssh-askpass2
312        mv gnome-ssh-askpass2 gnome-ssh-askpass
313else
314        make gnome-ssh-askpass1
315        mv gnome-ssh-askpass1 gnome-ssh-askpass
316fi
317popd
318%endif
319
320%install
321rm -rf $RPM_BUILD_ROOT
322mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
323mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
324mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
325mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
326
327make install DESTDIR=$RPM_BUILD_ROOT
328
329touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
330install -d $RPM_BUILD_ROOT/etc/pam.d/
331install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
332install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
333install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
334install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
335
336%if ! %{scard}
337        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
338%endif
339
340%if ! %{no_gnome_askpass}
341install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
342install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
343install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
344%endif
345
346%if %{no_gnome_askpass}
347rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
348%endif
349
350# for contrib package
351install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
352install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
353mv contrib/README contrib/README.contrib
354
355perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
356
357%clean
358rm -rf $RPM_BUILD_ROOT
359
360%triggerun server -- ssh-server
361if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
362        touch /var/run/sshd.restart
363fi
364
365%triggerun server -- openssh-server < 2.5.0p1
366# Count the number of HostKey and HostDsaKey statements we have.
367gawk    'BEGIN {IGNORECASE=1}
368         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
369         END {exit sawhostkey}' /etc/ssh/sshd_config
370# And if we only found one, we know the client was relying on the old default
371# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
372# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
373# one nullifies the default, which would have loaded both.
374if [ $? -eq 1 ] ; then
375        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
376        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
377fi
378
379%triggerpostun server -- ssh-server
380if [ "$1" != 0 ] ; then
381        /sbin/chkconfig --add sshd
382        if test -f /var/run/sshd.restart ; then
383                rm -f /var/run/sshd.restart
384                # /sbin/service sshd start > /dev/null 2>&1 || :
385                /sbin/service sshd start
386        fi
387fi
388
389%pre server
390%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
391%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
392        -g sshd -M -r sshd 2>/dev/null || :
393
394%post server
395/sbin/chkconfig --add sshd
396
397%postun server
398# /sbin/service sshd condrestart > /dev/null 2>&1 || :
399/sbin/service sshd condrestart
400exit 0
401
402%preun server
403if [ "$1" = 0 ]
404then
405        /sbin/service sshd stop > /dev/null 2>&1 || :
406        /sbin/chkconfig --del sshd
407fi
408
409%files
410%defattr(-,root,root)
411%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
412%attr(0755,root,root) %{_bindir}/scp
413%attr(0644,root,root) %{_mandir}/man1/scp.1*
414%attr(0755,root,root) %dir %{_sysconfdir}/ssh
415%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
416%attr(644,root,root) %{_mandir}/man5/moduli.5*
417%if ! %{rescue}
418%attr(0755,root,root) %{_bindir}/ssh-keygen
419%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
420%attr(0755,root,root) %dir %{_libexecdir}/openssh
421%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
422%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
423%endif
424%if %{scard}
425%attr(0755,root,root) %dir %{_datadir}/openssh
426%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
427%endif
428
429%files clients
430%defattr(-,root,root)
431%attr(0755,root,root) %{_bindir}/ssh
432%attr(0644,root,root) %{_mandir}/man1/ssh.1*
433%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
434%attr(0644,root,root) %{_mandir}/man1/slogin.1*
435%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
436%attr(-,root,root) %{_bindir}/slogin
437%if ! %{rescue}
438%attr(0755,root,root) %{_bindir}/ssh-agent
439%attr(0755,root,root) %{_bindir}/ssh-add
440%attr(0755,root,root) %{_bindir}/ssh-keyscan
441%attr(0755,root,root) %{_bindir}/sftp
442%attr(0755,root,root) %{_bindir}/ssh-copy-id
443%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
444%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
445%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
446%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
447%attr(0644,root,root) %{_mandir}/man1/sftp.1*
448%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
449%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
450%endif
451
452%if ! %{rescue}
453%files server
454%defattr(-,root,root)
455%dir %attr(0711,root,root) %{_var}/empty/sshd
456%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
457%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
458%attr(0755,root,root) %{_sbindir}/sshd
459%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
460%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
461%attr(0644,root,root) %{_mandir}/man8/sshd.8*
462%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
463%attr(0755,root,root) %dir %{_sysconfdir}/ssh
464%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
465%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
466%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
467%endif
468
469%if ! %{no_gnome_askpass}
470%files askpass-gnome
471%defattr(-,root,root)
472%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
473%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
474%endif
475
476
477%changelog
478* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
479- new upstream release
480- obsolete contrib subpackage, move ssh-copy-id to client subpackage
481
482* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
483- rebuilt with openssl 1.0.0c
484
485* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
486- drop x11-askpass, add Obsoletes: openssh-askpass
487- add BR: groff
488- enable --with-libedit option, add BR: libedit-devel
489- remove unrecognized option '--with-rsh'
490
491* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
492- add BR: xorg-x11-xauth for X11 forwarding support
493
494* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
495- new upstream release
496- update patch0,2
497- drop patch3,22
498
499* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
500- new upstream release
501
502* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
503- new upstream release
504
505* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
506- rebuild with xorg-x11-7.3
507
508* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
509- new upstream release with security fix (CVE-2008-1483)
510- drop patch31 which is included in new release (This was for CVE-2008-1483)
511
512* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
513- new upstream release with security fix ("ForceCommand" Directive)
514- turn on daemon restart message
515- new versioning policy
516
517* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
518- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
519
520* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
521- new upstream release
522
523* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
524- build with -fpie/-pie by default.
525- enable ipv6 by default.
526
527* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
528- new upstream release
529
530* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
531- new upstream release
532
533* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
534- new upstream release
535
536* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
537- new upstream release
538
539* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
540- new upstream release
541- remove build6x stuff
542- remove libgnome-devel from BuildRequires
543- cleanup BuildRequires
544- drop Patch200, it is merged in upstream.
545- import patches(25-35) from FC-devel
546
547* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
548- SECURITY FIX: CVE-2006-0225
549  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
550- update BuildPreReq: s/XFree86-devel/XOrg-devel/
551- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
552  - When GNOME2 is used, using libgnome-devel
553  - add BuildPreReq: gtk2-devel for GNOME2
554
555* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
556- rebuild with gtk+-2.8 final
557
558* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
559- new upstream release
560- build with gtk+-2.7
561
562* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
563- new upstream release
564
565* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
566- cleanup obsolete patches and added patches from fedora
567
568* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
569- new upstream release
570
571* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
572- new upstream release
573
574* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
575- new upstream release
576
577* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
578- rebuild with openssl-0.9.7d
579
580* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
581- new upstream release
582
583* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
584- create contrib package
585
586* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
587- new upstream release
588- fix security issue: http://www.openssh.com/txt/sshpam.adv
589
590* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
591- new upstream release
592- fix security issue: http://www.openssh.com/txt/buffer.adv
593
594* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
595- new upstream release
596
597* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
598- rebuild with gtk2
599
600* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
601- new upstream release
602
603* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
604- rebuild with new tool chain
605
606* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
607- new upstream release
608- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
609
610* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
611- change some defines in spec files
612
613* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
614- add patch110 ( 3.4p1 does not include mmap-fallback patch )
615
616* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
617- new upstream release
618  - security fix
619- drop patch10
620
621* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
622- add patch from Solar Designer to make privsep work with a 2.2 kernel.
623
624* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
625- new upstream release
626- add {sshd,ssh}_config.5 manpages
627- add ssh-keysign
628
629* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
630- new upstream release
631
632* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
633- new upstream release
634- drop patch1
635
636* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
637- new upstream release
638- merged with rawhide release.
639- drop Patch101 (merged in upstream)
640
641* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
642- seurity patch for off-by-one bug
643
644* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
645- merged with Rawhide 3.0.2p1-2
646
647* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
648- updated to 3.0.2p1
649
650* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
651- updated to 3.0.1p1
652
653* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
654- updated to 3.0p1
655
656* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
657- add japanese summery and descriptions.
658- update x11-askpass 1.2.5
659
660* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
661- update to openssh-2.9.9p2
662
663* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
664- rebuilt with openssl-0.9.6b
665
666* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
667- do not Permit RootLogin
668
669* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
670- update to openssh-2.5.2p2
671
672* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
673- update to openssh-2.5.2p1
674
675* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
676- update to openssh-2.5.1p2
677
678* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
679- update to openssh-2.5.1p1
680
681* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
682- update to openssh-2.5.1p1
683
684* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
685- remove suid bit from ssh
686
687* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
688- moved man dir to /usr/share/man
689
690* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
691- fixed askpass's link in ssh-add
692- partially used rpmmacros
693
694* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
695- update to 2.3.0p1
696- update x11-askpass 1.0.3
697
698* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
699- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
700  Redhat 7.0 spec file
701
702* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
703- rebuild for Vine Linux
704
705* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
706- Use RPM configure macro
707* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
708- Some surgery to sshd.init (generate keys at runtime)
709- Cleanup of groups and removal of keygen calls
710* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
711- Make building of X11-askpass and gnome-askpass optional
712* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
713- Glob manpages to catch compressed files
714* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
715- Updated for new location
716- Updated for new gnome-ssh-askpass build
717* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
718- Added Jim Knoble's <jmknoble@pobox.com> askpass
719* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
720- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
721* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
722- Added 'Obsoletes' directives
723* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
724- Use make install
725- Subpackages
726* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
727- Added links for slogin
728- Fixed perms on manpages
729* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
730- Renamed init script
731* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
732- Back to old binary names
733* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
734- Use autoconf
735- New binary names
736* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
737- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
738
Note: See TracBrowser for help on using the repository browser.