source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 1064

Revision 1064, 24.9 KB checked in by daisuke, 14 years ago (diff)

openssh:

  • drop x11-askpass, add Obsoletes: openssh-askpass
  • add BR: groff
  • enable --with-libedit option, add BR: libedit-devel
  • remove unrecognized option '--with-rsh'
Line 
1%define ver 5.5p1
2%define rel 3%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
67Patch0: openssh-5.5p1-vine.patch
68Patch2: openssh-5.3p1-skip-initial.patch
69Patch4: openssh-5.2p1-vendor.patch
70Patch5: openssh-3.9p1-noinitlog.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-4.3p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-4.0p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-4.2p1-askpass-progress.patch
80# Vine Patch
81Patch100: openssh-norootlogin.patch
82Patch120: openssh-4.7p1-sshd.init.patch
83
84License: BSD
85Group: Applications/Internet
86BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
87
88Obsoletes: ssh
89
90BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
91BuildRequires: util-linux
92BuildRequires: db4-devel
93BuildRequires: pam-devel
94BuildRequires: zlib-devel
95%if ! %{no_gnome_askpass}
96BuildRequires: libX11-devel
97BuildRequires: gtk2-devel
98%endif
99BuildRequires: xorg-x11-xauth
100BuildRequires: groff
101BuildRequires: libedit-devel
102
103Vendor: Project Vine
104Distribution: Vine Linux
105Packager: daisuke
106
107%package clients
108Summary: OpenSSH clients.
109Summary(ja): OpenSSH Secure Shell プロトコルクライアント
110Requires: openssh = %{version}-%{release}
111Group: Applications/Internet
112Obsoletes: ssh-clients
113
114%package server
115Summary: The OpenSSH server daemon.
116Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
117Group: System Environment/Daemons
118Obsoletes: ssh-server
119Requires(post): openssh = %{version}-%{release}
120Requires(post): chkconfig
121Requires(pre): shadow-utils
122Requires(post): initscripts >= 5.20
123Requires: pam
124
125%package askpass-gnome
126Summary: A passphrase dialog for OpenSSH, X, and GNOME.
127Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
128Group: Applications/Internet
129Requires: openssh = %{version}-%{release}
130Obsoletes: ssh-extras
131Obsoletes: openssh-askpass < 5.5p1-3vl6
132Provides: openssh-askpass = %{version}-%{release}
133
134%package contrib
135Summary: addons for OpenSSH
136Summary(ja): OpenSSH のためのアドオン
137Group: Applications/Internet
138Requires: openssh-clients = %{version}-%{release}
139
140%description
141SSH (Secure SHell) is a program for logging into and executing
142commands on a remote machine. SSH is intended to replace rlogin and
143rsh, and to provide secure encrypted communications between two
144untrusted hosts over an insecure network. X11 connections and
145arbitrary TCP/IP ports can also be forwarded over the secure channel.
146
147OpenSSH is OpenBSD's version of the last free version of SSH, bringing
148it up to date in terms of security and features, as well as removing
149all patented algorithms to separate libraries.
150
151This package includes the core files necessary for both the OpenSSH
152client and server. To make this package useful, you should also
153install openssh-clients, openssh-server, or both.
154
155#'
156%description -l ja
157OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
158Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
159するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
160ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
161可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
162な通信路の中を通すことができます。
163
164OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
165最新のセキュリティと機能を提供しています。またすべての特許がからむ
166アルゴリズムは分割したライブラリにわかれています。
167
168このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
169コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
170openssh-clients および/または openssh-server が必要です。
171
172%description clients
173OpenSSH is a free version of SSH (Secure SHell), a program for logging
174into and executing commands on a remote machine. This package includes
175the clients necessary to make encrypted connections to SSH servers.
176You'll also need to install the openssh package on OpenSSH clients.
177
178#'
179%description -l ja clients
180OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
181Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
182するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
183ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
184可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
185な通信路の中を通すことができます。
186
187OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
188最新のセキュリティと機能を提供しています。またすべての特許がからむ
189アルゴリズムは分割したライブラリにわかれています。
190
191このパッケージは OpenSSH をクライアントとして使用する場合に
192必要なものを含んでいます。
193
194
195%description server
196OpenSSH is a free version of SSH (Secure SHell), a program for logging
197into and executing commands on a remote machine. This package contains
198the secure shell daemon (sshd). The sshd daemon allows SSH clients to
199securely connect to your SSH server. You also need to have the openssh
200package installed.
201
202%description -l ja server
203OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
204Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
205するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
206ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
207可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
208な通信路の中を通すことができます。
209
210OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
211最新のセキュリティと機能を提供しています。またすべての特許がからむ
212アルゴリズムは分割したライブラリにわかれています。
213
214このパッケージは OpenSSH をサーバとして使用する場合に必要な
215デーモンなどを含んでいます。
216
217%description askpass-gnome
218OpenSSH is a free version of SSH (Secure SHell), a program for logging
219into and executing commands on a remote machine. This package contains
220an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
221environment.
222
223%description -l ja askpass-gnome
224OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
225Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
226するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
227ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
228可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
229な通信路の中を通すことができます。
230
231OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
232最新のセキュリティと機能を提供しています。またすべての特許がからむ
233アルゴリズムは分割したライブラリにわかれています。
234
235このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
236
237%description contrib
238addons for OpenSSH
239
240%description -l ja contrib
241OpenSSH のためのアドオン
242
243%prep
244
245%setup -q
246%patch0 -p1 -b .vine
247%patch2 -p1 -b .skip-initial
248%patch4 -p1 -b .vendor
249%patch5 -p1 -b .noinitlog
250
251%if %{WITH_SELINUX}
252#SELinux
253%patch12 -p1 -b .selinux
254%endif
255
256%patch21 -p1 -b .safe-stop
257%patch24 -p1 -b .fromto-remote
258%patch26 -p1 -b .stack
259%patch27 -p1 -b .log-chroot
260%patch30 -p1 -b .exit-deadlock
261%patch35 -p1 -b .progress
262
263%patch100 -p1 -b .norootlogin
264%patch120 -p1 -b .localtime
265
266autoreconf
267
268
269%build
270CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
271%if %{rescue}
272CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
273%endif
274%if %{pie}
275%ifarch s390 s390x sparc sparc64
276CFLAGS="$CFLAGS -fPIE"
277%else
278CFLAGS="$CFLAGS -fpie"
279%endif
280export CFLAGS
281LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
282%endif
283
284%configure \
285        --sysconfdir=%{_sysconfdir}/ssh \
286        --libexecdir=%{_libexecdir}/openssh \
287        --datadir=%{_datadir}/openssh \
288        --with-tcp-wrappers \
289        --with-default-path=/usr/local/bin:/bin:/usr/bin \
290        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
291        --with-privsep-path=%{_var}/empty/sshd \
292        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
293        --with-libedit \
294%if %{scard}
295        --with-smartcard \
296%endif
297%if %{noip6}
298        --with-ipv4-default \
299%endif
300%if %{rescue}
301        --without-pam --with-md5-passwords
302%else
303        --with-pam
304%endif
305
306%if %{static_libcrypto}
307perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
308%endif
309
310make
311
312%if %{gtk2}
313        gtk2=yes
314%else
315        gtk2=no
316%endif
317
318%if ! %{no_gnome_askpass}
319pushd contrib
320if [ $gtk2 = yes ]; then
321        make gnome-ssh-askpass2
322        mv gnome-ssh-askpass2 gnome-ssh-askpass
323else
324        make gnome-ssh-askpass1
325        mv gnome-ssh-askpass1 gnome-ssh-askpass
326fi
327popd
328%endif
329
330%install
331rm -rf $RPM_BUILD_ROOT
332mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
333mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
334mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
335mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
336
337make install DESTDIR=$RPM_BUILD_ROOT
338
339touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
340install -d $RPM_BUILD_ROOT/etc/pam.d/
341install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
342install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
343install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
344install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
345
346%if ! %{scard}
347        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
348%endif
349
350%if ! %{no_gnome_askpass}
351install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
352install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
353install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
354%endif
355
356%if %{no_gnome_askpass}
357rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
358%endif
359
360# for contrib package
361install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
362install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
363mv contrib/README contrib/README.contrib
364
365perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
366
367%clean
368rm -rf $RPM_BUILD_ROOT
369
370%triggerun server -- ssh-server
371if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
372        touch /var/run/sshd.restart
373fi
374
375%triggerun server -- openssh-server < 2.5.0p1
376# Count the number of HostKey and HostDsaKey statements we have.
377gawk    'BEGIN {IGNORECASE=1}
378         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
379         END {exit sawhostkey}' /etc/ssh/sshd_config
380# And if we only found one, we know the client was relying on the old default
381# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
382# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
383# one nullifies the default, which would have loaded both.
384if [ $? -eq 1 ] ; then
385        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
386        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
387fi
388
389%triggerpostun server -- ssh-server
390if [ "$1" != 0 ] ; then
391        /sbin/chkconfig --add sshd
392        if test -f /var/run/sshd.restart ; then
393                rm -f /var/run/sshd.restart
394                # /sbin/service sshd start > /dev/null 2>&1 || :
395                /sbin/service sshd start
396        fi
397fi
398
399%pre server
400%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
401%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
402        -g sshd -M -r sshd 2>/dev/null || :
403
404%post server
405/sbin/chkconfig --add sshd
406
407%postun server
408# /sbin/service sshd condrestart > /dev/null 2>&1 || :
409/sbin/service sshd condrestart
410exit 0
411
412%preun server
413if [ "$1" = 0 ]
414then
415        /sbin/service sshd stop > /dev/null 2>&1 || :
416        /sbin/chkconfig --del sshd
417fi
418
419%files
420%defattr(-,root,root)
421%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
422%attr(0755,root,root) %{_bindir}/scp
423%attr(0644,root,root) %{_mandir}/man1/scp.1*
424%attr(0755,root,root) %dir %{_sysconfdir}/ssh
425%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
426%attr(644,root,root) %{_mandir}/man5/moduli.5*
427%if ! %{rescue}
428%attr(0755,root,root) %{_bindir}/ssh-keygen
429%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
430%attr(0755,root,root) %dir %{_libexecdir}/openssh
431%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
432%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
433%endif
434%if %{scard}
435%attr(0755,root,root) %dir %{_datadir}/openssh
436%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
437%endif
438
439%files clients
440%defattr(-,root,root)
441%attr(0755,root,root) %{_bindir}/ssh
442%attr(0644,root,root) %{_mandir}/man1/ssh.1*
443%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
444%attr(0644,root,root) %{_mandir}/man1/slogin.1*
445%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
446%attr(-,root,root) %{_bindir}/slogin
447%if ! %{rescue}
448%attr(0755,root,root) %{_bindir}/ssh-agent
449%attr(0755,root,root) %{_bindir}/ssh-add
450%attr(0755,root,root) %{_bindir}/ssh-keyscan
451%attr(0755,root,root) %{_bindir}/sftp
452%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
453%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
454%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
455%attr(0644,root,root) %{_mandir}/man1/sftp.1*
456%endif
457
458%if ! %{rescue}
459%files server
460%defattr(-,root,root)
461%dir %attr(0711,root,root) %{_var}/empty/sshd
462%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
463%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
464%attr(0755,root,root) %{_sbindir}/sshd
465%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
466%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
467%attr(0644,root,root) %{_mandir}/man8/sshd.8*
468%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
469%attr(0755,root,root) %dir %{_sysconfdir}/ssh
470%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
471%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
472%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
473%endif
474
475%if ! %{no_gnome_askpass}
476%files askpass-gnome
477%defattr(-,root,root)
478%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
479%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
480%endif
481
482%files contrib
483%defattr(-,root,root)
484%doc contrib/README.contrib
485%{_bindir}/ssh-copy-id
486%{_mandir}/man1/ssh-copy-id.1*
487
488%changelog
489* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
490- drop x11-askpass, add Obsoletes: openssh-askpass
491- add BR: groff
492- enable --with-libedit option, add BR: libedit-devel
493- remove unrecognized option '--with-rsh'
494
495* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
496- add BR: xorg-x11-xauth for X11 forwarding support
497
498* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
499- new upstream release
500- update patch0,2
501- drop patch3,22
502
503* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
504- new upstream release
505
506* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
507- new upstream release
508
509* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
510- rebuild with xorg-x11-7.3
511
512* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
513- new upstream release with security fix (CVE-2008-1483)
514- drop patch31 which is included in new release (This was for CVE-2008-1483)
515
516* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
517- new upstream release with security fix ("ForceCommand" Directive)
518- turn on daemon restart message
519- new versioning policy
520
521* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
522- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
523
524* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
525- new upstream release
526
527* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
528- build with -fpie/-pie by default.
529- enable ipv6 by default.
530
531* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
532- new upstream release
533
534* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
535- new upstream release
536
537* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
538- new upstream release
539
540* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
541- new upstream release
542
543* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
544- new upstream release
545- remove build6x stuff
546- remove libgnome-devel from BuildRequires
547- cleanup BuildRequires
548- drop Patch200, it is merged in upstream.
549- import patches(25-35) from FC-devel
550
551* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
552- SECURITY FIX: CVE-2006-0225
553  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
554- update BuildPreReq: s/XFree86-devel/XOrg-devel/
555- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
556  - When GNOME2 is used, using libgnome-devel
557  - add BuildPreReq: gtk2-devel for GNOME2
558
559* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
560- rebuild with gtk+-2.8 final
561
562* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
563- new upstream release
564- build with gtk+-2.7
565
566* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
567- new upstream release
568
569* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
570- cleanup obsolete patches and added patches from fedora
571
572* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
573- new upstream release
574
575* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
576- new upstream release
577
578* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
579- new upstream release
580
581* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
582- rebuild with openssl-0.9.7d
583
584* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
585- new upstream release
586
587* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
588- create contrib package
589
590* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
591- new upstream release
592- fix security issue: http://www.openssh.com/txt/sshpam.adv
593
594* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
595- new upstream release
596- fix security issue: http://www.openssh.com/txt/buffer.adv
597
598* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
599- new upstream release
600
601* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
602- rebuild with gtk2
603
604* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
605- new upstream release
606
607* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
608- rebuild with new tool chain
609
610* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
611- new upstream release
612- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
613
614* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
615- change some defines in spec files
616
617* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
618- add patch110 ( 3.4p1 does not include mmap-fallback patch )
619
620* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
621- new upstream release
622  - security fix
623- drop patch10
624
625* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
626- add patch from Solar Designer to make privsep work with a 2.2 kernel.
627
628* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
629- new upstream release
630- add {sshd,ssh}_config.5 manpages
631- add ssh-keysign
632
633* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
634- new upstream release
635
636* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
637- new upstream release
638- drop patch1
639
640* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
641- new upstream release
642- merged with rawhide release.
643- drop Patch101 (merged in upstream)
644
645* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
646- seurity patch for off-by-one bug
647
648* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
649- merged with Rawhide 3.0.2p1-2
650
651* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
652- updated to 3.0.2p1
653
654* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
655- updated to 3.0.1p1
656
657* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
658- updated to 3.0p1
659
660* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
661- add japanese summery and descriptions.
662- update x11-askpass 1.2.5
663
664* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
665- update to openssh-2.9.9p2
666
667* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
668- rebuilt with openssl-0.9.6b
669
670* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
671- do not Permit RootLogin
672
673* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
674- update to openssh-2.5.2p2
675
676* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
677- update to openssh-2.5.2p1
678
679* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
680- update to openssh-2.5.1p2
681
682* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
683- update to openssh-2.5.1p1
684
685* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
686- update to openssh-2.5.1p1
687
688* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
689- remove suid bit from ssh
690
691* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
692- moved man dir to /usr/share/man
693
694* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
695- fixed askpass's link in ssh-add
696- partially used rpmmacros
697
698* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
699- update to 2.3.0p1
700- update x11-askpass 1.0.3
701
702* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
703- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
704  Redhat 7.0 spec file
705
706* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
707- rebuild for Vine Linux
708
709* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
710- Use RPM configure macro
711* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
712- Some surgery to sshd.init (generate keys at runtime)
713- Cleanup of groups and removal of keygen calls
714* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
715- Make building of X11-askpass and gnome-askpass optional
716* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
717- Glob manpages to catch compressed files
718* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
719- Updated for new location
720- Updated for new gnome-ssh-askpass build
721* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
722- Added Jim Knoble's <jmknoble@pobox.com> askpass
723* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
724- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
725* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
726- Added 'Obsoletes' directives
727* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
728- Use make install
729- Subpackages
730* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
731- Added links for slogin
732- Fixed perms on manpages
733* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
734- Renamed init script
735* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
736- Back to old binary names
737* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
738- Use autoconf
739- New binary names
740* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
741- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
742
Note: See TracBrowser for help on using the repository browser.