source: projects/specs/trunk/o/opensp/opensp-vl.spec @ 9058

Revision 9058, 5.0 KB checked in by inagaki, 9 years ago (diff)

2014-11-04 Ryoichi INAGAKI <ryo1@…>

  • gnuchess, ibus-qt, openjade, opensp: updated


Line 
1Summary: SGML and XML parser
2Summary(ja): SGML, XML パーサ
3Name: opensp
4Version: 1.5.2
5Release: 9%{?_dist_release}
6
7License: MIT
8Group: Applications/Text
9URL: http://openjade.sourceforge.net/
10
11Source: http://download.sourceforge.net/openjade/OpenSP-%{version}.tar.gz
12Patch0: opensp-multilib.patch
13Patch1: opensp-nodeids.patch
14Patch2: opensp-sigsegv.patch
15Patch3: opensp-manpage.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: jadetex
19BuildRequires: xmlto
20Requires: sgml-common >= 0.5
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26OpenSP is an implementation of the ISO/IEC 8879:1986 standard SGML
27(Standard Generalized Markup Language). OpenSP is based on James
28Clark's SP implementation of SGML. OpenSP is a command-line
29application and a set of components, including a generic API.
30
31%package devel
32Summary: Files for developing applications that use OpenSP
33Summary(ja): OpenSP を用いるアプリケーションの開発に必要なファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36
37%description devel
38Header files and libtool library for developing applications that use OpenSP.
39
40
41%prep
42%setup -q -n OpenSP-%{version}
43%patch0 -p1 -b .multilib
44%patch1 -p1 -b .nodeids
45%patch2 -p1 -b .sigsegv
46%patch3 -p1 -b .manpage
47# convert files to UTF-8
48iconv -f latin1 -t utf8 ChangeLog -o ChangeLog.tmp
49mv -f ChangeLog.tmp ChangeLog
50
51%build
52%configure --disable-dependency-tracking --disable-static --enable-http \
53 --enable-default-catalog=%{_sysconfdir}/sgml/catalog \
54 --enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml
55
56# specify --skip-validation option
57make %{?_smp_mflags} XMLTO="%{_bindir}/xmlto --skip-validation"
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make install DESTDIR=$RPM_BUILD_ROOT
63
64# Get rid of libtool libraries
65rm $RPM_BUILD_ROOT%{_libdir}/*.la
66
67# oMy, othis ois osilly.
68for file in nsgmls sgmlnorm spam spent sx ; do
69   ln -s o$file $RPM_BUILD_ROOT%{_bindir}/$file
70   echo ".so man1/o${file}.1" > $RPM_BUILD_ROOT%{_mandir}/man1/${file}.1
71done
72
73#
74# Rename sx to sgml2xml.
75mv $RPM_BUILD_ROOT%{_bindir}/sx $RPM_BUILD_ROOT%{_bindir}/sgml2xml
76mv $RPM_BUILD_ROOT%{_mandir}/man1/{sx,sgml2xml}.1
77
78#
79# Clean out (installed) redundant copies of the docs and DTDs.
80rm -rf $RPM_BUILD_ROOT%{_docdir}/OpenSP
81rm -rf $RPM_BUILD_ROOT%{_datadir}/OpenSP
82
83%find_lang sp5
84
85
86%check
87make check || : # failures as of 1.5.2pre1 :(
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96
97%files -f sp5.lang
98%defattr(-,root,root)
99%doc doc/*.htm
100%doc docsrc/releasenotes.html
101%doc AUTHORS BUGS COPYING ChangeLog NEWS README
102%doc pubtext/opensp-implied.dcl
103%{_bindir}/*
104%{_libdir}/libosp.so.*
105%{_mandir}/man1/*.1*
106
107%files devel
108%defattr(-,root,root)
109%{_includedir}/OpenSP/
110%{_libdir}/libosp.so
111
112
113%changelog
114* Mon Nov  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.5.2-9
115- converted doc files to UTF
116- added XMLTO option to build on current xmlto
117- added Patch3 from FC
118  * Thu Aug 15 2013 Ondrej Vasik <ovasik@redhat.com> - 1.5.2-18
119  - fix the inconsistency between man page and help (#854941)
120
121* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.2-8
122- rebuild with VineSeed environment
123
124* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1.5.2-7
125- rebuilt with rpm-4.8.1-3
126
127* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-6
128- rebuilt with new toolchain
129
130* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.5.2-5vl5
131- removed *.la
132- spec in utf-8
133
134* Sun May 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-4vl5
135- added Patch1 and 2 from Fedora
136  * Thu Jun 21 2007 Ondrej Vasik <ovasik@redhat.com>
137  - fixed SIGSEGV (bug #245104)
138  * Mon Feb 12 2007 Tim Waugh <twaugh@redhat.com>
139  - Give IDs to nodes in the release notes source to prevent releasenotes.html
140    having multilib conflicts (bug #228320).
141
142* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-3vl1
143- based on FC6 1.5.2-3.1, built on new toolchain
144
145* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-3.1
146- rebuild
147
148* Tue Jun 13 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-3
149- Fixed multilib fix (bug #194702).
150
151* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-2
152- Fixed multilib devel conflicts (bug #192741).
153
154* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.2
155- bump again for double-long bug on ppc(64)
156
157* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.1
158- rebuilt for new gcc4.1 snapshot and glibc changes
159
160* Thu Jan  5 2006 Tim Waugh <twaugh@redhat.com>  1.5.2-1
161- 1.5.2.
162
163* Wed Dec 14 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-2
164- Backported patch from 1.5.2pre1 to fix ArcEngine crash.
165
166* Tue Dec 13 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-1
167- Back down to 1.5.1 for now.
168- Fixes for GCC4.1.
169
170* Sun Dec  4 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 1.5.2-0.1.pre1
171- Fix build dependencies.
172- Require exact version of main package in -devel.
173- Build with dependency tracking disabled.
174- Add %%{_datadir}/xml to default search path.
175- Run test suite during build.
176- Add URL tag.
177- Use %%find_lang.
178- Cosmetic improvements.
179
180* Tue Nov 29 2005 Terje Bless <link@pobox.com> 1.5.2-0.pre1
181- New package OpenSP.
182
Note: See TracBrowser for help on using the repository browser.