source: projects/specs/trunk/o/opensp/opensp-vl.spec @ 8084

Revision 8084, 4.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: SGML and XML parser
2Summary(ja): SGML, XML パーサ
3Name: opensp
4Version: 1.5.2
5Release: 8%{?_dist_release}
6URL: http://openjade.sourceforge.net/
7Source: http://download.sourceforge.net/openjade/OpenSP-%{version}.tar.gz
8Patch0: opensp-multilib.patch
9Patch1: opensp-nodeids.patch
10Patch2: opensp-sigsegv.patch
11License: BSD
12Group: Applications/Text
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: xmlto, jadetex
16Requires: sgml-common >= 0.5
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22OpenSP is an implementation of the ISO/IEC 8879:1986 standard SGML
23(Standard Generalized Markup Language). OpenSP is based on James
24Clark's SP implementation of SGML. OpenSP is a command-line
25application and a set of components, including a generic API.
26
27%package devel
28Summary: Files for developing applications that use OpenSP
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33Header files and libtool library for developing applications that use OpenSP.
34
35
36%prep
37%setup -q -n OpenSP-%{version}
38%patch0 -p1 -b .multilib
39%patch1 -p1 -b .nodeids
40%patch2 -p1 -b .sigsegv
41
42%build
43%configure --disable-dependency-tracking --disable-static --enable-http \
44 --enable-default-catalog=%{_sysconfdir}/sgml/catalog \
45 --enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml
46make %{?_smp_mflags}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51make install DESTDIR=$RPM_BUILD_ROOT
52
53# Fix up libtool libraries
54find $RPM_BUILD_ROOT -name '*.la' | \
55  xargs perl -p -i -e "s|-L$RPM_BUILD_DIR[\w/.-]*||g"
56
57# oMy, othis ois osilly.
58for file in nsgmls sgmlnorm spam spent sx ; do
59   ln -s o$file $RPM_BUILD_ROOT%{_bindir}/$file
60   echo ".so man1/o${file}.1" > $RPM_BUILD_ROOT%{_mandir}/man1/${file}.1
61done
62
63#
64# Rename sx to sgml2xml.
65mv $RPM_BUILD_ROOT%{_bindir}/sx $RPM_BUILD_ROOT%{_bindir}/sgml2xml
66mv $RPM_BUILD_ROOT%{_mandir}/man1/{sx,sgml2xml}.1
67
68#
69# Clean out (installed) redundant copies of the docs and DTDs.
70rm -rf $RPM_BUILD_ROOT%{_docdir}/OpenSP
71rm -rf $RPM_BUILD_ROOT%{_datadir}/OpenSP
72
73%find_lang sp5
74
75## remove unuse files
76rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
77
78
79%check
80make check || : # failures as of 1.5.2pre1 :(
81
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91
92%files -f sp5.lang
93%defattr(-,root,root)
94%doc doc/*.htm
95%doc docsrc/releasenotes.html
96%doc AUTHORS BUGS COPYING ChangeLog NEWS README
97%doc pubtext/opensp-implied.dcl
98%{_bindir}/*
99%{_libdir}/libosp.so.*
100%{_mandir}/man1/*.1*
101
102%files devel
103%defattr(-,root,root)
104%{_includedir}/OpenSP/
105%{_libdir}/libosp.so
106
107
108%changelog
109* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.2-8
110- rebuild with VineSeed environment
111
112* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1.5.2-7
113- rebuilt with rpm-4.8.1-3
114
115* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-6
116- rebuilt with new toolchain
117
118* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.5.2-5vl5
119- removed *.la
120- spec in utf-8
121
122* Sun May 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-4vl5
123- added Patch1 and 2 from Fedora
124  * Thu Jun 21 2007 Ondrej Vasik <ovasik@redhat.com>
125  - fixed SIGSEGV (bug #245104)
126  * Mon Feb 12 2007 Tim Waugh <twaugh@redhat.com>
127  - Give IDs to nodes in the release notes source to prevent releasenotes.html
128    having multilib conflicts (bug #228320).
129
130* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-3vl1
131- based on FC6 1.5.2-3.1, built on new toolchain
132
133* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-3.1
134- rebuild
135
136* Tue Jun 13 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-3
137- Fixed multilib fix (bug #194702).
138
139* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-2
140- Fixed multilib devel conflicts (bug #192741).
141
142* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.2
143- bump again for double-long bug on ppc(64)
144
145* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.1
146- rebuilt for new gcc4.1 snapshot and glibc changes
147
148* Thu Jan  5 2006 Tim Waugh <twaugh@redhat.com>  1.5.2-1
149- 1.5.2.
150
151* Wed Dec 14 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-2
152- Backported patch from 1.5.2pre1 to fix ArcEngine crash.
153
154* Tue Dec 13 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-1
155- Back down to 1.5.1 for now.
156- Fixes for GCC4.1.
157
158* Sun Dec  4 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 1.5.2-0.1.pre1
159- Fix build dependencies.
160- Require exact version of main package in -devel.
161- Build with dependency tracking disabled.
162- Add %%{_datadir}/xml to default search path.
163- Run test suite during build.
164- Add URL tag.
165- Use %%find_lang.
166- Cosmetic improvements.
167
168* Tue Nov 29 2005 Terje Bless <link@pobox.com> 1.5.2-0.pre1
169- New package OpenSP.
170
Note: See TracBrowser for help on using the repository browser.