source: projects/specs/trunk/o/opensource-cobol/opensource-cobol-vl.spec @ 10285

Revision 10285, 3.8 KB checked in by ara_t, 8 years ago (diff)

first commit

Line 
1%define pkg_name    opensource-cobol
2%define pkg_version 1.4.0J
3%define pkg_release 2%{?_dist_release}
4
5Summary: An open-source COBOL compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv2
11Group:   Applications/Languages
12URL:     https://www.osscons.jp/
13Source0: %{name}-%{version}-utf8.tar.gz
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17%if %{?_dist_release} == "vl6"
18BuildRequires: db4-devel
19%endif
20%if %{?_dist_release} == "vl7"
21BuildRequires: libdb-devel
22%endif
23BuildRequires: gmp-devel
24BuildRequires: ncurses-devel
25
26BuildRequires: texinfo
27BuildRequires: texlive-common
28%if %{?_dist_release} == "vl6"
29BuildRequires: texlive-collection-texinfo
30%endif
31%if %{?_dist_release} == "vl7"
32BuildRequires: texlive-collection-plainextra
33BuildRequires: texlive-collection-fontsrecommended
34# rpm -qa --qf "BuildRequires: %{name}\n" | grep -v -e "doc$" | \
35#   grep texlive-collection-lang
36BuildRequires: texlive-collection-langenglish
37BuildRequires: texlive-collection-langkorean
38BuildRequires: texlive-collection-langitalian
39BuildRequires: texlive-collection-langpolish
40BuildRequires: texlive-collection-langgerman
41BuildRequires: texlive-collection-langjapanese
42BuildRequires: texlive-collection-langgreek
43BuildRequires: texlive-collection-langcyrillic
44BuildRequires: texlive-collection-langeuropean
45BuildRequires: texlive-collection-langspanish
46BuildRequires: texlive-collection-langcjk
47BuildRequires: texlive-collection-langczechslovak
48BuildRequires: texlive-collection-langfrench
49BuildRequires: texlive-collection-langarabic
50BuildRequires: texlive-collection-langother
51BuildRequires: texlive-collection-langportuguese
52BuildRequires: texlive-collection-langindic
53BuildRequires: texlive-collection-langafrican
54BuildRequires: texlive-collection-langchinese
55%endif
56
57%if %{?_dist_release} == "vl6"
58Requires: db4
59%endif
60%if %{?_dist_release} == "vl7"
61Requires: libdb
62%endif
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: ara_t
67
68
69%description
70"opensource COBOL" is open-source COBOL compiler,
71an extension of the Japan-specific features.
72"opensource COBOL" translates COBOL program to C code
73and compiles it using GCC or CL.
74
75It was forked from OpenCOBOL in 2012.
76See also OpenCOBOL project.
77    http://www.opencobol.org/
78    http://sourceforge.net/projects/open-cobol/
79
80%description -l ja
81opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
82COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
83コンパイルします。
84
85opensource COBOLは、オープンCOBOLソリューション部会によって
86OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
87メンテナンスを加えたものです。
88
89
90%prep
91%{__rm} -rf ${RPM_BUILD_ROOT}
92%setup -q -n %{name}-%{version}-utf8
93
94%build
95%{configure} \
96 --enable-utf8 \
97 --disable-static
98
99%{__make} %{?_smp_mflags}
100%{__make} pdf html
101
102%check
103%{__make} check
104
105%install
106%{make_install}
107%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
108%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
109
110%clean
111%{__rm} -rf ${RPM_BUILD_ROOT}
112
113%post
114/sbin/install-info %{_infodir}/open-cobol.info.gz %{_infodir}/dir 2>/dev/null
115%{_syssbindir}/ldconfig
116
117%preun
118if [ $1 = 0 ]; then
119    /sbin/install-info --delete %{_infodir}/open-cobol.info.gz \
120                       %{_infodir}/dir 2>/dev/null
121fi
122
123%postun -p %{_syssbindir}/ldconfig
124
125
126%files
127%defattr(-,root,root)
128%doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
129%doc texi/open-cobol.pdf
130%doc texi/open-cobol.html/
131%{_bindir}/
132%{_includedir}/libcob.h
133%{_includedir}/libcob
134%{_libdir}/libcob.so*
135%{_datadir}/locale/
136%{_datadir}/%{name}-%{version}
137%{_infodir}/*.info.gz
138
139
140%changelog
141* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
142- rebuild under texlive 2016 pretest
143- add BuildRequires
144
145* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
146- new package
147
Note: See TracBrowser for help on using the repository browser.