source: projects/specs/trunk/o/opensource-cobol/opensource-cobol-vl.spec @ 10385

Revision 10385, 2.9 KB checked in by ara_t, 8 years ago (diff)

update to 1.5.0J

Line 
1%define pkg_name    opensource-cobol
2%define pkg_version 1.5.0J
3%define pkg_release 1%{?_dist_release}
4
5Summary: An open-source COBOL compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv2
11Group:   Applications/Languages
12URL:     https://www.osscons.jp/
13Source0: %{name}-%{version}-utf8.tar.gz
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17%if %{?_dist_release} == "vl6"
18BuildRequires: db4-devel
19%else
20BuildRequires: libdb-devel
21%endif
22BuildRequires: gmp-devel
23BuildRequires: ncurses-devel
24
25BuildRequires: texinfo
26BuildRequires: texlive-common
27%if %{?_dist_release} == "vl6"
28BuildRequires: texlive-collection-texinfo
29%else
30BuildRequires: texlive-collection-plainextra
31BuildRequires: texlive-collection-fontsrecommended
32%endif
33
34%if %{?_dist_release} == "vl6"
35Requires: db4
36%else
37Requires: libdb
38%endif
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: ara_t
43
44
45%description
46"opensource COBOL" is open-source COBOL compiler,
47an extension of the Japan-specific features.
48"opensource COBOL" translates COBOL program to C code
49and compiles it using GCC or CL.
50
51It was forked from OpenCOBOL in 2012.
52See also OpenCOBOL project.
53    http://www.opencobol.org/
54    http://sourceforge.net/projects/open-cobol/
55
56%description -l ja
57opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
58COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
59コンパイルします。
60
61opensource COBOLは、オープンCOBOLソリューション部会によって
62OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
63メンテナンスを加えたものです。
64
65
66%prep
67%{__rm} -rf ${RPM_BUILD_ROOT}
68%setup -q -n %{name}-%{version}-utf8
69
70%build
71%{configure} \
72 --enable-utf8 \
73 --disable-static
74
75%{__make} %{?_smp_mflags}
76%{__make} pdf html
77
78%check
79%{__make} check
80
81%install
82%{make_install}
83%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
84%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
85
86%clean
87%{__rm} -rf ${RPM_BUILD_ROOT}
88
89%post
90/sbin/install-info %{_infodir}/open-cobol.info.gz %{_infodir}/dir 2>/dev/null
91%{_syssbindir}/ldconfig
92
93%preun
94if [ $1 = 0 ]; then
95    /sbin/install-info --delete %{_infodir}/open-cobol.info.gz \
96                       %{_infodir}/dir 2>/dev/null
97fi
98
99%postun -p %{_syssbindir}/ldconfig
100
101
102%files
103%defattr(-,root,root)
104%doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
105%doc texi/open-cobol.pdf
106%doc texi/open-cobol.html/
107%{_bindir}/
108%{_includedir}/libcob.h
109%{_includedir}/libcob
110%{_libdir}/libcob.so*
111%{_datadir}/locale/
112%{_datadir}/%{name}-%{version}
113%{_infodir}/*.info.gz
114
115
116%changelog
117* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-1
118- update to 1.5.0J
119- delete BuildRequires: texlive-collection-lang*
120
121* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
122- rebuild under texlive 2016 pretest
123- add BuildRequires
124
125* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
126- new package
127
Note: See TracBrowser for help on using the repository browser.