source: projects/specs/trunk/o/opencv/opencv-vl.spec @ 12418

Revision 12418, 23.0 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

eigen3-3.3.7-1

opencv-4.3.0-1

tbb-2020.2-1

Line 
1%bcond_with test
2
3%bcond_without gstreamer
4#global indice   a
5
6Name:           opencv
7Version:        4.3.0
8Release:        1%{?_dist_release}
9Summary:        Collection of algorithms for computer vision
10Summary(ja):    コンピュータビジョン用のアルゴリズム集
11Group:          System Environment/Libraries
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15# This is normal three clause BSD.
16License:        BSD
17URL:            https://opencv.org
18
19# Need to remove SIFT/SURF from source tarball, due to legal concerns
20# rm -f opencv-%%{version}/modules/nonfree/src/sift.cpp
21# rm -f opencv-%%{version}/modules/nonfree/src/surf.cpp
22# Removed because we don't use pre-built contribs
23# rm -rf 3rdparty
24#Source0:        http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.zip
25Source0:        %{name}-clean-%{version}.tar.gz
26Source1:        %{name}_contrib-clean-%{version}.tar.gz
27Source2:        %{name}_extra-clean-%{version}.tar.gz
28Source3:        face_landmark_model.dat.xz
29# from https://github.com/opencv/ade/archive/v0.1.1f.zip
30Source4:        b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
31Source5:        xorg.conf
32
33Patch0:         opencv-4.1.0-install_3rdparty_licenses.patch
34Patch1:         https://patch-diff.githubusercontent.com/raw/opencv/opencv/pull/17431.patch
35Patch2:         https://patch-diff.githubusercontent.com/raw/opencv/opencv_contrib/pull/2549.patch
36# Comment out removed vulkan symbols
37Patch3:         opencv_vulkan.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40BuildRequires:  libtool
41BuildRequires:  cmake >= 2.6.3
42BuildRequires:  chrpath
43
44BuildRequires:  eigen3-devel
45BuildRequires:  libtheora-devel
46BuildRequires:  libvorbis-devel
47#BuildRequires:  libraw1394-devel
48#BuildRequires:  libdc1394-devel
49BuildRequires:  jasper-devel
50BuildRequires:  libpng-devel
51BuildRequires:  libjpeg-devel
52BuildRequires:  libtiff-devel
53BuildRequires:  libv4l-devel
54BuildRequires:  libwebp-devel
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  OpenEXR-devel
57#ifarch %{ix86} x86_64
58#BuildRequires:  openni-devel
59#BuildRequires:  openni-primesense
60#endif
61BuildRequires:  tbb-devel
62
63BuildRequires:  qt5-qtbase-devel
64BuildRequires:  freetype2-devel
65BuildRequires:  harfbuzz-devel
66
67BuildRequires:  zlib-devel pkgconfig
68BuildRequires:  python3-devel
69BuildRequires:  python3-setuptools
70BuildRequires:  python3-rpm-macros
71BuildRequires:  python3-numpy
72BuildRequires:  swig >= 1.3.24
73#BuildRequires:  python-sphinx
74#BuildRequires:  ffmpeg-devel >= 0.4.9
75
76BuildRequires:  gstreamer1-devel
77BuildRequires:  gstreamer1-plugins-base-devel
78#BuildRequires:  xine-lib-devel
79#BuildRequires:  opencl-headers
80
81Requires:       opencv-core = %{version}-%{release}
82
83
84%description
85OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
86C functions and a few C++ classes that implement some popular Image Processing
87and Computer Vision algorithms.
88
89
90%package        core
91Summary:        OpenCV core libraries
92Summary(ja):    OpenCV コアライブラリ
93Group:          System Environment/Libraries
94Obsoletes:      %{name}-python < %{version}-%{release}
95
96%description    core
97This package contains the OpenCV C/C++ core libraries.
98
99%package        devel
100Summary:        Development files for using the OpenCV library
101Summary(ja):    OpenCV ライブラリを使用するための開発用ファイル
102Group:          Development/Libraries
103Requires:       opencv = %{version}-%{release}
104
105%description    devel
106This package contains the OpenCV C/C++ library and header files, as well as
107documentation. It should be installed if you want to develop programs that
108will use the OpenCV library. You should consider installing opencv-devel-docs
109package.
110
111%package -n     python3-opencv
112Summary:        Python bindings for apps which use OpenCV
113Summary(ja):    OpenCV を使用するアプリケーション用の Python バインディング
114Group:          Development/Libraries
115Requires:       opencv = %{version}-%{release}
116Requires:       python3-numpy
117
118%description -n python3-opencv
119This package contains Python bindings for the OpenCV library.
120
121%package        contrib
122Summary:        OpenCV contributed functionality
123Summary(ja):    寄付された OpenCV の追加機能
124
125%description    contrib
126This package is intended for development of so-called "extra" modules, contribut
127ed
128functionality. New modules quite often do not have stable API, and they are not
129well-tested. Thus, they shouldn't be released as a part of official OpenCV
130distribution, since the library maintains binary compatibility, and tries
131to provide decent performance and stability.
132
133
134%prep
135%setup -q -a1 -a2
136# we don't use pre-built contribs except quirc
137pushd 3rdparty
138shopt -s extglob
139rm -r !(openexr|openvx|quirc)
140shopt -u extglob
141popd &>/dev/null
142
143%patch0 -p1 -b .install_3rdparty_licenses
144%patch1 -p1
145%patch3 -p1
146
147pushd %{name}_contrib-%{version}
148%patch2 -p1
149popd
150
151# Install ADE, needed for opencv_gapi
152mkdir -p .cache/ade
153install -pm 0644 %{SOURCE4} .cache/ade/
154
155
156%build
157# enabled by default if libraries are presents at build time:
158# GTK, GSTREAMER, 1394, V4L
159# non available on Fedora: FFMPEG, XINE
160mkdir -p build
161pushd build
162
163rm -rf  share/opencv4/testdata/cv/face
164mkdir -p share/opencv4/testdata/cv/face
165install -pm 0644 %{SOURCE3} share/opencv4/testdata/cv/face
166pushd share/opencv4/testdata/cv/face
167  xz -d face_landmark_model.dat.xz
168popd
169
170# disabling IPP because it is closed source library from intel
171
172%cmake CMAKE_VERBOSE=1 \
173        -DWITH_IPP=OFF \
174        -DWITH_ITT=OFF \
175        -DWITH_QT=ON \
176        -DWITH_OPENGL=ON \
177        -DOpenGL_GL_PREFERENCE=GLVND \
178        -DWITH_GDAL=ON \
179        -DWITH_OPENEXR=ON \
180        -DWITH_UNICAP=ON \
181        -DCMAKE_SKIP_RPATH=ON \
182        -DWITH_CAROTENE=OFF \
183%ifnarch x86_64 ia64
184        -DENABLE_SSE=0 \
185        -DENABLE_SSE2=0 \
186%else
187        -DCPU_BASELINE=SSE2 \
188%endif
189        -DENABLE_PRECOMPILED_HEADERS=OFF \
190        -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
191        -DBUILD_opencv_java=OFF \
192        %{?with_tbb: -DWITH_TBB=ON } \
193        %{!?with_gstreamer: -DWITH_GSTREAMER=OFF } \
194        -DWITH_FFMPEG=OFF \
195        %{?with_openni: -DWITH_OPENNI=ON } \
196        -DWITH_XINE=OFF \
197        -DBUILD_DOCS=OFF \
198        -DBUILD_EXAMPLES=OFF \
199        -DBUILD_opencv_python2=OFF \
200        -DINSTALL_C_EXAMPLES=OFF \
201        -DINSTALL_PYTHON_EXAMPLES=OFF \
202        -DPYTHON3_EXECUTABLE=%{__python3} \
203        -DPYTHON3_PACKAGES_PATH=%{python3_sitearch} \
204        -DENABLE_PYLINT=ON \
205        -DBUILD_PROTOBUF=OFF \
206        -DPROTOBUF_UPDATE_FILES=ON \
207        -DWITH_OPENCL=OFF \
208        -DOPENCV_SKIP_PYTHON_LOADER=ON \
209        -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
210        -DWITH_LIBV4L=ON \
211        -DWITH_OPENMP=ON \
212        -DOPENCV_CONFIG_INSTALL_PATH=%{_lib}/cmake/OpenCV \
213        -DOPENCV_GENERATE_PKGCONFIG=ON \
214        -DOPENCV_TEST_DATA_PATH=opencv_extra-%{version}/testdata \
215        %{?with_gdcm: -DWITH_GDCM=ON } \
216        %{?with_libmfx: -DWITH_MFX=ON } \
217        %{?with_clp: -DWITH_CLP=ON } \
218        %{?with_va: -DWITH_VA=ON } \
219        -DWITH_VTK=OFF \
220        -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
221        ..
222 
223make VERBOSE=1 %{?_smp_mflags}
224
225popd
226
227
228%install
229rm -rf %{buildroot}
230%make_install -C build
231find %{buildroot} -name '*.la' -delete
232rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
233
234
235%if %{with test}
236%check
237# Check fails since we don't support most video
238# read/write capability and we don't provide a display
239# ARGS=-V increases output verbosity
240pushd build
241    cp %SOURCE5 .
242    if [ -x /usr/libexec/Xorg ]; then
243       Xorg=/usr/libexec/Xorg
244    else
245       Xorg=/usr/libexec/Xorg.bin
246    fi
247    $Xorg -noreset +extension GLX +extension RANDR +extension RENDER -logfile ./xorg.log -config ./xorg.conf -configdir . :99 &
248    export DISPLAY=:99
249    LD_LIBRARY_PATH=%{_builddir}/%{name}-%{version}/build/lib:$LD_LIBARY_PATH make test ARGS=-V || :
250popd
251%endif
252
253
254%clean
255rm -rf %{buildroot}
256
257
258%post core -p /sbin/ldconfig
259%postun core -p /sbin/ldconfig
260
261%post -p /sbin/ldconfig
262%postun -p /sbin/ldconfig
263
264%post contrib -p /sbin/ldconfig
265%postun contrib -p /sbin/ldconfig
266
267
268%files
269%doc README.md
270%{_bindir}/opencv_*
271%dir %{_datadir}/opencv4
272%{_datadir}/opencv4/haarcascades
273%{_datadir}/opencv4/lbpcascades
274%{_datadir}/opencv4/valgrind*
275%{_datadir}/opencv4/quality
276
277%files core
278%license LICENSE
279%{_datadir}/licenses/opencv4/
280%{_libdir}/libopencv_alphamat.so.*
281%{_libdir}/libopencv_core.so.*
282%{_libdir}/libopencv_cvv.so.*
283%{_libdir}/libopencv_features2d.so.*
284%{_libdir}/libopencv_flann.so.*
285%{_libdir}/libopencv_gapi.so.*
286%{_libdir}/libopencv_hfs.so.*
287%{_libdir}/libopencv_highgui.so.*
288%{_libdir}/libopencv_imgcodecs.so.*
289%{_libdir}/libopencv_imgproc.so.*
290%{_libdir}/libopencv_intensity_transform.so.*
291%{_libdir}/libopencv_ml.so.*
292%{_libdir}/libopencv_objdetect.so.*
293%{_libdir}/libopencv_photo.so.*
294%{_libdir}/libopencv_rapid.so.*
295%{_libdir}/libopencv_shape.so.*
296%{_libdir}/libopencv_stitching.so.*
297%{_libdir}/libopencv_superres.so.*
298%{_libdir}/libopencv_video.so.*
299%{_libdir}/libopencv_videoio.so.*
300%{_libdir}/libopencv_videostab.so.*
301
302%files devel
303%dir %{_includedir}/opencv4
304%{_includedir}/opencv4/opencv2
305%{_libdir}/lib*.so
306%{_libdir}/pkgconfig/opencv*.pc
307%{_libdir}/cmake/OpenCV/*.cmake
308
309%files -n python3-opencv
310%exclude %{_bindir}/setup_vars_opencv4.sh
311%{python3_sitearch}/cv2.cpython-3*.so
312
313
314%files contrib
315%{_libdir}/libopencv_aruco.so.*
316%{_libdir}/libopencv_bgsegm.so.*
317%{_libdir}/libopencv_bioinspired.so.*
318%{_libdir}/libopencv_calib3d.so.*
319%{_libdir}/libopencv_ccalib.so.*
320%{_libdir}/libopencv_datasets.so.*
321# needs protobuf
322#{_libdir}/libopencv_dnn.so.*
323#{_libdir}/libopencv_dnn_objdetect.so.*
324#{_libdir}/libopencv_dnn_superres.so.*
325%{_libdir}/libopencv_dpm.so.*
326%{_libdir}/libopencv_face.so.*
327%{_libdir}/libopencv_freetype.so.*
328%{_libdir}/libopencv_fuzzy.so.*
329# needs hdf5
330#{_libdir}/libopencv_hdf.so.*
331%{_libdir}/libopencv_img_hash.so.*
332%{_libdir}/libopencv_line_descriptor.so.*
333%{_libdir}/libopencv_optflow.so.*
334%{_libdir}/libopencv_phase_unwrapping.so.*
335%{_libdir}/libopencv_plot.so.*
336%{_libdir}/libopencv_reg.so.*
337%{_libdir}/libopencv_rgbd.so.*
338%{_libdir}/libopencv_quality.so.*
339%{_libdir}/libopencv_saliency.so.*
340%{_libdir}/libopencv_stereo.so.*
341%{_libdir}/libopencv_structured_light.so.*
342%{_libdir}/libopencv_surface_matching.so.*
343# needs tesseract
344#{_libdir}/libopencv_text.so.*
345%{_libdir}/libopencv_tracking.so.*
346%{_libdir}/libopencv_ximgproc.so.*
347%{_libdir}/libopencv_xobjdetect.so.*
348%{_libdir}/libopencv_xphoto.so.*
349
350
351%changelog
352* Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
353- new upstream release.
354
355* Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
356- use eigen2 on Vine Linux 6.x
357- disable tbb/v4l on Vine Linux 6.x
358
359* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
360- rebuild with gcc-5.4.0
361
362* Wed Mar  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
363- built with tbb
364- moved main package to System Environment/Libraries Group
365
366* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
367- Initial build for Vine Linux
368
369* Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
370- rebuild (openexr)
371
372* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
373- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
374
375* Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
376- backport support for GStreamer 1 (#1123078)
377
378* Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
379- Update to 2.4.9
380
381* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
382- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
383
384* Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
385- revert pkgcmake2 patch (#1070428)
386
387* Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
388- Fix opencv_ocl isn't part of -core
389
390* Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
391- Enable OpenCL support.
392- SPEC small cleanup.
393
394* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
395- rebuild (openexr)
396
397* Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
398- OpenCV cmake configuration broken (#1031312)
399
400* Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
401- Update to 2.4.7
402
403* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
404- rebuild (openexr)
405
406* Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
407- Update to 2.4.6.1
408
409* Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
410- Update to 2.4.5-clean
411- Spec file clean-up
412- Split core libraries into a sub-package
413
414* Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
415- change project URL.
416
417* Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
418- make clean source without SIFT/SURF
419
420* Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
421- Update to 2.4.4a
422- Fix ttb-devel architecture conditionals
423
424* Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
425- rebuild (OpenEXR)
426
427* Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
428- Update to 2.4.4 beta
429- Drop python-imaging also from requires
430- Drop merged patch for additionals codecs
431- Disable the java binding for now (untested)
432
433* Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
434- Do not build with 1394 libs in rhel
435
436* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
437- rebuild due to "jpeg8-ABI" feature drop
438
439* Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
440- Add more FourCC for gstreamer - rhbz#812628
441- Allow to use python-pillow - rhbz#895767
442
443* Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
444- Switch Build Type to ReleaseWithDebInfo to avoid -03
445
446* Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
447- Disable SSE3 and allow --with sse3 build conditional.
448- Disable gpu module as we don't build cuda
449- Update to 2.4.3
450
451* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
452- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
453
454* Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
455- Update to 2.4.2
456
457* Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
458- Fixed cmake script for generating opencv.pc file
459- Fixed OpenCVConfig script file
460
461* Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
462- Update to 2.4.1
463- Rework dependencies - rhbz#828087
464  Re-enable using --with tbb,opennpi,eigen2,eigen3
465
466* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
467- Rebuilt for c++ ABI breakage
468
469* Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
470- Update gcc46 patch for ARM FTBFS
471
472* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
473- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
474
475* Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
476- Rebuild for new libpng
477
478* Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
479- Rebuilt for tbb silent ABI change
480
481* Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
482- Update to 2.3.1a
483
484* Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
485- openni is exclusive for x86/x86_64
486
487* Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
488- Update to 2.3.1
489- Add BR openni-devel python-sphinx
490- Remove deprecated cmake options
491- Add --with cuda conditional (wip)
492- Disable make test (unavailable)
493
494* Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
495- Backport fixes from branch 2.2 to date
496
497* Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
498- Re-enable v4l on f15
499- Remove unused cmake options
500
501* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
502- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
503
504* Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
505- Fix with gcc46
506- Disable V4L as V4L1 is disabled for Fedora 15
507
508* Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
509- Update to 2.2.0
510- Disable -msse and -msse2 on x86_32
511
512* Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
513- -devel: include OpenCVConfig.cmake (#627359)
514
515* Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
516- TBB is available only on x86/x86_64 and ia64
517
518* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
519- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
520
521* Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
522- Move samples from main to -devel
523- Fix spurious permission
524- Add BR tbb-devel
525- Fix CFLAGS
526
527* Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
528- Update to 2.1.0
529- Update libdir patch
530
531* Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
532- Fix nonstandard executable permissions
533
534* Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
535- apply the previously added patch
536
537* Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
538- re-enable testing on CMake build system
539- fix memory corruption in the gaussian random number generator
540
541* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
542- replaced BR unicap-devel by libucil-devel (unicap split)
543
544* Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
545- use cmake build system
546- applications renamed to opencv_xxx instead of opencv-xxx
547- add devel-docs subpackage #546605
548- add OpenCVConfig.cmake
549- enable openmp build
550- enable old SWIG based python wrappers
551- opencv package is a good boy and use global instead of define
552
553* Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
554- Set CXXFLAXS without -match=i386 for i386 architecture #565074
555
556* Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
557- Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
558
559* Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
560- Fixed spec file issues detected by rpmlint
561
562* Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
563- Fix autotools scripts (missing LBP features) - #544167
564
565* Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
566- Updated to 2.0.0
567- Removed upstream-ed patches
568- Ugly hack (added cvconfig.h)
569- Disable %%check on ppc64
570
571* Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
572- fix build on s390x where we don't have libraw1394 and devel
573
574* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
575- Fix typo I introduced that prevented build on i386/i586
576
577* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
578- Added 1394 libs and unicap support
579
580* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
581- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
582
583* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
584- Build with gstreamer support - #491223
585- Backport gcc43 fix from trunk
586
587* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
588- Fix FTBFS #511705
589
590* Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
591- Update to 1.1pre1
592- Disable CXXFLAGS hardcoded optimization
593- Add BR: python-imaging, numpy
594- Disable make check failure for now
595
596* Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
597- Fix for gcc44
598- Enable BR jasper-devel
599- Disable ldconfig run on python modules (uneeded)
600- Prevent timestamp change on install
601
602* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
603- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
604
605* Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
606- fix URL field
607
608* Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
609- Adopt latest python spec rules.
610- Rebuild for Python 2.6 once again.
611
612* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
613- Rebuild for Python 2.6
614
615* Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
616- fix license tag
617
618* Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
619- Adjust library order in opencv.pc.in (BZ 445937).
620
621* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
622- Autorebuild for GCC 4.3
623
624* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
625- Rebuild for gcc43.
626
627* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
628- Rebuild for selinux ppc32 issue.
629
630* Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
631- Mass rebuild.
632
633* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
634- Fix %%{_datadir}/opencv/samples ownership.
635- Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
636
637* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
638- Move all of the python module to pyexecdir (BZ 233128).
639- Activate the testsuite.
640
641* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
642- Upstream update.
643
644* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
645- Remove python-abi.
646
647* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
648- rebuilt for unwind info generation, broken in gcc-4.1.1-21
649
650* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
651- Stop configure.in from hacking CXXFLAGS.
652- Activate testsuite.
653- Let *-devel require pkgconfig.
654
655* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
656- Upstream update.
657- Don't BR: autotools.
658- Install samples' Makefile as GNUmakefile.
659
660* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
661- Un'%%ghost *.pyo.
662- Separate %%{pythondir} from %%{pyexecdir}.
663
664* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
665- Rebuild for FC6.
666- BR: libtool.
667
668* Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
669- Rebuild.
670
671* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
672- Force a re-run of Autotools by calling autoreconf.
673
674* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
675- Added build dependency on Autotools.
676
677* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
678- Changed intrinsics patch so that it matches upstream.
679
680* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
681- More intrinsics patch fixing.
682
683* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
684- Don't do "make check" because it doesn't run any tests anyway.
685- Back to main intrinsics patch.
686
687* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
688- Using simple intrinsincs patch.
689
690* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
691- Still more fixing of intrinsics patch for Python bindings on x86_64.
692
693* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
694- Again fixed intrinsics patch so that Python modules build on x86_64.
695
696* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
697- Fixed intrinsics patch so that it works.
698
699* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
700- Fixed Python bindings location on x86_64.
701
702* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
703- SSE2 support on x86_64.
704
705* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
706- Rebuild
707
708* Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
709- Removed useless sample compilation makefiles/project files and replaced them
710  with one that works on Fedora Core.
711- Removed shellbang from Python modules.
712
713* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
714- Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
715
716* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
717- Initial package.
Note: See TracBrowser for help on using the repository browser.