source: projects/specs/trunk/o/opencv/opencv-vl.spec @ 12510

Revision 12510, 23.0 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

Field3D-1.7.3-2

ImageMagick?-6.9.11.48-1

OpenEXR-2.5.3-1

OpenImageIO-2.2.9.0-1

babl-0.1.82-1

fmt-7.1.3-2

gegl04-0.4.26-2

gimp-2.10.22-1

hdf5-1.12.0-1

opencv-4.5.0-1

robin-map-0.6.3-4

Line 
1%bcond_with test
2
3%bcond_without gstreamer
4#global indice   a
5
6Name:           opencv
7Version:        4.5.0
8Release:        1%{?_dist_release}
9Summary:        Collection of algorithms for computer vision
10Summary(ja):    コンピュータビジョン用のアルゴリズム集
11Group:          graphics
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15# This is normal three clause BSD.
16License:        BSD
17URL:            https://opencv.org
18
19# RUN opencv-clean.sh TO PREPARE TARBALLS
20#
21# Need to remove copyrighted lena.jpg images from tarball (rhbz#1295173)
22# and SIFT/SURF from tarball, due to legal concerns.
23#
24#Source0:        https://github.com/opencv/opencv/archive/%{version}.tar.gz
25Source0:        %{name}-clean-%{version}.tar.gz
26Source1:        %{name}_contrib-clean-%{version}.tar.gz
27Source2:        %{name}_extra-clean-%{version}.tar.gz
28Source3:        face_landmark_model.dat.xz
29# from https://github.com/opencv/ade/archive/v0.1.1f.zip
30Source4:        b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
31Source5:        xorg.conf
32Source100:      opencv-clean.sh
33
34Patch0:         opencv-4.1.0-install_3rdparty_licenses.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37BuildRequires:  libtool
38BuildRequires:  cmake >= 2.6.3
39BuildRequires:  chrpath
40
41BuildRequires:  eigen3-devel
42BuildRequires:  libtheora-devel
43BuildRequires:  libvorbis-devel
44#BuildRequires:  libraw1394-devel
45#BuildRequires:  libdc1394-devel
46BuildRequires:  jasper-devel
47BuildRequires:  libpng-devel
48BuildRequires:  libjpeg-devel
49BuildRequires:  libtiff-devel
50BuildRequires:  libv4l-devel
51BuildRequires:  libwebp-devel
52BuildRequires:  mesa-libGL-devel
53BuildRequires:  OpenEXR-devel
54BuildRequires:  openjpeg2-devel
55#ifarch %{ix86} x86_64
56#BuildRequires:  openni-devel
57#BuildRequires:  openni-primesense
58#endif
59BuildRequires:  tbb-devel
60
61BuildRequires:  qt5-qtbase-devel
62BuildRequires:  freetype2-devel
63BuildRequires:  harfbuzz-devel
64
65BuildRequires:  zlib-devel pkgconfig
66BuildRequires:  python3-devel
67BuildRequires:  python3-setuptools
68BuildRequires:  python3-rpm-macros
69BuildRequires:  python3-numpy
70BuildRequires:  swig >= 1.3.24
71#BuildRequires:  python-sphinx
72#BuildRequires:  ffmpeg-devel >= 0.4.9
73
74BuildRequires:  gstreamer1-devel
75BuildRequires:  gstreamer1-plugins-base-devel
76#BuildRequires:  xine-lib-devel
77#BuildRequires:  opencl-headers
78BuildRequires:  vulkan-headers
79BuildRequires:  mesa-dri-drivers
80BuildRequires:  xorg-x11-drv-dummy
81
82Requires:       opencv-core = %{version}-%{release}
83
84%description
85OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
86C functions and a few C++ classes that implement some popular Image Processing
87and Computer Vision algorithms.
88
89
90%package        core
91Summary:        OpenCV core libraries
92Summary(ja):    OpenCV コアライブラリ
93Group:          graphics
94Obsoletes:      %{name}-python < %{version}-%{release}
95
96%description    core
97This package contains the OpenCV C/C++ core libraries.
98
99
100%package        devel
101Summary:        Development files for using the OpenCV library
102Summary(ja):    OpenCV ライブラリを使用するための開発用ファイル
103Group:          programming
104Requires:       opencv = %{version}-%{release}
105
106%description    devel
107This package contains the OpenCV C/C++ library and header files, as well as
108documentation. It should be installed if you want to develop programs that
109will use the OpenCV library. You should consider installing opencv-devel-docs
110package.
111
112
113%package -n     python3-opencv
114Summary:        Python bindings for apps which use OpenCV
115Summary(ja):    OpenCV を使用するアプリケーション用の Python バインディング
116Group:          programming
117Requires:       opencv = %{version}-%{release}
118Requires:       python3-numpy
119
120%description -n python3-opencv
121This package contains Python bindings for the OpenCV library.
122
123
124%package        contrib
125Summary:        OpenCV contributed functionality
126Summary(ja):    寄付された OpenCV の追加機能
127Group:          graphics
128
129%description    contrib
130This package is intended for development of so-called "extra" modules, contribut
131ed
132functionality. New modules quite often do not have stable API, and they are not
133well-tested. Thus, they shouldn't be released as a part of official OpenCV
134distribution, since the library maintains binary compatibility, and tries
135to provide decent performance and stability.
136
137
138%debug_package
139
140
141%prep
142%setup -q -a1 -a2
143# we don't use pre-built contribs except quirc
144pushd 3rdparty
145shopt -s extglob
146rm -r !(openexr|openvx|quirc)
147shopt -u extglob
148popd &>/dev/null
149
150%patch0 -p1 -b .install_3rdparty_licenses
151
152# Install ADE, needed for opencv_gapi
153mkdir -p .cache/ade
154install -pm 0644 %{SOURCE4} .cache/ade/
155
156
157%build
158# enabled by default if libraries are presents at build time:
159# GTK, GSTREAMER, 1394, V4L
160# non available on Fedora: FFMPEG, XINE
161mkdir -p build
162pushd build
163
164rm -rf  share/opencv4/testdata/cv/face
165mkdir -p share/opencv4/testdata/cv/face
166install -pm 0644 %{SOURCE3} share/opencv4/testdata/cv/face
167pushd share/opencv4/testdata/cv/face
168  xz -d face_landmark_model.dat.xz
169popd
170
171# disabling IPP because it is closed source library from intel
172
173%cmake CMAKE_VERBOSE=1 \
174        -DWITH_IPP=OFF \
175        -DWITH_ITT=OFF \
176        -DWITH_QT=ON \
177        -DWITH_OPENGL=ON \
178        -DOpenGL_GL_PREFERENCE=GLVND \
179        -DWITH_GDAL=ON \
180        -DWITH_OPENEXR=ON \
181        -DWITH_UNICAP=ON \
182        -DCMAKE_SKIP_RPATH=ON \
183        -DWITH_CAROTENE=OFF \
184%ifnarch x86_64 ia64
185        -DENABLE_SSE=0 \
186        -DENABLE_SSE2=0 \
187%else
188        -DCPU_BASELINE=SSE2 \
189%endif
190        -DENABLE_PRECOMPILED_HEADERS=OFF \
191        -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
192        -DBUILD_opencv_java=OFF \
193        %{?with_tbb: -DWITH_TBB=ON } \
194        %{!?with_gstreamer: -DWITH_GSTREAMER=OFF } \
195        -DWITH_FFMPEG=OFF \
196        %{?with_openni: -DWITH_OPENNI=ON } \
197        -DWITH_XINE=OFF \
198        -DBUILD_DOCS=OFF \
199        -DBUILD_EXAMPLES=OFF \
200        -DBUILD_opencv_python2=OFF \
201        -DINSTALL_C_EXAMPLES=OFF \
202        -DINSTALL_PYTHON_EXAMPLES=OFF \
203        -DPYTHON3_EXECUTABLE=%{__python3} \
204        -DPYTHON3_PACKAGES_PATH=%{python3_sitearch} \
205        -DENABLE_PYLINT=ON \
206        -DBUILD_PROTOBUF=OFF \
207        -DPROTOBUF_UPDATE_FILES=ON \
208        -DWITH_OPENCL=OFF \
209        -DOPENCV_SKIP_PYTHON_LOADER=ON \
210        -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
211        -DWITH_LIBV4L=ON \
212        -DWITH_OPENMP=ON \
213        -DOPENCV_CONFIG_INSTALL_PATH=%{_lib}/cmake/OpenCV \
214        -DOPENCV_GENERATE_PKGCONFIG=ON \
215        -DOPENCV_TEST_DATA_PATH=opencv_extra-%{version}/testdata \
216        %{?with_gdcm: -DWITH_GDCM=ON } \
217        %{?with_libmfx: -DWITH_MFX=ON } \
218        %{?with_clp: -DWITH_CLP=ON } \
219        %{?with_va: -DWITH_VA=ON } \
220        -DWITH_VTK=OFF \
221        -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
222        -DWITH_VULKAN=ON -DVULKAN_INCLUDE_DIRS=%{_includedir}/vulkan \
223        ..
224 
225make VERBOSE=1 %{?_smp_mflags}
226
227popd
228
229
230%install
231rm -rf %{buildroot}
232%make_install -C build
233find %{buildroot} -name '*.la' -delete
234rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
235
236
237%if %{with test}
238%check
239# Check fails since we don't support most video
240# read/write capability and we don't provide a display
241# ARGS=-V increases output verbosity
242pushd build
243    cp %SOURCE5 .
244    if [ -x /usr/libexec/Xorg ]; then
245       Xorg=/usr/libexec/Xorg
246    else
247       Xorg=/usr/libexec/Xorg.bin
248    fi
249    $Xorg -noreset +extension GLX +extension RANDR +extension RENDER -logfile ./xorg.log -config ./xorg.conf -configdir . :99 &
250    export DISPLAY=:99
251    LD_LIBRARY_PATH=%{_builddir}/%{name}-%{version}/build/lib:$LD_LIBARY_PATH make test ARGS=-V || :
252popd
253%endif
254
255
256%clean
257rm -rf %{buildroot}
258
259
260%post core -p /sbin/ldconfig
261%postun core -p /sbin/ldconfig
262
263%post -p /sbin/ldconfig
264%postun -p /sbin/ldconfig
265
266%post contrib -p /sbin/ldconfig
267%postun contrib -p /sbin/ldconfig
268
269
270%files
271%doc README.md
272%{_bindir}/opencv_*
273%dir %{_datadir}/opencv4
274%{_datadir}/opencv4/haarcascades
275%{_datadir}/opencv4/lbpcascades
276%{_datadir}/opencv4/valgrind*
277%{_datadir}/opencv4/quality
278
279%files core
280%license LICENSE
281%{_datadir}/licenses/opencv4/
282%{_libdir}/libopencv_alphamat.so.*
283%{_libdir}/libopencv_core.so.*
284%{_libdir}/libopencv_cvv.so.*
285%{_libdir}/libopencv_features2d.so.*
286%{_libdir}/libopencv_flann.so.*
287%{_libdir}/libopencv_gapi.so.*
288%{_libdir}/libopencv_hfs.so.*
289%{_libdir}/libopencv_highgui.so.*
290%{_libdir}/libopencv_imgcodecs.so.*
291%{_libdir}/libopencv_imgproc.so.*
292%{_libdir}/libopencv_intensity_transform.so.*
293%{_libdir}/libopencv_ml.so.*
294%{_libdir}/libopencv_objdetect.so.*
295%{_libdir}/libopencv_photo.so.*
296%{_libdir}/libopencv_rapid.so.*
297%{_libdir}/libopencv_shape.so.*
298%{_libdir}/libopencv_stitching.so.*
299%{_libdir}/libopencv_superres.so.*
300%{_libdir}/libopencv_video.so.*
301%{_libdir}/libopencv_videoio.so.*
302%{_libdir}/libopencv_videostab.so.*
303
304%files devel
305%dir %{_includedir}/opencv4
306%{_includedir}/opencv4/opencv2
307%{_libdir}/lib*.so
308%{_libdir}/pkgconfig/opencv*.pc
309%{_libdir}/cmake/OpenCV/*.cmake
310
311%files -n python3-opencv
312%exclude %{_bindir}/setup_vars_opencv4.sh
313%{python3_sitearch}/cv2.cpython-3*.so
314
315
316%files contrib
317%{_libdir}/libopencv_aruco.so.*
318%{_libdir}/libopencv_bgsegm.so.*
319%{_libdir}/libopencv_bioinspired.so.*
320%{_libdir}/libopencv_calib3d.so.*
321%{_libdir}/libopencv_ccalib.so.*
322%{_libdir}/libopencv_datasets.so.*
323# needs protobuf
324#{_libdir}/libopencv_dnn.so.*
325#{_libdir}/libopencv_dnn_objdetect.so.*
326#{_libdir}/libopencv_dnn_superres.so.*
327%{_libdir}/libopencv_dpm.so.*
328%{_libdir}/libopencv_face.so.*
329%{_libdir}/libopencv_freetype.so.*
330%{_libdir}/libopencv_fuzzy.so.*
331# needs hdf5
332#{_libdir}/libopencv_hdf.so.*
333%{_libdir}/libopencv_img_hash.so.*
334%{_libdir}/libopencv_line_descriptor.so.*
335%{_libdir}/libopencv_optflow.so.*
336%{_libdir}/libopencv_phase_unwrapping.so.*
337%{_libdir}/libopencv_plot.so.*
338%{_libdir}/libopencv_reg.so.*
339%{_libdir}/libopencv_rgbd.so.*
340%{_libdir}/libopencv_quality.so.*
341%{_libdir}/libopencv_saliency.so.*
342%{_libdir}/libopencv_stereo.so.*
343%{_libdir}/libopencv_structured_light.so.*
344%{_libdir}/libopencv_surface_matching.so.*
345# needs tesseract
346#{_libdir}/libopencv_text.so.*
347%{_libdir}/libopencv_tracking.so.*
348%{_libdir}/libopencv_ximgproc.so.*
349%{_libdir}/libopencv_xobjdetect.so.*
350%{_libdir}/libopencv_xphoto.so.*
351
352
353%changelog
354* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.5.0-1
355- new upstream release.
356
357* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4.0-1
358- new upstream release.
359- enabled vulkan compute backend
360
361* Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
362- new upstream release.
363
364* Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
365- use eigen2 on Vine Linux 6.x
366- disable tbb/v4l on Vine Linux 6.x
367
368* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
369- rebuild with gcc-5.4.0
370
371* Wed Mar  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
372- built with tbb
373- moved main package to System Environment/Libraries Group
374
375* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
376- Initial build for Vine Linux
377
378* Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
379- rebuild (openexr)
380
381* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
382- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
383
384* Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
385- backport support for GStreamer 1 (#1123078)
386
387* Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
388- Update to 2.4.9
389
390* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
391- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
392
393* Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
394- revert pkgcmake2 patch (#1070428)
395
396* Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
397- Fix opencv_ocl isn't part of -core
398
399* Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
400- Enable OpenCL support.
401- SPEC small cleanup.
402
403* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
404- rebuild (openexr)
405
406* Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
407- OpenCV cmake configuration broken (#1031312)
408
409* Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
410- Update to 2.4.7
411
412* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
413- rebuild (openexr)
414
415* Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
416- Update to 2.4.6.1
417
418* Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
419- Update to 2.4.5-clean
420- Spec file clean-up
421- Split core libraries into a sub-package
422
423* Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
424- change project URL.
425
426* Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
427- make clean source without SIFT/SURF
428
429* Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
430- Update to 2.4.4a
431- Fix ttb-devel architecture conditionals
432
433* Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
434- rebuild (OpenEXR)
435
436* Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
437- Update to 2.4.4 beta
438- Drop python-imaging also from requires
439- Drop merged patch for additionals codecs
440- Disable the java binding for now (untested)
441
442* Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
443- Do not build with 1394 libs in rhel
444
445* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
446- rebuild due to "jpeg8-ABI" feature drop
447
448* Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
449- Add more FourCC for gstreamer - rhbz#812628
450- Allow to use python-pillow - rhbz#895767
451
452* Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
453- Switch Build Type to ReleaseWithDebInfo to avoid -03
454
455* Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
456- Disable SSE3 and allow --with sse3 build conditional.
457- Disable gpu module as we don't build cuda
458- Update to 2.4.3
459
460* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
461- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
462
463* Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
464- Update to 2.4.2
465
466* Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
467- Fixed cmake script for generating opencv.pc file
468- Fixed OpenCVConfig script file
469
470* Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
471- Update to 2.4.1
472- Rework dependencies - rhbz#828087
473  Re-enable using --with tbb,opennpi,eigen2,eigen3
474
475* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
476- Rebuilt for c++ ABI breakage
477
478* Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
479- Update gcc46 patch for ARM FTBFS
480
481* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
482- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
483
484* Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
485- Rebuild for new libpng
486
487* Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
488- Rebuilt for tbb silent ABI change
489
490* Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
491- Update to 2.3.1a
492
493* Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
494- openni is exclusive for x86/x86_64
495
496* Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
497- Update to 2.3.1
498- Add BR openni-devel python-sphinx
499- Remove deprecated cmake options
500- Add --with cuda conditional (wip)
501- Disable make test (unavailable)
502
503* Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
504- Backport fixes from branch 2.2 to date
505
506* Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
507- Re-enable v4l on f15
508- Remove unused cmake options
509
510* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
511- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
512
513* Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
514- Fix with gcc46
515- Disable V4L as V4L1 is disabled for Fedora 15
516
517* Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
518- Update to 2.2.0
519- Disable -msse and -msse2 on x86_32
520
521* Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
522- -devel: include OpenCVConfig.cmake (#627359)
523
524* Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
525- TBB is available only on x86/x86_64 and ia64
526
527* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
528- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
529
530* Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
531- Move samples from main to -devel
532- Fix spurious permission
533- Add BR tbb-devel
534- Fix CFLAGS
535
536* Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
537- Update to 2.1.0
538- Update libdir patch
539
540* Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
541- Fix nonstandard executable permissions
542
543* Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
544- apply the previously added patch
545
546* Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
547- re-enable testing on CMake build system
548- fix memory corruption in the gaussian random number generator
549
550* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
551- replaced BR unicap-devel by libucil-devel (unicap split)
552
553* Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
554- use cmake build system
555- applications renamed to opencv_xxx instead of opencv-xxx
556- add devel-docs subpackage #546605
557- add OpenCVConfig.cmake
558- enable openmp build
559- enable old SWIG based python wrappers
560- opencv package is a good boy and use global instead of define
561
562* Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
563- Set CXXFLAXS without -match=i386 for i386 architecture #565074
564
565* Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
566- Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
567
568* Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
569- Fixed spec file issues detected by rpmlint
570
571* Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
572- Fix autotools scripts (missing LBP features) - #544167
573
574* Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
575- Updated to 2.0.0
576- Removed upstream-ed patches
577- Ugly hack (added cvconfig.h)
578- Disable %%check on ppc64
579
580* Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
581- fix build on s390x where we don't have libraw1394 and devel
582
583* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
584- Fix typo I introduced that prevented build on i386/i586
585
586* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
587- Added 1394 libs and unicap support
588
589* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
590- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
591
592* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
593- Build with gstreamer support - #491223
594- Backport gcc43 fix from trunk
595
596* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
597- Fix FTBFS #511705
598
599* Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
600- Update to 1.1pre1
601- Disable CXXFLAGS hardcoded optimization
602- Add BR: python-imaging, numpy
603- Disable make check failure for now
604
605* Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
606- Fix for gcc44
607- Enable BR jasper-devel
608- Disable ldconfig run on python modules (uneeded)
609- Prevent timestamp change on install
610
611* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
612- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
613
614* Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
615- fix URL field
616
617* Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
618- Adopt latest python spec rules.
619- Rebuild for Python 2.6 once again.
620
621* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
622- Rebuild for Python 2.6
623
624* Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
625- fix license tag
626
627* Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
628- Adjust library order in opencv.pc.in (BZ 445937).
629
630* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
631- Autorebuild for GCC 4.3
632
633* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
634- Rebuild for gcc43.
635
636* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
637- Rebuild for selinux ppc32 issue.
638
639* Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
640- Mass rebuild.
641
642* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
643- Fix %%{_datadir}/opencv/samples ownership.
644- Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
645
646* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
647- Move all of the python module to pyexecdir (BZ 233128).
648- Activate the testsuite.
649
650* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
651- Upstream update.
652
653* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
654- Remove python-abi.
655
656* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
657- rebuilt for unwind info generation, broken in gcc-4.1.1-21
658
659* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
660- Stop configure.in from hacking CXXFLAGS.
661- Activate testsuite.
662- Let *-devel require pkgconfig.
663
664* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
665- Upstream update.
666- Don't BR: autotools.
667- Install samples' Makefile as GNUmakefile.
668
669* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
670- Un'%%ghost *.pyo.
671- Separate %%{pythondir} from %%{pyexecdir}.
672
673* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
674- Rebuild for FC6.
675- BR: libtool.
676
677* Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
678- Rebuild.
679
680* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
681- Force a re-run of Autotools by calling autoreconf.
682
683* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
684- Added build dependency on Autotools.
685
686* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
687- Changed intrinsics patch so that it matches upstream.
688
689* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
690- More intrinsics patch fixing.
691
692* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
693- Don't do "make check" because it doesn't run any tests anyway.
694- Back to main intrinsics patch.
695
696* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
697- Using simple intrinsincs patch.
698
699* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
700- Still more fixing of intrinsics patch for Python bindings on x86_64.
701
702* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
703- Again fixed intrinsics patch so that Python modules build on x86_64.
704
705* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
706- Fixed intrinsics patch so that it works.
707
708* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
709- Fixed Python bindings location on x86_64.
710
711* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
712- SSE2 support on x86_64.
713
714* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
715- Rebuild
716
717* Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
718- Removed useless sample compilation makefiles/project files and replaced them
719  with one that works on Fedora Core.
720- Removed shellbang from Python modules.
721
722* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
723- Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
724
725* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
726- Initial package.
Note: See TracBrowser for help on using the repository browser.