source: projects/specs/trunk/o/opencv/opencv-vl.spec @ 9410

Revision 9410, 20.2 KB checked in by inagaki, 9 years ago (diff)

2015-03-05 Ryoichi INAGAKI <ryo1@…>

  • opencv, suitesparse: rebuilt with tbb
  • pcre: updated with security fix
  • tbb: new


Line 
1#global indice   a
2
3Name:           opencv
4Version:        2.4.9
5Release:        6%{?_dist_release}
6Summary:        Collection of algorithms for computer vision
7Summary(ja):    コンピュータビジョン用のアルゴリズム集
8
9Group:          System Environment/Libraries
10# This is normal three clause BSD.
11License:        BSD
12URL:            http://opencv.org
13
14# Need to remove SIFT/SURF from source tarball, due to legal concerns
15# rm -f opencv-%%{version}/modules/nonfree/src/sift.cpp
16# rm -f opencv-%%{version}/modules/nonfree/src/surf.cpp
17# Removed because we don't use pre-built contribs
18# rm -rf 3rdparty
19#Source0:        http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.zip
20Source0:        %{name}-clean-%{version}%{?indice}.tar.xz
21Source1:        opencv-samples-Makefile
22Patch0:         opencv-pkgcmake.patch
23#http://code.opencv.org/issues/2720
24Patch2:         OpenCV-2.4.4-pillow.patch
25Patch3:         opencv-2.4.9-ts_static.patch
26# fix/simplify cmake config install location (upstreamable)
27# https://bugzilla.redhat.com/1031312
28Patch4:         opencv-2.4.7-cmake_paths.patch
29
30# relevant gst1-related patches from upstream master branch
31# 0550 needed slight rebasing -- rex
32Patch10: 0550-bomb-commit-of-gstreamer-videocapture-and-videowrite.patch
33Patch11: 0552-eliminated-warnings.patch
34Patch12: 0587-Fix-build-with-gstreamer-0.10.28.patch
35Patch13: 0865-gstreamer-cleaning-up-resources.patch
36Patch14: 0871-allow-for-arbitraty-number-of-sources-and-sinks.patch
37
38BuildRoot:      %{_tmppath}/%{name}-%{version}-root
39BuildRequires:  libtool
40BuildRequires:  cmake >= 2.6.3
41BuildRequires:  chrpath
42
43BuildRequires:  eigen3-devel
44BuildRequires:  gtk2-devel
45BuildRequires:  libtheora-devel
46BuildRequires:  libvorbis-devel
47BuildRequires:  libraw1394-devel
48BuildRequires:  libdc1394-devel
49BuildRequires:  jasper-devel
50BuildRequires:  libpng-devel
51BuildRequires:  libjpeg-devel
52BuildRequires:  libtiff-devel
53BuildRequires:  libv4l-devel
54BuildRequires:  mesa-libGL-devel
55BuildRequires:  gtkglext-devel
56BuildRequires:  OpenEXR-devel
57#ifarch %{ix86} x86_64
58#BuildRequires:  openni-devel
59#BuildRequires:  openni-primesense
60#endif
61
62%ifarch %{ix86} x86_64 ia64 ppc ppc64
63BuildRequires:  tbb-devel
64%endif
65
66BuildRequires:  zlib-devel pkgconfig
67BuildRequires:  python-devel
68BuildRequires:  numpy
69BuildRequires:  swig >= 1.3.24
70BuildRequires:  python-sphinx
71#BuildRequires:  ffmpeg-devel >= 0.4.9
72
73BuildRequires:  gstreamer1-devel
74BuildRequires:  gstreamer1-plugins-base-devel
75#BuildRequires:  xine-lib-devel
76#BuildRequires:  opencl-headers
77
78Requires:       opencv-core = %{version}-%{release}
79
80
81%description
82OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
83C functions and a few C++ classes that implement some popular Image Processing
84and Computer Vision algorithms.
85
86
87%package        core
88Summary:        OpenCV core libraries
89Summary(ja):    OpenCV コアライブラリ
90Group:          System Environment/Libraries
91
92%description    core
93This package contains the OpenCV C/C++ core libraries.
94
95%package        devel
96Summary:        Development files for using the OpenCV library
97Summary(ja):    OpenCV ライブラリを使用するための開発用ファイル
98Group:          Development/Libraries
99Requires:       opencv = %{version}-%{release}
100
101%description    devel
102This package contains the OpenCV C/C++ library and header files, as well as
103documentation. It should be installed if you want to develop programs that
104will use the OpenCV library. You should consider installing opencv-devel-docs
105package.
106
107%package        devel-docs
108Summary:        Development files for using the OpenCV library
109Summary(ja):    OpenCV ライブラリを使用するための開発用ドキュメント
110Group:          Documentation
111Requires:       opencv-devel = %{version}-%{release}
112BuildArch:      noarch
113
114%description    devel-docs
115This package contains the OpenCV documentation and examples programs.
116
117%package        python
118Summary:        Python bindings for apps which use OpenCV
119Summary(ja):    OpenCV 使用するアプリケーション用の Python バインディング
120Group:          Development/Libraries
121Requires:       opencv = %{version}-%{release}
122Requires:       numpy
123
124%description    python
125This package contains Python bindings for the OpenCV library.
126
127
128%prep
129%setup -q
130%patch0 -p1 -b .pkgcmake
131%patch2 -p1 -b .pillow
132%patch3 -p1 -b .ts_static
133%patch4 -p1 -b .cmake_paths
134
135# for gst1
136%patch10 -p1 -b .10
137%patch11 -p1 -b .11
138%patch12 -p1 -b .12
139%patch13 -p1 -b .13
140%patch14 -p1 -b .14
141
142# fix dos end of lines
143sed -i 's|\r||g'  samples/c/adaptiveskindetector.cpp
144
145
146%build
147# enabled by default if libraries are presents at build time:
148# GTK, GSTREAMER, UNICAP, 1394, V4L
149# non available on Fedora: FFMPEG, XINE
150mkdir -p build
151pushd build
152%cmake CMAKE_VERBOSE=1 \
153       -DPYTHON_PACKAGES_PATH=%{python_sitearch} \
154       -DCMAKE_SKIP_RPATH=ON \
155       -DENABLE_PRECOMPILED_HEADERS:BOOL=OFF \
156%ifnarch x86_64 ia64
157       -DENABLE_SSE=0 \
158       -DENABLE_SSE2=0 \
159%endif
160       -DENABLE_SSE3=0 \
161       -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
162       -DBUILD_TEST=1 \
163       -DBUILD_opencv_java=0 \
164       -DBUILD_opencv_nonfree=0 \
165       -DBUILD_opencv_gpu=0 \
166       -DWITH_FFMPEG=0 \
167       -DWITH_GSTREAMER_1_X=1 \
168       -DWITH_OPENGL=1 \
169       -DWITH_OPENMP=1 \
170%ifarch %{ix86} x86_64 ia64
171       -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
172%endif
173       -DWITH_XINE=0 \
174       -DINSTALL_C_EXAMPLES=1 \
175       -DINSTALL_PYTHON_EXAMPLES=1 \
176       ..
177
178
179#{?_without_gstreamer:-DWITH_GSTREAMER=0} \
180
181#%{?_with_cuda: \
182# -DCUDA_TOOLKIT_ROOT_DIR=%{?_cuda_topdir} \
183# -DCUDA_VERBOSE_BUILD=1 \
184# -DCUDA_PROPAGATE_HOST_FLAGS=0 \
185#} \
186
187 #%ifarch %{ix86} x86_64
188#%{?_with_openni: \
189# -DWITH_OPENNI=ON \
190#} \
191#%endif
192
193# -DOPENCL_INCLUDE_DIR=${_includedir}/CL \
194 
195make VERBOSE=1 %{?_smp_mflags}
196
197popd
198
199
200%install
201rm -rf %{buildroot}
202rm -rf __devel-doc
203pushd build
204make install DESTDIR=%{buildroot} INSTALL="install -p" CPPROG="cp -p"
205find %{buildroot} -name '*.la' -delete
206
207rm -f %{buildroot}%{_datadir}/OpenCV/samples/c/build_all.sh \
208      %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.dsp \
209      %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.vcproj \
210      %{buildroot}%{_datadir}/OpenCV/samples/c/facedetect.cmd
211install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/OpenCV/samples/c/GNUmakefile
212
213# remove unnecessary documentation
214rm -rf %{buildroot}%{_datadir}/OpenCV/doc
215
216popd
217
218%check
219# Check fails since we don't support most video
220# read/write capability and we don't provide a display
221# ARGS=-V increases output verbosity
222# Make test is unavailble as of 2.3.1
223%if 0
224#ifnarch ppc64
225pushd build
226    LD_LIBRARY_PATH=%{_builddir}/%{tar_name}-%{version}/lib:$LD_LIBARY_PATH make test ARGS=-V || :
227popd
228%endif
229
230%clean
231rm -rf %{buildroot}
232
233%post core -p /sbin/ldconfig
234%postun core -p /sbin/ldconfig
235
236%post -p /sbin/ldconfig
237%postun -p /sbin/ldconfig
238
239%files
240%doc LICENSE README.md
241%{_bindir}/opencv_*
242%{_libdir}/libopencv_calib3d.so.2.4*
243%{_libdir}/libopencv_contrib.so.2.4*
244%{_libdir}/libopencv_features2d.so.2.4*
245%{_libdir}/libopencv_highgui.so.2.4*
246%{_libdir}/libopencv_legacy.so.2.4*
247%{_libdir}/libopencv_objdetect.so.2.4*
248#{_libdir}/libopencv_ocl.so.2.4*
249%{_libdir}/libopencv_stitching.so.2.4*
250%{_libdir}/libopencv_superres.so.2.4*
251%{_libdir}/libopencv_ts.so.2.4*
252%{_libdir}/libopencv_videostab.so.2.4*
253%dir %{_datadir}/OpenCV
254%{_datadir}/OpenCV/haarcascades
255%{_datadir}/OpenCV/lbpcascades
256
257%files core
258%{_libdir}/libopencv_core.so.2.4*
259%{_libdir}/libopencv_flann.so.2.4*
260%{_libdir}/libopencv_imgproc.so.2.4*
261%{_libdir}/libopencv_ml.so.2.4*
262%{_libdir}/libopencv_photo.so.2.4*
263%{_libdir}/libopencv_video.so.2.4*
264
265%files devel
266%{_includedir}/opencv
267%{_includedir}/opencv2
268%{_libdir}/lib*.so
269%{_libdir}/pkgconfig/opencv.pc
270%dir %{_libdir}/OpenCV/
271%{_libdir}/OpenCV/*.cmake
272
273%files devel-docs
274%doc doc/*.{htm,png,jpg}
275%doc %{_datadir}/OpenCV/samples
276
277%files python
278%{python_sitearch}/cv.py*
279%{python_sitearch}/cv2.so
280
281%changelog
282* Wed Mar  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
283- built with tbb
284- moved main package to System Environment/Libraries Group
285
286* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
287- Initial build for Vine Linux
288
289* Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
290- rebuild (openexr)
291
292* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
293- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
294
295* Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
296- backport support for GStreamer 1 (#1123078)
297
298* Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
299- Update to 2.4.9
300
301* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
302- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
303
304* Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
305- revert pkgcmake2 patch (#1070428)
306
307* Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
308- Fix opencv_ocl isn't part of -core
309
310* Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
311- Enable OpenCL support.
312- SPEC small cleanup.
313
314* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
315- rebuild (openexr)
316
317* Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
318- OpenCV cmake configuration broken (#1031312)
319
320* Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
321- Update to 2.4.7
322
323* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
324- rebuild (openexr)
325
326* Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
327- Update to 2.4.6.1
328
329* Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
330- Update to 2.4.5-clean
331- Spec file clean-up
332- Split core libraries into a sub-package
333
334* Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
335- change project URL.
336
337* Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
338- make clean source without SIFT/SURF
339
340* Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
341- Update to 2.4.4a
342- Fix ttb-devel architecture conditionals
343
344* Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
345- rebuild (OpenEXR)
346
347* Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
348- Update to 2.4.4 beta
349- Drop python-imaging also from requires
350- Drop merged patch for additionals codecs
351- Disable the java binding for now (untested)
352
353* Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
354- Do not build with 1394 libs in rhel
355
356* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
357- rebuild due to "jpeg8-ABI" feature drop
358
359* Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
360- Add more FourCC for gstreamer - rhbz#812628
361- Allow to use python-pillow - rhbz#895767
362
363* Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
364- Switch Build Type to ReleaseWithDebInfo to avoid -03
365
366* Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
367- Disable SSE3 and allow --with sse3 build conditional.
368- Disable gpu module as we don't build cuda
369- Update to 2.4.3
370
371* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
372- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
373
374* Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
375- Update to 2.4.2
376
377* Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
378- Fixed cmake script for generating opencv.pc file
379- Fixed OpenCVConfig script file
380
381* Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
382- Update to 2.4.1
383- Rework dependencies - rhbz#828087
384  Re-enable using --with tbb,opennpi,eigen2,eigen3
385
386* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
387- Rebuilt for c++ ABI breakage
388
389* Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
390- Update gcc46 patch for ARM FTBFS
391
392* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
393- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
394
395* Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
396- Rebuild for new libpng
397
398* Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
399- Rebuilt for tbb silent ABI change
400
401* Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
402- Update to 2.3.1a
403
404* Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
405- openni is exclusive for x86/x86_64
406
407* Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
408- Update to 2.3.1
409- Add BR openni-devel python-sphinx
410- Remove deprecated cmake options
411- Add --with cuda conditional (wip)
412- Disable make test (unavailable)
413
414* Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
415- Backport fixes from branch 2.2 to date
416
417* Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
418- Re-enable v4l on f15
419- Remove unused cmake options
420
421* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
422- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
423
424* Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
425- Fix with gcc46
426- Disable V4L as V4L1 is disabled for Fedora 15
427
428* Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
429- Update to 2.2.0
430- Disable -msse and -msse2 on x86_32
431
432* Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
433- -devel: include OpenCVConfig.cmake (#627359)
434
435* Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
436- TBB is available only on x86/x86_64 and ia64
437
438* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
439- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
440
441* Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
442- Move samples from main to -devel
443- Fix spurious permission
444- Add BR tbb-devel
445- Fix CFLAGS
446
447* Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
448- Update to 2.1.0
449- Update libdir patch
450
451* Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
452- Fix nonstandard executable permissions
453
454* Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
455- apply the previously added patch
456
457* Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
458- re-enable testing on CMake build system
459- fix memory corruption in the gaussian random number generator
460
461* Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
462- replaced BR unicap-devel by libucil-devel (unicap split)
463
464* Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
465- use cmake build system
466- applications renamed to opencv_xxx instead of opencv-xxx
467- add devel-docs subpackage #546605
468- add OpenCVConfig.cmake
469- enable openmp build
470- enable old SWIG based python wrappers
471- opencv package is a good boy and use global instead of define
472
473* Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
474- Set CXXFLAXS without -match=i386 for i386 architecture #565074
475
476* Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
477- Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
478
479* Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
480- Fixed spec file issues detected by rpmlint
481
482* Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
483- Fix autotools scripts (missing LBP features) - #544167
484
485* Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
486- Updated to 2.0.0
487- Removed upstream-ed patches
488- Ugly hack (added cvconfig.h)
489- Disable %%check on ppc64
490
491* Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
492- fix build on s390x where we don't have libraw1394 and devel
493
494* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
495- Fix typo I introduced that prevented build on i386/i586
496
497* Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
498- Added 1394 libs and unicap support
499
500* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
501- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
502
503* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
504- Build with gstreamer support - #491223
505- Backport gcc43 fix from trunk
506
507* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
508- Fix FTBFS #511705
509
510* Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
511- Update to 1.1pre1
512- Disable CXXFLAGS hardcoded optimization
513- Add BR: python-imaging, numpy
514- Disable make check failure for now
515
516* Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
517- Fix for gcc44
518- Enable BR jasper-devel
519- Disable ldconfig run on python modules (uneeded)
520- Prevent timestamp change on install
521
522* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
523- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
524
525* Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
526- fix URL field
527
528* Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
529- Adopt latest python spec rules.
530- Rebuild for Python 2.6 once again.
531
532* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
533- Rebuild for Python 2.6
534
535* Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
536- fix license tag
537
538* Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
539- Adjust library order in opencv.pc.in (BZ 445937).
540
541* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
542- Autorebuild for GCC 4.3
543
544* Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
545- Rebuild for gcc43.
546
547* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
548- Rebuild for selinux ppc32 issue.
549
550* Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
551- Mass rebuild.
552
553* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
554- Fix %%{_datadir}/opencv/samples ownership.
555- Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
556
557* Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
558- Move all of the python module to pyexecdir (BZ 233128).
559- Activate the testsuite.
560
561* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
562- Upstream update.
563
564* Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
565- Remove python-abi.
566
567* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
568- rebuilt for unwind info generation, broken in gcc-4.1.1-21
569
570* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
571- Stop configure.in from hacking CXXFLAGS.
572- Activate testsuite.
573- Let *-devel require pkgconfig.
574
575* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
576- Upstream update.
577- Don't BR: autotools.
578- Install samples' Makefile as GNUmakefile.
579
580* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
581- Un'%%ghost *.pyo.
582- Separate %%{pythondir} from %%{pyexecdir}.
583
584* Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
585- Rebuild for FC6.
586- BR: libtool.
587
588* Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
589- Rebuild.
590
591* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
592- Force a re-run of Autotools by calling autoreconf.
593
594* Wed Mar  8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
595- Added build dependency on Autotools.
596
597* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
598- Changed intrinsics patch so that it matches upstream.
599
600* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
601- More intrinsics patch fixing.
602
603* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
604- Don't do "make check" because it doesn't run any tests anyway.
605- Back to main intrinsics patch.
606
607* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
608- Using simple intrinsincs patch.
609
610* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
611- Still more fixing of intrinsics patch for Python bindings on x86_64.
612
613* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
614- Again fixed intrinsics patch so that Python modules build on x86_64.
615
616* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
617- Fixed intrinsics patch so that it works.
618
619* Tue Mar  7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
620- Fixed Python bindings location on x86_64.
621
622* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
623- SSE2 support on x86_64.
624
625* Mon Mar  6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
626- Rebuild
627
628* Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
629- Removed useless sample compilation makefiles/project files and replaced them
630  with one that works on Fedora Core.
631- Removed shellbang from Python modules.
632
633* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
634- Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
635
636* Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
637- Initial package.
Note: See TracBrowser for help on using the repository browser.