source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 1034

Revision 1034, 12.2 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           openbox
2Version:        3.4.11.2
3Release:        1%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        openbox.desktop
15
16Patch0:         openbox-3.4.9-autostartdir.patch
17Patch1:         openbox-3.4.8-gdm.patch
18Patch3:         openbox-3.4.7.2-autostartid.patch
19#Patch6:         05_fix_gnome-settings-daemon_path.patch
20Patch7:         openbox-3.4.7.2-24bit.patch
21Patch9:         openbox-3.4.10-obxpropman.patch
22Patch10:        openbox-3.4.11-Xau.patch
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28BuildRequires:  gettext
29BuildRequires:  glib2-devel >= 2.14.0
30BuildRequires:  desktop-file-utils
31BuildRequires:  pango-devel
32BuildRequires:  startup-notification-devel
33BuildRequires:  libxml2-devel >= 2.6.0
34BuildRequires:  libSM-devel
35BuildRequires:  libXcursor-devel
36BuildRequires:  libXfixes-devel
37BuildRequires:  libXt-devel
38BuildRequires:  libXrandr-devel
39BuildRequires:  libXinerama-devel
40
41# The xdg-menu dynamic pipe menu requires the gmenu Python module
42Requires:       gnome-menus
43
44Requires:       pyxdg
45
46%description
47Openbox is a window manager designed explicity for standards-compliance and
48speed. It is fast, lightweight, and heavily configurable (using XML for its
49configuration data). It has many features that make it unique among window
50managers: window resistance, chainable key bindings, customizable mouse
51actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
52
53For a full list of the FreeDesktop.org standards with which it is compliant,
54please see the COMPLIANCE file in the included documentation of this package.
55For a graphical configuration editor, you'll need to install the obconf
56package. For a graphical menu editor, you'll need to install the obmenu
57package.
58
59
60%package        devel
61Summary:        Development files for %{name}
62Summary(ja):    %{name} の開発ファイル
63Group:          Development/Libraries
64Requires:       %{name}-libs = %{version}-%{release}
65Requires:       pkgconfig
66Requires:       pango-devel
67Requires:       libxml2-devel
68Requires:       glib2-devel
69
70%description    devel
71The %{name}-devel package contains libraries and header files for
72developing applications that use %{name}.
73
74
75%package        libs
76Summary:        Shared libraries for %{name}
77Summary:        %{name} の共有ライブラリ
78Group:          System Environment/Libraries
79
80%description    libs
81The %{name}-libs package contains shared libraries used by %{name}.
82
83
84%prep
85%setup -q
86%patch0 -p1 -b .autostartdir
87%patch1 -p1 -b .gdm
88%patch3 -p1 -b .autostartid
89#%patch6
90%patch7 -p1 -b .24bit
91%patch9 -p1 -b .obxpropman
92%patch10 -p1 -b .Xau
93
94
95%build
96%configure \
97        --disable-static
98## Fix RPATH hardcoding.
99sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
100sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
101make %{?_smp_mflags}
102
103gcc %{optflags} -o setlayout %{SOURCE1} -lX11
104
105%install
106rm -rf %{buildroot}
107make install DESTDIR=%{buildroot}
108
109install setlayout %{buildroot}%{_bindir}
110install -p %{SOURCE2} %{buildroot}%{_datadir}/%{name}/xdg-menu
111sed 's|_XDGMENU_|%{_datadir}/%{name}/xdg-menu|g' < %{SOURCE3} \
112        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
113
114desktop-file-install --vendor="" \
115        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
116        %{SOURCE4}
117
118%find_lang %{name}
119rm -f %{buildroot}%{_libdir}/*.la
120rm -rf %{buildroot}%{_datadir}/doc/%{name}
121
122
123%clean
124rm -rf %{buildroot}
125
126
127%files -f %{name}.lang
128%defattr(-,root,root,-)
129%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
130%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
131%dir %{_sysconfdir}/xdg/%{name}/
132%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
133%{_bindir}/gnome-panel-control
134%{_bindir}/gdm-control
135%{_bindir}/%{name}*
136%{_bindir}/obxprop
137%{_bindir}/setlayout
138%{_datadir}/applications/*%{name}.desktop
139%{_datadir}/%{name}
140%{_datadir}/themes/*/
141%{_datadir}/pixmaps/%{name}.png
142%{_datadir}/gnome/wm-properties/
143%{_datadir}/xsessions/%{name}*.desktop
144%{_mandir}/man1/*
145
146%files  libs
147%{_libdir}/libobrender.so.*
148%{_libdir}/libobparser.so.*
149
150%files  devel
151%{_includedir}/%{name}/
152%{_libdir}/libobrender.so
153%{_libdir}/libobparser.so
154%{_libdir}/pkgconfig/*.pc
155
156
157%post libs -p /sbin/ldconfig
158
159
160%postun libs -p /sbin/ldconfig
161
162
163%changelog
164* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
165- new upstream release
166- added Requires: pyxdg
167
168* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
169- new upstream release
170- changed URL and Source0
171- dropt Patch6
172- added BuildRequires: libXfixes-devel, libSM-devel
173- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
174
175* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
176- new upstream release
177- added Patch10 from Fedora
178- added summary(ja) in -devel and -libs
179
180* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
181- new upstream release
182- dropt Patch8
183- Patch9 from Fedora
184
185* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
186- new upstream release
187  - dropt patch2
188  - replaced and renamed Patch0 from Fedora
189
190* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
191- new upstream release
192  - dropt patch4,5
193  - added Patch8 from Fedora
194- added Requires: gnome-menus
195
196* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
197- improved Source3
198  - enabled administration menu (disabled preference menu because included)
199- added Patch6 from Mandriva
200- added Patch7 from Fedora
201- replaced Source1 from Fedora
202
203* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
204- updated Source4
205- added Patch4,5 from Debian
206
207* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
208- changed openbox-libs Group: System Environment/Libraries
209- spec in UTF-8
210
211* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
212- initial build for VineSeed
213
214* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
216
217* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
218- Restore gnome session script (#474143)
219- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
220
221* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
222- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
223- Add application desktop file to allow starting openbox in gnome-session
224  when configured in gconf
225
226* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
227- Don't use --choose-session option in gnome session script
228
229* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
230- Remove field codes from commands in xdg-menu (#452403)
231- Add support for launching applications in xterm to xdg-menu
232
233* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
234- Clean up properties after gdm in session scripts (#444135)
235- Add license to xdg-menu script
236
237* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
238- Drop numdesks patch (#444135)
239
240* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
241- Update to 3.4.7.2
242- Use gnome menus by default (Luke Macken) (#443548)
243- Force setting number of desktops (#444135)
244
245* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
246- Update to 3.4.7.1
247- Don't require /usr/share/themes
248
249* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
250- Update to 3.4.6.1
251
252* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
253- Update to 3.4.6
254
255* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
256- Update to 3.4.5
257
258* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
259- Rebuild
260
261* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
262- Update to 3.4.4
263- Update license tag
264
265* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
266- Update to 3.4.3
267- Package setlayout tool
268
269* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
270- Update to 3.4.2
271
272* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
273- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
274  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
275  Lichvar for the bug report.)
276
277* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
278- Split shared libraries into a -libs subpackage to properly handle multilib
279  setups. (This precludes the further need to %%ghost the byte-compiled
280  themeupdate scripts which was introduced in the previous release.)
281- Fix handling of the startup_notification build conditional. It will actually
282  work properly now. :)
283- Remove the hardcoded RPATH using some sed invocations from the packaging
284  guidelines.
285
286* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
287- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
288  (bug #228379).
289
290* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
291- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
292  by gnome-session in Rawhide and we should not have ownership conflicts with
293  Core packages.
294
295* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
296- Rebuild to pick up unwind info generation fixes in new GCC
297
298* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
299- Allow building with startup-notification as an rpmbuild option (though it is
300  disabled by default as recommended by upstream).
301
302* Sun Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
303- Update to new 3.3.1 from upstream
304
305* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
306- Mass FC6 rebuild
307
308* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
309- Bump release to fix sources tagging issue
310
311* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
312- Update to 3.3 final release from upstream
313- Remove the slew of versioning macros, as it's overkill for this and just adds
314  unneeded complexity to the spec.
315
316* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
317- Add missing BuildRequires: libXxf86vm-devel
318
319* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
320- Unconditionalize the BuildRequires for modular X.org, since it's branched
321  for a specific Fedora release.
322
323* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
324- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
325
326* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
327- Add %%{_datadir}/themes to Requires (#195292)
328
329* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
330- Own all created theme directories (#195292)
331- Fix previous review bug IDs in this %%changelog to point to the recreated
332  review bug (due to recent bugzilla outage)
333
334* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
335- Don't default to an executable xsession script (#195292)
336
337* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
338- Fix versioning to conform to the Extras packaging guidelines
339
340* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
341- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
342  login screen (#195292)
343
344* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
345- Unorphan, rewriting nearly all of the spec file
346- Update to upstream 3.3 RC2
347
348* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
349- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
350- Need to conflict with fluxbox (#422 / #440)
351
352* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
353- Need to own /usr/share/apps/switchdesk (#422)
354
355* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
356- More spec revisions (#422); change make and preserve timestamps
357
358* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
359- Minor spec revisions (#422); add epoch and versions to changelogs
360
361* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
362- Add switchdesk support
363- Add display manager support
364- Fix NLS build on Cambridge
365- Fedora'ize the spec
366
367* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
368- Rev to 2.3.1 release
369- Make go with GCC 3.3
370
371* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
372- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.