source: projects/specs/trunk/o/openbox/openbox-vl.spec @ 1940

Revision 1940, 12.3 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           openbox
2Version:        3.4.11.2
3Release:        2%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        openbox.desktop
15
16Patch0:         openbox-3.4.9-autostartdir.patch
17Patch1:         openbox-3.4.8-gdm.patch
18Patch3:         openbox-3.4.7.2-autostartid.patch
19#Patch6:         05_fix_gnome-settings-daemon_path.patch
20Patch7:         openbox-3.4.7.2-24bit.patch
21Patch9:         openbox-3.4.10-obxpropman.patch
22Patch10:        openbox-3.4.11-Xau.patch
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28BuildRequires:  gettext
29BuildRequires:  glib2-devel >= 2.14.0
30BuildRequires:  desktop-file-utils
31BuildRequires:  pango-devel
32BuildRequires:  startup-notification-devel
33BuildRequires:  libxml2-devel >= 2.6.0
34BuildRequires:  libSM-devel
35BuildRequires:  libXau-devel
36BuildRequires:  libXcursor-devel
37BuildRequires:  libXfixes-devel
38BuildRequires:  libXt-devel
39BuildRequires:  libXrandr-devel
40BuildRequires:  libXinerama-devel
41
42# The xdg-menu dynamic pipe menu requires the gmenu Python module
43Requires:       gnome-menus
44
45Requires:       pyxdg
46
47%description
48Openbox is a window manager designed explicity for standards-compliance and
49speed. It is fast, lightweight, and heavily configurable (using XML for its
50configuration data). It has many features that make it unique among window
51managers: window resistance, chainable key bindings, customizable mouse
52actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
53
54For a full list of the FreeDesktop.org standards with which it is compliant,
55please see the COMPLIANCE file in the included documentation of this package.
56For a graphical configuration editor, you'll need to install the obconf
57package. For a graphical menu editor, you'll need to install the obmenu
58package.
59
60
61%package        devel
62Summary:        Development files for %{name}
63Summary(ja):    %{name} の開発ファイル
64Group:          Development/Libraries
65Requires:       %{name}-libs = %{version}-%{release}
66Requires:       pkgconfig
67Requires:       pango-devel
68Requires:       libxml2-devel
69Requires:       glib2-devel
70
71%description    devel
72The %{name}-devel package contains libraries and header files for
73developing applications that use %{name}.
74
75
76%package        libs
77Summary:        Shared libraries for %{name}
78Summary:        %{name} の共有ライブラリ
79Group:          System Environment/Libraries
80
81%description    libs
82The %{name}-libs package contains shared libraries used by %{name}.
83
84
85%prep
86%setup -q
87%patch0 -p1 -b .autostartdir
88%patch1 -p1 -b .gdm
89%patch3 -p1 -b .autostartid
90#%patch6
91%patch7 -p1 -b .24bit
92%patch9 -p1 -b .obxpropman
93%patch10 -p1 -b .Xau
94
95
96%build
97%configure \
98        --disable-static
99## Fix RPATH hardcoding.
100sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
101sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
102make %{?_smp_mflags}
103
104gcc %{optflags} -o setlayout %{SOURCE1} -lX11
105
106%install
107rm -rf %{buildroot}
108make install DESTDIR=%{buildroot}
109
110install setlayout %{buildroot}%{_bindir}
111install -p %{SOURCE2} %{buildroot}%{_datadir}/%{name}/xdg-menu
112sed 's|_XDGMENU_|%{_datadir}/%{name}/xdg-menu|g' < %{SOURCE3} \
113        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
114
115desktop-file-install --vendor="" \
116        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
117        %{SOURCE4}
118
119%find_lang %{name}
120rm -f %{buildroot}%{_libdir}/*.la
121rm -rf %{buildroot}%{_datadir}/doc/%{name}
122
123
124%clean
125rm -rf %{buildroot}
126
127
128%files -f %{name}.lang
129%defattr(-,root,root,-)
130%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
131%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
132%dir %{_sysconfdir}/xdg/%{name}/
133%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
134%{_bindir}/gnome-panel-control
135%{_bindir}/gdm-control
136%{_bindir}/%{name}*
137%{_bindir}/obxprop
138%{_bindir}/setlayout
139%{_datadir}/applications/*%{name}.desktop
140%{_datadir}/%{name}
141%{_datadir}/themes/*/
142%{_datadir}/pixmaps/%{name}.png
143%{_datadir}/gnome/wm-properties/
144%{_datadir}/xsessions/%{name}*.desktop
145%{_mandir}/man1/*
146
147%files  libs
148%{_libdir}/libobrender.so.*
149%{_libdir}/libobparser.so.*
150
151%files  devel
152%{_includedir}/%{name}/
153%{_libdir}/libobrender.so
154%{_libdir}/libobparser.so
155%{_libdir}/pkgconfig/*.pc
156
157
158%post libs -p /sbin/ldconfig
159
160
161%postun libs -p /sbin/ldconfig
162
163
164%changelog
165* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
166- rebuilt with rpm-4.8.1 for pkg-config
167- BuildRequires: libXau-devel
168
169* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
170- new upstream release
171- added Requires: pyxdg
172
173* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
174- new upstream release
175- changed URL and Source0
176- dropt Patch6
177- added BuildRequires: libXfixes-devel, libSM-devel
178- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
179
180* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
181- new upstream release
182- added Patch10 from Fedora
183- added summary(ja) in -devel and -libs
184
185* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
186- new upstream release
187- dropt Patch8
188- Patch9 from Fedora
189
190* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
191- new upstream release
192  - dropt patch2
193  - replaced and renamed Patch0 from Fedora
194
195* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
196- new upstream release
197  - dropt patch4,5
198  - added Patch8 from Fedora
199- added Requires: gnome-menus
200
201* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
202- improved Source3
203  - enabled administration menu (disabled preference menu because included)
204- added Patch6 from Mandriva
205- added Patch7 from Fedora
206- replaced Source1 from Fedora
207
208* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
209- updated Source4
210- added Patch4,5 from Debian
211
212* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
213- changed openbox-libs Group: System Environment/Libraries
214- spec in UTF-8
215
216* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
217- initial build for VineSeed
218
219* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
221
222* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
223- Restore gnome session script (#474143)
224- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
225
226* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
227- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
228- Add application desktop file to allow starting openbox in gnome-session
229  when configured in gconf
230
231* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
232- Don't use --choose-session option in gnome session script
233
234* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
235- Remove field codes from commands in xdg-menu (#452403)
236- Add support for launching applications in xterm to xdg-menu
237
238* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
239- Clean up properties after gdm in session scripts (#444135)
240- Add license to xdg-menu script
241
242* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
243- Drop numdesks patch (#444135)
244
245* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
246- Update to 3.4.7.2
247- Use gnome menus by default (Luke Macken) (#443548)
248- Force setting number of desktops (#444135)
249
250* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
251- Update to 3.4.7.1
252- Don't require /usr/share/themes
253
254* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
255- Update to 3.4.6.1
256
257* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
258- Update to 3.4.6
259
260* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
261- Update to 3.4.5
262
263* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
264- Rebuild
265
266* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
267- Update to 3.4.4
268- Update license tag
269
270* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
271- Update to 3.4.3
272- Package setlayout tool
273
274* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
275- Update to 3.4.2
276
277* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
278- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
279  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
280  Lichvar for the bug report.)
281
282* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
283- Split shared libraries into a -libs subpackage to properly handle multilib
284  setups. (This precludes the further need to %%ghost the byte-compiled
285  themeupdate scripts which was introduced in the previous release.)
286- Fix handling of the startup_notification build conditional. It will actually
287  work properly now. :)
288- Remove the hardcoded RPATH using some sed invocations from the packaging
289  guidelines.
290
291* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
292- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
293  (bug #228379).
294
295* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
296- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
297  by gnome-session in Rawhide and we should not have ownership conflicts with
298  Core packages.
299
300* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
301- Rebuild to pick up unwind info generation fixes in new GCC
302
303* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
304- Allow building with startup-notification as an rpmbuild option (though it is
305  disabled by default as recommended by upstream).
306
307* Sun Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
308- Update to new 3.3.1 from upstream
309
310* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
311- Mass FC6 rebuild
312
313* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
314- Bump release to fix sources tagging issue
315
316* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
317- Update to 3.3 final release from upstream
318- Remove the slew of versioning macros, as it's overkill for this and just adds
319  unneeded complexity to the spec.
320
321* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
322- Add missing BuildRequires: libXxf86vm-devel
323
324* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
325- Unconditionalize the BuildRequires for modular X.org, since it's branched
326  for a specific Fedora release.
327
328* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
329- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
330
331* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
332- Add %%{_datadir}/themes to Requires (#195292)
333
334* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
335- Own all created theme directories (#195292)
336- Fix previous review bug IDs in this %%changelog to point to the recreated
337  review bug (due to recent bugzilla outage)
338
339* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
340- Don't default to an executable xsession script (#195292)
341
342* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
343- Fix versioning to conform to the Extras packaging guidelines
344
345* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
346- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
347  login screen (#195292)
348
349* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
350- Unorphan, rewriting nearly all of the spec file
351- Update to upstream 3.3 RC2
352
353* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
354- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
355- Need to conflict with fluxbox (#422 / #440)
356
357* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
358- Need to own /usr/share/apps/switchdesk (#422)
359
360* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
361- More spec revisions (#422); change make and preserve timestamps
362
363* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
364- Minor spec revisions (#422); add epoch and versions to changelogs
365
366* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
367- Add switchdesk support
368- Add display manager support
369- Fix NLS build on Cambridge
370- Fedora'ize the spec
371
372* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
373- Rev to 2.3.1 release
374- Make go with GCC 3.3
375
376* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
377- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.