source: projects/specs/trunk/o/octave/octave-vl.spec @ 11734

Revision 11734, 10.8 KB checked in by ara_t, 6 years ago (diff)

octave: enable GUI

Line 
1%define pkg_name    octave
2%define pkg_version 4.4.0
3%define pkg_release 4%{?_dist_release}
4
5%define gui   1
6%define sound 1
7
8
9Summary:     GNU Octave -- a high-level language for numerical computations
10Summary(ja): 数値計算のための高級言語
11Name:        %{pkg_name}
12Version:     %{pkg_version}
13Release:     %{pkg_release}
14
15License: GPLv3
16Group:   Applications/Edutainment
17URL:     http://www.gnu.org/software/octave/
18Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires: gcc-gfortran
23BuildRequires: bison flex gperf texinfo less
24BuildRequires: gnuplot
25BuildRequires: ghostscript-devel
26BuildRequires: mesa-libOSMesa-devel
27BuildRequires: blas-devel lapack-devel
28BuildRequires: pcre-devel
29BuildRequires: readline-devel
30%if %{?_dist_release} == "vl6"
31BuildRequires: arpack
32%endif
33%if %{?_dist_release} >= "vl7"
34BuildRequires: arpack-devel
35%endif
36BuildRequires: curl-devel
37BuildRequires: fftw3-devel
38BuildRequires: fontconfig-devel
39BuildRequires: freetype-devel
40BuildRequires: glpk-devel
41BuildRequires: GraphicsMagick-c++-devel
42BuildRequires: hdf5-devel
43BuildRequires: java-devel
44BuildRequires: qhull-devel
45BuildRequires: qrupdate
46BuildRequires: suitesparse-devel
47BuildRequires: zlib-devel
48BuildRequires: xz-devel
49BuildRequires: libtool-ltdl-devel
50BuildRequires: libXext-devel
51BuildRequires: openssl-devel
52%if %{gui}
53BuildRequires: desktop-file-utils
54BuildRequires: freeglut-devel
55BuildRequires: fltk-devel
56BuildRequires: gl2ps-devel
57%if %{?_dist_release} == "vl6"
58BuildRequires: qt4-devel
59BuildRequires: qscintilla-devel
60%endif
61%if %{?_dist_release} >= "vl7"
62BuildRequires: qt5-qtbase-devel
63BuildRequires: qt5-qttools-devel
64%endif
65%endif
66%if %{sound}
67BuildRequires: portaudio-devel
68BuildRequires: libsndfile-devel
69%endif
70BuildRequires: lzip
71
72Requires: ghostscript
73Requires: blas lapack
74Requires: pcre
75Requires: readline
76Requires: mesa-libOSMesa
77Requires: gnuplot
78Requires: arpack
79Requires: curl
80Requires: fftw3
81Requires: fontconfig
82Requires: freetype
83Requires: glpk
84Requires: GraphicsMagick-c++
85Requires: hdf5
86Requires: qhull
87Requires: qrupdate
88Requires: suitesparse
89Requires: zlib
90Requires: openssl
91Requires: pstoedit epstool transfig
92%if %{gui}
93Requires: freeglut
94Requires: fltk
95Requires: gl2ps
96%if %{?_dist_release} == "vl6"
97Requires: qt4
98Requires: qscintilla
99%endif
100%if %{?_dist_release} >= "vl7"
101Requires: qt5-qtbase
102Requires: qt5-qttools-libs-help
103%endif
104%endif
105%if %{sound}
106Requires: portaudio
107Requires: libsndfile
108%endif
109
110Requires(post):   /sbin/install-info
111Requires(postun): /sbin/ldconfig
112Requires(post):   /sbin/ldconfig
113Requires(preun):  /sbin/install-info
114
115Vendor: Project Vine
116Distribution: Vine Linux
117Packager: ara_t
118
119
120%description
121GNU Octave is a high-level language, primarily intended for numerical
122computations. It provides a convenient command line interface for
123solving linear and nonlinear problems numerically, and for performing
124other numerical experiments using a language that is mostly compatible
125with Matlab. It may also be used as a batch-oriented language.
126
127Octave has extensive tools for solving common numerical linear algebra
128problems, finding the roots of nonlinear equations, integrating
129ordinary functions, manipulating polynomials, and integrating ordinary
130differential and differential-algebraic equations. It is easily
131extensible and customizable via user-defined functions written in
132Octave's own language, or using dynamically loaded modules written in
133C++, C, Fortran, or other languages.
134# '
135
136%description -l ja
137GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
138問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
139を行うための使いやすいコマンドライン・インタフェースを備えています。
140バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
141一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
142行うことができます。
143Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
144書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
145
146%if %{gui}
147(注意)
148デフォルトではグラフの描画にOpenGL/fltkを使用してます。
149もし不安定な場合には、
150gnuplotをデフォルトとするために ~/.octaverc に
151graphics_toolkit("gnuplot");
152を追加してから起動して下さい。
153%endif
154
155
156%prep
157%{__rm} -rf ${RPM_BUILD_ROOT}
158%setup -q
159
160%build
161%{configure} \
162 CPPFLAGS="-I%{_includedir}/pcre" \
163 --with-x \
164 --with-magick=GraphicsMagick \
165 --with-curl-includedir=%{_includedir}/curl \
166 --with-glpk-includedir=%{_includedir}/glpk \
167 --with-qhull-includedir=%{_includedir}/libqhull \
168 --with-amd-includedir=%{_includedir}/suitesparse \
169 --with-camd-includedir=%{_includedir}/suitesparse \
170 --with-colamd-includedir=%{_includedir}/suitesparse \
171 --with-ccolamd-includedir=%{_includedir}/suitesparse \
172 --with-cholmod-includedir=%{_includedir}/suitesparse \
173 --with-cxsparse-includedir=%{_includedir}/suitesparse \
174 --with-umfpack-includedir=%{_includedir}/suitesparse \
175 --enable-java \
176%if %{gui}
177 --with-qt=5 \
178%endif
179%if !%{gui}
180 --without-opengl \
181 --without-fltk \
182%endif
183%if !%{sound}
184 --without-sndfile --without-portaudio \
185%endif
186
187%{__make} %{?_smp_mflags}
188
189
190%install
191%{make_install}
192
193find %{buildroot} -name "*.oct" | xargs strip
194
195# Make library links
196%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
197echo "%{_libdir}/octave-%{version}" > \
198     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
199
200%if %{gui}
201# desktop file
202%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
203 ${RPM_BUILD_ROOT}%{_datadir}/applications/org.octave.Octave.desktop
204%endif
205
206%check
207%{__make} %{?_smp_mflags} check
208
209%clean
210%{__rm} -rf ${RPM_BUILD_ROOT}
211
212
213%post -p %{_syssbindir}/ldconfig
214
215%postun -p %{_syssbindir}/ldconfig
216
217
218%files
219%defattr(-,root,root)
220%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
221%doc examples doc/interpreter/octave.pdf doc/refcard
222%config(noreplace) /etc/ld.so.conf.d/
223%{_bindir}/
224%{_libdir}/octave
225%{_includedir}/octave-%{version}
226%if %{gui}
227%{_datadir}/applications/
228%endif
229%{_datadir}/icons/
230%{_datadir}/metainfo/
231%{_datadir}/octave
232%{_libexecdir}/octave
233
234
235%changelog
236* Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-4
237- using qt5 for VineSeed
238  - add configure option: --with-qt=5
239  - add BuildRequires: qt5-qtbase-devel and qt5-qttools-devel
240  - add Requires: qt5-qtbase and qt5-qttools-libs-help
241
242* Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-3
243- rebuild with hdf5-1.8.20 for VineSeed
244
245* Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-2
246- add BuildRequires: arpack-devel for VineSeed
247
248* Sun May 20 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-1
249- update to 4.4.0
250- correct License
251
252* Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
253- update to 4.2.2
254
255* Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
256- rebuild under glpk-4.63
257
258* Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
259- update to 4.2.1
260
261* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
262- update to 4.2.0
263- add make check
264- add BuildRequires: lzip
265- change BuildRequires: java-devel
266
267* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
268- update to 4.0.3
269- change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
270
271* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
272- update to 4.0.2
273- add BuildRequires: openssl-devel
274- add Requires: openssl
275
276* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
277- update to 4.0.1
278- change dependencies
279
280* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
281- [BTS:0002801] add configure option --with-magick=Magick
282- delete BuildRequires: texlive-collection-texinfo
283- add BuildRequires: texlive-collection-plainextra
284- add BuildRequires: texlive-collection-latexextra
285- add BuildRequires: texlive-collection-fontsrecommended
286-   for VineSeed
287
288* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
289- update to 3.6.4
290- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
291
292* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
293- delete octave from menu (programming)
294
295* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
296- update to 3.6.2
297- correct spec file for version 3.6.2
298- add BuildRequires: pcre-devel fltk-devel
299- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
300- add BuildRequires: gcc-gfortran
301- add BuildRequires: texlive texlive-common texlive-collection-basic
302- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
303- chanfe Group to Applications/Edutainment
304
305* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
306- update to 3.0.2
307- applied new versioning policy, spec in utf-8
308
309* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
310- update to 3.0.0
311
312* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
313- rebuilt for VineSeed
314
315* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
316- update to 2.9.13
317- rebuilt with new toolchain and environment
318
319* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
320- update to 2.0.17
321- rebuild with new toolchains
322- add BuildRequires: gcc295, gcc295-c++
323
324* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
325- ver.up
326
327* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
328- build for Vine Linux 2.1
329
330* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
331- automatically added BuildRequires
332
333* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
334- Macros, BM, add multiple icons sizes
335
336* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
337- strip oct file
338- add menu entry
339 
340* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
341- corrected for new groups
342
343* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
344- mandrake build
345- v2.0.16
346
347* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
348- update to 2.0.13.90
349
350* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
351- repackage in powertools.
352
353* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
354- Add %attr, build as user.
355
356* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
357- Add BuildRoot, installinfo, require gnuplot, description from
358  Octave's web page, update to Octave 2.0.13.
359- Adapt from existing spec file.
360
361* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
362- removed libreadline stuff from the file list
363
364* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
365- changed configure command to put things in $RPM_ARCH-rehat-linux,
366  rather than genereated one... was causing problems between building
367  on i686 build machine.
368
369* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
370- moved buildroot from /tmp to /var/tmp
371
372* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
373- Upgraded to version 2.0.9 and built for glibc system
374
375* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
376- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.