source: projects/specs/trunk/o/octave/octave-vl.spec @ 11733

Revision 11733, 10.3 KB checked in by ara_t, 6 years ago (diff)

octave: rebuild with hdf5-1.8.20

Line 
1%define pkg_name    octave
2%define pkg_version 4.4.0
3%define pkg_release 3%{?_dist_release}
4
5%define gui   1
6%define sound 1
7
8
9Summary:     GNU Octave -- a high-level language for numerical computations
10Summary(ja): 数値計算のための高級言語
11Name:        %{pkg_name}
12Version:     %{pkg_version}
13Release:     %{pkg_release}
14
15License: GPLv3
16Group:   Applications/Edutainment
17URL:     http://www.gnu.org/software/octave/
18Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires: gcc-gfortran
23BuildRequires: bison flex gperf texinfo less
24BuildRequires: gnuplot
25BuildRequires: ghostscript-devel
26BuildRequires: mesa-libOSMesa-devel
27BuildRequires: blas-devel lapack-devel
28BuildRequires: pcre-devel
29BuildRequires: readline-devel
30%if %{?_dist_release} == "vl6"
31BuildRequires: arpack
32%endif
33%if %{?_dist_release} >= "vl7"
34BuildRequires: arpack-devel
35%endif
36BuildRequires: curl-devel
37BuildRequires: fftw3-devel
38BuildRequires: fontconfig-devel
39BuildRequires: freetype-devel
40BuildRequires: glpk-devel
41BuildRequires: GraphicsMagick-c++-devel
42BuildRequires: hdf5-devel
43BuildRequires: java-devel
44BuildRequires: qhull-devel
45BuildRequires: qrupdate
46BuildRequires: suitesparse-devel
47BuildRequires: zlib-devel
48BuildRequires: xz-devel
49BuildRequires: libtool-ltdl-devel
50BuildRequires: libXext-devel
51BuildRequires: openssl-devel
52%if %{gui}
53BuildRequires: desktop-file-utils
54BuildRequires: freeglut-devel
55BuildRequires: fltk-devel
56BuildRequires: gl2ps-devel
57BuildRequires: qt4-devel
58BuildRequires: qscintilla-devel
59%endif
60%if %{sound}
61BuildRequires: portaudio-devel
62BuildRequires: libsndfile-devel
63%endif
64BuildRequires: lzip
65
66Requires: ghostscript
67Requires: blas lapack
68Requires: pcre
69Requires: readline
70Requires: mesa-libOSMesa
71Requires: gnuplot
72Requires: arpack
73Requires: curl
74Requires: fftw3
75Requires: fontconfig
76Requires: freetype
77Requires: glpk
78Requires: GraphicsMagick-c++
79Requires: hdf5
80Requires: qhull
81Requires: qrupdate
82Requires: suitesparse
83Requires: zlib
84Requires: openssl
85Requires: pstoedit epstool transfig
86%if %{gui}
87Requires: freeglut
88Requires: fltk
89Requires: gl2ps
90Requires: qt4
91Requires: qscintilla
92%endif
93%if %{sound}
94Requires: portaudio
95Requires: libsndfile
96%endif
97
98Requires(post):   /sbin/install-info
99Requires(postun): /sbin/ldconfig
100Requires(post):   /sbin/ldconfig
101Requires(preun):  /sbin/install-info
102
103Vendor: Project Vine
104Distribution: Vine Linux
105Packager: ara_t
106
107
108%description
109GNU Octave is a high-level language, primarily intended for numerical
110computations. It provides a convenient command line interface for
111solving linear and nonlinear problems numerically, and for performing
112other numerical experiments using a language that is mostly compatible
113with Matlab. It may also be used as a batch-oriented language.
114
115Octave has extensive tools for solving common numerical linear algebra
116problems, finding the roots of nonlinear equations, integrating
117ordinary functions, manipulating polynomials, and integrating ordinary
118differential and differential-algebraic equations. It is easily
119extensible and customizable via user-defined functions written in
120Octave's own language, or using dynamically loaded modules written in
121C++, C, Fortran, or other languages.
122# '
123
124%description -l ja
125GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
126問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
127を行うための使いやすいコマンドライン・インタフェースを備えています。
128バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
129一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
130行うことができます。
131Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
132書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
133
134%if %{gui}
135(注意)
136デフォルトではグラフの描画にOpenGL/fltkを使用してます。
137もし不安定な場合には、
138gnuplotをデフォルトとするために ~/.octaverc に
139graphics_toolkit("gnuplot");
140を追加してから起動して下さい。
141%endif
142
143
144%prep
145%{__rm} -rf ${RPM_BUILD_ROOT}
146%setup -q
147
148%build
149%{configure} \
150 CPPFLAGS="-I%{_includedir}/pcre" \
151 --with-x \
152 --with-magick=GraphicsMagick \
153 --with-curl-includedir=%{_includedir}/curl \
154 --with-glpk-includedir=%{_includedir}/glpk \
155 --with-qhull-includedir=%{_includedir}/qhull \
156 --with-amd-includedir=%{_includedir}/suitesparse \
157 --with-camd-includedir=%{_includedir}/suitesparse \
158 --with-colamd-includedir=%{_includedir}/suitesparse \
159 --with-ccolamd-includedir=%{_includedir}/suitesparse \
160 --with-cholmod-includedir=%{_includedir}/suitesparse \
161 --with-cxsparse-includedir=%{_includedir}/suitesparse \
162 --with-umfpack-includedir=%{_includedir}/suitesparse \
163 --enable-java \
164%if !%{gui}
165 --disable-gui \
166 --without-opengl \
167 --without-fltk \
168%endif
169%if !%{sound}
170 --without-sndfile --without-portaudio \
171%endif
172
173%{__make} %{?_smp_mflags}
174
175
176%install
177%{make_install}
178
179find %{buildroot} -name "*.oct" | xargs strip
180
181# Make library links
182%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
183echo "%{_libdir}/octave-%{version}" > \
184     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
185
186%if %{gui}
187# desktop file
188%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
189 ${RPM_BUILD_ROOT}%{_datadir}/applications/org.octave.Octave.desktop
190%endif
191
192
193%check
194%{__make} %{?_smp_mflags} check
195
196%clean
197%{__rm} -rf ${RPM_BUILD_ROOT}
198
199
200%post -p %{_syssbindir}/ldconfig
201
202%postun -p %{_syssbindir}/ldconfig
203
204
205%files
206%defattr(-,root,root)
207%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
208%doc examples doc/interpreter/octave.pdf doc/refcard
209%config(noreplace) /etc/ld.so.conf.d/
210%{_bindir}/
211%{_libdir}/octave
212%{_includedir}/octave-%{version}
213%if %{gui}
214%{_datadir}/applications/
215%endif
216%{_datadir}/icons/
217%{_datadir}/metainfo/
218%{_datadir}/octave
219%{_libexecdir}/octave
220
221
222%changelog
223* Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-3
224- rebuild under hdf5-1.8.20 for VineSeed
225
226* Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-2
227- add BuildRequires: arpack-devel for VineSeed
228
229* Sun May 20 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-1
230- update to 4.4.0
231- correct License
232
233* Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
234- update to 4.2.2
235
236* Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
237- rebuild under glpk-4.63
238
239* Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
240- update to 4.2.1
241
242* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
243- update to 4.2.0
244- add make check
245- add BuildRequires: lzip
246- change BuildRequires: java-devel
247
248* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
249- update to 4.0.3
250- change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
251
252* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
253- update to 4.0.2
254- add BuildRequires: openssl-devel
255- add Requires: openssl
256
257* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
258- update to 4.0.1
259- change dependencies
260
261* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
262- [BTS:0002801] add configure option --with-magick=Magick
263- delete BuildRequires: texlive-collection-texinfo
264- add BuildRequires: texlive-collection-plainextra
265- add BuildRequires: texlive-collection-latexextra
266- add BuildRequires: texlive-collection-fontsrecommended
267-   for VineSeed
268
269* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
270- update to 3.6.4
271- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
272
273* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
274- delete octave from menu (programming)
275
276* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
277- update to 3.6.2
278- correct spec file for version 3.6.2
279- add BuildRequires: pcre-devel fltk-devel
280- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
281- add BuildRequires: gcc-gfortran
282- add BuildRequires: texlive texlive-common texlive-collection-basic
283- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
284- chanfe Group to Applications/Edutainment
285
286* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
287- update to 3.0.2
288- applied new versioning policy, spec in utf-8
289
290* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
291- update to 3.0.0
292
293* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
294- rebuilt for VineSeed
295
296* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
297- update to 2.9.13
298- rebuilt with new toolchain and environment
299
300* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
301- update to 2.0.17
302- rebuild with new toolchains
303- add BuildRequires: gcc295, gcc295-c++
304
305* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
306- ver.up
307
308* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
309- build for Vine Linux 2.1
310
311* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
312- automatically added BuildRequires
313
314* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
315- Macros, BM, add multiple icons sizes
316
317* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
318- strip oct file
319- add menu entry
320 
321* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
322- corrected for new groups
323
324* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
325- mandrake build
326- v2.0.16
327
328* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
329- update to 2.0.13.90
330
331* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
332- repackage in powertools.
333
334* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
335- Add %attr, build as user.
336
337* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
338- Add BuildRoot, installinfo, require gnuplot, description from
339  Octave's web page, update to Octave 2.0.13.
340- Adapt from existing spec file.
341
342* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
343- removed libreadline stuff from the file list
344
345* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
346- changed configure command to put things in $RPM_ARCH-rehat-linux,
347  rather than genereated one... was causing problems between building
348  on i686 build machine.
349
350* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
351- moved buildroot from /tmp to /var/tmp
352
353* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
354- Upgraded to version 2.0.9 and built for glibc system
355
356* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
357- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.