source: projects/specs/trunk/o/octave/octave-vl.spec @ 11640

Revision 11640, 10.0 KB checked in by ara_t, 6 years ago (diff)

octave: update to 4.4.0

Line 
1%define pkg_name    octave
2%define pkg_version 4.4.0
3%define pkg_release 1%{?_dist_release}
4
5%define gui   1
6%define sound 1
7
8
9Summary:     GNU Octave -- a high-level language for numerical computations
10Summary(ja): 数値計算のための高級言語
11Name:        %{pkg_name}
12Version:     %{pkg_version}
13Release:     %{pkg_release}
14
15License: GPLv3
16Group:   Applications/Edutainment
17URL:     http://www.gnu.org/software/octave/
18Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires: gcc-gfortran
23BuildRequires: bison flex gperf texinfo less
24BuildRequires: gnuplot
25BuildRequires: ghostscript-devel
26BuildRequires: mesa-libOSMesa-devel
27BuildRequires: blas-devel lapack-devel
28BuildRequires: pcre-devel
29BuildRequires: readline-devel
30BuildRequires: arpack
31BuildRequires: curl-devel
32BuildRequires: fftw3-devel
33BuildRequires: fontconfig-devel
34BuildRequires: freetype-devel
35BuildRequires: glpk-devel
36BuildRequires: GraphicsMagick-c++-devel
37BuildRequires: hdf5-devel
38BuildRequires: java-devel
39BuildRequires: qhull-devel
40BuildRequires: qrupdate
41BuildRequires: suitesparse-devel
42BuildRequires: zlib-devel
43BuildRequires: xz-devel
44BuildRequires: libtool-ltdl-devel
45BuildRequires: libXext-devel
46BuildRequires: openssl-devel
47%if %{gui}
48BuildRequires: desktop-file-utils
49BuildRequires: freeglut-devel
50BuildRequires: fltk-devel
51BuildRequires: gl2ps-devel
52BuildRequires: qt4-devel
53BuildRequires: qscintilla-devel
54%endif
55%if %{sound}
56BuildRequires: portaudio-devel
57BuildRequires: libsndfile-devel
58%endif
59BuildRequires: lzip
60
61Requires: ghostscript
62Requires: blas lapack
63Requires: pcre
64Requires: readline
65Requires: mesa-libOSMesa
66Requires: gnuplot
67Requires: arpack
68Requires: curl
69Requires: fftw3
70Requires: fontconfig
71Requires: freetype
72Requires: glpk
73Requires: GraphicsMagick-c++
74Requires: hdf5
75Requires: qhull
76Requires: qrupdate
77Requires: suitesparse
78Requires: zlib
79Requires: openssl
80Requires: pstoedit epstool transfig
81%if %{gui}
82Requires: freeglut
83Requires: fltk
84Requires: gl2ps
85Requires: qt4
86Requires: qscintilla
87%endif
88%if %{sound}
89Requires: portaudio
90Requires: libsndfile
91%endif
92
93Requires(post):   /sbin/install-info
94Requires(postun): /sbin/ldconfig
95Requires(post):   /sbin/ldconfig
96Requires(preun):  /sbin/install-info
97
98Vendor: Project Vine
99Distribution: Vine Linux
100Packager: ara_t
101
102
103%description
104GNU Octave is a high-level language, primarily intended for numerical
105computations. It provides a convenient command line interface for
106solving linear and nonlinear problems numerically, and for performing
107other numerical experiments using a language that is mostly compatible
108with Matlab. It may also be used as a batch-oriented language.
109
110Octave has extensive tools for solving common numerical linear algebra
111problems, finding the roots of nonlinear equations, integrating
112ordinary functions, manipulating polynomials, and integrating ordinary
113differential and differential-algebraic equations. It is easily
114extensible and customizable via user-defined functions written in
115Octave's own language, or using dynamically loaded modules written in
116C++, C, Fortran, or other languages.
117# '
118
119%description -l ja
120GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
121問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
122を行うための使いやすいコマンドライン・インタフェースを備えています。
123バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
124一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
125行うことができます。
126Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
127書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
128
129%if %{gui}
130(注意)
131デフォルトではグラフの描画にOpenGL/fltkを使用してます。
132もし不安定な場合には、
133gnuplotをデフォルトとするために ~/.octaverc に
134graphics_toolkit("gnuplot");
135を追加してから起動して下さい。
136%endif
137
138
139%prep
140%{__rm} -rf ${RPM_BUILD_ROOT}
141%setup -q
142
143%build
144%{configure} \
145 CPPFLAGS="-I%{_includedir}/pcre" \
146 --with-x \
147 --with-magick=GraphicsMagick \
148 --with-curl-includedir=%{_includedir}/curl \
149 --with-glpk-includedir=%{_includedir}/glpk \
150 --with-qhull-includedir=%{_includedir}/qhull \
151 --with-amd-includedir=%{_includedir}/suitesparse \
152 --with-camd-includedir=%{_includedir}/suitesparse \
153 --with-colamd-includedir=%{_includedir}/suitesparse \
154 --with-ccolamd-includedir=%{_includedir}/suitesparse \
155 --with-cholmod-includedir=%{_includedir}/suitesparse \
156 --with-cxsparse-includedir=%{_includedir}/suitesparse \
157 --with-umfpack-includedir=%{_includedir}/suitesparse \
158 --enable-java \
159%if !%{gui}
160 --disable-gui \
161 --without-opengl \
162 --without-fltk \
163%endif
164%if !%{sound}
165 --without-sndfile --without-portaudio \
166%endif
167
168%{__make} %{?_smp_mflags}
169
170
171%install
172%{make_install}
173
174find %{buildroot} -name "*.oct" | xargs strip
175
176# Make library links
177%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
178echo "%{_libdir}/octave-%{version}" > \
179     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
180
181%if %{gui}
182# desktop file
183%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
184 ${RPM_BUILD_ROOT}%{_datadir}/applications/org.octave.Octave.desktop
185%endif
186
187
188%check
189%{__make} %{?_smp_mflags} check
190
191%clean
192%{__rm} -rf ${RPM_BUILD_ROOT}
193
194
195%post -p %{_syssbindir}/ldconfig
196
197%postun -p %{_syssbindir}/ldconfig
198
199
200%files
201%defattr(-,root,root)
202%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
203%doc examples doc/interpreter/octave.pdf doc/refcard
204%config(noreplace) /etc/ld.so.conf.d/
205%{_bindir}/
206%{_libdir}/octave
207%{_includedir}/octave-%{version}
208%if %{gui}
209%{_datadir}/applications/
210%endif
211%{_datadir}/icons/
212%{_datadir}/metainfo/
213%{_datadir}/octave
214%{_libexecdir}/octave
215
216
217%changelog
218* Sun May 20 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-1
219- update to 4.4.0
220- correct License
221
222* Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
223- update to 4.2.2
224
225* Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
226- rebuild under glpk-4.63
227
228* Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
229- update to 4.2.1
230
231* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
232- update to 4.2.0
233- add make check
234- add BuildRequires: lzip
235- change BuildRequires: java-devel
236
237* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
238- update to 4.0.3
239- change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
240
241* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
242- update to 4.0.2
243- add BuildRequires: openssl-devel
244- add Requires: openssl
245
246* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
247- update to 4.0.1
248- change dependencies
249
250* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
251- [BTS:0002801] add configure option --with-magick=Magick
252- delete BuildRequires: texlive-collection-texinfo
253- add BuildRequires: texlive-collection-plainextra
254- add BuildRequires: texlive-collection-latexextra
255- add BuildRequires: texlive-collection-fontsrecommended
256-   for VineSeed
257
258* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
259- update to 3.6.4
260- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
261
262* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
263- delete octave from menu (programming)
264
265* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
266- update to 3.6.2
267- correct spec file for version 3.6.2
268- add BuildRequires: pcre-devel fltk-devel
269- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
270- add BuildRequires: gcc-gfortran
271- add BuildRequires: texlive texlive-common texlive-collection-basic
272- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
273- chanfe Group to Applications/Edutainment
274
275* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
276- update to 3.0.2
277- applied new versioning policy, spec in utf-8
278
279* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
280- update to 3.0.0
281
282* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
283- rebuilt for VineSeed
284
285* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
286- update to 2.9.13
287- rebuilt with new toolchain and environment
288
289* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
290- update to 2.0.17
291- rebuild with new toolchains
292- add BuildRequires: gcc295, gcc295-c++
293
294* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
295- ver.up
296
297* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
298- build for Vine Linux 2.1
299
300* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
301- automatically added BuildRequires
302
303* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
304- Macros, BM, add multiple icons sizes
305
306* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
307- strip oct file
308- add menu entry
309 
310* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
311- corrected for new groups
312
313* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
314- mandrake build
315- v2.0.16
316
317* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
318- update to 2.0.13.90
319
320* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
321- repackage in powertools.
322
323* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
324- Add %attr, build as user.
325
326* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
327- Add BuildRoot, installinfo, require gnuplot, description from
328  Octave's web page, update to Octave 2.0.13.
329- Adapt from existing spec file.
330
331* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
332- removed libreadline stuff from the file list
333
334* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
335- changed configure command to put things in $RPM_ARCH-rehat-linux,
336  rather than genereated one... was causing problems between building
337  on i686 build machine.
338
339* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
340- moved buildroot from /tmp to /var/tmp
341
342* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
343- Upgraded to version 2.0.9 and built for glibc system
344
345* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
346- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.