source: projects/specs/trunk/o/octave/octave-vl.spec @ 10184

Revision 10184, 10.0 KB checked in by ara_t, 8 years ago (diff)

update to 4.0.1

Line 
1%define pkg_name    octave
2%define pkg_version 4.0.1
3%define pkg_release 1%{?_dist_release}
4
5%define gui   1
6%define sound 1
7
8%if %{?_dist_release} == "vl6"
9%define openjdk_ver 1.6.0
10%endif
11%if %{?_dist_release} == "vl7"
12%define openjdk_ver 1.7.0
13%endif
14
15
16Summary:     GNU Octave -- a high-level language for numerical computations
17Summary(ja): 数値計算のための高級言語
18Name:        %{pkg_name}
19Version:     %{pkg_version}
20Release:     %{pkg_release}
21
22License: GPL
23Group:   Applications/Edutainment
24URL:     http://www.gnu.org/software/octave/
25Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.gz
26
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28
29BuildRequires: gcc-gfortran
30BuildRequires: bison flex gperf texinfo less
31BuildRequires: gnuplot
32BuildRequires: ghostscript-devel
33BuildRequires: mesa-libOSMesa-devel
34BuildRequires: librsvg2
35BuildRequires: blas-devel lapack-devel
36BuildRequires: pcre-devel
37BuildRequires: readline-devel
38BuildRequires: arpack
39BuildRequires: curl-devel
40BuildRequires: fftw3-devel
41BuildRequires: fontconfig-devel
42BuildRequires: freetype-devel
43BuildRequires: glpk-devel
44BuildRequires: GraphicsMagick-c++-devel
45BuildRequires: hdf5-devel
46BuildRequires: java-%{openjdk_ver}-openjdk-devel
47BuildRequires: qhull-devel
48BuildRequires: qrupdate
49BuildRequires: suitesparse-devel
50BuildRequires: zlib-devel
51BuildRequires: xz-devel
52BuildRequires: libtool-ltdl-devel
53BuildRequires: libXext-devel
54%if %{gui}
55BuildRequires: desktop-file-utils
56BuildRequires: freeglut-devel
57BuildRequires: fltk-devel
58BuildRequires: gl2ps-devel
59BuildRequires: qt4-devel
60BuildRequires: qscintilla-devel
61%endif
62%if %{sound}
63BuildRequires: portaudio-devel
64BuildRequires: libsndfile-devel
65%endif
66
67Requires: ghostscript
68Requires: blas lapack
69Requires: pcre
70Requires: readline
71Requires: mesa-libOSMesa
72Requires: gnuplot
73Requires: arpack
74Requires: curl
75Requires: fftw3
76Requires: fontconfig
77Requires: freetype
78Requires: glpk
79Requires: GraphicsMagick-c++
80Requires: hdf5
81Requires: qhull
82Requires: qrupdate
83Requires: suitesparse
84Requires: zlib
85Requires: pstoedit epstool transfig
86%if %{gui}
87Requires: freeglut
88Requires: fltk
89Requires: gl2ps
90Requires: qt4
91Requires: qscintilla
92%endif
93%if %{sound}
94Requires: portaudio
95Requires: libsndfile
96%endif
97
98Requires(post):   /sbin/install-info
99Requires(postun): /sbin/ldconfig
100Requires(post):   /sbin/ldconfig
101Requires(preun):  /sbin/install-info
102
103Vendor: Project Vine
104Distribution: Vine Linux
105Packager: ara_t
106
107
108%description
109GNU Octave is a high-level language, primarily intended for numerical
110computations. It provides a convenient command line interface for
111solving linear and nonlinear problems numerically, and for performing
112other numerical experiments using a language that is mostly compatible
113with Matlab. It may also be used as a batch-oriented language.
114
115Octave has extensive tools for solving common numerical linear algebra
116problems, finding the roots of nonlinear equations, integrating
117ordinary functions, manipulating polynomials, and integrating ordinary
118differential and differential-algebraic equations. It is easily
119extensible and customizable via user-defined functions written in
120Octave's own language, or using dynamically loaded modules written in
121C++, C, Fortran, or other languages.
122# '
123
124%description -l ja
125GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
126問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
127を行うための使いやすいコマンドライン・インタフェースを備えています。
128バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
129一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
130行うことができます。
131Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
132書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
133
134%if %{gui}
135(注意)
136デフォルトではグラフの描画にOpenGL/fltkを使用してます。
137もし不安定な場合には、
138gnuplotをデフォルトとするために ~/.octaverc に
139graphics_toolkit("gnuplot");
140を追加してから起動して下さい。
141%endif
142
143
144%prep
145%{__rm} -rf ${RPM_BUILD_ROOT}
146%setup -q
147
148%build
149%{configure} \
150 CPPFLAGS="-I%{_includedir}/pcre" \
151 --with-x \
152 --with-magick=GraphicsMagick \
153 --with-curl-includedir=%{_includedir}/curl \
154 --with-glpk-includedir=%{_includedir}/glpk \
155 --with-qhull-includedir=%{_includedir}/qhull \
156 --with-amd-includedir=%{_includedir}/suitesparse \
157 --with-camd-includedir=%{_includedir}/suitesparse \
158 --with-colamd-includedir=%{_includedir}/suitesparse \
159 --with-ccolamd-includedir=%{_includedir}/suitesparse \
160 --with-cholmod-includedir=%{_includedir}/suitesparse \
161 --with-cxsparse-includedir=%{_includedir}/suitesparse \
162 --with-umfpack-includedir=%{_includedir}/suitesparse \
163 --enable-java \
164%if !%{gui}
165 --disable-gui \
166 --without-opengl \
167 --without-fltk \
168%endif
169%if !%{sound}
170 --without-sndfile --without-portaudio \
171%endif
172
173%{__make} %{?_smp_mflags}
174# %{__make} check
175
176%install
177%{make_install}
178%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
179
180find %{buildroot} -name "*.oct" | xargs strip
181
182# Make library links
183%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
184echo "%{_libdir}/octave-%{version}" > \
185     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
186
187%if %{gui}
188# Create desktop file
189%{__mv} \
190 ${RPM_BUILD_ROOT}%{_datadir}/applications/www.octave.org-octave.desktop \
191 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
192%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
193 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
194%endif
195
196# rename %{_datadir}/appdata/*
197%{__mv} \
198 ${RPM_BUILD_ROOT}%{_datadir}/appdata/www.octave.org-octave.appdata.xml \
199 ${RPM_BUILD_ROOT}%{_datadir}/appdata/octave.appdata.xml
200
201%clean
202%{__rm} -rf ${RPM_BUILD_ROOT}
203
204%post
205%{_syssbindir}/ldconfig
206/sbin/install-info --info-dir=%{_infodir} --section="Programming" \
207                   %{_infodir}/octave.info || :
208
209%preun
210if [ "$1" = "0" ]; then
211    /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/octave.info || :
212fi
213
214%postun -p %{_syssbindir}/ldconfig
215
216
217%files
218%defattr(-,root,root)
219%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
220%doc examples doc/interpreter/octave.p* doc/refcard
221%config(noreplace) /etc/ld.so.conf.d/
222%{_bindir}/
223%{_libdir}/octave
224%{_includedir}/octave-%{version}
225%{_datadir}/appdata/
226%if %{gui}
227%{_datadir}/applications/
228%endif
229%{_datadir}/icons/
230%{_datadir}/octave
231%{_libexecdir}/octave
232%{_mandir}/man*/*
233%{_infodir}/octave*
234%{_infodir}/liboctave.info*
235
236
237%changelog
238* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
239- update to 4.0.1
240- change dependencies
241
242* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
243- [BTS:0002801] add configure option --with-magick=Magick
244- delete BuildRequires: texlive-collection-texinfo
245- add BuildRequires: texlive-collection-plainextra
246- add BuildRequires: texlive-collection-latexextra
247- add BuildRequires: texlive-collection-fontsrecommended
248-   for VineSeed
249
250* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
251- update to 3.6.4
252- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
253
254* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
255- delete octave from menu (programming)
256
257* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
258- update to 3.6.2
259- correct spec file for version 3.6.2
260- add BuildRequires: pcre-devel fltk-devel
261- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
262- add BuildRequires: gcc-gfortran
263- add BuildRequires: texlive texlive-common texlive-collection-basic
264- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
265- chanfe Group to Applications/Edutainment
266
267* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
268- update to 3.0.2
269- applied new versioning policy, spec in utf-8
270
271* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
272- update to 3.0.0
273
274* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
275- rebuilt for VineSeed
276
277* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
278- update to 2.9.13
279- rebuilt with new toolchain and environment
280
281* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
282- update to 2.0.17
283- rebuild with new toolchains
284- add BuildRequires: gcc295, gcc295-c++
285
286* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
287- ver.up
288
289* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
290- build for Vine Linux 2.1
291
292* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
293- automatically added BuildRequires
294
295* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
296- Macros, BM, add multiple icons sizes
297
298* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
299- strip oct file
300- add menu entry
301 
302* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
303- corrected for new groups
304
305* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
306- mandrake build
307- v2.0.16
308
309* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
310- update to 2.0.13.90
311
312* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
313- repackage in powertools.
314
315* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
316- Add %attr, build as user.
317
318* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
319- Add BuildRoot, installinfo, require gnuplot, description from
320  Octave's web page, update to Octave 2.0.13.
321- Adapt from existing spec file.
322
323* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
324- removed libreadline stuff from the file list
325
326* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
327- changed configure command to put things in $RPM_ARCH-rehat-linux,
328  rather than genereated one... was causing problems between building
329  on i686 build machine.
330
331* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
332- moved buildroot from /tmp to /var/tmp
333
334* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
335- Upgraded to version 2.0.9 and built for glibc system
336
337* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
338- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.