source: projects/specs/trunk/o/octave/octave-vl.spec @ 10279

Revision 10279, 10.1 KB checked in by ara_t, 8 years ago (diff)

update to 4.0.2

Line 
1%define pkg_name    octave
2%define pkg_version 4.0.2
3%define pkg_release 1%{?_dist_release}
4
5%define gui   1
6%define sound 1
7
8%if %{?_dist_release} == "vl6"
9%define openjdk_ver 1.6.0
10%endif
11%if %{?_dist_release} == "vl7"
12%define openjdk_ver 1.7.0
13%endif
14
15
16Summary:     GNU Octave -- a high-level language for numerical computations
17Summary(ja): 数値計算のための高級言語
18Name:        %{pkg_name}
19Version:     %{pkg_version}
20Release:     %{pkg_release}
21
22License: GPL
23Group:   Applications/Edutainment
24URL:     http://www.gnu.org/software/octave/
25Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.gz
26
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28
29BuildRequires: gcc-gfortran
30BuildRequires: bison flex gperf texinfo less
31BuildRequires: gnuplot
32BuildRequires: ghostscript-devel
33BuildRequires: mesa-libOSMesa-devel
34BuildRequires: blas-devel lapack-devel
35BuildRequires: pcre-devel
36BuildRequires: readline-devel
37BuildRequires: arpack
38BuildRequires: curl-devel
39BuildRequires: fftw3-devel
40BuildRequires: fontconfig-devel
41BuildRequires: freetype-devel
42BuildRequires: glpk-devel
43BuildRequires: GraphicsMagick-c++-devel
44BuildRequires: hdf5-devel
45BuildRequires: java-%{openjdk_ver}-openjdk-devel
46BuildRequires: qhull-devel
47BuildRequires: qrupdate
48BuildRequires: suitesparse-devel
49BuildRequires: zlib-devel
50BuildRequires: xz-devel
51BuildRequires: libtool-ltdl-devel
52BuildRequires: libXext-devel
53BuildRequires: openssl-devel
54%if %{gui}
55BuildRequires: desktop-file-utils
56BuildRequires: freeglut-devel
57BuildRequires: fltk-devel
58BuildRequires: gl2ps-devel
59BuildRequires: qt4-devel
60BuildRequires: qscintilla-devel
61%endif
62%if %{sound}
63BuildRequires: portaudio-devel
64BuildRequires: libsndfile-devel
65%endif
66
67Requires: ghostscript
68Requires: blas lapack
69Requires: pcre
70Requires: readline
71Requires: mesa-libOSMesa
72Requires: gnuplot
73Requires: arpack
74Requires: curl
75Requires: fftw3
76Requires: fontconfig
77Requires: freetype
78Requires: glpk
79Requires: GraphicsMagick-c++
80Requires: hdf5
81Requires: qhull
82Requires: qrupdate
83Requires: suitesparse
84Requires: zlib
85Requires: openssl
86Requires: pstoedit epstool transfig
87%if %{gui}
88Requires: freeglut
89Requires: fltk
90Requires: gl2ps
91Requires: qt4
92Requires: qscintilla
93%endif
94%if %{sound}
95Requires: portaudio
96Requires: libsndfile
97%endif
98
99Requires(post):   /sbin/install-info
100Requires(postun): /sbin/ldconfig
101Requires(post):   /sbin/ldconfig
102Requires(preun):  /sbin/install-info
103
104Vendor: Project Vine
105Distribution: Vine Linux
106Packager: ara_t
107
108
109%description
110GNU Octave is a high-level language, primarily intended for numerical
111computations. It provides a convenient command line interface for
112solving linear and nonlinear problems numerically, and for performing
113other numerical experiments using a language that is mostly compatible
114with Matlab. It may also be used as a batch-oriented language.
115
116Octave has extensive tools for solving common numerical linear algebra
117problems, finding the roots of nonlinear equations, integrating
118ordinary functions, manipulating polynomials, and integrating ordinary
119differential and differential-algebraic equations. It is easily
120extensible and customizable via user-defined functions written in
121Octave's own language, or using dynamically loaded modules written in
122C++, C, Fortran, or other languages.
123# '
124
125%description -l ja
126GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
127問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
128を行うための使いやすいコマンドライン・インタフェースを備えています。
129バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
130一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
131行うことができます。
132Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
133書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
134
135%if %{gui}
136(注意)
137デフォルトではグラフの描画にOpenGL/fltkを使用してます。
138もし不安定な場合には、
139gnuplotをデフォルトとするために ~/.octaverc に
140graphics_toolkit("gnuplot");
141を追加してから起動して下さい。
142%endif
143
144
145%prep
146%{__rm} -rf ${RPM_BUILD_ROOT}
147%setup -q
148
149%build
150%{configure} \
151 CPPFLAGS="-I%{_includedir}/pcre" \
152 --with-x \
153 --with-magick=GraphicsMagick \
154 --with-curl-includedir=%{_includedir}/curl \
155 --with-glpk-includedir=%{_includedir}/glpk \
156 --with-qhull-includedir=%{_includedir}/qhull \
157 --with-amd-includedir=%{_includedir}/suitesparse \
158 --with-camd-includedir=%{_includedir}/suitesparse \
159 --with-colamd-includedir=%{_includedir}/suitesparse \
160 --with-ccolamd-includedir=%{_includedir}/suitesparse \
161 --with-cholmod-includedir=%{_includedir}/suitesparse \
162 --with-cxsparse-includedir=%{_includedir}/suitesparse \
163 --with-umfpack-includedir=%{_includedir}/suitesparse \
164 --enable-java \
165%if !%{gui}
166 --disable-gui \
167 --without-opengl \
168 --without-fltk \
169%endif
170%if !%{sound}
171 --without-sndfile --without-portaudio \
172%endif
173
174%{__make} %{?_smp_mflags}
175# %{__make} check
176
177%install
178%{make_install}
179%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
180
181find %{buildroot} -name "*.oct" | xargs strip
182
183# Make library links
184%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
185echo "%{_libdir}/octave-%{version}" > \
186     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
187
188%if %{gui}
189# Create desktop file
190%{__mv} \
191 ${RPM_BUILD_ROOT}%{_datadir}/applications/www.octave.org-octave.desktop \
192 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
193%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
194 ${RPM_BUILD_ROOT}%{_datadir}/applications/octave.desktop
195%endif
196
197# rename %{_datadir}/appdata/*
198%{__mv} \
199 ${RPM_BUILD_ROOT}%{_datadir}/appdata/www.octave.org-octave.appdata.xml \
200 ${RPM_BUILD_ROOT}%{_datadir}/appdata/octave.appdata.xml
201
202%clean
203%{__rm} -rf ${RPM_BUILD_ROOT}
204
205%post
206%{_syssbindir}/ldconfig
207/sbin/install-info --info-dir=%{_infodir} --section="Programming" \
208                   %{_infodir}/octave.info.gz || :
209
210%preun
211if [ "$1" = "0" ]; then
212    /sbin/install-info --delete --info-dir=%{_infodir} \
213                       %{_infodir}/octave.info.gz || :
214fi
215
216%postun -p %{_syssbindir}/ldconfig
217
218
219%files
220%defattr(-,root,root)
221%doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
222%doc examples doc/interpreter/octave.p* doc/refcard
223%config(noreplace) /etc/ld.so.conf.d/
224%{_bindir}/
225%{_libdir}/octave
226%{_includedir}/octave-%{version}
227%{_datadir}/appdata/
228%if %{gui}
229%{_datadir}/applications/
230%endif
231%{_datadir}/icons/
232%{_datadir}/octave
233%{_libexecdir}/octave
234%{_mandir}/man*/*
235%{_infodir}/octave*
236%{_infodir}/liboctave.info*
237
238
239%changelog
240* Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
241- update to 4.0.2
242- add BuildRequires: openssl-devel
243- add Requires: openssl
244
245* Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
246- update to 4.0.1
247- change dependencies
248
249* Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
250- [BTS:0002801] add configure option --with-magick=Magick
251- delete BuildRequires: texlive-collection-texinfo
252- add BuildRequires: texlive-collection-plainextra
253- add BuildRequires: texlive-collection-latexextra
254- add BuildRequires: texlive-collection-fontsrecommended
255-   for VineSeed
256
257* Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
258- update to 3.6.4
259- add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
260
261* Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
262- delete octave from menu (programming)
263
264* Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
265- update to 3.6.2
266- correct spec file for version 3.6.2
267- add BuildRequires: pcre-devel fltk-devel
268- add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
269- add BuildRequires: gcc-gfortran
270- add BuildRequires: texlive texlive-common texlive-collection-basic
271- add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
272- chanfe Group to Applications/Edutainment
273
274* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
275- update to 3.0.2
276- applied new versioning policy, spec in utf-8
277
278* Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
279- update to 3.0.0
280
281* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
282- rebuilt for VineSeed
283
284* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
285- update to 2.9.13
286- rebuilt with new toolchain and environment
287
288* Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
289- update to 2.0.17
290- rebuild with new toolchains
291- add BuildRequires: gcc295, gcc295-c++
292
293* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
294- ver.up
295
296* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
297- build for Vine Linux 2.1
298
299* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
300- automatically added BuildRequires
301
302* Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
303- Macros, BM, add multiple icons sizes
304
305* Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
306- strip oct file
307- add menu entry
308 
309* Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
310- corrected for new groups
311
312* Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
313- mandrake build
314- v2.0.16
315
316* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
317- update to 2.0.13.90
318
319* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
320- repackage in powertools.
321
322* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
323- Add %attr, build as user.
324
325* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
326- Add BuildRoot, installinfo, require gnuplot, description from
327  Octave's web page, update to Octave 2.0.13.
328- Adapt from existing spec file.
329
330* Tue Dec  2 1997 Otto Hammersmith <otto@redhat.com>
331- removed libreadline stuff from the file list
332
333* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
334- changed configure command to put things in $RPM_ARCH-rehat-linux,
335  rather than genereated one... was causing problems between building
336  on i686 build machine.
337
338* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
339- moved buildroot from /tmp to /var/tmp
340
341* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
342- Upgraded to version 2.0.9 and built for glibc system
343
344* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
345- Updated to version 2.0.5 and changed to build using a BuildRoot
Note: See TracBrowser for help on using the repository browser.