source: projects/specs/trunk/nonfree/self-build-x265/x265-vl.spec @ 9368

Revision 9368, 3.5 KB checked in by munepi, 9 years ago (diff)

self-build-x265: rebuild

Line 
1%global commit 9f0324125f53
2
3Summary: H.265/HEVC encoder library
4Name: x265
5Version: 1.5
6Release: 2%{?_dist_release}
7Group: System Environment/Libraries
8URL: http://x265.org/
9Source0: https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
10# fix pkgconfig file installation path
11#Patch0: x265-pc-path.patch
12# link test binaries with shared library
13Patch1: x265-1.5-test-shared.patch
14# build with -fPIC on arm and i686, too
15Patch2: x265-pic.patch
16# source/Lib/TLibCommon - BSD
17# source/Lib/TLibEncoder - BSD
18# everything else - GPLv2+
19License: GPLv2+ and BSD
20BuildRequires: cmake
21BuildRequires: yasm
22
23%description
24The primary objective of x265 is to become the best H.265/HEVC encoder
25available anywhere, offering the highest compression efficiency and the
26highest performance on a wide variety of hardware platforms.
27
28This package contains the command line encoder and the shared library.
29
30%package devel
31Summary: H.265/HEVC encoder library development files
32Requires: %{name}%{?_isa} = %{version}-%{release}
33
34%description devel
35The primary objective of x265 is to become the best H.265/HEVC encoder
36available anywhere, offering the highest compression efficiency and the
37highest performance on a wide variety of hardware platforms.
38
39This package contains the shared library development files.
40
41%prep
42%setup -q -n multicoreware-%{name}-%{commit}
43#%patch0 -p1 -b .p
44# tests are crashing on x86 if linked against shared libx265
45%ifnarch i686
46%patch1 -p1 -b .ts
47%endif
48%patch2 -p1 -b .pic
49
50# f=doc/uncrustify/drag-uncrustify.bat
51# tr -d '\r' < ${f} > ${f}.unix && \
52# touch -r ${f} ${f}.unix && \
53# %__mv ${f}.unix ${f} || exit 1
54
55%build
56%cmake -G "Unix Makefiles" \
57 -DCMAKE_SKIP_RPATH:BOOL=YES \
58 -DENABLE_TESTS:BOOL=ON \
59 source
60%__make %{?_smp_mflags}
61
62%install
63%__make DESTDIR=%{buildroot} install
64%__rm %{buildroot}%{_libdir}/libx265.a || exit 1
65# %__install -Dpm644 COPYING %{buildroot}%{_pkgdocdir}/COPYING
66
67%check
68#LD_LIBRARY_PATH=$(pwd) test/PoolTest
69LD_LIBRARY_PATH=$(pwd) test/TestBench
70
71exit 0
72
73%post -p /sbin/ldconfig
74
75%postun -p /sbin/ldconfig
76
77%files
78%{_bindir}/x265
79# %dir %{_pkgdocdir}
80# %{_pkgdocdir}/COPYING
81%doc COPYING
82%{_libdir}/libx265.so.43
83
84%files devel
85%doc doc/*
86%{_includedir}/x265.h
87%{_includedir}/x265_config.h
88%{_libdir}/libx265.so
89%{_libdir}/pkgconfig/x265.pc
90
91%changelog
92* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-2
93- rebuild
94
95* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-1
96- new upstream release (ABI 43)
97- drop x265-pc-path.patch
98- add x265-1.5-test-shared.patch
99
100* Sat Feb  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
101- added Group tag to Source0
102
103* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
104- new upstream release (ABI 35)
105- initial build based on RPM Fusion rawhide
106
107* Sun Aug 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-5
108- don't include contributor agreement in doc
109- make sure /usr/share/doc/x265 is owned
110- add a comment noting which files are BSD-licenced
111
112* Fri Aug 08 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-4
113- don't create bogus soname (patch by Xavier)
114
115* Thu Jul 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-3
116- fix tr call to remove DOS EOL
117- build the library with -fPIC on arm and i686, too
118
119* Sun Jul 13 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-2
120- use version in source URL
121- update License tag
122- fix EOL in drag-uncrustify.bat
123- don't link test binaries with shared binary on x86 (segfault)
124
125* Thu Jul 10 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-1
126- initial build
127- fix pkgconfig file install location
128- link test binaries with shared library
Note: See TracBrowser for help on using the repository browser.