source: projects/specs/trunk/nonfree/self-build-x265/x265-vl.spec @ 9367

Revision 9367, 3.3 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%global commit 9f0324125f53
2
3Summary: H.265/HEVC encoder library
4Name: x265
5Version: 1.5
6Release: 1%{?_dist_release}
7URL: http://x265.org/
8Source0: https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
9# fix pkgconfig file installation path
10#Patch0: x265-pc-path.patch
11# link test binaries with shared library
12Patch1: x265-1.5-test-shared.patch
13# build with -fPIC on arm and i686, too
14Patch2: x265-pic.patch
15# source/Lib/TLibCommon - BSD
16# source/Lib/TLibEncoder - BSD
17# everything else - GPLv2+
18License: GPLv2+ and BSD
19BuildRequires: cmake
20BuildRequires: yasm
21
22%description
23The primary objective of x265 is to become the best H.265/HEVC encoder
24available anywhere, offering the highest compression efficiency and the
25highest performance on a wide variety of hardware platforms.
26
27This package contains the command line encoder and the shared library.
28
29%package devel
30Summary: H.265/HEVC encoder library development files
31Requires: %{name}%{?_isa} = %{version}-%{release}
32
33%description devel
34The primary objective of x265 is to become the best H.265/HEVC encoder
35available anywhere, offering the highest compression efficiency and the
36highest performance on a wide variety of hardware platforms.
37
38This package contains the shared library development files.
39
40%prep
41%setup -q -n multicoreware-%{name}-%{commit}
42#%patch0 -p1 -b .p
43# tests are crashing on x86 if linked against shared libx265
44%ifnarch i686
45%patch1 -p1 -b .ts
46%endif
47%patch2 -p1 -b .pic
48
49# f=doc/uncrustify/drag-uncrustify.bat
50# tr -d '\r' < ${f} > ${f}.unix && \
51# touch -r ${f} ${f}.unix && \
52# %__mv ${f}.unix ${f} || exit 1
53
54%build
55%cmake -G "Unix Makefiles" \
56 -DCMAKE_SKIP_RPATH:BOOL=YES \
57 -DENABLE_TESTS:BOOL=ON \
58 source
59%__make %{?_smp_mflags}
60
61%install
62%__make DESTDIR=%{buildroot} install
63%__rm %{buildroot}%{_libdir}/libx265.a || exit 1
64# %__install -Dpm644 COPYING %{buildroot}%{_pkgdocdir}/COPYING
65
66%check
67#LD_LIBRARY_PATH=$(pwd) test/PoolTest
68LD_LIBRARY_PATH=$(pwd) test/TestBench
69
70exit 0
71
72%post -p /sbin/ldconfig
73
74%postun -p /sbin/ldconfig
75
76%files
77%{_bindir}/x265
78# %dir %{_pkgdocdir}
79# %{_pkgdocdir}/COPYING
80%doc COPYING
81%{_libdir}/libx265.so.43
82
83%files devel
84%doc doc/*
85%{_includedir}/x265.h
86%{_includedir}/x265_config.h
87%{_libdir}/libx265.so
88%{_libdir}/pkgconfig/x265.pc
89
90%changelog
91* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-1
92- new upstream release (ABI 43)
93- drop x265-pc-path.patch
94- add x265-1.5-test-shared.patch
95
96* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
97- new upstream release (ABI 35)
98- initial build based on RPM Fusion rawhide
99
100* Sun Aug 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-5
101- don't include contributor agreement in doc
102- make sure /usr/share/doc/x265 is owned
103- add a comment noting which files are BSD-licenced
104
105* Fri Aug 08 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-4
106- don't create bogus soname (patch by Xavier)
107
108* Thu Jul 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-3
109- fix tr call to remove DOS EOL
110- build the library with -fPIC on arm and i686, too
111
112* Sun Jul 13 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-2
113- use version in source URL
114- update License tag
115- fix EOL in drag-uncrustify.bat
116- don't link test binaries with shared binary on x86 (segfault)
117
118* Thu Jul 10 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-1
119- initial build
120- fix pkgconfig file install location
121- link test binaries with shared library
Note: See TracBrowser for help on using the repository browser.