source: projects/specs/trunk/nonfree/self-build-x265/x265-vl.spec @ 9335

Revision 9335, 3.5 KB checked in by inagaki, 9 years ago (diff)

2015-02-07 Ryoichi INAGAKI <ryo1@…>

  • self-build-x265: added Group tag to x265-vl.spec


Line 
1%global commit 5e604833c5aa
2
3Summary: H.265/HEVC encoder library
4Summary(ja): H.265/HEVC エンコーダライブラリ
5Name: x265
6Version: 1.4
7Release: 2%{?_dist_release}
8Group: System Environment/Libraries
9URL: http://x265.org/
10Source0: https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
11# fix pkgconfig file installation path
12Patch0: x265-pc-path.patch
13# link test binaries with shared library
14Patch1: x265-test-shared.patch
15# build with -fPIC on arm and i686, too
16Patch2: x265-pic.patch
17# source/Lib/TLibCommon - BSD
18# source/Lib/TLibEncoder - BSD
19# everything else - GPLv2+
20License: GPLv2+ and BSD
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: cmake
23BuildRequires: yasm
24
25%description
26The primary objective of x265 is to become the best H.265/HEVC encoder
27available anywhere, offering the highest compression efficiency and the
28highest performance on a wide variety of hardware platforms.
29
30This package contains the command line encoder and the shared library.
31
32%package devel
33Summary: H.265/HEVC encoder library development files
34Summary(ja): H.265/HEVC エンコーダライブラリの開発用ファイル
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37
38%description devel
39The primary objective of x265 is to become the best H.265/HEVC encoder
40available anywhere, offering the highest compression efficiency and the
41highest performance on a wide variety of hardware platforms.
42
43This package contains the shared library development files.
44
45%prep
46%setup -q -n multicoreware-%{name}-%{commit}
47%patch0 -p1 -b .p
48# tests are crashing on x86 if linked against shared libx265
49%ifnarch i686
50%patch1 -p1 -b .ts
51%endif
52%patch2 -p1 -b .pic
53
54# f=doc/uncrustify/drag-uncrustify.bat
55# tr -d '\r' < ${f} > ${f}.unix && \
56# touch -r ${f} ${f}.unix && \
57# %__mv ${f}.unix ${f} || exit 1
58
59%build
60%cmake -G "Unix Makefiles" \
61 -DCMAKE_SKIP_RPATH:BOOL=YES \
62 -DENABLE_TESTS:BOOL=ON \
63 source
64%__make %{?_smp_mflags}
65
66%install
67%__make DESTDIR=%{buildroot} install
68%__rm %{buildroot}%{_libdir}/libx265.a || exit 1
69# %__install -Dpm644 COPYING %{buildroot}%{_pkgdocdir}/COPYING
70
71%check
72LD_LIBRARY_PATH=$(pwd) test/PoolTest
73LD_LIBRARY_PATH=$(pwd) test/TestBench
74
75exit 0
76
77%post -p /sbin/ldconfig
78
79%postun -p /sbin/ldconfig
80
81%files
82%{_bindir}/x265
83# %dir %{_pkgdocdir}
84# %{_pkgdocdir}/COPYING
85%doc COPYING
86%{_libdir}/libx265.so.35
87
88%files devel
89%doc doc/*
90%{_includedir}/x265.h
91%{_includedir}/x265_config.h
92%{_libdir}/libx265.so
93%{_libdir}/pkgconfig/x265.pc
94
95%changelog
96* Sat Feb  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
97- added Group tag
98
99* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
100- new upstream release
101- initial build based on RPM Fusion rawhide
102
103* Sun Aug 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-5
104- don't include contributor agreement in doc
105- make sure /usr/share/doc/x265 is owned
106- add a comment noting which files are BSD-licenced
107
108* Fri Aug 08 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-4
109- don't create bogus soname (patch by Xavier)
110
111* Thu Jul 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-3
112- fix tr call to remove DOS EOL
113- build the library with -fPIC on arm and i686, too
114
115* Sun Jul 13 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-2
116- use version in source URL
117- update License tag
118- fix EOL in drag-uncrustify.bat
119- don't link test binaries with shared binary on x86 (segfault)
120
121* Thu Jul 10 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-1
122- initial build
123- fix pkgconfig file install location
124- link test binaries with shared library
Note: See TracBrowser for help on using the repository browser.