source: projects/specs/trunk/nonfree/self-build-x265/self-build-x265-vl.spec @ 9215

Revision 9215, 4.7 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%global commit 5e604833c5aa
2
3%global pkgname         x265
4%global name            self-build-%{pkgname}
5%global version         1.4
6%global release         1%{?_dist_release}
7
8%global sourceurl0      https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16
17Source100: x265-pc-path.patch
18Source101: x265-test-shared.patch
19Source102: x265-pic.patch
20
21License:        GPLv2+ and BSD
22Group:          Restricted Software
23
24Obsoletes:      x265 < %{version}, x265-devel < %{version}
25Obsoletes:      self-build-x265 < %{version}-%{release}
26
27Requires(post):         self-build-setup >= 0.9.9
28
29# (build)requies of target package.
30Requires(post): cmake
31Requires(post): yasm
32
33BuildArch:      noarch
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35
36Packager:       munepi
37
38%description
39The primary objective of x265 is to become the best H.265/HEVC encoder
40available anywhere, offering the highest compression efficiency and the
41highest performance on a wide variety of hardware platforms.
42
43If you install this package, it automaticaly downloads source
44code ,compile it, and create rpm packages of %{pkgname}-%{version}.
45And the created rpm packages are automatically installed
46if installation is executed by apt-get command or synaptic
47package manager.
48
49[Note]
50This package requires many other packages to compile
51targetsoftware. So it consume more disk space than usual.
52Also installation takes logner time because of compilation.
53(This will take a few minutes to quarter or half of an hour,
54depends on building environment)
55
56[About self-build package]
57For some kind of software, distributing of binary package
58may viorate the patent or law. Therefore we chose self-build
59packge, create binary package on your machine, for such kind
60of softwares instead of distributing binary package.
61
62Please obey the national law when you use the created binary
63packages. And if you want to use the softwares using patented
64thechnology, it may be required to get a permission, make an
65agreement or purchas a license. Please consider it with your
66purpose or way of use and take appropriate action.
67
68%description -l ja
69x265はH.265/HEVCをエンコードするためのライブラリです。
70
71このパッケージをインストールすると、自動的にソースコードを
72ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
73パッケージを作成します。
74また apt-get コマンドや synaptic パッケージマネージャから実行
75した場合は、作成された rpm パッケージのインストールも自動的に
76行います。
77
78[注意]
79コンパイルに必要な多くの関連パッケージを要求するので通常より
80ディスクの領域を多く消費します。
81またインストール時にコンパイルを行うため、通常より時間がかか
82る場合があります。(環境にもよりますが数分から数十分程度)
83
84[self-build パッケージについて]
85ソフトウェアによってはバイナリパッケージの配布が特許や法律に
86違反する可能性があるものがあります。その為、このような問題が
87懸念されるソフトウェアについてはバイナリパッケージを直接配布
88せずに、ユーザの環境でバイナリを作成する self-build パッケー
89ジという方法を採っています。
90
91作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
92アのライセンス、および利用する国の各種法令に従ってください。
93また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
94センスの購入などが必要となる場合がありますので、利用する目的
95や形態に応じて各自で判断し適切な対応を取ってください。
96
97%prep
98[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
99
100
101%install
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
104%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
105%{__install} -m 644 %{SOURCE100} %{SOURCE101} %{SOURCE102} \
106             ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
107
108%clean
109%{__rm} -rf ${RPM_BUILD_ROOT}
110
111%posttrans
112/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 24000
113/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
114                                 %{pkgname}-devel-%{version}-%{release}
115
116%files
117%defattr(-,root,root)
118%{_datadir}/%{name}
119
120%changelog
121* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
122- new upstream release
123- initial build based on RPM Fusion rawhide
Note: See TracBrowser for help on using the repository browser.