source: projects/specs/trunk/nonfree/self-build-x265/self-build-x265-vl.spec @ 12250

Revision 12250, 5.4 KB checked in by ara_t, 5 years ago (diff)

self-build-x265: update to 3.2

Line 
1%global pkgname  x265
2%global name     self-build-%{pkgname}
3%global version  3.2
4%global release  1%{?_dist_release}
5
6%global sourceurl0  http://ftp.videolan.org/pub/videolan/x265/x265_%{version}.tar.gz
7
8Summary:  Package to automatically build %{pkgname} rpm package
9Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:    %{name}
11Version: %{version}
12Release: %{release}
13Source0: %{pkgname}-vl.spec
14
15#Source100: x265-pc-path.patch
16Source101: x265-test-shared.patch
17Source104: x265-detect_cpu_armhfp.patch
18
19License: GPLv2+ and BSD
20Group:   Restricted Software
21
22Obsoletes: x265 < %{version}, x265-devel < %{version}
23Obsoletes: self-build-x265 < %{version}-%{release}
24
25Requires(post): self-build-setup >= 0.9.9
26
27# (build)requies of target package.
28Requires(post): cmake
29Requires(post): yasm
30
31BuildArch: noarch
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34Packager:  munepi
35
36%description
37The primary objective of x265 is to become the best H.265/HEVC encoder
38available anywhere, offering the highest compression efficiency and the
39highest performance on a wide variety of hardware platforms.
40
41If you install this package, it automaticaly downloads source
42code ,compile it, and create rpm packages of %{pkgname}-%{version}.
43And the created rpm packages are automatically installed
44if installation is executed by apt-get command or synaptic
45package manager.
46
47[Note]
48This package requires many other packages to compile
49targetsoftware. So it consume more disk space than usual.
50Also installation takes logner time because of compilation.
51(This will take a few minutes to quarter or half of an hour,
52depends on building environment)
53
54[About self-build package]
55For some kind of software, distributing of binary package
56may viorate the patent or law. Therefore we chose self-build
57packge, create binary package on your machine, for such kind
58of softwares instead of distributing binary package.
59
60Please obey the national law when you use the created binary
61packages. And if you want to use the softwares using patented
62thechnology, it may be required to get a permission, make an
63agreement or purchas a license. Please consider it with your
64purpose or way of use and take appropriate action.
65
66%description -l ja
67x265はH.265/HEVCをエンコードするためのライブラリです。
68
69このパッケージをインストールすると、自動的にソースコードを
70ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
71パッケージを作成します。
72また apt-get コマンドや synaptic パッケージマネージャから実行
73した場合は、作成された rpm パッケージのインストールも自動的に
74行います。
75
76[注意]
77コンパイルに必要な多くの関連パッケージを要求するので通常より
78ディスクの領域を多く消費します。
79またインストール時にコンパイルを行うため、通常より時間がかか
80る場合があります。(環境にもよりますが数分から数十分程度)
81
82[self-build パッケージについて]
83ソフトウェアによってはバイナリパッケージの配布が特許や法律に
84違反する可能性があるものがあります。その為、このような問題が
85懸念されるソフトウェアについてはバイナリパッケージを直接配布
86せずに、ユーザの環境でバイナリを作成する self-build パッケー
87ジという方法を採っています。
88
89作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
90アのライセンス、および利用する国の各種法令に従ってください。
91また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
92センスの購入などが必要となる場合がありますので、利用する目的
93や形態に応じて各自で判断し適切な対応を取ってください。
94
95%prep
96[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
97
98
99%install
100%{__rm} -rf ${RPM_BUILD_ROOT}
101%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
102%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
103%{__install} -m 644 %{SOURCE101} %{SOURCE104} \
104 ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
105
106%clean
107%{__rm} -rf ${RPM_BUILD_ROOT}
108
109%posttrans
110/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
111/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
112                                 %{pkgname}-devel-%{version}-%{release}
113
114%files
115%defattr(-,root,root)
116%{_datadir}/%{name}
117
118%changelog
119* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 3.2-1
120- new upstream release (ABI 179)
121
122* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.8-1
123- new upstream release (ABI 68)
124
125* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-1
126- new upstream release (ABI 59)
127
128* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.6-1
129- new upstream release (ABI 51)
130- release tarballs are now hosted on videolan.org
131
132* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-2
133- rebuild
134
135* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-1
136- new upstream release
137- drop x265-pc-path.patch
138- add x265-1.5-test-shared.patch
139
140* Sat Feb  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
141- added Group tag to Source0
142
143* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
144- new upstream release
145- initial build based on RPM Fusion rawhide
Note: See TracBrowser for help on using the repository browser.