source: projects/specs/trunk/nonfree/self-build-x264/x264-vl.spec @ 615

Revision 615, 4.6 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define name x264
2%define version 0.0.0
3%define date 20100216
4%define time 2245
5%define release 13.%{date}%{?_dist_release}
6
7Summary: Library for encoding and decoding H264/AVC video streams
8Name: %{name}
9Version: %{version}
10Release: %{release}
11#Source: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
12Source: http://www.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
13Source1: %{name}.desktop
14# # don't remove config.h and don't re-run version.sh
15# #Patch0: x264-nover.patch
16# Patch0: x264-nover-20100216.patch
17# link with shared libx264
18Patch1: x264-shared.patch
19# don't strip if configured with --enable-debug
20Patch2: x264-nostrip.patch
21License: GPLv2+
22Group: System Environment/Libraries
23URL: http://www.videolan.org/developers/x264.html
24
25%ifarch x86_64 %{ix86}
26BuildRequires: yasm
27%endif
28# gpac-devel package provided by self-build-gpac
29# in self-build-%{name}.spec as PreReq.
30#BuildRequires: gpac-devel
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34%description
35x264 is a free library for encoding H264/AVC video streams, written from
36scratch.
37
38%package devel
39Summary: Development files for the x264 library
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: pkgconfig
43
44%description devel
45x264 is a free library for encoding H264/AVC video streams, written from
46scratch.
47
48This package contains header files, static library and API documentation
49for the x264.
50
51%prep
52%setup -q -n %{name}-snapshot-%{date}-%{time}
53#% patch0 -p1 -b .nover
54%patch1 -p1 -b .shared
55%patch2 -p1 -b .nostrip
56# AUTHORS file is in iso-8859-1
57iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
58%__mv -f AUTHORS.utf8 AUTHORS
59
60%build
61./configure \
62        --host=%{_target_platform} \
63        --prefix=%{_prefix} \
64        --exec-prefix=%{_exec_prefix} \
65        --bindir=%{_bindir} \
66        --includedir=%{_includedir} \
67        --libdir=%{_libdir} \
68        --extra-cflags="$RPM_OPT_FLAGS" \
69        --enable-mp4-output \
70        %{?_with_visualize:--enable-visualize} \
71%ifnarch %{ix86}
72        --disable-asm \
73%endif
74        --enable-pthread \
75        --enable-debug \
76        --enable-shared \
77        --enable-pic
78
79%{__make} %{?_smp_mflags}
80
81%install
82%{__rm} -rf %{buildroot}
83%{__make} DESTDIR=%{buildroot} install
84
85
86%clean
87%{__rm} -rf %{buildroot}
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93
94%files
95%defattr(644, root, root, 0755)
96%doc AUTHORS COPYING
97%attr(755,root,root) %{_bindir}/x264
98%{_libdir}/libx264.so.*
99
100%files devel
101%defattr(644, root, root, 0755)
102%doc doc/ratecontrol.txt doc/vui.txt
103%{_includedir}/x264.h
104%exclude %{_libdir}/libx264.a
105%{_libdir}/libx264.so
106%{_libdir}/pkgconfig/%{name}.pc
107
108
109
110%changelog
111* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
112- change release to sync with self-build-x264
113
114* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
115- updated source snapshot 20100216
116- applied to link x264 binary to the shared library from RPM Fusion development
117
118* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
119- changed Source0: to http://www.videolan.org/pub/videolan/x264/snapshots
120
121* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
122- change release to sync with self-build-x264
123
124* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
125- 20090522 snapshot
126  - updated x264-vine.patch
127
128* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
129- corrected release number
130
131* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
132- added configure options: --enable-mp4-output
133- added BuildRequires: gpac-devel
134
135* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
136- change release to sync with self-build-x264
137
138* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
139- 20090110 snapshot
140
141* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
142- fixed License: GPLv2+
143- added BuildRequires: gettext
144- source updated
145- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
146  and added x264-vine.patch
147#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
148
149* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
150- spec in utf8
151
152* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
153- apply new versioning policy
154
155* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
156- initial build for Vine Linux 4.2
157
158* Sun Jan 20 2008 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.57-0.r721vlmp1
159- update to SVN r721
160
161* Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.56-0.r667vlmp1
162- initial build for Vine Linux 4.1
163
164### end of file
Note: See TracBrowser for help on using the repository browser.