source: projects/specs/trunk/nonfree/self-build-x264/x264-vl.spec @ 1258

Revision 1258, 4.8 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define date 20100625
2%define time 2245
3
4Summary: Library for encoding and decoding H264/AVC video streams
5Name: x264
6Version: 0.0.0
7Release: 14.%{date}%{?_dist_release}
8License: GPLv2+
9Group: System Environment/Libraries
10URL: http://www.videolan.org/developers/x264.html
11#Source: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
12Source: http://www.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
13Source1: %{name}.desktop
14# # don't remove config.h and don't re-run version.sh
15# Patch0: x264-nover.patch
16# link with shared libx264
17Patch1: x264-shared.patch
18# don't strip if configured with --enable-debug
19Patch2: x264-nostrip.patch
20%ifarch x86_64 %{ix86}
21BuildRequires: yasm
22%endif
23# gpac-devel package provided by self-build-gpac
24# in self-build-%{name}.spec as PreReq.
25#BuildRequires: gpac-devel
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28
29Provides:       libx264 = %{version}
30Obsoletes:      libx264 < %{version}
31Obsoletes:      x264 < %{version}
32
33
34%description
35x264 is a free library for encoding H264/AVC video streams, written from
36scratch.
37
38%package devel
39Summary: Development files for the x264 library
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: pkgconfig
43
44%description devel
45x264 is a free library for encoding H264/AVC video streams, written from
46scratch.
47
48This package contains the development files.
49
50%prep
51%setup -q -n %{name}-snapshot-%{date}-%{time}
52# %patch0 -p1 -b .nover
53%patch1 -p1 -b .shared
54%patch2 -p1 -b .nostrip
55# AUTHORS file is in iso-8859-1
56iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
57%__mv -f AUTHORS.utf8 AUTHORS
58
59%build
60./configure \
61    --host=%{_target_platform} \
62    --prefix=%{_prefix} \
63    --exec-prefix=%{_exec_prefix} \
64    --bindir=%{_bindir} \
65    --includedir=%{_includedir} \
66    --libdir=%{_libdir} \
67    --extra-cflags="$RPM_OPT_FLAGS" \
68    --enable-mp4-output \
69    %{?_with_visualize:--enable-visualize} \
70    \
71    --enable-lavf \
72    --disable-ffms \
73    --enable-gpac \
74    --enable-pthread \
75    --enable-asm \
76    --enable-debug \
77    --enable-shared \
78    --enable-pic \
79    ;
80
81
82%{__make} %{?_smp_mflags}
83
84%install
85%{__rm} -rf %{buildroot}
86%{__make} DESTDIR=%{buildroot} install
87
88
89%clean
90%{__rm} -rf %{buildroot}
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96
97%files
98%defattr(644, root, root, 0755)
99%doc AUTHORS COPYING
100%attr(755,root,root) %{_bindir}/x264
101%{_libdir}/libx264.so.*
102
103%files devel
104%defattr(644, root, root, 0755)
105%doc doc/ratecontrol.txt doc/vui.txt
106%{_includedir}/x264.h
107%exclude %{_libdir}/libx264.a
108%{_libdir}/libx264.so
109%{_libdir}/pkgconfig/%{name}.pc
110
111
112
113%changelog
114* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
115- updated source snapshot 20100625
116
117* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
118- change release to sync with self-build-x264
119
120* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
121- updated source snapshot 20100216
122- applied to link x264 binary to the shared library from RPM Fusion development
123
124* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
125- changed Source0: to http://www.videolan.org/pub/videolan/x264/snapshots
126
127* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
128- change release to sync with self-build-x264
129
130* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
131- 20090522 snapshot
132  - updated x264-vine.patch
133
134* Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
135- corrected release number
136
137* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
138- added configure options: --enable-mp4-output
139- added BuildRequires: gpac-devel
140
141* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
142- change release to sync with self-build-x264
143
144* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
145- 20090110 snapshot
146
147* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
148- fixed License: GPLv2+
149- added BuildRequires: gettext
150- source updated
151- fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
152  and added x264-vine.patch
153#- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
154
155* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
156- spec in utf8
157
158* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
159- apply new versioning policy
160
161* Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
162- initial build for Vine Linux 4.2
163
164* Sun Jan 20 2008 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.57-0.r721vlmp1
165- update to SVN r721
166
167* Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 0.56-0.r667vlmp1
168- initial build for Vine Linux 4.1
169
170### end of file
Note: See TracBrowser for help on using the repository browser.