source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 9366

Revision 9366, 15.0 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%global rcversion 2
2
3%define pkgname vlc
4%define name    self-build-%{pkgname}
5%define version 2.2.0
6%define release 2%{?rcversion:.rc%rcversion}%{?_dist_release}
7
8%define with_mozilla                    0
9
10#% define with_dc1394                   1
11
12%define with_ncurses                    0
13
14#% define sourceurl0    http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.xz
15%define sourceurl0      http://download.videolan.org/pub/videolan/testing/vlc-2.2.0-rc2/vlc-2.2.0-rc2.tar.xz
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22
23Obsoletes:      vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
24Obsoletes:      self-build-vlc < %{version}-%{release}
25
26Source0:        %{pkgname}-vl.spec
27
28License:        GPLv2+
29Group:          Restricted Software
30
31Requires(post):         self-build-setup >= 0.9.9
32
33Requires(post): unzip
34Requires(post): desktop-file-utils
35Requires(post): gettext
36Requires(post): gettext-devel
37Requires(post): libtool
38Requires(post): aalib-devel
39Requires(post): alsa-lib-devel
40Requires(post): avahi-devel
41Requires(post):  cdparanoia-devel
42Requires(post):  dbus-devel
43%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
44#Requires(post):  directfb-devel
45Requires(post):  libdirectfb-devel
46Requires(post): flac-devel
47##!! Requires(post):  fluidsynth-devel
48Requires(post): fribidi-devel
49Requires(post):  gnome-vfs2-devel
50Requires(post): gnutls-devel >= 1.0.17
51Requires(post): gsm-devel
52%if %{?_dist_release} >= "vl7"
53Requires(post): jack-audio-connection-kit-devel
54%endif
55%{?with_dc1394:Requires(post):  libavc1394-devel}
56Requires(post): libass-devel >= 0.9.7
57##!! Requires(post):    libcaca-devel
58Requires(post): libcddb-devel
59Requires(post): libcdio-devel >= 0.77-3
60%{?with_dc1394:Requires(post):  libavc1394-devel >= 0.5.3}
61%{?with_dc1394:Requires(post):  libdc1394-devel >= 2.1.0}
62%{?with_dc1394:Requires(post):  libdv-devel}
63Requires(post): libdvdnav-devel
64Requires(post): libdvdread-devel
65Requires(post):  libebml-devel
66Requires(post): libid3tag-devel
67%{?_with_kate:  Requires(post): libkate-devel}
68Requires(post): libmatroska-devel >= 0.7.6
69Requires(post): libmodplug-devel
70Requires(post): libmp4v2-devel
71Requires(post): libmpcdec-devel
72Requires(post): libmtp-devel
73Requires(post):  libnotify-devel
74##!! Requires(post):    libprojectM-qt-devel
75Requires(post):  libproxy-devel
76Requires(post): librsvg2-devel >= 2.9.0
77Requires(post):  librtmp-devel
78Requires(post): libssh2-devel
79##!! Requires(post):    libsysfs-devel
80Requires(post):  libshout-devel
81Requires(post):  libsmbclient-devel
82##!! Requires(post):    libtar-devel
83Requires(post): libtheora-devel
84##!! Requires(post):    libtiger-devel
85Requires(post):  libtiff-devel
86Requires(post): libudev-devel >= 142
87Requires(post):  libupnp-devel
88Requires(post): libv4l-devel
89Requires(post): libva-devel
90Requires(post): libvorbis-devel
91Requires(post):  libxml2-devel
92#Requires(post):        lirc-devel
93%{?_with_lirc:Requires(post):   lirc}
94#Requires(post):        live555-devel >= 0-0.19.2008.04.03
95Requires(post):  kernel-headers >= 2.6.20
96# Requires(post):       libGL-devel
97# Requires(post):       libGLU-devel
98Requires(post):  libmusicbrainz-devel
99Requires(post):  lua-devel
100##!! Requires(post):  minizip-devel
101##!! Requires(post):    mpeg2dec-devel >= 0.3.2
102%if %with_ncurses
103Requires(post): ncurses-devel
104%endif
105##!! Requires(post):  opencv-devel
106Requires(post): openslp-devel
107Requires(post):  pcre-devel
108Requires(post):  pulseaudio-libs-devel >= 0.9.8
109##!! Requires(post):  portaudio-devel
110Requires(post):  qt4-devel >= 4.5.2
111##!! Requires(post):  schroedinger-devel
112Requires(post): SDL_image-devel
113Requires(post): speex-devel >= 1.1.5
114Requires(post):  taglib-devel
115Requires(post): twolame-devel
116Requires(post): vcdimager-devel >= 0.7.21
117Requires(post): zlib-devel
118##!! Requires(post):  zvbi-devel
119
120# X-libs
121Requires(post): libXt-devel
122Requires(post): libXv-devel
123Requires(post):  libXxf86vm-devel
124Requires(post):  libX11-devel
125Requires(post):  libXext-devel
126Requires(post):  libXpm-devel
127Requires(post):  libXvMC-devel
128Requires(post):  xcb-util-devel
129Requires(post):  xorg-x11-proto-devel
130
131Requires(post):  pulseaudio-libs-devel >= 0.9.8
132
133%if %with_mozilla
134Requires(post):  gecko-devel
135Requires(post):  nspr-devel
136%endif
137
138Requires: TrueType-dejavu
139
140## vine
141Requires(post): libgcrypt-devel
142Requires(post): wxGTK-devel
143Requires(post): mesa-libGL
144Requires(post): xorg-x11-devel
145Requires(post): mesa-libGL-devel
146Requires(post): self-build-libmpeg2
147Requires(post): self-build-a52dec
148Requires(post): self-build-faac
149Requires(post): self-build-faad2
150Requires(post): self-build-ffmpeg >= 2.4.0
151Requires(post): self-build-libdca
152Requires(post): self-build-libdvbpsi >= 1.0.0
153Requires(post): self-build-libmad
154Requires(post): self-build-x264 >= 0.136
155Requires(post): self-build-xvidcore
156
157BuildArch:      noarch
158BuildRoot:      %{_tmppath}/%{name}-%{version}-root
159
160Packager:       munepi
161
162%description
163VLC (initially VideoLAN Client) is a highly portable multimedia player
164for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
165mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
166It can also be used as a server to stream in unicast or multicast in
167IPv4 or IPv6 on a high-bandwidth network.
168
169
170[Note]
171This package requires many other packages to compile
172targetsoftware. So it consume more disk space than usual.
173Also installation takes logner time because of compilation.
174(This will take a few minutes to quarter or half of an hour,
175depends on building environment)
176
177[About self-build package]
178For some kind of software, distributing of binary package
179may viorate the patent or law. Therefore we chose self-build
180packge, create binary package on your machine, for such kind
181of softwares instead of distributing binary package.
182
183Please obey the national law when you use the created binary
184packages. And if you want to use the softwares using patented
185thechnology, it may be required to get a permission, make an
186agreement or purchas a license. Please consider it with your
187purpose or way of use and take appropriate action.
188
189%description -l ja
190VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
191様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
192mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
193対応しています.
194また,高帯域幅上の IPv4 や IPv6 で,
195ユニキャストやマルチキャストのストリームに,
196サーバーとして使用することもできます.
197
198
199このパッケージをインストールすると、自動的にソースコードを
200ダウンロードしてコンパイルし、%{pkgname}-%{version}
201の rpm パッケージを作成します。
202また apt-get コマンドや synaptic パッケージマネージャから実行
203した場合は、作成された rpm パッケージのインストールも自動的に
204行います。
205
206[注意]
207コンパイルに必要な多くの関連パッケージを要求するので通常より
208ディスクの領域を多く消費します。
209またインストール時にコンパイルを行うため、通常より時間がかか
210る場合があります。(環境にもよりますが数分から数十分程度)
211
212[self-build パッケージについて]
213ソフトウェアによってはバイナリパッケージの配布が特許や法律に
214違反する可能性があるものがあります。その為、このような問題が
215懸念されるソフトウェアについてはバイナリパッケージを直接配布
216せずに、ユーザの環境でバイナリを作成する self-build パッケー
217ジという方法を採っています。
218
219作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
220アのライセンス、および利用する国の各種法令に従ってください。
221また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
222センスの購入などが必要となる場合がありますので、利用する目的
223や形態に応じて各自で判断し適切な対応を取ってください。
224
225%prep
226[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
227
228%install
229%{__rm} -rf ${RPM_BUILD_ROOT}
230%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
231%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
232
233%clean
234%{__rm} -rf ${RPM_BUILD_ROOT}
235
236%posttrans
237/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 794000
238
239/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
240                                 %{pkgname}-devel-%{version}-%{release}
241
242%files
243%defattr(-,root,root)
244%{_datadir}/%{name}
245
246
247%changelog
248* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-2.rc2
249- rebuild
250
251* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-1.rc2
252- updated to 2.2.0-rc2
253
254* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.2-2
255- remove Requires(post): xosd-devel
256
257* Sat Dec 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.2-1
258- new upstream release
259
260* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-2
261- added Obsoletes: vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
262
263* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
264- new upstream release
265- built with new x264 (ABI 0.136) and ffmpeg (1.2.x)
266
267* Wed Jul  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.7-1
268- new upstream release
269
270* Tue Apr 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.6-1
271- new upstream release
272
273* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-2
274- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
275
276* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-1
277- new upstream release
278
279* Wed Nov  7 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.4-1
280- new upstream release
281
282* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.3-1
283- new upstream release
284- s/wx-gtk2/wxGTK/g
285
286* Sat Jun 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
287- new upstream release
288
289* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
290- new upstream release
291- dropped DC1394 and DV
292
293* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.13-1
294- new upstream release
295
296* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
297- rebuilt with new x264 and ffmpeg
298
299* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
300- s/self-build-libmp4v2/libmp4v2/
301- s/self-build-libdvdnav/libdvdnav/
302
303* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-1
304- new upstream release
305
306* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
307- dropped Requires(post): svga-devel
308- added BuildArch: noarch
309
310* Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
311- new upstream release
312
313* Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
314- new upstream release
315- backport from 1.1-bugfix from RPM Fusion development
316
317* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
318- added Requires(post): unzip
319
320* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
321- new upstream release
322- applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
323
324* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
325- new upstream release
326- added Requires(post):
327  - libcddb-devel
328  - libdc1394-devel >= 2.1.0
329  - libmodplug-devel
330  - libproxy-devel
331  - librtmp-devel
332  - libssh2-devel
333  - libudev-devel >= 142
334  - pcre-devel
335  - vcdimager-devel >= 0.7.21
336  - xcb-util-devel
337
338* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
339- new upstream release
340- dropped upstreamed patches
341- applied a reverted patch to pulse.c for vl5
342
343* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
344- backport lirc and signal fixes
345
346* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
347- new upstream release
348- dropped temporarily BuildRequires: lirc
349- added BuildRequires: libass-devel as the tag Requires(post)
350
351* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
352- new upstream release
353
354* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
355- new upstream release
356
357* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
358- new upstream release
359
360* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
361- for only vl6, supported libva
362- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
363
364* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
365- new upstream release
366- added Requires(post): libva-devel
367
368* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
369- renamed %%{Source0} to vlc-vl.spec
370
371* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
372- added Requires(post): libsmbclient-devel
373
374* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
375- new upstream release
376
377* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
378- built with libdvbpsi-devel
379- dropped 0002-Default-aout-for-pulse.patch
380
381* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
382- new upstream release
383- updated 0002-Default-aout-for-pulse.patch
384
385* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
386- added Requires(post): libmtp-devel
387
388* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
389- new upstream release
390
391* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
392- rebuilt to add signature
393
394* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
395- new upstream release
396  - applied vlc-1.0.2-compiler.patch from RPM Fusion
397- added Requires(post): lua-devel
398
399* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
400- new upstream release
401
402* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
403- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
404
405* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
406- new upstream release
407- clean-up some old patches and merged some patches from RPM Fusion package
408- added vlc-trunk-default_font-vine.patch
409- added vlc-handlers.schemas
410  - Gonf2 url-handler support
411- added shine.c, enc_base.h
412  - missing sources
413- check version between original spec and self-build spec in %%prep
414
415* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
416- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
417
418* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
419- rebuild with x264 >= 0.0.0-9.20090522
420- avoided to execute self-build-rpm.sh on RPM transaction
421  - moved %%post actions to %%posttrans
422
423* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
424- new upstream release
425- added BuildArch: noarch
426- s/TrueType-DejaVu/TrueType-dejavu/
427
428* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
429- corrected release number in vlc.spec
430- dropped ExclusiveArch
431
432* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
433- add ppc to ExclusiveArch
434
435* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
436- changed to PreReq:  self-build-faad2 from faad2-devel
437- changed to PreReq:  self-build-libmad from libmad-devel
438
439* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
440- initial build
441
442### end of file
Note: See TracBrowser for help on using the repository browser.