source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 615

Revision 615, 10.5 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname vlc
2%define name    self-build-%{pkgname}
3%define version 1.0.5
4%define release 3%{?_dist_release}
5
6%if %{?_dist_release} == "vl4"
7## dummy echo
8echo This package cannot build on Vine Linux 4.2.
9exit 1
10%endif
11
12%define with_mozilla                    0
13%define with_dc1394                     0
14%define with_directfb                   1
15
16%define with_samba                      0
17
18%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
19
20
21Summary:        Package to automatically build %{pkgname} rpm package
22Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
23Name:           %{name}
24Version:        %{version}
25Release:        %{release}
26
27Obsoletes:      vlc < 1.0.0
28Obsoletes:      vlc-devel < 1.0.0
29
30Source0:        %{pkgname}-vl.spec
31
32Source10:       vlc-handlers.schemas
33Source100:      vlc-trunk-default_font-vine.patch
34Source101:      0001-Default-libv4l2-to-true.patch
35Source103:      300_all_pic.patch
36Source104:      310_all_mmx_pic.patch
37
38License:        GPLv2+
39Group:          Restricted Software
40
41Requires(post):         self-build-setup >= 0.9.9
42
43Requires(post): desktop-file-utils
44Requires(post): gettext
45Requires(post): gettext-devel
46Requires(post): libtool
47Requires(post): aalib-devel
48Requires(post): alsa-lib-devel
49Requires(post): avahi-devel
50Requires(post):  cdparanoia-devel
51Requires(post):  dbus-devel
52%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
53%if %with_directfb
54Requires(post):  libdirectfb-devel
55%endif
56Requires(post): flac-devel
57Requires(post): fribidi-devel
58Requires(post):  gnome-vfs2-devel
59Requires(post): gnutls-devel >= 1.0.17
60Requires(post): gsm-devel
61Requires(post): hal-devel
62Requires(post): jack-audio-connection-kit-devel
63Requires(post):  libavc1394-devel
64Requires(post): libcdio-devel >= 0.77-3
65Requires(post): libdv-devel
66Requires(post): libdvdread-devel
67Requires(post):  libebml-devel
68Requires(post): libid3tag-devel
69%{?_with_kate:  Requires(post): libkate-devel}
70Requires(post): libmatroska-devel >= 0.7.6
71Requires(post): libmpcdec-devel
72Requires(post): libmtp-devel
73Requires(post):  libnotify-devel
74Requires(post): librsvg2-devel >= 2.5.0
75Requires(post):  libshout-devel
76Requires(post):  libsmbclient-devel
77Requires(post): libtheora-devel
78Requires(post):  libtiff-devel
79Requires(post):  libupnp-devel
80Requires(post): libv4l-devel
81Requires(post): libvorbis-devel
82Requires(post):  libxml2-devel
83Requires(post): lirc
84Requires(post):  kernel-headers >= 2.6.20
85Requires(post):  libmusicbrainz-devel
86Requires(post): lua-devel
87Requires(post): ncurses-devel
88Requires(post): openslp-devel
89Requires(post):  qt4-devel
90Requires(post): SDL_image-devel
91Requires(post): speex-devel >= 1.1.5
92%ifarch %{ix86} x86_64
93Requires(post):  svgalib-devel
94%endif
95Requires(post):  taglib-devel
96Requires(post): twolame-devel
97Requires(post): xosd-devel
98Requires(post): zlib-devel
99
100# X-libs
101Requires(post): libXt-devel
102Requires(post): libXv-devel
103Requires(post):  libXxf86vm-devel
104Requires(post):  libX11-devel
105Requires(post):  libXext-devel
106Requires(post):  libXpm-devel
107%ifarch %{ix86} x86_64
108Requires(post):  libXvMC-devel
109%endif
110Requires(post):  xorg-x11-proto-devel
111
112%if %with_samba
113Requires(post):  samba-libsmbclient-devel
114%endif
115
116Requires(post):  pulseaudio-libs-devel >= 0.9.8
117
118%if %with_mozilla
119Requires(post):  gecko-devel
120Requires(post):  nspr-devel
121%endif
122
123Requires(post):  libraw1394-devel
124
125Requires: TrueType-dejavu
126
127## vine
128Requires(post): libgcrypt-devel
129Requires(post): wx-gtk2-devel
130Requires:       mesa-libGL
131Requires(post): xorg-x11-devel
132Requires(post): mesa-libGL-devel
133Requires(post): self-build-libmpeg2
134Requires(post): self-build-a52dec
135Requires(post): self-build-faac
136Requires(post): self-build-faad2
137Requires(post): self-build-ffmpeg >= 0.4.9
138Requires(post): self-build-libdca
139Requires(post): self-build-libdvbpsi
140Requires(post): self-build-libdvdnav
141Requires(post): self-build-libmad
142Requires(post): self-build-libmp4v2
143Requires(post): self-build-x264 >= 0.0.0-9.20090522
144Requires(post): self-build-xvidcore
145
146BuildRoot:      %{_tmppath}/%{name}-%{version}-root
147
148Packager:       munepi
149
150%description
151VLC (initially VideoLAN Client) is a highly portable multimedia player
152for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
153mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
154It can also be used as a server to stream in unicast or multicast in
155IPv4 or IPv6 on a high-bandwidth network.
156
157
158[Note]
159This package requires many other packages to compile
160targetsoftware. So it consume more disk space than usual.
161Also installation takes logner time because of compilation.
162(This will take a few minutes to quarter or half of an hour,
163depends on building environment)
164
165[About self-build package]
166For some kind of software, distributing of binary package
167may viorate the patent or law. Therefore we chose self-build
168packge, create binary package on your machine, for such kind
169of softwares instead of distributing binary package.
170
171Please obey the national law when you use the created binary
172packages. And if you want to use the softwares using patented
173thechnology, it may be required to get a permission, make an
174agreement or purchas a license. Please consider it with your
175purpose or way of use and take appropriate action.
176
177%description -l ja
178VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
179様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
180mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
181対応しています.
182また,高帯域幅上の IPv4 や IPv6 で,
183ユニキャストやマルチキャストのストリームに,
184サーバーとして使用することもできます.
185
186
187このパッケージをインストールすると、自動的にソースコードを
188ダウンロードしてコンパイルし、%{pkgname}-%{version}
189の rpm パッケージを作成します。
190また apt-get コマンドや synaptic パッケージマネージャから実行
191した場合は、作成された rpm パッケージのインストールも自動的に
192行います。
193
194[注意]
195コンパイルに必要な多くの関連パッケージを要求するので通常より
196ディスクの領域を多く消費します。
197またインストール時にコンパイルを行うため、通常より時間がかか
198る場合があります。(環境にもよりますが数分から数十分程度)
199
200[self-build パッケージについて]
201ソフトウェアによってはバイナリパッケージの配布が特許や法律に
202違反する可能性があるものがあります。その為、このような問題が
203懸念されるソフトウェアについてはバイナリパッケージを直接配布
204せずに、ユーザの環境でバイナリを作成する self-build パッケー
205ジという方法を採っています。
206
207作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
208アのライセンス、および利用する国の各種法令に従ってください。
209また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
210センスの購入などが必要となる場合がありますので、利用する目的
211や形態に応じて各自で判断し適切な対応を取ってください。
212
213%prep
214[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
215
216%install
217%{__rm} -rf ${RPM_BUILD_ROOT}
218%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
219%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
220%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
221
222%{__install} -m 644 \
223    %{SOURCE100} %{SOURCE101} %{SOURCE103} %{SOURCE104} \
224    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
225
226
227%clean
228%{__rm} -rf ${RPM_BUILD_ROOT}
229
230%posttrans
231/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 2325000
232/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
233                                 %{pkgname}-devel-%{version}-%{release}
234
235%files
236%defattr(-,root,root)
237%{_datadir}/%{name}
238
239
240%changelog
241* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
242- renamed %%{Source0} to vlc-vl.spec
243
244* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
245- added Requires(post): libsmbclient-devel
246
247* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
248- new upstream release
249
250* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
251- built with libdvbpsi-devel
252- dropped 0002-Default-aout-for-pulse.patch
253
254* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
255- new upstream release
256- updated 0002-Default-aout-for-pulse.patch
257
258* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
259- added Requires(post): libmtp-devel
260
261* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
262- new upstream release
263
264* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
265- rebuilt to add signature
266
267* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
268- new upstream release
269  - applied vlc-1.0.2-compiler.patch from RPM Fusion
270- added Requires(post): lua-devel
271
272* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
273- new upstream release
274
275* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
276- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
277
278* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
279- new upstream release
280- clean-up some old patches and merged some patches from RPM Fusion package
281- added vlc-trunk-default_font-vine.patch
282- added vlc-handlers.schemas
283  - Gonf2 url-handler support
284- added shine.c, enc_base.h
285  - missing sources
286- check version between original spec and self-build spec in %%prep
287
288* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
289- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
290
291* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
292- rebuild with x264 >= 0.0.0-9.20090522
293- avoided to execute self-build-rpm.sh on RPM transaction
294  - moved %%post actions to %%posttrans
295
296* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
297- new upstream release
298- added BuildArch: noarch
299- s/TrueType-DejaVu/TrueType-dejavu/
300
301* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
302- corrected release number in vlc.spec
303- dropped ExclusiveArch
304
305* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
306- add ppc to ExclusiveArch
307
308* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
309- changed to PreReq:  self-build-faad2 from faad2-devel
310- changed to PreReq:  self-build-libmad from libmad-devel
311
312* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
313- initial build
314
315### end of file
Note: See TracBrowser for help on using the repository browser.