source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 7842

Revision 7842, 15.3 KB checked in by munepi, 11 years ago (diff)

new x264 (ABI 0.136)

Line 
1%define pkgname vlc
2%define name    self-build-%{pkgname}
3%define version 2.1.0
4%define release 1%{?_dist_release}
5
6%define with_mozilla                    0
7
8#% define with_dc1394                   1
9
10%define with_ncurses                    0
11
12%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.xz
13%define sourceurl10     http://2sen.dip.jp/cgi-bin/dtvup/source/up0617.zip
14
15
16Summary:        Package to automatically build %{pkgname} rpm package
17Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
18Name:           %{name}
19Version:        %{version}
20Release:        %{release}
21
22Obsoletes:      self-build-vlc < %{version}-%{release}
23Obsoletes:      vlc < %{version}, vlc-devel < %{version}
24
25#Source0:       %{pkgname}-vl.spec
26Source0:        %{pkgname}-vl.spec.in
27
28Source100:      vlc-2.0.1-fftype.patch
29#Source105:         vlc-1.1.8-bugfix.opencv22.patch
30
31License:        GPLv2+
32Group:          Restricted Software
33
34Requires(post):         self-build-setup >= 0.9.9
35
36Requires(post): unzip
37Requires(post): desktop-file-utils
38Requires(post): gettext
39Requires(post): gettext-devel
40Requires(post): libtool
41Requires(post): aalib-devel
42Requires(post): alsa-lib-devel
43Requires(post): avahi-devel
44Requires(post):  cdparanoia-devel
45Requires(post):  dbus-devel
46%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
47#Requires(post):  directfb-devel
48Requires(post):  libdirectfb-devel
49Requires(post): flac-devel
50##!! Requires(post):  fluidsynth-devel
51Requires(post): fribidi-devel
52Requires(post):  gnome-vfs2-devel
53Requires(post): gnutls-devel >= 1.0.17
54Requires(post): gsm-devel
55Requires(post): jack-audio-connection-kit-devel
56%{?with_dc1394:Requires(post):  libavc1394-devel}
57Requires(post): libass-devel >= 0.9.7
58##!! Requires(post):    libcaca-devel
59Requires(post): libcddb-devel
60Requires(post): libcdio-devel >= 0.77-3
61%{?with_dc1394:Requires(post):  libavc1394-devel >= 0.5.3}
62%{?with_dc1394:Requires(post):  libdc1394-devel >= 2.1.0}
63%{?with_dc1394:Requires(post):  libdv-devel}
64Requires(post): libdvdnav-devel
65Requires(post): libdvdread-devel
66Requires(post):  libebml-devel
67Requires(post): libid3tag-devel
68%{?_with_kate:  Requires(post): libkate-devel}
69Requires(post): libmatroska-devel >= 0.7.6
70Requires(post): libmodplug-devel
71Requires(post): libmp4v2-devel
72Requires(post): libmpcdec-devel
73Requires(post): libmtp-devel
74Requires(post):  libnotify-devel
75##!! Requires(post):    libprojectM-qt-devel
76Requires(post):  libproxy-devel
77Requires(post): librsvg2-devel >= 2.9.0
78Requires(post):  librtmp-devel
79Requires(post): libssh2-devel
80##!! Requires(post):    libsysfs-devel
81Requires(post):  libshout-devel
82Requires(post):  libsmbclient-devel
83##!! Requires(post):    libtar-devel
84Requires(post): libtheora-devel
85##!! Requires(post):    libtiger-devel
86Requires(post):  libtiff-devel
87Requires(post): libudev-devel >= 142
88Requires(post):  libupnp-devel
89Requires(post): libv4l-devel
90Requires(post): libva-devel
91Requires(post): libvorbis-devel
92Requires(post):  libxml2-devel
93#Requires(post):        lirc-devel
94%{?_with_lirc:Requires(post):   lirc}
95#Requires(post):        live555-devel >= 0-0.19.2008.04.03
96Requires(post):  kernel-headers >= 2.6.20
97# Requires(post):       libGL-devel
98# Requires(post):       libGLU-devel
99Requires(post):  libmusicbrainz-devel
100Requires(post):  lua-devel
101##!! Requires(post):  minizip-devel
102##!! Requires(post):    mpeg2dec-devel >= 0.3.2
103%if %with_ncurses
104Requires(post): ncurses-devel
105%endif
106##!! Requires(post):  opencv-devel
107Requires(post): openslp-devel
108Requires(post):  pcre-devel
109Requires(post):  pulseaudio-libs-devel >= 0.9.8
110##!! Requires(post):  portaudio-devel
111Requires(post):  qt4-devel >= 4.5.2
112##!! Requires(post):  schroedinger-devel
113Requires(post): SDL_image-devel
114Requires(post): speex-devel >= 1.1.5
115Requires(post):  taglib-devel
116Requires(post): twolame-devel
117Requires(post): vcdimager-devel >= 0.7.21
118Requires(post): xosd-devel
119Requires(post): zlib-devel
120##!! Requires(post):  zvbi-devel
121
122# X-libs
123Requires(post): libXt-devel
124Requires(post): libXv-devel
125Requires(post):  libXxf86vm-devel
126Requires(post):  libX11-devel
127Requires(post):  libXext-devel
128Requires(post):  libXpm-devel
129Requires(post):  libXvMC-devel
130Requires(post):  xcb-util-devel
131Requires(post):  xorg-x11-proto-devel
132
133Requires(post):  pulseaudio-libs-devel >= 0.9.8
134
135%if %with_mozilla
136Requires(post):  gecko-devel
137Requires(post):  nspr-devel
138%endif
139
140Requires: TrueType-dejavu
141
142## vine
143Requires(post): libgcrypt-devel
144Requires(post): wxGTK-devel
145Requires(post): mesa-libGL
146Requires(post): xorg-x11-devel
147Requires(post): mesa-libGL-devel
148Requires(post): self-build-libmpeg2
149Requires(post): self-build-a52dec
150Requires(post): self-build-faac
151Requires(post): self-build-faad2
152Requires(post): self-build-ffmpeg >= 1.1.0
153Requires(post): self-build-libdca
154Requires(post): self-build-libdvbpsi
155Requires(post): self-build-libmad
156Requires(post): self-build-x264 >= 0.129
157Requires(post): self-build-xvidcore
158
159BuildArch:      noarch
160BuildRoot:      %{_tmppath}/%{name}-%{version}-root
161
162Packager:       munepi
163
164%description
165VLC (initially VideoLAN Client) is a highly portable multimedia player
166for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
167mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
168It can also be used as a server to stream in unicast or multicast in
169IPv4 or IPv6 on a high-bandwidth network.
170
171
172[Note]
173This package requires many other packages to compile
174targetsoftware. So it consume more disk space than usual.
175Also installation takes logner time because of compilation.
176(This will take a few minutes to quarter or half of an hour,
177depends on building environment)
178
179[About self-build package]
180For some kind of software, distributing of binary package
181may viorate the patent or law. Therefore we chose self-build
182packge, create binary package on your machine, for such kind
183of softwares instead of distributing binary package.
184
185Please obey the national law when you use the created binary
186packages. And if you want to use the softwares using patented
187thechnology, it may be required to get a permission, make an
188agreement or purchas a license. Please consider it with your
189purpose or way of use and take appropriate action.
190
191%description -l ja
192VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
193様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
194mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
195対応しています.
196また,高帯域幅上の IPv4 や IPv6 で,
197ユニキャストやマルチキャストのストリームに,
198サーバーとして使用することもできます.
199
200
201このパッケージをインストールすると、自動的にソースコードを
202ダウンロードしてコンパイルし、%{pkgname}-%{version}
203の rpm パッケージを作成します。
204また apt-get コマンドや synaptic パッケージマネージャから実行
205した場合は、作成された rpm パッケージのインストールも自動的に
206行います。
207
208[注意]
209コンパイルに必要な多くの関連パッケージを要求するので通常より
210ディスクの領域を多く消費します。
211またインストール時にコンパイルを行うため、通常より時間がかか
212る場合があります。(環境にもよりますが数分から数十分程度)
213
214[self-build パッケージについて]
215ソフトウェアによってはバイナリパッケージの配布が特許や法律に
216違反する可能性があるものがあります。その為、このような問題が
217懸念されるソフトウェアについてはバイナリパッケージを直接配布
218せずに、ユーザの環境でバイナリを作成する self-build パッケー
219ジという方法を採っています。
220
221作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
222アのライセンス、および利用する国の各種法令に従ってください。
223また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
224センスの購入などが必要となる場合がありますので、利用する目的
225や形態に応じて各自で判断し適切な対応を取ってください。
226
227%prep
228[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
229
230%install
231%{__rm} -rf ${RPM_BUILD_ROOT}
232%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
233%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
234%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
235
236
237%clean
238%{__rm} -rf ${RPM_BUILD_ROOT}
239
240%postun
241%__rm -f %{_datadir}/%{name}/%{pkgname}-vl.spec
242
243%posttrans
244#set -x
245QUEDIR=/var/cache/self-build
246[ ! -d ${QUEDIR} ] && %__mkdir_p ${QUEDIR}
247
248# copy up0617.zip if you have
249[ ! -f %{_datadir}/%{name}/$(basename %{sourceurl10}) -a \
250  -f ${QUEDIR}/$(basename %{sourceurl10}) ] && \
251  %__cp -fav ${QUEDIR}/$(basename %{sourceurl10}) %{_datadir}/%{name}/
252
253USE_UP0617_ZIP=
254[ -f %{_datadir}/%{name}/$(basename %{sourceurl10}) ] && \
255  USE_UP0617_ZIP=1 || USE_UP0617_ZIP=0
256%__sed -e "s,@@USE_UP0617_ZIP@@,${USE_UP0617_ZIP}," %{_datadir}/%{name}/%{pkgname}-vl.spec.in > %{_datadir}/%{name}/%{pkgname}-vl.spec
257
258## NOTE: stopped 2sen.dip.jp/cgi-bin/dtvup
259# /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
260#     %{sourceurl0} %{sourceurl10} 1556000
261/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 794000
262
263/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
264                                 %{pkgname}-devel-%{version}-%{release}
265
266%files
267%defattr(-,root,root)
268%{_datadir}/%{name}
269
270
271%changelog
272* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
273- new upstream release
274- built with new x264 (ABI 0.136) and ffmpeg (1.2.x)
275
276* Wed Jul  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.7-1
277- new upstream release
278
279* Tue Apr 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.6-1
280- new upstream release
281
282* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-2
283- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
284
285* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-1
286- new upstream release
287
288* Wed Nov  7 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.4-1
289- new upstream release
290
291* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.3-1
292- new upstream release
293- s/wx-gtk2/wxGTK/g
294
295* Sat Jun 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
296- new upstream release
297
298* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
299- new upstream release
300- dropped DC1394 and DV
301
302* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.13-1
303- new upstream release
304
305* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
306- rebuilt with new x264 and ffmpeg
307
308* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
309- s/self-build-libmp4v2/libmp4v2/
310- s/self-build-libdvdnav/libdvdnav/
311
312* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-1
313- new upstream release
314
315* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
316- dropped Requires(post): svga-devel
317- added BuildArch: noarch
318
319* Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
320- new upstream release
321
322* Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
323- new upstream release
324- backport from 1.1-bugfix from RPM Fusion development
325
326* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
327- added Requires(post): unzip
328
329* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
330- new upstream release
331- applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
332
333* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
334- new upstream release
335- added Requires(post):
336  - libcddb-devel
337  - libdc1394-devel >= 2.1.0
338  - libmodplug-devel
339  - libproxy-devel
340  - librtmp-devel
341  - libssh2-devel
342  - libudev-devel >= 142
343  - pcre-devel
344  - vcdimager-devel >= 0.7.21
345  - xcb-util-devel
346
347* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
348- new upstream release
349- dropped upstreamed patches
350- applied a reverted patch to pulse.c for vl5
351
352* Fri Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
353- backport lirc and signal fixes
354
355* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
356- new upstream release
357- dropped temporarily BuildRequires: lirc
358- added BuildRequires: libass-devel as the tag Requires(post)
359
360* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
361- new upstream release
362
363* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
364- new upstream release
365
366* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
367- new upstream release
368
369* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
370- for only vl6, supported libva
371- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
372
373* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
374- new upstream release
375- added Requires(post): libva-devel
376
377* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
378- renamed %%{Source0} to vlc-vl.spec
379
380* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
381- added Requires(post): libsmbclient-devel
382
383* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
384- new upstream release
385
386* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
387- built with libdvbpsi-devel
388- dropped 0002-Default-aout-for-pulse.patch
389
390* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
391- new upstream release
392- updated 0002-Default-aout-for-pulse.patch
393
394* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
395- added Requires(post): libmtp-devel
396
397* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
398- new upstream release
399
400* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
401- rebuilt to add signature
402
403* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
404- new upstream release
405  - applied vlc-1.0.2-compiler.patch from RPM Fusion
406- added Requires(post): lua-devel
407
408* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
409- new upstream release
410
411* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
412- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
413
414* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
415- new upstream release
416- clean-up some old patches and merged some patches from RPM Fusion package
417- added vlc-trunk-default_font-vine.patch
418- added vlc-handlers.schemas
419  - Gonf2 url-handler support
420- added shine.c, enc_base.h
421  - missing sources
422- check version between original spec and self-build spec in %%prep
423
424* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
425- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
426
427* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
428- rebuild with x264 >= 0.0.0-9.20090522
429- avoided to execute self-build-rpm.sh on RPM transaction
430  - moved %%post actions to %%posttrans
431
432* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
433- new upstream release
434- added BuildArch: noarch
435- s/TrueType-DejaVu/TrueType-dejavu/
436
437* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
438- corrected release number in vlc.spec
439- dropped ExclusiveArch
440
441* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
442- add ppc to ExclusiveArch
443
444* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
445- changed to PreReq:  self-build-faad2 from faad2-devel
446- changed to PreReq:  self-build-libmad from libmad-devel
447
448* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
449- initial build
450
451### end of file
Note: See TracBrowser for help on using the repository browser.