source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 6241

Revision 6241, 13.7 KB checked in by munepi, 12 years ago (diff)

upgrade some self-build packages; remove obsolete self-build packages

Line 
1%define pkgname vlc
2%define name    self-build-%{pkgname}
3%define version 2.0.1
4%define release 1%{?_dist_release}
5
6%define with_mozilla                    0
7
8#% define with_dc1394                   1
9
10%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.xz
11%define sourceurl10     http://2sen.dip.jp/cgi-bin/dtvup/source/up0617.zip
12
13
14Summary:        Package to automatically build %{pkgname} rpm package
15Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
16Name:           %{name}
17Version:        %{version}
18Release:        %{release}
19
20Obsoletes:      self-build-vlc < %{version}-%{release}
21Obsoletes:      vlc < %{version}, vlc-devel < %{version}
22
23Source0:        %{pkgname}-vl.spec
24
25Source100:      vlc-2.0.1-fftype.patch
26#Source105:         vlc-1.1.8-bugfix.opencv22.patch
27
28License:        GPLv2+
29Group:          Restricted Software
30
31Requires(post):         self-build-setup >= 0.9.9
32
33Requires(post): unzip
34Requires(post): desktop-file-utils
35Requires(post): gettext
36Requires(post): gettext-devel
37Requires(post): libtool
38Requires(post): aalib-devel
39Requires(post): alsa-lib-devel
40Requires(post): avahi-devel
41Requires(post):  cdparanoia-devel
42Requires(post):  dbus-devel
43%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
44#Requires(post):  directfb-devel
45Requires(post):  libdirectfb-devel
46Requires(post): flac-devel
47##!! Requires(post):  fluidsynth-devel
48Requires(post): fribidi-devel
49Requires(post):  gnome-vfs2-devel
50Requires(post): gnutls-devel >= 1.0.17
51Requires(post): gsm-devel
52Requires(post): jack-audio-connection-kit-devel
53%{?with_dc1394:Requires(post):  libavc1394-devel}
54Requires(post): libass-devel >= 0.9.7
55##!! Requires(post):    libcaca-devel
56Requires(post): libcddb-devel
57Requires(post): libcdio-devel >= 0.77-3
58%{?with_dc1394:Requires(post):  libavc1394-devel >= 0.5.3}
59%{?with_dc1394:Requires(post):  libdc1394-devel >= 2.1.0}
60%{?with_dc1394:Requires(post):  libdv-devel}
61Requires(post): libdvdnav-devel
62Requires(post): libdvdread-devel
63Requires(post):  libebml-devel
64Requires(post): libid3tag-devel
65%{?_with_kate:  Requires(post): libkate-devel}
66Requires(post): libmatroska-devel >= 0.7.6
67Requires(post): libmodplug-devel
68Requires(post): libmp4v2-devel
69Requires(post): libmpcdec-devel
70Requires(post): libmtp-devel
71Requires(post):  libnotify-devel
72##!! Requires(post):    libprojectM-qt-devel
73Requires(post):  libproxy-devel
74Requires(post): librsvg2-devel >= 2.9.0
75Requires(post):  librtmp-devel
76Requires(post): libssh2-devel
77##!! Requires(post):    libsysfs-devel
78Requires(post):  libshout-devel
79Requires(post):  libsmbclient-devel
80##!! Requires(post):    libtar-devel
81Requires(post): libtheora-devel
82##!! Requires(post):    libtiger-devel
83Requires(post):  libtiff-devel
84Requires(post): libudev-devel >= 142
85Requires(post):  libupnp-devel
86Requires(post): libv4l-devel
87Requires(post): libva-devel
88Requires(post): libvorbis-devel
89Requires(post):  libxml2-devel
90#Requires(post):        lirc-devel
91%{?_with_lirc:Requires(post):   lirc}
92#Requires(post):        live555-devel >= 0-0.19.2008.04.03
93Requires(post):  kernel-headers >= 2.6.20
94# Requires(post):       libGL-devel
95# Requires(post):       libGLU-devel
96Requires(post):  libmusicbrainz-devel
97Requires(post):  lua-devel
98##!! Requires(post):  minizip-devel
99##!! Requires(post):    mpeg2dec-devel >= 0.3.2
100Requires(post): ncurses-devel
101##!! Requires(post):  opencv-devel
102Requires(post): openslp-devel
103Requires(post):  pcre-devel
104Requires(post):  pulseaudio-libs-devel >= 0.9.8
105##!! Requires(post):  portaudio-devel
106Requires(post):  qt4-devel >= 4.5.2
107##!! Requires(post):  schroedinger-devel
108Requires(post): SDL_image-devel
109Requires(post): speex-devel >= 1.1.5
110Requires(post):  taglib-devel
111Requires(post): twolame-devel
112Requires(post): vcdimager-devel >= 0.7.21
113Requires(post): xosd-devel
114Requires(post): zlib-devel
115##!! Requires(post):  zvbi-devel
116
117# X-libs
118Requires(post): libXt-devel
119Requires(post): libXv-devel
120Requires(post):  libXxf86vm-devel
121Requires(post):  libX11-devel
122Requires(post):  libXext-devel
123Requires(post):  libXpm-devel
124Requires(post):  libXvMC-devel
125Requires(post):  xcb-util-devel
126Requires(post):  xorg-x11-proto-devel
127
128Requires(post):  pulseaudio-libs-devel >= 0.9.8
129
130%if %with_mozilla
131Requires(post):  gecko-devel
132Requires(post):  nspr-devel
133%endif
134
135Requires: TrueType-dejavu
136
137## vine
138Requires(post): libgcrypt-devel
139Requires(post): wx-gtk2-devel
140Requires(post): mesa-libGL
141Requires(post): xorg-x11-devel
142Requires(post): mesa-libGL-devel
143Requires(post): self-build-libmpeg2
144Requires(post): self-build-a52dec
145Requires(post): self-build-faac
146Requires(post): self-build-faad2
147Requires(post): self-build-ffmpeg >= 0.4.9
148Requires(post): self-build-libdca
149Requires(post): self-build-libdvbpsi
150Requires(post): self-build-libmad
151Requires(post): self-build-x264 >= 0.120
152Requires(post): self-build-xvidcore
153
154BuildArch:      noarch
155BuildRoot:      %{_tmppath}/%{name}-%{version}-root
156
157Packager:       munepi
158
159%description
160VLC (initially VideoLAN Client) is a highly portable multimedia player
161for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
162mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
163It can also be used as a server to stream in unicast or multicast in
164IPv4 or IPv6 on a high-bandwidth network.
165
166
167[Note]
168This package requires many other packages to compile
169targetsoftware. So it consume more disk space than usual.
170Also installation takes logner time because of compilation.
171(This will take a few minutes to quarter or half of an hour,
172depends on building environment)
173
174[About self-build package]
175For some kind of software, distributing of binary package
176may viorate the patent or law. Therefore we chose self-build
177packge, create binary package on your machine, for such kind
178of softwares instead of distributing binary package.
179
180Please obey the national law when you use the created binary
181packages. And if you want to use the softwares using patented
182thechnology, it may be required to get a permission, make an
183agreement or purchas a license. Please consider it with your
184purpose or way of use and take appropriate action.
185
186%description -l ja
187VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
188様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
189mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
190対応しています.
191また,高帯域幅上の IPv4 や IPv6 で,
192ユニキャストやマルチキャストのストリームに,
193サーバーとして使用することもできます.
194
195
196このパッケージをインストールすると、自動的にソースコードを
197ダウンロードしてコンパイルし、%{pkgname}-%{version}
198の rpm パッケージを作成します。
199また apt-get コマンドや synaptic パッケージマネージャから実行
200した場合は、作成された rpm パッケージのインストールも自動的に
201行います。
202
203[注意]
204コンパイルに必要な多くの関連パッケージを要求するので通常より
205ディスクの領域を多く消費します。
206またインストール時にコンパイルを行うため、通常より時間がかか
207る場合があります。(環境にもよりますが数分から数十分程度)
208
209[self-build パッケージについて]
210ソフトウェアによってはバイナリパッケージの配布が特許や法律に
211違反する可能性があるものがあります。その為、このような問題が
212懸念されるソフトウェアについてはバイナリパッケージを直接配布
213せずに、ユーザの環境でバイナリを作成する self-build パッケー
214ジという方法を採っています。
215
216作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
217アのライセンス、および利用する国の各種法令に従ってください。
218また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
219センスの購入などが必要となる場合がありますので、利用する目的
220や形態に応じて各自で判断し適切な対応を取ってください。
221
222%prep
223[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
224
225%install
226%{__rm} -rf ${RPM_BUILD_ROOT}
227%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
228%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
229%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
230
231
232%clean
233%{__rm} -rf ${RPM_BUILD_ROOT}
234
235%posttrans
236/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
237    %{sourceurl0} %{sourceurl10} 1556000
238/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
239                                 %{pkgname}-devel-%{version}-%{release}
240
241%files
242%defattr(-,root,root)
243%{_datadir}/%{name}
244
245
246%changelog
247* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
248- new upstream release
249- dropped DC1394 and DV
250
251* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.13-1
252- new upstream release
253
254* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
255- rebuilt with new x264 and ffmpeg
256
257* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
258- s/self-build-libmp4v2/libmp4v2/
259- s/self-build-libdvdnav/libdvdnav/
260
261* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-1
262- new upstream release
263
264* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
265- dropped Requires(post): svga-devel
266- added BuildArch: noarch
267
268* Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
269- new upstream release
270
271* Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
272- new upstream release
273- backport from 1.1-bugfix from RPM Fusion development
274
275* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
276- added Requires(post): unzip
277
278* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
279- new upstream release
280- applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
281
282* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
283- new upstream release
284- added Requires(post):
285  - libcddb-devel
286  - libdc1394-devel >= 2.1.0
287  - libmodplug-devel
288  - libproxy-devel
289  - librtmp-devel
290  - libssh2-devel
291  - libudev-devel >= 142
292  - pcre-devel
293  - vcdimager-devel >= 0.7.21
294  - xcb-util-devel
295
296* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
297- new upstream release
298- dropped upstreamed patches
299- applied a reverted patch to pulse.c for vl5
300
301* Fri Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
302- backport lirc and signal fixes
303
304* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
305- new upstream release
306- dropped temporarily BuildRequires: lirc
307- added BuildRequires: libass-devel as the tag Requires(post)
308
309* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
310- new upstream release
311
312* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
313- new upstream release
314
315* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
316- new upstream release
317
318* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
319- for only vl6, supported libva
320- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
321
322* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
323- new upstream release
324- added Requires(post): libva-devel
325
326* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
327- renamed %%{Source0} to vlc-vl.spec
328
329* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
330- added Requires(post): libsmbclient-devel
331
332* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
333- new upstream release
334
335* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
336- built with libdvbpsi-devel
337- dropped 0002-Default-aout-for-pulse.patch
338
339* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
340- new upstream release
341- updated 0002-Default-aout-for-pulse.patch
342
343* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
344- added Requires(post): libmtp-devel
345
346* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
347- new upstream release
348
349* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
350- rebuilt to add signature
351
352* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
353- new upstream release
354  - applied vlc-1.0.2-compiler.patch from RPM Fusion
355- added Requires(post): lua-devel
356
357* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
358- new upstream release
359
360* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
361- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
362
363* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
364- new upstream release
365- clean-up some old patches and merged some patches from RPM Fusion package
366- added vlc-trunk-default_font-vine.patch
367- added vlc-handlers.schemas
368  - Gonf2 url-handler support
369- added shine.c, enc_base.h
370  - missing sources
371- check version between original spec and self-build spec in %%prep
372
373* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
374- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
375
376* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
377- rebuild with x264 >= 0.0.0-9.20090522
378- avoided to execute self-build-rpm.sh on RPM transaction
379  - moved %%post actions to %%posttrans
380
381* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
382- new upstream release
383- added BuildArch: noarch
384- s/TrueType-DejaVu/TrueType-dejavu/
385
386* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
387- corrected release number in vlc.spec
388- dropped ExclusiveArch
389
390* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
391- add ppc to ExclusiveArch
392
393* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
394- changed to PreReq:  self-build-faad2 from faad2-devel
395- changed to PreReq:  self-build-libmad from libmad-devel
396
397* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
398- initial build
399
400### end of file
Note: See TracBrowser for help on using the repository browser.