source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 4754

Revision 4754, 13.7 KB checked in by munepi, 13 years ago (diff)

updated self-build-*: supported vl7 (VineSeed)

Line 
1%define pkgname vlc
2%define name    self-build-%{pkgname}
3%define version 1.1.11
4%define release 2%{?_dist_release}
5
6%define with_mozilla                    0
7%define with_dc1394                     0
8
9%define with_samba                      0
10
11%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
12%define sourceurl10     http://2sen.dip.jp/cgi-bin/dtvup/source/up0617.zip
13
14
15Summary:        Package to automatically build %{pkgname} rpm package
16Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
17Name:           %{name}
18Version:        %{version}
19Release:        %{release}
20
21Obsoletes:      vlc < 1.1.0
22Obsoletes:      vlc-devel < 1.1.0
23
24Source0:        %{pkgname}-vl.spec
25
26Source100:      vlc-1.1.0-vlc-cache-gen_noerror.patch
27Source103:      vlc-1.1.6-hardode_font_patch.patch
28Source104:      vlc-1.1.4-tls_path.patch
29Source106:      vlc-1.1-backport_20110607.patch
30
31## vine
32Source150:      vlc-1.1.7-revert-pulse-c.patch
33
34License:        GPLv2+
35Group:          Restricted Software
36
37Requires(post):         self-build-setup >= 0.9.9
38
39Requires(post): unzip
40Requires(post): desktop-file-utils
41Requires(post): gettext
42Requires(post): gettext-devel
43Requires(post): libtool
44Requires(post): aalib-devel
45Requires(post): alsa-lib-devel
46Requires(post): avahi-devel
47Requires(post):  cdparanoia-devel
48Requires(post):  dbus-devel
49%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
50#Requires(post):  directfb-devel
51Requires(post):  libdirectfb-devel
52Requires(post): flac-devel
53##!! Requires(post):  fluidsynth-devel
54Requires(post): fribidi-devel
55Requires(post):  gnome-vfs2-devel
56Requires(post): gnutls-devel >= 1.0.17
57Requires(post): gsm-devel
58Requires(post): hal-devel
59Requires(post): jack-audio-connection-kit-devel
60Requires(post):  libavc1394-devel
61Requires(post): libass-devel >= 0.9.7
62##!! Requires(post):    libcaca-devel
63Requires(post): libcddb-devel
64Requires(post): libcdio-devel >= 0.77-3
65Requires(post): libdc1394-devel >= 2.1.0
66Requires(post): libdv-devel
67Requires(post): libdvdread-devel
68Requires(post):  libebml-devel
69Requires(post): libid3tag-devel
70%{?_with_kate:  Requires(post): libkate-devel}
71Requires(post): libmatroska-devel >= 0.7.6
72Requires(post): libmodplug-devel
73Requires(post): libmpcdec-devel
74Requires(post): libmtp-devel
75Requires(post):  libnotify-devel
76##!! Requires(post):    libprojectM-qt-devel
77Requires(post):  libproxy-devel
78Requires(post): librsvg2-devel >= 2.9.0
79Requires(post):  librtmp-devel
80%if %{?_dist_release} != "vl5"
81Requires(post): libssh2-devel
82%endif
83##!! Requires(post):    libsysfs-devel
84Requires(post):  libshout-devel
85Requires(post):  libsmbclient-devel
86##!! Requires(post):    libtar-devel
87Requires(post): libtheora-devel
88##!! Requires(post):    libtiger-devel
89Requires(post):  libtiff-devel
90%if %{?_dist_release} != "vl5"
91Requires(post): libudev-devel >= 142
92%endif
93Requires(post):  libupnp-devel
94Requires(post): libv4l-devel
95%if %{?_dist_release} == "vl6"
96Requires(post): libva-devel
97%endif
98Requires(post): libvorbis-devel
99Requires(post):  libxml2-devel
100#Requires(post):        lirc-devel
101%{?_with_lirc:Requires(post):   lirc}
102#Requires(post):        live555-devel >= 0-0.19.2008.04.03
103Requires(post):  kernel-headers >= 2.6.20
104# Requires(post):       libGL-devel
105# Requires(post):       libGLU-devel
106Requires(post):  libmusicbrainz-devel
107Requires(post):  lua-devel
108##!! Requires(post):  minizip-devel
109##!! Requires(post):    mpeg2dec-devel >= 0.3.2
110Requires(post): ncurses-devel
111##!! Requires(post):  opencv-devel
112Requires(post): openslp-devel
113Requires(post):  pcre-devel
114Requires(post):  pulseaudio-libs-devel >= 0.9.8
115##!! Requires(post):  portaudio-devel
116Requires(post):  qt4-devel >= 4.5.2
117##!! Requires(post):  schroedinger-devel
118Requires(post): SDL_image-devel
119Requires(post): speex-devel >= 1.1.5
120Requires(post):  taglib-devel
121Requires(post): twolame-devel
122%if %{?_dist_release} != "vl5"
123Requires(post): vcdimager-devel >= 0.7.21
124%endif
125Requires(post): xosd-devel
126Requires(post): zlib-devel
127##!! Requires(post):  zvbi-devel
128
129# X-libs
130Requires(post): libXt-devel
131Requires(post): libXv-devel
132Requires(post):  libXxf86vm-devel
133Requires(post):  libX11-devel
134Requires(post):  libXext-devel
135Requires(post):  libXpm-devel
136Requires(post):  libXvMC-devel
137%if %{?_dist_release} != "vl5"
138Requires(post):  xcb-util-devel
139%endif
140Requires(post):  xorg-x11-proto-devel
141
142%if %with_samba
143Requires(post):  samba-libsmbclient-devel
144%endif
145
146Requires(post):  pulseaudio-libs-devel >= 0.9.8
147
148%if %with_mozilla
149Requires(post):  gecko-devel
150Requires(post):  nspr-devel
151%endif
152
153Requires(post):  libraw1394-devel
154
155Requires: TrueType-dejavu
156
157## vine
158Requires(post): libgcrypt-devel
159Requires(post): wx-gtk2-devel
160Requires:       mesa-libGL
161Requires(post): xorg-x11-devel
162Requires(post): mesa-libGL-devel
163Requires(post): self-build-libmpeg2
164Requires(post): self-build-a52dec
165Requires(post): self-build-faac
166Requires(post): self-build-faad2
167Requires(post): self-build-ffmpeg >= 0.4.9
168Requires(post): self-build-libdca
169Requires(post): self-build-libdvbpsi
170Requires(post): self-build-libdvdnav
171Requires(post): self-build-libmad
172Requires(post): self-build-libmp4v2
173%if %{?_dist_release} != "vl5"
174Requires(post): self-build-x264 >= 0.0.0-15.20110322
175%elseif %{?_dist_release} == "vl5"
176Requires(post): self-build-x264 >= 0.0.0-9.20090522
177%endif
178Requires(post): self-build-xvidcore
179
180BuildArch:      noarch
181BuildRoot:      %{_tmppath}/%{name}-%{version}-root
182
183Packager:       munepi
184
185%description
186VLC (initially VideoLAN Client) is a highly portable multimedia player
187for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
188mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
189It can also be used as a server to stream in unicast or multicast in
190IPv4 or IPv6 on a high-bandwidth network.
191
192
193[Note]
194This package requires many other packages to compile
195targetsoftware. So it consume more disk space than usual.
196Also installation takes logner time because of compilation.
197(This will take a few minutes to quarter or half of an hour,
198depends on building environment)
199
200[About self-build package]
201For some kind of software, distributing of binary package
202may viorate the patent or law. Therefore we chose self-build
203packge, create binary package on your machine, for such kind
204of softwares instead of distributing binary package.
205
206Please obey the national law when you use the created binary
207packages. And if you want to use the softwares using patented
208thechnology, it may be required to get a permission, make an
209agreement or purchas a license. Please consider it with your
210purpose or way of use and take appropriate action.
211
212%description -l ja
213VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
214様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
215mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
216対応しています.
217また,高帯域幅上の IPv4 や IPv6 で,
218ユニキャストやマルチキャストのストリームに,
219サーバーとして使用することもできます.
220
221
222このパッケージをインストールすると、自動的にソースコードを
223ダウンロードしてコンパイルし、%{pkgname}-%{version}
224の rpm パッケージを作成します。
225また apt-get コマンドや synaptic パッケージマネージャから実行
226した場合は、作成された rpm パッケージのインストールも自動的に
227行います。
228
229[注意]
230コンパイルに必要な多くの関連パッケージを要求するので通常より
231ディスクの領域を多く消費します。
232またインストール時にコンパイルを行うため、通常より時間がかか
233る場合があります。(環境にもよりますが数分から数十分程度)
234
235[self-build パッケージについて]
236ソフトウェアによってはバイナリパッケージの配布が特許や法律に
237違反する可能性があるものがあります。その為、このような問題が
238懸念されるソフトウェアについてはバイナリパッケージを直接配布
239せずに、ユーザの環境でバイナリを作成する self-build パッケー
240ジという方法を採っています。
241
242作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
243アのライセンス、および利用する国の各種法令に従ってください。
244また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
245センスの購入などが必要となる場合がありますので、利用する目的
246や形態に応じて各自で判断し適切な対応を取ってください。
247
248%prep
249[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
250
251%install
252%{__rm} -rf ${RPM_BUILD_ROOT}
253%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
254%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
255
256%{__install} -m 644 \
257    %{SOURCE100} %{SOURCE103} %{SOURCE104} %{SOURCE106} \
258    %{SOURCE150} \
259    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
260
261
262%clean
263%{__rm} -rf ${RPM_BUILD_ROOT}
264
265%posttrans
266/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
267    %{sourceurl0} %{sourceurl10} 1216000
268/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
269                                 %{pkgname}-devel-%{version}-%{release}
270
271%files
272%defattr(-,root,root)
273%{_datadir}/%{name}
274
275
276%changelog
277* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
278- dropped Requires(post): svga-devel
279- added BuildArch: noarch
280
281* Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
282- new upstream release
283
284* Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
285- new upstream release
286- backport from 1.1-bugfix from RPM Fusion development
287
288* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
289- added Requires(post): unzip
290
291* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
292- new upstream release
293- applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
294
295* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
296- new upstream release
297- added Requires(post):
298  - libcddb-devel
299  - libdc1394-devel >= 2.1.0
300  - libmodplug-devel
301  - libproxy-devel
302  - librtmp-devel
303  - libssh2-devel
304  - libudev-devel >= 142
305  - pcre-devel
306  - vcdimager-devel >= 0.7.21
307  - xcb-util-devel
308
309* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
310- new upstream release
311- dropped upstreamed patches
312- applied a reverted patch to pulse.c for vl5
313
314* Fri Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
315- backport lirc and signal fixes
316
317* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
318- new upstream release
319- dropped temporarily BuildRequires: lirc
320- added BuildRequires: libass-devel as the tag Requires(post)
321
322* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
323- new upstream release
324
325* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
326- new upstream release
327
328* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
329- new upstream release
330
331* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
332- for only vl6, supported libva
333- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
334
335* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
336- new upstream release
337- added Requires(post): libva-devel
338
339* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
340- renamed %%{Source0} to vlc-vl.spec
341
342* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
343- added Requires(post): libsmbclient-devel
344
345* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
346- new upstream release
347
348* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
349- built with libdvbpsi-devel
350- dropped 0002-Default-aout-for-pulse.patch
351
352* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
353- new upstream release
354- updated 0002-Default-aout-for-pulse.patch
355
356* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
357- added Requires(post): libmtp-devel
358
359* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
360- new upstream release
361
362* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
363- rebuilt to add signature
364
365* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
366- new upstream release
367  - applied vlc-1.0.2-compiler.patch from RPM Fusion
368- added Requires(post): lua-devel
369
370* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
371- new upstream release
372
373* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
374- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
375
376* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
377- new upstream release
378- clean-up some old patches and merged some patches from RPM Fusion package
379- added vlc-trunk-default_font-vine.patch
380- added vlc-handlers.schemas
381  - Gonf2 url-handler support
382- added shine.c, enc_base.h
383  - missing sources
384- check version between original spec and self-build spec in %%prep
385
386* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
387- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
388
389* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
390- rebuild with x264 >= 0.0.0-9.20090522
391- avoided to execute self-build-rpm.sh on RPM transaction
392  - moved %%post actions to %%posttrans
393
394* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
395- new upstream release
396- added BuildArch: noarch
397- s/TrueType-DejaVu/TrueType-dejavu/
398
399* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
400- corrected release number in vlc.spec
401- dropped ExclusiveArch
402
403* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
404- add ppc to ExclusiveArch
405
406* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
407- changed to PreReq:  self-build-faad2 from faad2-devel
408- changed to PreReq:  self-build-libmad from libmad-devel
409
410* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
411- initial build
412
413### end of file
Note: See TracBrowser for help on using the repository browser.