source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 10524

Revision 10524, 15.7 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1#% global rcversion 2
2
3%define pkgname vlc
4%define name    self-build-%{pkgname}
5%define version 2.2.2
6%define release 2%{?rcversion:.rc%rcversion}%{?_dist_release}
7
8%define with_mozilla                    0
9
10#% define with_dc1394                   1
11
12%define with_ncurses                    0
13
14%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.xz
15#% define sourceurl0    http://download.videolan.org/pub/videolan/testing/vlc-2.2.0-rc2/vlc-2.2.0-rc2.tar.xz
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22
23Obsoletes:      vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
24Obsoletes:      self-build-vlc < %{version}-%{release}
25
26Source0:        %{pkgname}-vl.spec
27
28License:        GPLv2+
29Group:          Restricted Software
30
31Requires(post):         self-build-setup >= 0.9.9
32
33Requires(post): unzip
34Requires(post): desktop-file-utils
35Requires(post): gettext
36Requires(post): gettext-devel
37Requires(post): libtool
38Requires(post): aalib-devel
39Requires(post): alsa-lib-devel
40Requires(post): avahi-devel
41Requires(post):  cdparanoia-devel
42Requires(post):  dbus-devel
43%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
44#Requires(post):  directfb-devel
45Requires(post):  libdirectfb-devel
46Requires(post): flac-devel
47##!! Requires(post):  fluidsynth-devel
48Requires(post): fribidi-devel
49Requires(post):  gnome-vfs2-devel
50Requires(post): gnutls-devel >= 1.0.17
51Requires(post): gsm-devel
52%if %{?_dist_release} >= "vl7"
53Requires(post): jack-audio-connection-kit-devel
54%endif
55%{?with_dc1394:Requires(post):  libavc1394-devel}
56Requires(post): libass-devel >= 0.9.7
57##!! Requires(post):    libcaca-devel
58Requires(post): libcddb-devel
59Requires(post): libcdio-devel >= 0.77-3
60%{?with_dc1394:Requires(post):  libavc1394-devel >= 0.5.3}
61%{?with_dc1394:Requires(post):  libdc1394-devel >= 2.1.0}
62%{?with_dc1394:Requires(post):  libdv-devel}
63Requires(post): libdvdnav-devel
64Requires(post): libdvdread-devel
65Requires(post):  libebml-devel
66Requires(post): libid3tag-devel
67%{?_with_kate:  Requires(post): libkate-devel}
68Requires(post): libmatroska-devel >= 0.7.6
69Requires(post): libmodplug-devel
70Requires(post): libmp4v2-devel
71Requires(post): libmpcdec-devel
72Requires(post): libmtp-devel
73Requires(post):  libnotify-devel
74##!! Requires(post):    libprojectM-qt-devel
75Requires(post):  libproxy-devel
76Requires(post): librsvg2-devel >= 2.9.0
77Requires(post):  librtmp-devel
78Requires(post): libssh2-devel
79##!! Requires(post):    libsysfs-devel
80Requires(post):  libshout-devel
81Requires(post):  libsmbclient-devel
82##!! Requires(post):    libtar-devel
83Requires(post): libtheora-devel
84##!! Requires(post):    libtiger-devel
85Requires(post):  libtiff-devel
86Requires(post): libudev-devel >= 142
87Requires(post):  libupnp-devel
88Requires(post): libv4l-devel
89Requires(post): libva-devel
90Requires(post): libvorbis-devel
91Requires(post):  libxml2-devel
92#Requires(post):        lirc-devel
93%{?_with_lirc:Requires(post):   lirc}
94#Requires(post):        live555-devel >= 0-0.19.2008.04.03
95Requires(post):  kernel-headers >= 2.6.20
96# Requires(post):       libGL-devel
97# Requires(post):       libGLU-devel
98Requires(post):  libmusicbrainz-devel
99Requires(post):  lua-devel
100##!! Requires(post):  minizip-devel
101##!! Requires(post):    mpeg2dec-devel >= 0.3.2
102%if %with_ncurses
103Requires(post): ncurses-devel
104%endif
105##!! Requires(post):  opencv-devel
106Requires(post): openslp-devel
107Requires(post):  pcre-devel
108Requires(post):  pulseaudio-libs-devel >= 0.9.8
109##!! Requires(post):  portaudio-devel
110Requires(post):  qt4-devel >= 4.5.2
111##!! Requires(post):  schroedinger-devel
112Requires(post): SDL_image-devel
113Requires(post): speex-devel >= 1.1.5
114Requires(post):  taglib-devel
115Requires(post): twolame-devel
116Requires(post): vcdimager-devel >= 0.7.21
117Requires(post): zlib-devel
118##!! Requires(post):  zvbi-devel
119
120# X-libs
121Requires(post): libXt-devel
122Requires(post): libXv-devel
123Requires(post):  libXxf86vm-devel
124Requires(post):  libX11-devel
125Requires(post):  libXext-devel
126Requires(post):  libXpm-devel
127Requires(post):  libXvMC-devel
128Requires(post):  xcb-util-devel
129Requires(post):  xorg-x11-proto-devel
130
131Requires(post):  pulseaudio-libs-devel >= 0.9.8
132
133%if %with_mozilla
134Requires(post):  gecko-devel
135Requires(post):  nspr-devel
136%endif
137
138Requires: TrueType-dejavu
139
140## vine
141Requires(post): libgcrypt-devel
142Requires(post): wxGTK-devel
143Requires(post): mesa-libGL
144Requires(post): xorg-x11-devel
145Requires(post): mesa-libGL-devel
146Requires(post): self-build-libmpeg2
147Requires(post): self-build-a52dec
148Requires(post): self-build-faac
149Requires(post): self-build-faad2
150Requires(post): self-build-ffmpeg >= 2.4.0
151Requires(post): self-build-libdca
152Requires(post): self-build-libdvbpsi >= 1.0.0
153Requires(post): self-build-libmad
154Requires(post): self-build-x264 >= 0.136
155Requires(post): self-build-xvidcore
156
157BuildArch:      noarch
158BuildRoot:      %{_tmppath}/%{name}-%{version}-root
159
160Packager:       munepi
161
162%description
163VLC (initially VideoLAN Client) is a highly portable multimedia player
164for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
165mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
166It can also be used as a server to stream in unicast or multicast in
167IPv4 or IPv6 on a high-bandwidth network.
168
169
170[Note]
171This package requires many other packages to compile
172targetsoftware. So it consume more disk space than usual.
173Also installation takes logner time because of compilation.
174(This will take a few minutes to quarter or half of an hour,
175depends on building environment)
176
177[About self-build package]
178For some kind of software, distributing of binary package
179may viorate the patent or law. Therefore we chose self-build
180packge, create binary package on your machine, for such kind
181of softwares instead of distributing binary package.
182
183Please obey the national law when you use the created binary
184packages. And if you want to use the softwares using patented
185thechnology, it may be required to get a permission, make an
186agreement or purchas a license. Please consider it with your
187purpose or way of use and take appropriate action.
188
189%description -l ja
190VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
191様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
192mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
193対応しています.
194また,高帯域幅上の IPv4 や IPv6 で,
195ユニキャストやマルチキャストのストリームに,
196サーバーとして使用することもできます.
197
198
199このパッケージをインストールすると、自動的にソースコードを
200ダウンロードしてコンパイルし、%{pkgname}-%{version}
201の rpm パッケージを作成します。
202また apt-get コマンドや synaptic パッケージマネージャから実行
203した場合は、作成された rpm パッケージのインストールも自動的に
204行います。
205
206[注意]
207コンパイルに必要な多くの関連パッケージを要求するので通常より
208ディスクの領域を多く消費します。
209またインストール時にコンパイルを行うため、通常より時間がかか
210る場合があります。(環境にもよりますが数分から数十分程度)
211
212[self-build パッケージについて]
213ソフトウェアによってはバイナリパッケージの配布が特許や法律に
214違反する可能性があるものがあります。その為、このような問題が
215懸念されるソフトウェアについてはバイナリパッケージを直接配布
216せずに、ユーザの環境でバイナリを作成する self-build パッケー
217ジという方法を採っています。
218
219作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
220アのライセンス、および利用する国の各種法令に従ってください。
221また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
222センスの購入などが必要となる場合がありますので、利用する目的
223や形態に応じて各自で判断し適切な対応を取ってください。
224
225%prep
226[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
227
228%install
229%{__rm} -rf ${RPM_BUILD_ROOT}
230%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
231%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
232
233%clean
234%{__rm} -rf ${RPM_BUILD_ROOT}
235
236%posttrans
237/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 794000
238
239/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
240                                 %{pkgname}-devel-%{version}-%{release}
241
242%files
243%defattr(-,root,root)
244%{_datadir}/%{name}
245
246
247%changelog
248* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.2-2
249- rebuild with libcdio-0.93
250
251* Mon Feb  8 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.2-1
252- new upstream release
253
254* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-4
255- rebuilt
256
257* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-3
258- rebuild with gnutls-3.4.7
259
260* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-2
261- rebuilt
262
263* Sun Apr 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-1
264- new upstream release
265
266* Sun Apr 12 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-4
267- new upstream release
268
269* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-3.rc2
270- rebuild
271
272* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-2.rc2
273- rebuild
274
275* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-1.rc2
276- updated to 2.2.0-rc2
277
278* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.2-2
279- remove Requires(post): xosd-devel
280
281* Sat Dec 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.2-1
282- new upstream release
283
284* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-2
285- added Obsoletes: vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
286
287* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
288- new upstream release
289- built with new x264 (ABI 0.136) and ffmpeg (1.2.x)
290
291* Wed Jul  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.7-1
292- new upstream release
293
294* Tue Apr 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.6-1
295- new upstream release
296
297* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-2
298- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
299
300* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-1
301- new upstream release
302
303* Wed Nov  7 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.4-1
304- new upstream release
305
306* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.3-1
307- new upstream release
308- s/wx-gtk2/wxGTK/g
309
310* Sat Jun 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
311- new upstream release
312
313* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
314- new upstream release
315- dropped DC1394 and DV
316
317* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.13-1
318- new upstream release
319
320* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
321- rebuilt with new x264 and ffmpeg
322
323* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
324- s/self-build-libmp4v2/libmp4v2/
325- s/self-build-libdvdnav/libdvdnav/
326
327* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-1
328- new upstream release
329
330* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
331- dropped Requires(post): svga-devel
332- added BuildArch: noarch
333
334* Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
335- new upstream release
336
337* Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
338- new upstream release
339- backport from 1.1-bugfix from RPM Fusion development
340
341* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
342- added Requires(post): unzip
343
344* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
345- new upstream release
346- applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
347
348* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
349- new upstream release
350- added Requires(post):
351  - libcddb-devel
352  - libdc1394-devel >= 2.1.0
353  - libmodplug-devel
354  - libproxy-devel
355  - librtmp-devel
356  - libssh2-devel
357  - libudev-devel >= 142
358  - pcre-devel
359  - vcdimager-devel >= 0.7.21
360  - xcb-util-devel
361
362* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
363- new upstream release
364- dropped upstreamed patches
365- applied a reverted patch to pulse.c for vl5
366
367* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
368- backport lirc and signal fixes
369
370* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
371- new upstream release
372- dropped temporarily BuildRequires: lirc
373- added BuildRequires: libass-devel as the tag Requires(post)
374
375* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
376- new upstream release
377
378* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
379- new upstream release
380
381* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
382- new upstream release
383
384* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
385- for only vl6, supported libva
386- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
387
388* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
389- new upstream release
390- added Requires(post): libva-devel
391
392* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
393- renamed %%{Source0} to vlc-vl.spec
394
395* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
396- added Requires(post): libsmbclient-devel
397
398* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
399- new upstream release
400
401* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
402- built with libdvbpsi-devel
403- dropped 0002-Default-aout-for-pulse.patch
404
405* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
406- new upstream release
407- updated 0002-Default-aout-for-pulse.patch
408
409* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
410- added Requires(post): libmtp-devel
411
412* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
413- new upstream release
414
415* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
416- rebuilt to add signature
417
418* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
419- new upstream release
420  - applied vlc-1.0.2-compiler.patch from RPM Fusion
421- added Requires(post): lua-devel
422
423* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
424- new upstream release
425
426* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
427- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
428
429* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
430- new upstream release
431- clean-up some old patches and merged some patches from RPM Fusion package
432- added vlc-trunk-default_font-vine.patch
433- added vlc-handlers.schemas
434  - Gonf2 url-handler support
435- added shine.c, enc_base.h
436  - missing sources
437- check version between original spec and self-build spec in %%prep
438
439* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
440- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
441
442* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
443- rebuild with x264 >= 0.0.0-9.20090522
444- avoided to execute self-build-rpm.sh on RPM transaction
445  - moved %%post actions to %%posttrans
446
447* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
448- new upstream release
449- added BuildArch: noarch
450- s/TrueType-DejaVu/TrueType-dejavu/
451
452* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
453- corrected release number in vlc.spec
454- dropped ExclusiveArch
455
456* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
457- add ppc to ExclusiveArch
458
459* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
460- changed to PreReq:  self-build-faad2 from faad2-devel
461- changed to PreReq:  self-build-libmad from libmad-devel
462
463* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
464- initial build
465
466### end of file
Note: See TracBrowser for help on using the repository browser.