source: projects/specs/trunk/nonfree/self-build-mplayer/self-build-mplayer-vl.spec @ 6241

Revision 6241, 16.2 KB checked in by munepi, 12 years ago (diff)

upgrade some self-build packages; remove obsolete self-build packages

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5# define with_ffmpeg 1
6
7%global pkgname mplayer
8%global name    self-build-%{pkgname}
9%global version 1.0
10#% global extver        rc4
11%global svndate  20120525
12%global release 47%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
13
14%global source0path     MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
15%global source1path     MPlayer/skins/Blue-1.8.tar.bz2
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23Source10:       %{pkgname}-snapshot-vine.sh
24
25#Source102:        %{pkgname}-config.patch
26Source102:        %{pkgname}-config-20120525-vine.patch
27Source108:        %{pkgname}-manlinks.patch
28Source114:        %{pkgname}-nodvdcss.patch
29Source118:        %{pkgname}-ffmpeg.patch
30
31License:        GPLv2+
32Group:          Restricted Software
33
34Obsoletes:      mplayer < %{version}-%{release}
35Obsoletes:      self-build-mplayer < %{version}-%{release}
36
37Requires(post):         self-build-setup >= 0.9.9
38Requires(post):         subversion
39
40# (build)requies of target package.
41Requires(post): SDL-devel
42Requires(post):  aalib-devel
43Requires(post): alsa-lib-devel
44Requires(post): cdparanoia-devel
45Requires(post):  desktop-file-utils
46Requires(post): libdvdnav-devel
47Requires(post):  enca-devel
48Requires(post): freetype2-devel >= 2.0.9
49Requires(post):  fribidi-devel
50Requires(post):  fontconfig-devel
51Requires(post): giflib-devel
52Requires(post): gtk2-devel
53Requires(post): mesa-libGL-devel
54Requires(post):  libXinerama-devel
55Requires(post):  libXScrnSaver-devel
56Requires(post):  libXv-devel
57Requires(post):  libXvMC-devel
58Requires(post):  libXxf86dga-devel
59Requires(post):  libXxf86vm-devel
60Requires(post):  libass-devel
61Requires(post): libpng-devel
62Requires(post): libjpeg-devel
63Requires(post): libdvdread
64Requires(post):  libmpcdec-devel >= 1.2.1
65Requires(post):  librtmp-devel >= 2.3
66Requires(post):  speex-devel >= 1.1
67%{?with_vaapi:Requires(post):libva-devel}
68Requires(post):  libvdpau-devel
69Requires(post): libvorbis-devel
70%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
71Requires(post):  lzo-devel >= 2
72Requires(post):  pulseaudio-lib-devel
73Requires(post):  speex-devel >= 1.1
74Requires(post):  twolame-devel
75Requires(post): xorg-x11-devel
76Requires(post):  yasm
77Requires(post): zlib-devel
78
79Requires(post):         self-build-mplayer-codecs
80##!!Requires(post):             self-build-libdvdcss
81Requires(post):         self-build-faac
82Requires(post):         self-build-faad2 >= 2.6.1
83Requires(post):         self-build-lame
84Requires(post):         self-build-libdca
85Requires(post):         self-build-libmad
86Requires(post): self-build-x264 >= 0.120
87Requires(post):         self-build-xvidcore >= 0.9.2
88Requires(post):         self-build-libmpeg2
89Requires:       TrueType-vlgothic
90Requires:       mesa-libGL
91
92BuildArch:      noarch
93BuildRoot:      %{_tmppath}/%{name}-%{version}-root
94
95Packager:       munepi
96
97%description
98MPlayer can play most standard video formats out of the box and almost
99all others with the help of external codecs.
100MPlayer currently works best from the command line, but visual feedback
101for many functions is available from its onscreen status display (OSD),
102which is also used for displaying subtitles.
103MPlayer also has a GUI with skin support and several unofficial alternative
104graphical frontends are available.
105
106MEncoder is a command line video encoder for advanced users that can
107be built from the MPlayer source tree. Unofficial graphical frontends
108exist but arenot included.
109
110MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
111support for some newer codecs are not yet inpmlemented.
112You should install mplayer-codecs package if you want to play videos
113using those new codecs.
114
115
116Additional function is automatically included if following
117packages are installed in advance.
118
119samba-libsmbclient-devel: SMB file system support
120
121
122[Note]
123This package requires many other packages to compile
124targetsoftware. So it consume more disk space than usual.
125Also installation takes logner time because of compilation.
126(This will take a few minutes to quarter or half of an hour,
127depends on building environment)
128
129[About self-build package]
130For some kind of software, distributing of binary package
131may viorate the patent or law. Therefore we chose self-build
132packge, create binary package on your machine, for such kind
133of softwares instead of distributing binary package.
134
135Please obey the national law when you use the created binary
136packages. And if you want to use the softwares using patented
137thechnology, it may be required to get a permission, make an
138agreement or purchas a license. Please consider it with your
139purpose or way of use and take appropriate action.
140
141%description -l ja
142MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
143またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
144で再生できます。
145現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
146は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
147面上で確認できます。
148MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
149非公式なフロントエンドも利用できます。
150
151MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
152非公式な GUI フロントエンドもありますが、このパッケージには含まれて
153いません。
154
155MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
156を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
157いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
158をインストールする必要があります。
159
160
161このパッケージより前に以下の関連パッケージをインストールして
162おくと、%{pkgname} が対応できる機能が自動的に追加されます。
163
164samba-libsmbclient-devel: SMB ファイルシステムのサポート
165
166
167[注意]
168コンパイルに必要な多くの関連パッケージを要求するので通常より
169ディスクの領域を多く消費します。
170またインストール時にコンパイルを行うため、通常より時間がかか
171る場合があります。(環境にもよりますが数分から数十分程度)
172
173[self-build パッケージについて]
174ソフトウェアによってはバイナリパッケージの配布が特許や法律に
175違反する可能性があるものがあります。その為、このような問題が
176懸念されるソフトウェアについてはバイナリパッケージを直接配布
177せずに、ユーザの環境でバイナリを作成する self-build パッケー
178ジという方法を採っています。
179
180作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
181アのライセンス、および利用する国の各種法令に従ってください。
182また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
183センスの購入などが必要となる場合がありますので、利用する目的
184や形態に応じて各自で判断し適切な対応を取ってください。
185
186
187%prep
188[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
189
190%install
191%{__rm} -rf ${RPM_BUILD_ROOT}
192%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
193%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
194%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
195%{__install} -m 644 \
196    %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
197    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
198
199
200%clean
201%{__rm} -rf ${RPM_BUILD_ROOT}
202
203%posttrans
204# ## official tarball
205# /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
206#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
207#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
208#     635000
209# exit 0
210
211## svn checkout
212# set locale
213case $LANG in
214    ja*)LOCALE=ja ;;
215    *) LOCALE=C ;;
216esac
217
218GetSrc_C(){
219    echo -n "     "
220    echo "Download source file with Subversion..."
221}
222
223GetSrc_ja(){
224    echo -n "     "
225    echo "Subversion を用いてソースファイルをダウンロードしています..."
226}
227
228GetSrc_$LOCALE
229
230# svn checkout
231. /etc/self-build.conf
232(cd $TEMP_DIR
233su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
234%__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
235)
236
237/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
238    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} 1368000
239   
240
241%files
242%defattr(-,root,root)
243%{_datadir}/%{name}
244
245%changelog
246* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
247- updated snapshot 20120525 with ffmpeg 0.11
248- dropped Requires(post): self-build-libdvdcss
249
250* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
251- updated snapshot 20111217 (with ffmpeg 0.9)
252
253* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
254- s/self-build-libdvdnav/libdvdnav/
255
256* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
257- updated %%source1path
258  - update to 1.8
259
260* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
261- dropped Requires(post): esound-devel
262
263* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
264- new upstream release
265  - ready for Vine Linux 6
266  - revived support for Vine Linux 5
267- added Requires(post):
268  - libass-devel
269  - librtmp-devel >= 2.3
270  - speex-devel >= 1.1
271
272* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
273- added BuildRequires:
274  - aalib-devel
275  - enca-devel
276  - lzo-devel
277  - speex-devel
278
279* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
280- updated fixed %{name}-config.patch
281  - applied %{name}-config-20100709-vine.patch
282
283* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
284- unpacked source archives
285
286* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
287- updated source snapshot 20100709
288- renamed %%Source10 to mplayer-snapshot-vine.sh
289- added Requires(post): libva-devel, libvpx-devel >= 0.9.1
290- dropped vl4 support
291- updated %%description
292
293* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
294- updated source snapshot 20100621
295- added Requires(post): libXinerama-devel
296- dropped vl4 support
297
298* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
299- updated source snapshot 20100401
300
301* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
302- updated source snapshot 20100317
303- renamed %%{Source0} to mplayer-vl.spec
304
305* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
306- updated source snapshot 20100216
307- dropped obsolete patches
308- added Requires(post): libvdpau-devel libXScrnSaver-devel
309
310* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
311- update mplayer-config-20091215-vine.patch
312- update mplayer-20091215-x86_32-compile.patch
313
314* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
315- source snapshot 20091031
316  - updated mplayer-20091031-x86_32-compile.patch
317
318* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
319- source snapshot 20091003
320
321* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
322- added some if conditions for "vl6"
323
324* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
325- source snapshot 20090905
326- added settings for vl6
327
328* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
329- source snapshot 20090821
330- replaced BR: libungif-devel with BR: giflib-devel
331- mentioned VDPAU support in %%description
332
333* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
334- source snapshot 20090722
335
336* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
337- source snapshot 20090702
338- check version between original spec and self-build spec in %%prep
339
340* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
341- source snapshot 20090611
342
343* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
344- added Requires: TrueType-vlgothic
345
346* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
347- source snapshot 20090522
348  - build with x264 >= 0.0.0-9.20090522
349  - updated mplayer-20090502-nodvdcss.patch
350- avoided to execute self-build-rpm.sh on RPM transaction
351  - moved %%post actions to %%posttrans
352
353* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
354- added PreReq: self-build-mplayer-codecs
355
356* Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
357- added BuildArch: noarch
358- source snapshot 20090502
359- updated mplayer-20090503-x86_32-compile.patch
360- updated mplayer-20090502-nodvdcss.patch
361
362* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
363- included source archives:
364  - mplayer-export-20090327.tar.bz2
365  - Blue-1.7.tar.bz2
366- applied mplayer-config-vine.patch
367
368* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
369- source snapshot 20090327
370- updated mplayer-20090327-x86_32-compile.patch
371- updated mplayer-20090325-nodvdcss.patch
372- dropped gmplayer-about-vine.patch
373
374* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
375- source snapshot 20090206
376- dropped mplayer-man-zh_CN.patch
377- updated mplayer-20090206-nodvdcss.patch
378- changed to PreReq:  self-build-faad2 from faad2-devel
379- added PreReq:  self-build-libmad
380
381* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
382- source snapshot 20090131
383- fixed %%files section
384
385* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
386- fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
387
388* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
389- source snapshot
390- update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
391- added PreReq:
392  - faad2-devel
393  - libmpcdec-devel
394  - twolame-devel
395  - yasm
396  - self-build-libdvdcss
397  - self-build-libdvdnav
398  - self-build-faac
399  - self-build-lame
400  - self-build-libdca
401  - self-build-x264 >= 0.0.0-4.20090110
402  - self-build-xvidcore >= 0.9.2
403- move %%define source0Exists() from %%post section to header
404- fixed %%post section: clean up source archive
405
406* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
407- source snapshot
408- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
409  --disable-faad-internal in configure options
410- dropped gmplayer-add-flv-extension.patch
411
412* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
413- source snapshot
414- fixed License
415- added some patches from RPM Fusion
416- updated gmplayer-about-vine.patch for 20081001 snapshot
417- added BuildRequires:  libdvdread
418- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
419- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
420  in configure options
421#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
422- added PreReq: subversion
423
424* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
425- fixed License
426- added some devel packages to support OpenGL
427
428* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
429- spec in utf8
430- fix sybolic link of subfont for vl5
431
432* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
433- add "Source105: CVE-2008-1558.patch".
434
435* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
436- build with new versioning policy.
437- add "Source200: gmplayer-about-vine.patch".
438- add "Source201: gmplayer-add-flv-extension.patch".
439- fix <BTS:VineLinux:603>.
440  - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
441  - add mirror URLs to self-build-rpm.sh.
442
443* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
444- add four official security patches (CVE-2008-0485, CVE-2008-0486,
445  CVE-2008-0629, CVE-2008-0630)
446- add mplayer-1.0rc2-20080211-stream_cddb.patch
447
448* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
449- change source download URL. <BTS:VineLinux:603>
450
451* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
452- fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
453
454* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
455- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.