source: projects/specs/trunk/nonfree/self-build-mplayer/self-build-mplayer-vl.spec @ 5297

Revision 5297, 16.2 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5# define with_ffmpeg 1
6
7%global pkgname mplayer
8%global name    self-build-%{pkgname}
9%global version 1.0
10#% global extver        rc4
11%global svndate  20111210
12%global release 45%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
13
14%global source0path     MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
15%global source1path     MPlayer/skins/Blue-1.8.tar.bz2
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22Source0:        %{pkgname}-vl.spec
23Source10:       %{pkgname}-snapshot-vine.sh
24
25#Source102:        %{pkgname}-config.patch
26Source102:        %{pkgname}-config-20111217-vine.patch
27Source108:        %{pkgname}-manlinks.patch
28Source114:        %{pkgname}-nodvdcss.patch
29Source118:        %{pkgname}-ffmpeg.patch
30
31Source150:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
32
33License:        GPLv2+
34Group:          Restricted Software
35
36Requires(post):         self-build-setup >= 0.9.9
37Requires(post):         subversion
38
39# (build)requies of target package.
40Requires(post): SDL-devel
41Requires(post):  aalib-devel
42Requires(post): alsa-lib-devel
43Requires(post): cdparanoia-devel
44Requires(post):  desktop-file-utils
45Requires(post): libdvdnav-devel
46Requires(post):  enca-devel
47Requires(post): freetype2-devel >= 2.0.9
48Requires(post):  fribidi-devel
49Requires(post):  fontconfig-devel
50Requires(post): giflib-devel
51Requires(post): gtk2-devel
52Requires(post): mesa-libGL-devel
53Requires(post):  libXinerama-devel
54Requires(post):  libXScrnSaver-devel
55Requires(post):  libXv-devel
56Requires(post):  libXvMC-devel
57Requires(post):  libXxf86dga-devel
58Requires(post):  libXxf86vm-devel
59Requires(post):  libass-devel
60Requires(post): libpng-devel
61Requires(post): libjpeg-devel
62Requires(post): libdvdread
63Requires(post):  libmpcdec-devel >= 1.2.1
64Requires(post):  librtmp-devel >= 2.3
65Requires(post):  speex-devel >= 1.1
66%if %{?_dist_release} != "vl5"
67%{?with_vaapi:Requires(post):libva-devel}
68%endif
69Requires(post):  libvdpau-devel
70Requires(post): libvorbis-devel
71%if %{?_dist_release} != "vl5"
72%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
73%endif
74Requires(post):  lzo-devel >= 2
75Requires(post):  pulseaudio-lib-devel
76Requires(post):  speex-devel >= 1.1
77Requires(post):  twolame-devel
78Requires(post): xorg-x11-devel
79Requires(post):  yasm
80Requires(post): zlib-devel
81
82Requires(post):         self-build-mplayer-codecs
83Requires(post):         self-build-libdvdcss
84Requires(post):         self-build-faac
85Requires(post):         self-build-faad2 >= 2.6.1
86Requires(post):         self-build-lame
87Requires(post):         self-build-libdca
88Requires(post):         self-build-libmad
89%if %{?_dist_release} != "vl5"
90Requires(post): self-build-x264 >= 0.0.0-18.20111216
91%elseif %{?_dist_release} == "vl5"
92Requires(post): self-build-x264 >= 0.0.0-9.20090522
93%endif
94Requires(post):         self-build-xvidcore >= 0.9.2
95Requires(post):         self-build-libmpeg2
96Requires:       TrueType-vlgothic
97Requires:       mesa-libGL
98
99BuildArch:      noarch
100BuildRoot:      %{_tmppath}/%{name}-%{version}-root
101
102Packager:       munepi
103
104%description
105MPlayer can play most standard video formats out of the box and almost
106all others with the help of external codecs.
107MPlayer currently works best from the command line, but visual feedback
108for many functions is available from its onscreen status display (OSD),
109which is also used for displaying subtitles.
110MPlayer also has a GUI with skin support and several unofficial alternative
111graphical frontends are available.
112
113MEncoder is a command line video encoder for advanced users that can
114be built from the MPlayer source tree. Unofficial graphical frontends
115exist but arenot included.
116
117MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
118support for some newer codecs are not yet inpmlemented.
119You should install mplayer-codecs package if you want to play videos
120using those new codecs.
121
122
123Additional function is automatically included if following
124packages are installed in advance.
125
126samba-libsmbclient-devel: SMB file system support
127
128
129[Note]
130This package requires many other packages to compile
131targetsoftware. So it consume more disk space than usual.
132Also installation takes logner time because of compilation.
133(This will take a few minutes to quarter or half of an hour,
134depends on building environment)
135
136[About self-build package]
137For some kind of software, distributing of binary package
138may viorate the patent or law. Therefore we chose self-build
139packge, create binary package on your machine, for such kind
140of softwares instead of distributing binary package.
141
142Please obey the national law when you use the created binary
143packages. And if you want to use the softwares using patented
144thechnology, it may be required to get a permission, make an
145agreement or purchas a license. Please consider it with your
146purpose or way of use and take appropriate action.
147
148%description -l ja
149MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
150またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
151で再生できます。
152現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
153は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
154面上で確認できます。
155MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
156非公式なフロントエンドも利用できます。
157
158MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
159非公式な GUI フロントエンドもありますが、このパッケージには含まれて
160いません。
161
162MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
163を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
164いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
165をインストールする必要があります。
166
167
168このパッケージより前に以下の関連パッケージをインストールして
169おくと、%{pkgname} が対応できる機能が自動的に追加されます。
170
171samba-libsmbclient-devel: SMB ファイルシステムのサポート
172
173
174[注意]
175コンパイルに必要な多くの関連パッケージを要求するので通常より
176ディスクの領域を多く消費します。
177またインストール時にコンパイルを行うため、通常より時間がかか
178る場合があります。(環境にもよりますが数分から数十分程度)
179
180[self-build パッケージについて]
181ソフトウェアによってはバイナリパッケージの配布が特許や法律に
182違反する可能性があるものがあります。その為、このような問題が
183懸念されるソフトウェアについてはバイナリパッケージを直接配布
184せずに、ユーザの環境でバイナリを作成する self-build パッケー
185ジという方法を採っています。
186
187作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
188アのライセンス、および利用する国の各種法令に従ってください。
189また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
190センスの購入などが必要となる場合がありますので、利用する目的
191や形態に応じて各自で判断し適切な対応を取ってください。
192
193
194%prep
195[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
196
197%install
198%{__rm} -rf ${RPM_BUILD_ROOT}
199%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
200%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
201%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
202%{__install} -m 644 \
203    %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
204    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
205
206
207%clean
208%{__rm} -rf ${RPM_BUILD_ROOT}
209
210%posttrans
211# ## official tarball
212# /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
213#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
214#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
215#     635000
216# exit 0
217
218## svn checkout
219# set locale
220case $LANG in
221    ja*)LOCALE=ja ;;
222    *) LOCALE=C ;;
223esac
224
225GetSrc_C(){
226    echo -n "     "
227    echo "Download source file with Subversion..."
228}
229
230GetSrc_ja(){
231    echo -n "     "
232    echo "Subversion を用いてソースファイルをダウンロードしています..."
233}
234
235GetSrc_$LOCALE
236
237# svn checkout
238. /etc/self-build.conf
239(cd $TEMP_DIR
240su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
241%__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
242)
243
244/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
245    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
246    635000
247
248%files
249%defattr(-,root,root)
250%{_datadir}/%{name}
251
252%changelog
253* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
254- updated snapshot 20111217 (with ffmpeg 0.9)
255
256* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
257- s/self-build-libdvdnav/libdvdnav/
258
259* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
260- updated %%source1path
261  - update to 1.8
262
263* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
264- dropped Requires(post): esound-devel
265
266* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
267- new upstream release
268  - ready for Vine Linux 6
269  - revived support for Vine Linux 5
270- added Requires(post):
271  - libass-devel
272  - librtmp-devel >= 2.3
273  - speex-devel >= 1.1
274
275* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
276- added BuildRequires:
277  - aalib-devel
278  - enca-devel
279  - lzo-devel
280  - speex-devel
281
282* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
283- updated fixed %{name}-config.patch
284  - applied %{name}-config-20100709-vine.patch
285
286* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
287- unpacked source archives
288
289* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
290- updated source snapshot 20100709
291- renamed %%Source10 to mplayer-snapshot-vine.sh
292- added Requires(post): libva-devel, libvpx-devel >= 0.9.1
293- dropped vl4 support
294- updated %%description
295
296* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
297- updated source snapshot 20100621
298- added Requires(post): libXinerama-devel
299- dropped vl4 support
300
301* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
302- updated source snapshot 20100401
303
304* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
305- updated source snapshot 20100317
306- renamed %%{Source0} to mplayer-vl.spec
307
308* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
309- updated source snapshot 20100216
310- dropped obsolete patches
311- added Requires(post): libvdpau-devel libXScrnSaver-devel
312
313* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
314- update mplayer-config-20091215-vine.patch
315- update mplayer-20091215-x86_32-compile.patch
316
317* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
318- source snapshot 20091031
319  - updated mplayer-20091031-x86_32-compile.patch
320
321* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
322- source snapshot 20091003
323
324* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
325- added some if conditions for "vl6"
326
327* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
328- source snapshot 20090905
329- added settings for vl6
330
331* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
332- source snapshot 20090821
333- replaced BR: libungif-devel with BR: giflib-devel
334- mentioned VDPAU support in %%description
335
336* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
337- source snapshot 20090722
338
339* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
340- source snapshot 20090702
341- check version between original spec and self-build spec in %%prep
342
343* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
344- source snapshot 20090611
345
346* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
347- added Requires: TrueType-vlgothic
348
349* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
350- source snapshot 20090522
351  - build with x264 >= 0.0.0-9.20090522
352  - updated mplayer-20090502-nodvdcss.patch
353- avoided to execute self-build-rpm.sh on RPM transaction
354  - moved %%post actions to %%posttrans
355
356* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
357- added PreReq: self-build-mplayer-codecs
358
359* Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
360- added BuildArch: noarch
361- source snapshot 20090502
362- updated mplayer-20090503-x86_32-compile.patch
363- updated mplayer-20090502-nodvdcss.patch
364
365* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
366- included source archives:
367  - mplayer-export-20090327.tar.bz2
368  - Blue-1.7.tar.bz2
369- applied mplayer-config-vine.patch
370
371* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
372- source snapshot 20090327
373- updated mplayer-20090327-x86_32-compile.patch
374- updated mplayer-20090325-nodvdcss.patch
375- dropped gmplayer-about-vine.patch
376
377* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
378- source snapshot 20090206
379- dropped mplayer-man-zh_CN.patch
380- updated mplayer-20090206-nodvdcss.patch
381- changed to PreReq:  self-build-faad2 from faad2-devel
382- added PreReq:  self-build-libmad
383
384* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
385- source snapshot 20090131
386- fixed %%files section
387
388* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
389- fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
390
391* Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
392- source snapshot
393- update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
394- added PreReq:
395  - faad2-devel
396  - libmpcdec-devel
397  - twolame-devel
398  - yasm
399  - self-build-libdvdcss
400  - self-build-libdvdnav
401  - self-build-faac
402  - self-build-lame
403  - self-build-libdca
404  - self-build-x264 >= 0.0.0-4.20090110
405  - self-build-xvidcore >= 0.9.2
406- move %%define source0Exists() from %%post section to header
407- fixed %%post section: clean up source archive
408
409* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
410- source snapshot
411- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
412  --disable-faad-internal in configure options
413- dropped gmplayer-add-flv-extension.patch
414
415* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
416- source snapshot
417- fixed License
418- added some patches from RPM Fusion
419- updated gmplayer-about-vine.patch for 20081001 snapshot
420- added BuildRequires:  libdvdread
421- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
422- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
423  in configure options
424#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
425- added PreReq: subversion
426
427* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
428- fixed License
429- added some devel packages to support OpenGL
430
431* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
432- spec in utf8
433- fix sybolic link of subfont for vl5
434
435* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
436- add "Source105: CVE-2008-1558.patch".
437
438* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
439- build with new versioning policy.
440- add "Source200: gmplayer-about-vine.patch".
441- add "Source201: gmplayer-add-flv-extension.patch".
442- fix <BTS:VineLinux:603>.
443  - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
444  - add mirror URLs to self-build-rpm.sh.
445
446* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
447- add four official security patches (CVE-2008-0485, CVE-2008-0486,
448  CVE-2008-0629, CVE-2008-0630)
449- add mplayer-1.0rc2-20080211-stream_cddb.patch
450
451* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
452- change source download URL. <BTS:VineLinux:603>
453
454* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
455- fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
456
457* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
458- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.